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Preface 
The following topics are described in this section:  

• Purpose 

• Audience 

• Related Information 

• Typographic Conventions 

Purpose 
The Exigen Workflow Administrator's Guide, Part 2: Business Component Reference describes 
how to configure, manage, and run Exigen Workflow servers. 

For information on the main concepts of Exigen Workflow and instructions for setting up the 
system, see the Exigen Workflow Administrator’s Guide, Part 1: Design and Configuration. 

Audience 
This guide is intended for Exigen Workflow system administrators only. These administrators 
assign access rights to users, set up and maintain security, design workflow, and configure 
Exigen Workflow servers. The system administrator is often referred to as the administrator. 

This guide assumes basic computer knowledge for performing Windows® operations. It also 
assumes a familiarity with ODBC and basic experience working with the SQL language and 
databases. 

Related Information 
The following table lists guides that provide related information about Exigen Workflow: 
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Related information 
Title Description 
Exigen Workflow User’s 
Guide 

Describes how to operate Exigen Workflow. 

Exigen Workflow Installation 
Guide 

Describes how to install Exigen Workflow. 

Exigen Workflow 
Administrator’s Guides I-III 

Defines the main concepts underlying Exigen Workflow and describes 
how create projects and set up, manage, and monitor the system. 

Exigen Workflow Task 
Oriented Workflow 
Administrator's Guide 

Describes how to deploy Task Oriented Workflow. 

Typographic Conventions 
The following styles and conventions are used in Exigen documentation: 

Typographic styles and conventions 
Convention Description 
Bold • Represents user interface items such as check boxes, command buttons, 

dialog boxes, drop-down list values, field names, menu commands, menus, 
option buttons, perspectives, tabs, tooltip labels, tree elements, views, and 
windows. 

• Represents keys, such as F9 or CTRL+A. 
• Represents a term the first time it is defined. 

Courier Represents file and directory names, code, system messages, and command-line 
commands.  

Courier Bold Represents emphasized text in code.  
Select File > Save 
As 

Represents a command to perform, such as opening the File menu and selecting 
Save As.  

Italic • Represents any information to be entered in a field.  
• Represents documentation titles.  

<  > Represents placeholder values to be substituted with user specific values.  
Hyperlink Represents a hyperlink. Clicking on this field takes you to the identified 

place in this guide. 
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Chapter 1: Print Server and Monitor 
This chapter explains how to configure and run Print Server as well as how to monitor all print 
jobs in the database. The following topics are described in this section: 

• Overview 

• Exigen Workflow Print Server 

• Exigen Workflow Print Monitor 

Overview 
Exigen Workflow Print Server schedules, spools, and routes imaged documents to high-speed 
network printers. It is recommended that you use the Printer Server tool with networked printers 
because imaged documents take longer to spool and print than other documents. 

Print Monitor and Print Monitor Log manage the jobs sent to the printers. Jobs can be 
rerouted, suspended, or deleted as needed. 

Exigen Workflow enables you to change your default printer. Because a print server usually 
runs on a network workstation and not a user workstation, you can use Exigen Workflow Print 
Server setup to change a default print server. 

Exigen Workflow Print Server 
The Exigen Workflow Print Server application is used with a high-speed network printer. Each 
printer is run with a print server application. The application is run on a workstation to which the 
printer is connected. The association between the printer and the workstation is created during 
the device setup. 

Print Server is located in Exigen Workflow Explorer, in the Administration Tools folder, in the 
Servers subfolder.  

To open the Workflow Print Server window, double click the Print Server icon. 

 

The Workflow Print Server window displays the number of jobs currently in the print queue. 
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Figure 1: Workflow Print Server window 

The following topics are described in this section: 

• Configuring Print Server 

• Running Print Server 

Configuring Print Server 
Before a printer and print server can be used, they must be associated. This is done using the 
Print Server Setup function.  

To set up a printer, click Print Server Setup. 

 

The Print Server Setup window appears. 
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Figure 2: Print Server Setup window 

The Current Workstation is displayed at the top of the window. The table lists all configured 
printers with details in the following columns: 

Print Server setup 
Column Description 
Device Name Name visible to the users.  
Device Printer device name. 
Driver Print driver name used. 
Status Device status, either active or disabled. If disabled, users cannot send jobs 

to this device. 
Workstation Device workstation ID. 
Consolidation Device Print job consolidation device. 
Consolidation Port Print job consolidation port. 

The following topics are described in this section: 

• Configuring Advanced Printing Options for Exigen Workflow Web 

• Adding a Device 

• Modifying a Device 

• Deleting a Device 

• Assigning a Device to Print Server 
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• Selecting a Default Printer 

• Setting Extended Printing 

• Configuring Default Printing Options 

Configuring Advanced Printing Options for Exigen Workflow Web 

Advanced printing options that are available in Exigen Workflow can also be configured for 
Exigen Workflow Web. The following advanced printing options are available: 

• selecting multiple documents for printing 

• printing documents, folders, and subfolders on local printers 

• adding cover pages to folders and subfolders 

• monitoring the status of print jobs 

When advanced options are enabled for Exigen Workflow Web, documents are printed virtually 
to a print queue. After virtual printing, documents, folders, and subfolders can be physically 
printed on a local printer. 

To provide advanced printing options to Exigen Workflow Web users, the following configuration 
requirements must be fulfilled: 

• At least one Virtual Print Queue node must be included in a workflow, and all user groups 
that require advanced printing options must have access to a Virtual Print Queue. If security 
requires that users using the Retrieve node be prevented from viewing documents sent to 
the Virtual Print Queue by other users, one or more Virtual Print Queues must be set up in a 
separate workflow. Only authorized users must be provided access to see the documents in 
the Virtual Print Queues. For information on setting up workflow objects, see the Exigen 
Workflow Administrator's Guide Part 1: Design and Configuration, Chapter 5: Designing a 
Workflow, Setting Up Workflow Objects. 

• The NED Image Printer Driver must be installed to print Word and PDF files. It is located in 
the following directory: 

VISIFLOW\INSTALL\NedImagePrinter 

A NED driver is not required for printing DMS files. 

A virtual printing device must be set up in Print Server as described in Adding a Virtual Device. 

Adding a Device 

This section describes adding a device to Print Server. 

The following topics are described: 

• Adding a Standard Device 

• Adding a Virtual Device 
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Adding a Standard Device 

To add a new device to Print Server, proceed as follows: 

1. Click Add Device. 

The Add Device window appears. 

 
Figure 3: Adding a new device 

2. To collect all print jobs from the user into a single print job, select the Consolidate print 
jobs check box and the corresponding device. 

This resolves the problem of separating documents among users after all print jobs are 
completed. If the Consolidate print jobs check box is not selected, Print Server enables 
printing documents in order of print job arrival. 

Print job consolidation works as follows: 

• A user prints on the consolidation device. 
• As all of the user’s print jobs arrive, they are consolidated into a single print job and sent 

to the real printer.  
• A virtual printer device is used.  
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3. To install the virtual device, create a virtual printer port using the We Do Drivers, Inc. 
WDDPORT solution. 

4. To add a new printer, select Control Panel > Printers > Add Printer. 
5. To locate the device, click Select. 
6. If the device is not listed, close the Exigen Workflow Print Server, add the printer via the 

Control Panel, and proceed to Exigen Workflow Print Server Setup as described in 
Configuring Print Server. 

7. In the Device Name field, enter the name used to identify the printer. 

Spaces are not permitted. Underscores _ should be used instead of spaces. 

8. In the Workstation ID field, enter a known workstation ID number, or to automatically assign 
the ID of your workstation, click Set to Current. 

Workstation ID identifies the workstation where the print device is located. 

9. To specify the device status, select the Active or Disabled radio button. 

10. To add the device to the list, click Apply. 

The Print Server Setup window displays the new printer in the list. 

Adding a Virtual Device 

To add a virtual device, proceed as follows: 

1. Click Add Device. 

The Add Device window appears. 

2. Select the Virtual checkbox. 

3. To select the workflow of the virtual device, select a value in the Workflow list. 

4. To select the workflow node of the virtual device, select a value in the Node list. 

5. In the Device Name field, enter the name used to identify the printer. 

Spaces are not permitted. Underscores _ should be used instead of spaces. 

6. In the Workstation ID field, enter a known workstation ID number, or to automatically assign 
the ID of your workstation, click Set to Current. 

Workstation ID identifies the workstation where the print device is located. 

7. To ensure that the virtual printer is available to users, in the Device status section, select 
Active. 

8. To ensure that the virtual printer is not available to users, in the Device status section, 
select Disabled. 

9. To add the device to the list, click Apply. 

The new printer appears in the Print Server Setup window. 
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Modifying a Device 

To modify the Workstation ID or device for an existing record, select the device and click Modify 
Device. Note that the Device Name cannot be modified. 

Deleting a Device 

To delete a device, select the device and click Remove Device. 

Assigning a Device to Print Server 

To assign the device to Print Server, confirm that the record is selected in the Print Server 
Setup window before clicking Close. 

Note that multiple devices can be added to Print Server, but only unique device names must 
used for all devices on all print servers.  

Selecting a Default Printer 

To select a default printer, proceed as follows: 

1. Select Setup > Printer Setup. 

The Select Printer dialog displays all printers set up on your computer, including network 
printers.  

 
Figure 4: Selecting a default printer 

2. Select a printer. 

3. To set it as the default printer, click OK. 

Setting Extended Printing 

In Exigen Workflow Print Server, on and off switches can be configured to print Word and Excel 
files through OLE, and PDF files through Acrobat Reader. 

To configure printing files with this switch, proceed as follows: 
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1. Open the visiclt.ini file. 

2. In the [Extended Printing] section, enter yes or no next to the relevant file type. 
---------------------------------------------------- 
[Extended Printing] 
msword= 
msexcel= 
pdf= 
---------------------------------------------------- 

Note: If the visiclt.ini file does not contain such a section, or such entries in the section, an 
application cannot use the feature. 

Configuring Default Printing Options 

To configure the default printing options for the system, proceed as follows:  

1. Open the visi.ini file. 

2. In the [print] section of the visi.ini file, specify the default settings for printing 
documents with or without annotations. Indicate whether users can change these settings. 
For example: 

[print] 
print_version_readonly =1 /* users cannot change the settings */ 
print_version=0 /* the original version without overlays is printed */ 

Running Print Server 
Print Server contains an auto refresh feature that searches the print queue for jobs designated 
for that printer after a specified period of time. To determine the refresh rate, proceed as follows:  

1. Select Setup > Refresh Time Setup.  
2. In the Refresh Print Server Queue Every ….Seconds field, enter a number up to 60. 

3. To save the setting, click OK. 
4. To retain a log of all unprocessed print jobs or of all print jobs, both processed and 

unprocessed, select or clear the Store Only Unprocessed Jobs in Log box. 
5. To start Print Server, click Start Server. 

The status window displays the number of print jobs in the queue for the device. 

6. To stop the server, click Stop Server. 
7. To save the current window configuration, click Save Configuration. 

Exigen Workflow Print Monitor 
The Print Monitor application manages jobs in the print queue. All print jobs sent to all 
registered devices are listed in the Print Monitor. They can then be rescheduled, rerouted, 
suspended, or deleted as necessary. 
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Print Monitor is located in Exigen Workflow Explorer, in the Administration Tools folder, in the 
Servers subfolder. 

To open the Print Monitor window, double click the Print Monitor icon. 

 

The Workflow Print Monitor window appears. 

 
Figure 5: Print Monitor window 

A status box displays the number of items in the list and the sort order. 

All pending print jobs are shown in a table with the following details: 

Print Monitor window print jobs 
Column Description 
Job # Sequential internal number assigned to each print job.  
User ID User who initiated the print job. 
Doc # Internal document number, if a single document is being printed. 
Fld. # Internal folder number, if an entire folder is being printed. 
SubFld # Internal subfolder number, if a whole subfolder within a specific folder is 

being printed. 
Parc. # Internal parcel number, if a whole parcel is being printed. 
Workstation Workstation ID from where the job originated. 
Printer/Fax Name Device name the job was sent to. 
Project ID Project that the job was created in. 
Workflow Workflow ID that the job was created in. 
Node Node ID that the job was created in. 
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Print Monitor window print jobs 
Column Description 
Copies Number of copies to be printed. 
From Page First page to be printed if the job is a single document. 
To Page Last page to be printed if the job is a single document. 
Request Post Time Time that the job was posted. 
Execute After Time assigned for the job to execute. 
Priority Print job priority. 
Err Print job status. An Err value appears if the job was suspended or if there 

was a problem with the printing process. 
Last Error Last error of a print job. 

Jobs 
The following topics are described in this section: 

• Printing Jobs 

• Deleting Jobs 

• Setting Refresh Frequency 

• Printing a Report About Pending Jobs 

• Setting Up Print Server 

• Searching Jobs 

• Changing Job Attributes 

• Viewing a Document 

• Suspending a Job 

Printing Jobs 

Jobs can be executed in Print Monitor without the individual print servers running as follows: 

• To print a job, select it and click Execute.  

• To select multiple jobs, hold down the CTRL key and select the jobs in the list.  

• To print the entire list, select Job > Select All. 

Deleting Jobs 

To delete a job, select it and click Delete. 

Setting Refresh Frequency 

To set the refresh frequency of the list, proceed as follows:  

1. Select Options > Print Monitor Setup.  
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2. In the dialog box, enter the refresh rate in seconds. 

The maximum value is 65.  

3. To display any new print jobs, click Refresh. 

Printing a Report About Pending Jobs 

To print a report listing all pending print jobs, click Print Report.  

To view individual statistics for each print device, select Monitor > Statistics. 

To print statistics, click Report. 

Setting Up Print Server 

To add, modify, or remove print devices as you use the Print Server application, select Options 
> Print Server Setup. 

Searching Jobs 

To search for specific print jobs, proceed as follows:  

1. Select Job > Search. 

The Search window appears. 

 
Figure 6: Search window 
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All column names displayed in the Print Monitor window are listed in the Field Name 
column.  

2. To search for exact matches, in the Rules column, click =.  
3. To search for approximate matches, in the Rules column, click %.  
4. To specify a date for the search, in the From column, enter an exact date or a starting date. 

5. If you are specifying a range of dates for the search, in the To column, enter the final date. 

6. To make your search case specific, select the Case Sensitive box. 

Note: Whether the Case Sensitive check box is enabled or disabled depends on database sensitivity. 

7. To run the search, click Find. 

The Filter field in the Print Monitor window displays the search criteria to help identify the 
resulting list.  

8. To change the sort order of print jobs, select a value in the Sort Order list. 

Changing Job Attributes 

To change job attributes, select a job and select Job > Job Settings. The Job # window 
appears. 
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Figure 7: Job Settings window 

You can change the following job attributes: 

Job attributes  
Column Description 
Comments Comment. Can be added or removed as necessary. 
Priority Priority. By default, jobs are assigned a priority of Normal, or 2. This can be 

changed to Low, or 1, meaning it prints last, or High, or 3, meaning it prints 
first. If all jobs are Normal, first in, first out (FIFO) parameters are used. 

Execute after Date and time when a job executes. 
Name (Device Info) Destination printer name. This can be changed by clicking Change and 

selecting another printer. 
Phone Number, User 
Name, Addressee 

Information for a device and person receiving a fax. 

Copies, From, To Number of copies and range of pages to be printed.  
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Viewing a Document 

To view the document, click Display Document.  

To view a thumbnail of the first page of each document in a folder, click Folder View. This 
button is enabled only when the job consists of an entire folder or subfolder. 

Suspending a Job 

To delay printing a job, select the job and click Suspend. The job is removed from the Print 
Monitor window and sent to the Print Server Log window.  

To access the Workflow Print Server Log window, click Pull Up Log. The Workflow Print 
Server Log window appears. 

 
Figure 8: Print Server Log window 

The Print Server Log window displays all jobs that were either suspended from the Print 
Monitor window or did not process successfully through the print server.  

To recover a suspended job, select it in the list and click Move To Queue . 
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Chapter 2: Barcode Server 
This chapter describes Barcode Server and explains how to configure, run, and specify 
advanced options.  

The following topics are described in this section: 

• Overview 

• Barcode Server Window 

• Configuring Barcode Server 

• Running Barcode Server 

• Document Status 

• Defining Advanced Barcode Server Options 

• Barcode Server Audit File 

Overview 
Barcode Server reads bar codes in documents being scanned. The server converts the values 
into commands that create parcels for the documents and populate the document index fields. 
Bar codes are useful for scanning large batches of papers because they remove the need to 
split them into parcels and smaller documents. Barcode separator sheets, blank sheets with a 
barcode on them, can be inserted to separate the batches during the document preparation 
process. To add more information to each document, stickers with the barcode on them are 
used. 

On a workflow map, Barcode Server usually follows the Scan object. 

Warning: Barcode Server does not support processing of reference documents. 

Barcode Server Window 
To open the Barcode Server window, in Exigen Workflow Explorer, double click the Barcode 
Server icon.  

 

The Barcode Server window appears. 
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Figure 9: Barcode Server window 

The window consists of the following: 

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• statistics about the number of incoming batches, processed parcels, documents, and pages. 
Documents having a Y in the Locked column are checked out for editing and cannot be 
modified. 

• status window displaying the current mode of the server 

• toggle button to display data in either Form view or Column view  

Configuring Barcode Server 
Before running Barcode Server, configure it to read the incoming barcode values.  

To configure Barcode Server, select Run > Process Setup, or double click Process Setup. 

 

The Barcode Setup window appears. 
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Figure 10: Barcode Setup window 

The window is divided into two sections: Barcode Masks and Index Fields. 

From left to right, the Barcode Masks section displays the following: 

Barcode Masks section  
Column Description 
Barcode Mask Barcode character types. 
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Barcode Masks section  
Column Description 
Size Number of characters in the barcode value. 
New Doc If Y, a new document is created when this value is read. 
New Parc If Y, a new parcel and document are created when this value is read. 

If N, a new parcel is created only if the document cannot be attached to the 
current parcel. 

Coll Parc If Y, all documents with this barcode value are placed in the same parcel 
unless logical or indexing conflicts prevent the documents from being 
placed in the same parcel.   
All documents with the same barcode value can be placed in the same 
parcel automatically if there are no indexing conflicts and the mask does not 
require creating a new parcel.  
Y is recommended for Coll Parc only if a barcode mask already has Y set 
for New Parc. 

Del Page If Y, all pages with this barcode value are deleted.  

 

The Index Fields section lists the following: 

Index Fields section  
Column Description 
Table Name Index field table name. 
Column Name Field name. 
Start Position Starting position in the field for the value. 
# of Char Number of characters in the index field. 
Trim Left If Y, trimming of leading spaces in bar code is enabled. 
Trim Right If Y, trimming of trailing spaces in bar code is enabled. 

Note: Neither the bar code nor the barcode mask can contain the @ symbol. 

Note: Two bar codes are considered identical only if the extracted symbols of both are identical. 

The following configuration tasks are performed in the Barcode Setup window: 

• Specifying the Barcode Method 

• Selecting the Barcode Engine and Format 

• Specifying Queue Settings 

• Adding, Modifying, and Deleting Barcode Masks 

• Adding, Modifying, and Deleting Index Fields 

• Setting Stop Conditions 

Specifying the Barcode Method 
The Use Software Barcoding check box is used to specify the barcode method.  
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To specify the barcode method, proceed as follows: 

1. To use the barcode software that comes with Exigen Workflow, select the Use Software 
Barcoding check box.  

2. To test what bar codes can be recognized on the page, open a page with bar codes in the 
Image Viewer.  

3. Select Barcode > Read barcode and draw a rectangle on the entire page. 

A message box is displayed with values of recognized bar codes from the selected area, if 
any.  

4. To use only the barcode information supplied in the DMS file as electronic bar code, 
deselect the Use Software Barcoding check box.  

5. To view electronic bar codes for the entire document, select Barcode > Document Info in 
the Image Viewer. 

If both electronic and graphical bar codes are found on the page, the graphical ones are 
ignored even if Use Software Barcoding is selected. 

The Use Software Barcoding check box is selected by default. As a result, the barcode 
software delivered as part of Exigen Workflow is used.  

6. To change this setting, clear the Use Software Barcoding check box. 

A confirmation dialog appears. 

 
Figure 11: Confirmation dialog for changing a setting 

7. To use the barcode software supported by the scanner, click Yes. 

Selecting the Barcode Engine and Format 
In the drop-down lists at the top of the Barcode Setup window, select the engine and format. 
Exigen Workflow supports two third-party barcode engines:  

• Axtel 

• Pegasus SmartScan Xpress Barcode   

For each workstation where this option is applied, the license for Axtel, Pegasus, or both is 
required.  
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Specifying Queue Settings 
To change property settings for the server queue, click Queue Settings. The Define Queue 
Settings dialog appears. 

 
Figure 12: Define Queue Settings dialog 

The Define Queue Settings dialog has the following tabs enabled: 

• Common Queue Tab 

• Sort Tab 

Common Queue Tab 

The Common Queue allows more than one user to pull jobs from the same location. The 
Common Queue tab displays the names of the common queues and their user IDs.  

By default the Use common queue check box is not selected. All user jobs in the server queue 
are displayed.  

To see only your jobs and the jobs that you pull from the common queue, select the Use 
common queue check box. This selection is used to run multiple instances of the server with 
different user names. Each user can process assigned and pulled jobs.  

To view the number of jobs in a common queue, click Calculate.  
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To pull jobs from one of the common queues, select the queue, and click Select. The pulled job 
appears in your queue.  

Sort Tab 

The Sort tab is used to sort jobs pulled from the common queue. The order in which the fields 
are listed in the Sort By Field table is the order in which they are presented to the user. The 
most important field, for example, bat_priority or parcel_rec_date, must be selected first. The 
jobs with the smallest value are pulled first. 

Adding, Modifying, and Deleting Barcode Masks 
To add a barcode mask, proceed as follows: 

1. In the Barcode Masks section of the Barcode Setup window, click Add. 

The Add Barcode Description window appears. 
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Figure 13: Add Barcode Description window 

2. In the Job separator parameters area, select actions to perform when a barcode of the 
specified configuration is read. 

The following table describes options in the Job separator parameters area: 
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Job separator parameters area options 
Option Description 
Create New Document New document is created each time a barcode of this configuration is 

read. 
Create New Parcel New parcel is created each time a barcode of this configuration is read. 
Collect Parcel by 
Equal 

Collects documents with the same barcode value into one parcel. This 
option works only if documents with equal barcode values are arranged 
one after another in the document set. 

Delete Page Each page containing this barcode configuration is deleted. This option is 
used for deleting barcode separator sheets. 

3. In the Barcode string field, enter the barcode mask. For your convenience, the Barcode 
Mask Setup area contains all possible mask values. To enter the corresponding character 
in the Barcode string field, click the appropriate button. 

The barcode mask indicates the types of characters that comprise the bar code. For 
example, if the barcode value is a social security number, the value of 999999999 must be 
entered for the mask. This indicates that 9 digits are the expected value. The box to the right 
of the Barcode string field displays the number of characters in the mask.  

4. To complete the barcode mask configuration, click OK. 
5. To modify the existing barcode mask, select it and click Modify to change any of the values 

in the Barcode Setup window.  

6. To delete a mask, in the Barcode Setup window, select the mask and click Delete.  

Adding, Modifying, and Deleting Index Fields 
Once a barcode mask is set up, index fields can be assigned and populated with the value of 
the mask. The system reads the barcode font, translates it into text, and inserts that value into 
the appropriate table and column. 

To add an index field, proceed as follows: 

1. In the Barcode Setup window, select the appropriate barcode mask. 

2. Beneath the Index Fields table, click Add. 

The Add Assignment Fields to Bar code window appears. 
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Figure 14: Add Assignment Fields to bar code 

The mask for the selected bar code appears at the top. 

3. To assign an index field, beneath the Table Name field, select one of the following tables:  
• FOLDER 
• SUBFOLDER 
• DOCUMENT 
• BATCHPARCEL 

The system uses only these four tables at the indexing level. 

User-defined fields appear in the Field Name box. 

4. Select a field to fill. 

The system automatically inserts the Start Position into Barcode and Barcode Segment 
Length values based on the size of the barcode mask. Changing the start position adjusts 
the segment length accordingly. 

5. To trim extra spaces in bar code, select the following options:  
Options for trimming extra spaces 
Option Description 
Trim Left Deletes leading spaces. 
Trim Right Deletes trailing spaces. 
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Trim Left and Trim Right Deletes extra spaces from both sides. 

6. To configure the index field, click OK. 
7. To modify the start position of an index field bar code, click Modify in the Barcode Setup 

window.  

To change the table or field name, delete the existing record and add a new one.  

To delete a record, select it and click Delete. 

Setting Stop Conditions 
To set conditions for stopping Barcode Server, proceed as follows: 

1. In the Barcode Setup window, click Stop Conditions. 

The Stop Conditions window appears. 

 
Figure 15: Stop Conditions window 
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2. To select a field for defining the condition, in the Document Fields list, click a field name.  

The field name appears in the Stop When section. 

3. To set conditions on the values for stopping the server, at the bottom of the window, click an 
operator, for example, AND, OR, or =.  

The operator appears in the Stop When section. 

4. To finish specifying the condition, in the Stop When section, enter values, field names, and 
operators as required.  

5. To save changes, click OK. 

Running Barcode Server 
To run Barcode Server, click Start Server.  

If the Auto Send and Server Mode options are selected in the Run menu, the jobs to be 
processed are loaded by batch into Barcode Server. When a barcode value is recognized, it 
appears in the Additional Info column in the table.  

Note: Barcode Server recognizes only black-and-white images. 

After the entire batch is processed, the new parcels and documents are automatically sent to 
the next queue, and the processing of the next batch begins. 

If no selections are made each new parcel must be manually sent to the next queue by clicking 
Send Batch.  

The status window displays the processes being performed and the time elapsed. 

To stop the server, click Stop Server. 

For information on maintaining Barcode Server as a service, see Appendix B: Maintaining 
Exigen Workflow Servers as Services. 

Document Status 
Each document processed by Barcode Server is automatically assigned a status. The status 
appears in the FLG_JOB and FLG_BAR fields of the DOCUMENT database table.  

The following table describes Barcode Server document statuses: 

Barcode Server document statuses 
Status FLG_JOB field value  FLG_BAR field value 
Document processing is successful, and at 
least one bar code matching a specified 
mask is recognized. 

BarOk BarOk 
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Barcode Server document statuses 
Status FLG_JOB field value  FLG_BAR field value 
Document processing is successful, but 
the document contains no bar codes that 
match the specified masks. 

NoBar NoBar 

Document processing stopped after stop 
condition was fulfilled.  

Err## Err## 

Document is not in DMS format, is 
corrupted, or cannot be opened. 

ERDMS ERDMS 

Defining Advanced Barcode Server Options 
The following topics are described in this section: 

• Verifying the Number of Separated Documents and Parcels 

• Assigning Document Types 

• Setting the Maximum Size of Processed Pages 

Verifying the Number of Separated Documents and Parcels 
Barcode Server contains a configuration for splitting the incoming batches into separate 
documents and parcels according to the read barcode values. For information on splitting a 
batch into documents and parcels, see Adding, Modifying, and Deleting Barcode Masks. 

Barcode Server can be configured to check the expected number of documents and parcels in a 
batch, and the actual number of separated documents and parcels. 

To enable Barcode Server to verify the number of separated documents and parcels, in the 
BATCHPARCEL table, create the following custom fields: 

Additional BATCHPARCEL table fields 
Field Name Description 
A_DOCTOTAL Expected number of documents. 
A_DOCCOUNT Actual number of documents produced by Barcode Server. 
A_PRSTOTAL Expected number of parcels. 
A_PRSCOUNT Actual number of parcels produced by Barcode Server.  

All the fields must be type INTEGER and the Null is not allowed check box must be 
unselected. 

For information on adding table fields, see the Exigen Workflow Administrator’s Guide, Part 1: 
Design and Configuration, Chapter 3: Creating Projects. 

When the new table fields are created, the additional fields are available in the scan dialog in all 
workflow nodes that have the scan functionality. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 2: Barcode Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 38 of 391 

 
Figure 16: Parcel and document counter fields in the scan dialog 

The following table describes additional fields in the scan dialog: 

Additional scan dialog fields 
Field Name Description 
# of Parcels Expected number of parcels in the batch entered by the user that performs 

scanning. This number cannot exceed 999. 
# of Docs Expected number of documents in the batch entered by the user that performs 

scanning. This number cannot exceed 999. 
Counted Parcels Actual number of parcels produced by Barcode Server. 
Counted Docs Actual number of documents produced by Barcode Server. 

Values in the # of Parcels and # of Docs fields are entered by a user during scanning. After 
Barcode Server finishes processing the documents, it checks the actual results against the 
values entered during scanning. If the results do not match, the document is marked with the 
ERR## status and handled according to the routing rules for Barcode Server. 

Assigning Document Types 
By default, Barcode Server assigns numerical values for a document type. It is also possible to 
predefine textual values that can be read by Barcode Server and assigned as a document type. 
To assign this functionality, proceed as follows: 

1. In the Exigen Workflow Explorer window, select Database Tools and double click Project 
Builder.  

The Project Builder window appears. 

2. Select a project and click Project Maintenance . 

3. Select the DOCTYPE table and click New Field . 

4. In the Field Name field, enter A_BARVALUE. 
5. In the Field Type list, set the field type to INTEGER. 
6. To save settings, click Apply. 
7. To close the window, click Close. 
8. Exit Project Builder. 
9. In the Exigen Workflow Explorer window, select Workflow Tools and double click 

Administrator.  
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10. In the Administrator Utilities window, select a project and click Table Maintenance . 

11. Select the DOCTYPE table and click Run. 
12. In the Document Types window, click New Record. 
13. In the New Record window, enter a document type value next to the A_BARVALUE field 

description. 

14. To add as many document types as needed, repeat steps 12 and 13. 

When the document type values are assigned, Barcode Server looks for the value in the 
A_BARVALUE column of the DOCTYPE table. If it finds a matching value, a letter string of the 
corresponding DOC_TYPE column is assigned to the document. Otherwise, it assigns a 
numerical barcode value. 

Setting the Maximum Size of Processed Pages 
To set the maximum size of pages processed by Barcode Server, in the visiclt.ini file in 
the [setup_barcode] section, add the following parameter: 

MaxPageSize=<size in kilobytes> 

Barcode Server skips all pages that are larger than is specified in the MaxPageSize parameter. 

The default value for the MaxPageSize parameter is 250. 

Barcode Server Audit File 
If errors occur during barcode processing, Barcode Server creates the barlog folder with a 
Barcode Server audit file in the folder where the processed document image is located. The 
Barcode Server audit file has the same file name as the document image file and has file 
extension txt. 

The Barcode Server audit file logs information on two types of problems that may occur during 
batch processing: 

• The expected number of documents and parcels differs significantly from the actual number 
of documents and parcels scanned. 

• An error related to stop conditions occurs. 

For information on setting the expected number of documents and parcels, see Verifying the 
Number of Separated Documents and Parcels. For information on stop conditions, see 
Setting Stop Conditions. 

 



Administrator's Guide, Part 2: Business Component Reference  Chapter 3: Form OCR Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 40 of 391 

Chapter 3: Form OCR Server 
This chapter describes how to configure and run Form OCR Server. The following topics are 
described in this section: 

• Overview 

• Form OCR Server Window 

• Configuring Form OCR Server 

• Testing Form OCR Server Configurations 

• Running Form OCR Server 

Overview 
Form OCR Server extracts OCR data from incoming documents based on templates created 
by the Template Management Utility. For more information on the Template Management Utility, 
see the Exigen Workflow Administrator's Guide, Part 3: Utilities, Chapter 8: Template 
Management Utility. The zone data is used to populate database fields defined in form 
templates. 

Form templates are registered in Form OCR Server and are associated with database fields. 
Confirmation levels and default and substitute values are assigned to ensure zone data 
integrity, and to route the documents. Post processing tools allow you to add, delete, or replace 
specified values to maintain consistency in the way the data is eventually displayed.  

Warning: Form OCR Server does not support processing of reference documents. 

Form OCR Server Window 
To open the Form OCR Server window, in Exigen Workflow Explorer, double click the Form 
OCR Server icon. 

 

The Form OCR Server window appears. 
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Figure 17: Form OCR Server window 

The Form OCR Server window consists of the following features and information:  

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• information about the number of incoming batches, processed parcels, documents, and 
pages. Documents having a Y in the Locked column are checked out for editing and cannot 
be modified.  

• status window displaying the current mode of Form OCR Server 

• toggle button to display data in either Form view or Column view, or table view 

Configuring Form OCR Server 
Before running Form OCR Server, it must be configured. To configure Form OCR Server, 
proceed as follows: 

1. Select Run > Process Setup or Process Setup. 

The Process Setup window appears. 
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Figure 18: Process Setup window 

The table at the top of the window displays data specific to the form templates that are already 
configured. The columns display the following information: 

Form template  
Column Description 
Form Name Form template name. 
Pg Form page where the signature zone is located. 
Zone Name Signature zone name. 
Row Zone row that the data is extracted from. 
Identification (Signature) Form template signature identifier. 
Identification (BarCode) Form template Signature bar code. 
Identification (Doc. Type) Form template Signature document type. 
New Doc New document is created when the form template is recognized. 
New Parc New parcel is created when the form template is recognized. 
Coll Parc Form templates read and assigned to the same folder are merged into the 

same parcel. 
Del Page Page where the form signature appears is deleted. 
Advanced Advanced font is set. 
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2. To add, modify, or delete template assignments, click Add, Modify, or Delete to the right of 
the table. 

For more information on adding or modifying a form template, see Registering Form 
Templates. 

3. To configure the form signature flexible search options, click Advanced Search. 

For information on the form signature flexible search, see Using Form Signature Flexible 
Search. 

The Fields assigned to the form table at the bottom of the window displays the database fields 
that are populated by data extracted from specified zones of the form template. The columns 
display the following information: 

Fields assigned to the form  
Column Description 
Table Name Table to be updated by the zone data. 
Field Name Field to be updated by the zone data. 
Zone Name Zone that the data is extracted from. 
Zone Verification Mask Data mask expected in the extracted data. 
Start Pos Position in the zone where the data begins. 
# of Char Number of characters to be extracted from the zone. 
Row Row in the zone that the data is extracted from. 
Default value Default value to be assigned if the zone is blank. 
Post Proc Post processing rules are set to this zone. 
Validation Field validation rules are set to this zone. 
Advanced Advanced font is set to this zone. 

4. To add, modify, or delete zone assignments for the selected template, click Add, Modify or 
Delete to the right of the table. 

5. To set up the zone data flexible search, click Advanced Search. 

For information on the zone data flexible search, see Using Zone Data Flexible Search. 

6. To assign post processing rules to the zone, click Post Processing.  
7. To assign field validation rules to the zone, click Field Validation. 

For information on database fields and template zones, see Associating Database Fields 
with Template Zones. 

The Process Setup window is used to perform the following configuration tasks: 

• Registering Form Templates 

• Associating Database Fields with Template Zones 

• Post Processing Window 

• Validating Fields 



Administrator's Guide, Part 2: Business Component Reference  Chapter 3: Form OCR Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 44 of 391 

• Using Form Signature Flexible Search 

• Using Zone Data Flexible Search 

Registering Form Templates 
To register form templates, proceed as follows:  

1. In the Process Setup window, click Add. 

The Add Form Identification window appears. 

 
Figure 19: Add Form Identification 
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The Add Form Identification window registers new form templates. The Modify Form 
Identification window changes existing form template IDs in Form OCR Server. Before form 
templates can be registered, they must be created using the Template Management Utility. 
For more information on form templates, see the Exigen Workflow Administrator's Guide, 
Part 3: Utilities, Chapter 8: Template Management Utility. 

2. In the Add Form Identification window, specify the following settings: 
Add Form Identification settings 
Setting Description 

Search By Indicates which signature or combination of signatures can be used to identify the 
form template. The following options are available: 

• Form Signature: only used to search for a matching template. This option 
results in the longest query; therefore the other two options must be used 
whenever possible. 

• Form Bar Code: all templates are first checked for a matching barcode 
mask and the resulting templates checked for the matching signature 
zone. This option must be used when using multiple templates.  

• Doc. Type: only those documents assigned the same document type are 
checked for a matching signature zone. If you are assigning document 
types at the scanning level, this option must be used. 

Quality Identify the quality of the zone data to be read. The following options are available: 

• Laser Print: incoming forms are generated by a laser printer. This results 
in the highest level of recognition. 

• Dot Matrix: incoming forms are generated by a dot-matrix printer. If both 
laser and dot matrix printing are anticipated, this option must be used. 
Note that dot matrix results in a lower level of recognition. 

• Hand Print: incoming forms are mostly hand printed. This results in a low 
level of recognition due to different writing styles. 

Job Separations Determine what database actions can be taken when the form template is 
recognized. The following options are available: 

• Create New Document: when the form template signature is recognized, 
a new document record is created in the database. 

• Create New Parcel: when the form template signature is recognized, a 
new parcel record is created in the database. 

• Collect Parcel by Equal: if the same template signature is recognized 
and the documents are assigned to the same folder, all documents are 
merged into the same parcel. 

• Delete Page: when the form template signature is recognized, the page 
where it exists is deleted. 

Template name Displays all form templates that are created in the database. The template name is 
clicked to select it for registration. The template name appears in the top field. 

Page 

 

Value in the first field defaults to page 1 with the total number of pages in the 
template on the right. Signature fields can be assigned on any page of a template; 
however, each page must be registered in Form OCR Server. The arrow buttons 
are clicked or a number is entered to identify the page of the template where the 
associated signature is located. 
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Add Form Identification settings 
Setting Description 

Barcode If Form Bar Code is selected in the Search by section, this block is enabled.  

The engine and format are selected in the drop-down lists. Exigen Workflow 
supports the following third-party barcode engines: 

• Axtel 
• Pegasus SmartScan Xpress Barcode 

For each workstation where this option is applied, the license for Axtel, Pegasus, 
or both is required. 

The barcode mask is used to identify the form template. When Form OCR Server 
reads the form templates and locates this barcode mask, it searches only those 
templates containing the same barcode mask for a matching signature zone mask. 

Doc. Type Enables allowing a document type to be selected in the list box if Doc. Type is 
selected in the Search by section. Only documents assigned the same document 
type are checked for the signature zone. The document type can be assigned 
either during scanning or by Barcode Server. 

Form signature 
zone 

Displays all zones assigned to the selected page in the selected form template. In 
this list, select the zone designated as the signature zone when the form template 
was created. 

Form signature 
mask 

Anticipated mask for the signature zone. If this mask is not located during Forms 
OCR Processing, the form template zones and data is not applied or read. This is 
entered using the 10 buttons in this area of the window, or by entering a value. 

The exact signature zone data can be entered to ensure that a match is found. For 
example, if the signature zone for a specific form is the word INVOICE, the mask 
can be set up as either AAAAAAA or INVOICE. By using INVOICE, you ensure 
that an exact match is made and also free up the signature mask for another 7-
alpha character mask to be used for a different form template. 

Justification Identifies where in the zone the data is extracted from. There are the following 
justification options: 

• None: no justification is performed in the zone. All data in the zone is 
extracted. If the zone fits exactly around the data, this option must be 
used.  

• Left: the zone search begins from the left side of the zone. This option 
must be used if the zone is a text field that has varying lengths.  

• Right: the zone search begins from the right side of the zone. If the zone 
data is typically right justified, as in dollar amounts, this option must be 
used. 

Row to extract Selects the row in the zone that is extracted for the form template signature. If the 
zone contains only one row, 1 is entered in this field. 

Advanced Font Opens the Advanced Font Settings window. In the window, a language can be 
specified in the list, and which characters can be ignored. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 3: Form OCR Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 47 of 391 

 
Figure 20: Advanced Font Settings 

The following topics are described in this section: 

• Specifying Advanced Font Settings 

• Adding a Form Identification 

• Examples of Form Bar Code and Document Type Usage 

Specifying Advanced Font Settings 

To specify font settings for zones, proceed as follows: 

1. In the Add Form Identification window, click Advanced Font. 

The Advanced Font Settings window appears. 

2. In the Advanced Font Settings window, in the Language Name field, select a language. 

3. To specify characters to be removed, in the Ignore characters section, enter characters in 
any of the corresponding fields: 
• At the beginning of the word 
• At the end of the word 
• Anywhere in the word 
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4. To retain characters with a low OCR process confidence level, select the Keep if suspect 
option for the corresponding field. 

A low OCR process confidence level means that the character can be easily misread or 
confused with another character, for example, the letter l and the number 1. 

5. To save changes and close the window, click OK.  
6. To clear entries in the window, click Clear All. 
7. To close the window without saving changes, click Cancel. 

Adding a Form Identification 

To add a form identification, proceed as follows: 

1. In the Template name list, select a template to register. 

All created templates are listed, regardless of the project or workflow to which they belong. 
The current template page number, scroll arrows, and the total number of pages that exist in 
the form template are displayed. Since signatures and zones can be assigned to multiple 
pages of a form template, the scroll arrows differentiate between the pages. 

2. In the Form signature zone, click on the zone name defined as the signature zone for the 
selected template. 

The zone name appears in the top field.  

3. In the Form signature mask field, click the buttons to define a mask for the signature 
values, or enter the specific text value identified in the signature zone. If your signature 
consists of a specific value on the form, enter the actual value in the mask field. 

For example, the signature zone for the PO TEMPLATE is defined as the words 
PURCHASE ORDER. The mask could be defined as AAAAAAAA AAAAA representing an 
8-character, uppercase, alpha-text value followed by a space and a 5-character, uppercase, 
alpha-text value. By defining the mask as PURCHASE, you guarantee that the PO 
TEMPLATE zones are assigned only when those specific characters are recognized. It also 
cuts down on the processing time, because there can be more than one form template 
signature containing the same number of words and characters. 

4. Specify justification. 

Justification is important because it indicates where in the zone the mask is located. 
If None is selected, the system expects that the information in the zone exactly matches 
what is anticipated in the mask. For example, if the signature zone is a social security 
number, the zone can be created around the 9-digit number on the form. The mask is 
999999999 and the justification is None.  

During Form OCR processing, if the 999999999 mask is located exactly in the same zone 
as indicated in the form template, the system finds a match and the remaining zones in the 
template are applied to this form.  

5. To match the mask in the left portion of the zone, specify Left justification.  
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Using the example of the previous PURCHASE ORDER signature zone, the justification 
must be set at Left to ensure that, when the system searches for the mask, PURCHASE is 
in the left portion of the zone. If None is chosen, the system tries to match the mask 
PURCHASE with all of the text in the zone, which in this case is PURCHASE ORDER. 
Obviously no match can be found and the form is not recognized. 

6. To define masks for text that is normally right justified, such as dollar amounts, select Right 
justification.  

For example, if the signature zone for a form template is the total dollar amount, the logical 
mask is 99999.99. The signature zone is created around the area on the form where the 
amount is located. Since the value found in this zone can vary, such as 10.00 or 978.12, the 
None option does not work to find an exact match. Left justification does not match the 
mask because the value .99 always appears on the right. Right justification ensures that 
matching values are always found for this zone.  

7. In the Row to extract field, define the row in the zone where you want to extract the data.  

8. To save the new form template in the list, click Apply. 
9. To close the window without saving the template configuration, click Close. 
10. To modify an existing form template configuration, in the Process Setup window, select the 

desired template and click Modify. 
11. To delete a form template configuration, but not the template itself, select the template and 

click Delete. 

The template can no longer be used in the current Form OCR Server. 

Examples of Form Bar Code and Document Type Usage 

If the Form Bar Code option is selected in the Search by section in the Process Setup 
window, Form OCR Server searches for a unique combination of both the signature zone and a 
barcode value to identify a specific form template.  

When the Form Bar Code option is selected, the Barcode mask is enabled.  

Enter the barcode mask directly into the field to define the anticipated bar code. This feature is 
recommended if your processing is similar to the following scenario: 

Your company processes applications for employment for many businesses. Each business 
has its own unique application form requesting certain information. For each business, the 
application title differs depending on the position being applied for.  

A barcode value that appears on the first page of each application is used internally by your 
business to identify the company where the application is used. Each individual application 
form can be configured with the application title as the signature zone. This configuration 
does not work if more than one company uses the same application title, such as General 
Sales Application. 

By using both the signature zone, or application title, and barcode value, or company code, 
as form template identifiers, the following scenarios occur: 

1. You are not forced to find a different signature zone for all of the applications.  
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2. The template search time is reduced because a match is sought first for the barcode 
value and then for the signature zone.  

If you process applications for 50 companies that each use 10 types of applications, the 
processing time is drastically reduced by using both identifiers. 

The Doc. Type selection in the Search by section is based on the same premise. The initial 
search is based on a specific document type instead of a barcode value. When this option is 
selected, the Document type list box is enabled allowing a specific document type to be 
assigned. The following business scenario represents an example of when this type of search is 
beneficial: 

Your company images invoices along with other types of documents. Each invoice contains 
different information to be extracted depending on the department being billed. The 
department code appears on each invoice. The department code on each form can be used 
for the signature zone and all appropriate information is extracted.  

In addition to the invoice form templates, you also use many other form templates. The time 
it takes to search through each form template is significantly reduced by using the 
Document type feature to identify the invoices. By assigning the Document type Invoice 
during scanning, the document type is used to narrow the initial search. 

Associating Database Fields with Template Zones 
After registering a template in Form OCR Server, you can identify which database fields you 
want to populate with the data extracted from the template zones. A record is created for each 
template zone, and only one-to-one zone-to-field assignments can be configured. 

To add field configurations, proceed as follows: 

1. In the Process Setup window, click Add next to the Fields Assigned to Form table. 

The Add Field Value Assignment window appears. 
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Figure 21: Add Field Value Assignment 

2. In the Table Name list, select the table to update. 

When a table is selected, its fields are listed under Field Name.  

3. Select a field to update. 

4. In the Zone Name list, select the template zone that you want to use to populate the field 
value. 

5. In the Start Position into Zone field, enter the starting field position for extracting data from 
the zone. 

The Zone Segment Length displays the length of the Zone Verification Mask. The mask 
defaults to the length defined when the form template was created. The default value is 64. 
The Zone Length by Definition displays the actual length of the zone. The default value is 
64. 
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6. In the Row to Extract field, select the row where you want to extract the data. 

Zones can include multiple rows on a form, such as an address field. 

7. To extract only city, state, and ZIP information, define the entire address as the zone but 
extract data only from row 3. 

8. To ensure that your mask is located in the assigned zone, in the Content Justification field, 
specify content justification.  

9. To specify the importance of the data being extracted, in the Confirmation Level field, 
select one of the following confirmation levels: 
Confirmation levels  
Name Conditions for use 
High If Form OCR Processing is used to populate index fields in the database, 

the High confirmation level is recommended for those fields. 
High ensures that the value exactly matches the mask data during the 
verification process. 

Med If the values are important but are not necessarily index values, Med is 
used. 

None and Low If values are useful but not required, None or Low is used. 

10. Click the buttons at the bottom, or enter the Zone Verification Mask. 

The Zone Segment Length field adjusts to the number of characters you enter for the 
mask.  

The Field Default Value field can be used for two purposes:  

• To set up a template to read a zone on a form that does not contain data but requires a 
value in the database. When configuring the field, you can indicate that you do not want 
to select data from any row, and insert the default value that you want to populate the 
database with.  

• To assign a specific value to a field if Form OCR Processing cannot locate or interpret 
the text contained in the zone.   

11. To specify the form quality, select an option in the Quality section. 

For information on quality settings, see Registering Form Templates. 

12. To specify the preferred character set, select an item in the Preferred Char. Set field. 

The preferred character set determines the type of characters expected by Form OCR 
Server. By defining the type of characters to be searched for, Form OCR Server bypasses 
those that do not meet the criteria and improves the processing speed. This setting differs 
from the characters used to create the Zone Verification Mask. The following table lists the 
values and their meanings: 

Preferred character set 
Value Description 

ANSII (Any 
Character) 

Form OCR Server searches for any character type. Select this setting only if 
none of the others apply. 

Alpha Lowercase Form OCR Server searches for alpha, lowercase characters only. 
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Preferred character set 
Value Description 

Alpha Uppercase Form OCR Server searches for alpha, uppercase characters only. 

Alpha Mixed Case Form OCR Server searches for alpha characters only. 

Digit (0….9) Form OCR Server searches for numeric characters only. 

Alpha Digit (a…9) Form OCR Server searches for both alpha and numeric characters. 

Numeric  
(9,+%-$) 

Form OCR Server searches for both numeric and special characters 
normally associated with numeric values. 

Check Box Form OCR Server searches for a mark or value inside a check box. 

Barcode Form OCR Server searches for a bar code. 

13. When all values are entered, to add the field to the Process Setup window, click Apply. 
14. To cancel all changes, click Close. 
15. To open the online help section for the Add Field Value Assignment window, click Help. 
16. To modify an existing field assignment record, select the record and click Modify. 
17. To remove a field assignment from a template configuration record, click Delete. 

Post Processing Window 
The tools in the Post Processing window format the data extracted from the zones. For 
example, to ensure consistency in your database, you may want all phone number values to be 
displayed simply as 9999999999. By deleting specific characters, the data can be displayed in 
the same format, regardless of the original format of the data that was extracted. 

To open the Field Processing Settings window, select the zone record in the bottom table and 
click Post Processing in the Process Setup window. The Field Processing Settings window 
appears. 
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Figure 22: Field Processing Settings 

The window displays the Variable Type, or String, for the selected field. This value is derived 
from the Field Type assigned in the Project Builder application. The variable type is assigned 
as follows: 

Variable and field types  
Variable type Field type 
Date/Time DATE, TIME, DATETIME 
Number FLOAT, INTEGER, SMALLINT 
String CHAR, VARCHAR 

The three buttons to the right of the Variable Type are used with the three options in the 
Symbols section. Using the buttons with the commands, you can adjust the extracted data so 
that it appears uniformly in the database. 
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For example, phone numbers can be written as (999) 999-9999, (999)999-9999, or 999-999-
9999. Using Delimiter and the Remove All command, all phone numbers can be adjusted to 
display in the database as 9999999999. 

The following buttons are available in the Field Processing Settings window. 

 
Field Processing Settings window buttons 
Button Description 

Value Identifies the entire text being extracted from the image. 

Any Character Identifies any character found in a specific position in the extracted text. 

Delimiter Defines specific characters or character strings within the extracted text. 
 

The Field Processing Settings buttons are used with the three fields in the Symbols label. 

Field Processing Settings Symbols fields 
Field Description 

Remove All Removes specific values from the extracted text. To remove the entire value, or 
delete everything extracted, click Value once. To remove multiple characters or 
character strings within the extracted text, click Delimiter. Delimiter must be 
inserted after each character or character string that is to be removed. 

Insert Only Inserts the value entered in the field. 

Delete Only Deletes the value entered in the field. 
 

If you are extracting a dollar amount field from an image but do not want the dollar sign to 
appear in the database, the Remove All value appears as follows: 

 

Incoming text extracted as $123,000.55 is displayed in the database as 123,000.55. 

In the previous phone number example, the characters “(,” “),” [space], and “—” must be 
deleted. Each character is entered in the Remove All field with the delimiter between each. The 
Remove All value appears as follows: 

 

Incoming text extracted as (212) 555-1212 appears in the database as 2125551212. 

To insert a character or string before the extracted data, in the Insert Only field, click Value, 
and enter the character or string. If the phone numbers being extracted from the image are 
formatted as 9999999999 and you want to insert the “(,” “),” [space], and “—” characters, the 
Insert Only value appears as follows: 
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The values inserted are entered into the field. The x marks identify individual clicks on Any 
Char to represent any character in the field. Incoming text extracted as 2125551212 is 
displayed in the database as (212) 555-1212. 

To insert a character or string before the extracted data, in the Insert Only field, click Value and 
enter the character or string. For example, if the data being extracted is a dollar amount with no 
dollar sign and you want to view the dollar sign in the database, the Insert Only field appears 
as follows: 

 

To enter the dollar sign in the field, click Value. Incoming text extracted as 123,000.00 displays 
in the database as $123,000.00. 

To insert a character or string after the extracted data, enter the character or string and click 
Value. For example, if the data being extracted is in whole dollar amounts but you want to also 
see the cents, the Insert Only field appears as follows: 

 

When Value is clicked the text you want to insert is entered. Incoming text extracted as $125 
displays in the database as $125.00. 

Delimiter does not apply to the Insert Only option. 

The Replace section removes and replaces specific characters or strings.  

Field Processing Settings, Replace fields 
Field Description 

Current 
Symbols 

Extracted character or string to be replaced. 

To replace more than one character or string, Delimiter is clicked to separate the 
values. 

To replace all of the extracted data in the zone, Value is clicked. 

Required 
Symbols 

Values to be replaced. 

If more than one character or string is to be replaced and the Delimiter tool is 
used to separate them in the Current Symbols field, one or more values can be 
entered in the Required Symbols field. 

If all values entered in the Current Symbols field are to be replaced with one 
value, that value is entered in the Required Symbols field.  

If multiple values are replaced, delimiters must be used in the Required Symbols 
field. If two or more replacement values are entered in the Required Symbols 
field, the number of values in the Current Symbols and Required Symbols fields 
must be equal. 

For example, if the values @, # and $ are to be replaced and they are separated 
by delimiters in the Current Symbols field, three values separated by delimiters 
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Field Processing Settings, Replace fields 
Field Description 

must appear in the Required Symbols field. 

Format Formats the extracted data based on the Variable Type. The following string 
formats are available: 
• Lowercase 
• Unformatted 
• Uppercase 
For date and time, predefined formats can be used, or another format can be 
entered. The format is selected with which you want to populate the database.  

Note: Date and time are recognized according to the specified format. 

The Order of Processing box is used to change the order in which any post processing 
functions are executed. 

To set the order of processing, proceed as follows: 

1. Select a function. 

2. To move each function within the list, click the up, yellow, and down, green, arrow keys. 

3. If you are using post processing to perform more than one of the available functions, make 
sure the order is correct or you may not achieve the desired results. 

4. Test your settings. 

The Experimental Area tests the post processing changes.  

Field Processing Settings, Experimental area 
Field Description 

Experiment Mode Enables the test function. 

Input Value that represents the text being extracted from the zone. 

Output Displays all post processing changes made to the value entered in the Input 
field. 

Type Identifies the extracted data type. Types are Select String, Number, or 
DateTime. 

Post processing occurs during the Form OCR Index process and the adjustments are not visible 
during the Form OCR QA process. 

Validating Fields 
The Field Validation option ensures that the extracted data matches the data in an existing 
table. By performing validation, you can ensure that the database is populated with the correct 
values. 

To use Field Validation, proceed as follows: 

1. In the Process Setup window, select the field to validate and click Field Validation. 
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The Zone Validation Settings window appears. 

 
Figure 23: Zone Validation Settings 

2. In the Validation Table field, enter the table in which the values exist. Enter the entire table 
name including the project ID because you can use tables from other projects in the same 
database for validation. 

3. In the Validation Field, enter a column or field name. 

This field must exist in the Validation table.  

4. To substitute a value, enter a column name in the Substitution Field. 

The field must exist in the Validation table.  

Using Form Signature Flexible Search 
The flexible search feature expands the possibilities of the form signature search and enables 
the following options: 

• processing complicated forms in which the data location is not determined 

• using one template for similar forms with minor data positioning differences 

The following topics are described in this section: 

• Searching for Form Signature 

• Searching for Form Signature by Pattern 

• Setting Up the Advanced Search Options 

Searching for Form Signature 

This feature searches for the form signature defined when registering the form templates. For 
information on registering the form templates, see Registering Form Templates. 
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The flexible search defines the lines to search, vertically or horizontally. The procedure uses the 
best-fit search algorithm; the first result found according to the search options is returned. The 
best-fit algorithm is activated if no search pattern is defined. 

Searching for Form Signature by Pattern 

This feature searches for the form signature defined when registering the form templates by 
search pattern. For information on registering the form templates, see Registering Form 
Templates. 

The flexible search by pattern has the following algorithm: 

1. It searches for the pattern as defined in the search lines. 

2. If the pattern is found, it searches for the form signature according to the data position 
relative to the pattern defined. 

3. If the form signature is found, it returns the result. 

4. If the pattern or form signature is not found, it performs the best-fit search algorithm for the 
form signature and returns the first result found.  

For information on the best-fit algorithm, see Searching for Form Signature. 

Setting Up the Advanced Search Options 

To set up the advanced search options, proceed as follows: 

1. In the Process Setup window, select the form identification or the zone verification. 

2. Click Advanced Search. 

The Advanced Search Options window appears. 
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Figure 24: Setting the advanced search options 

The Advanced Search Options window lists all the existing configurations. The following 
table describes the window columns: 

Advanced Options window columns 
Column Description 
Configuration Name Names of all existing configurations. 
Best Fit Indicates whether the best-fit algorithm is used; that is, if the search pattern 

is defined. 
Pattern Patterns defined for each configuration. 

The active configuration is marked with an arrow. 

3. Select one of the following options: 
• To create a configuration, click New. 
• To modify a configuration, click Modify. 
• To delete a configuration, click Delete. 
For information on creating a configuration, see Adding a Configuration. 

For information on modifying a configuration, see Modifying a Configuration. 

For information on deleting a configuration, see Deleting a Configuration. 

4. To assign one or more configurations to the template, select the configuration and click 
Assign. 

5. To remove the configuration assignment from the template, click Unlink. 
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6. To exit, click Close. 

Adding a Configuration 

To add a configuration, proceed as follows: 

1. In the Advanced Search Options window, click Add. 

The Add Configuration window appears. 

 
Figure 25: Add Configuration window 

2. Specify the following options: 
Configuration options 
Option Description 
Configuration Name Configuration name. 
Search Pattern Pattern to search for. 
Vertical Direction Searches vertically.  

If the search pattern is used, this option is disabled. 

Note: Only the first value found is returned. 

Horizontal Direction Searches horizontally.  

Note: Only the first value found is returned. 

Lines To Search Line interval for the search. 
Data Position Relative to 
Pattern 

Position of the mask relative to the defined pattern.  
This option is enabled only if the search pattern is defined. 

3. To save the configuration, click Save. 
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Modifying a Configuration 

To modify an existing configuration, proceed as follows: 

1. Select the configuration to be modified. 

2. Click Modify. 
3. Set the necessary configuration options.  

For information on the configuration options, see Adding a Configuration. 

4. Click Save. 

Deleting a Configuration 

To delete a configuration, proceed as follows: 

1. Select the configuration to be deleted. 

2. Click Delete. 

You cannot delete a configuration that is used by another template. If you try to delete a 
configuration in use, an error message appears. 

Using Zone Data Flexible Search 
The flexible search feature expands the possibilities of the zone data search. This feature 
performs the following actions: 

• Searching for Zone Data 

• Searching for Zone Data by Pattern 

• Setting Up Advanced Zone Search Options 

Searching for Zone Data 
This feature searches for the zone data defined when associating database fields with template 
zones. For information on associating database fields with template zones, see Associating 
Database Fields with Template Zones. 

The flexible search for the zone data defines the lines to search, vertically or horizontally. The 
feature uses the best-fit search algorithm; the first result found according to the search options 
is returned. The best-fit algorithm is activated if no search pattern is defined. 

Searching for Zone Data by Pattern 

This feature searches for the zone data defined when associating database fields with template 
zones by the search pattern. For information on associating database fields with template 
zones, see Associating Database Fields with Template Zones. 

The flexible search by the search pattern has the following algorithm: 

1. It searches for the pattern in the search lines defined. 
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2. If the pattern is found, it searches for the zone data according to the data position relative to 
the pattern defined. 

3. If the zone data is found, it returns the result. 

4. If the pattern or zone data is not found, it performs the best-fit search algorithm for the zone 
data and returns the first result found.  

For information on the best-fit algorithm, see Searching for Zone Data. 

Setting Up Advanced Zone Search Options 

The zone data advanced search is set up in the same way as that for form signature. For 
information on setting up the form signature advanced search, see Setting Up the Advanced 
Search Options. 

Testing Form OCR Server Configurations 
Before using Form OCR processing, it is recommended that you test Form OCR Server 
configurations to make sure that all zone templates are read properly, for example, by sending a 
batch of scanned documents containing the templates to Form OCR Server. 

To test the Form OCR Server configurations, proceed as follows: 

1. Open the Form OCR Server window and, in the Run menu, deselect the Autosend option.  

2. Select Run > Start Test. 

The Form Recognition Test window displays the test data in the middle of the window.  

3. To begin testing, click Start Processes. 

The first page of the batch is displayed in the Form Recognition Test window. As each 
template is read, the Form Recognition Test window title is replaced by the word identification, 
followed by the zone mask and the page where the zone is found. The value found in the zone 
is displayed in a separate window with a status message. 

The following table describes message text values: 

Status messages 
Message Description 

Zone Recognition 
Successful 

Zone was located, but the value inside matches the zone mask. 

Quality Check is not 
Confirmed 

Zone was located, but the confirmation level of the value inside has not 
been reached. 

Mask Verification Check 
is not Confirmed 

Value inside the zone does not match the zone mask. 

The test stops after each zone is read. To continue testing, proceed as follows: 

1. To test the next zone, in the Zone Value window, click OK.  
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2. To stop the test at any time, click Stop Processes.  
3. To make appropriate changes, click Process Setup. 

The test can be started as many times as necessary.  

4. When testing is complete, select Run > Release Test and reselect the Auto Send and 
Server Mode options to begin regular processing. 

Running Form OCR Server 
To run Form OCR Server, proceed as follows: 

1. Click Start Processes. 

If the Auto Send and Server Mode options are selected, the jobs to be processed are 
loaded by batch into Form OCR Server.  

2. If Auto Send and Server Mode are not chosen, send each new parcel manually to the next 
queue by clicking Send Batch... 

Clicking this button sends all batches with the same parcel ID. 

The status window displays the processes being performed and the time elapsed. 

3. To stop the server, click Stop Processes.  

For information on maintaining Form OCR Server as a service, see Appendix B: Maintaining 
Exigen Workflow Servers as Services. 
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Chapter 4: Form OCR QA 
This chapter describes the Form OCR quality assurance (QA) process. The following topics are 
described in this section: 

• Overview 

• Form OCR QA Window 

Overview 
Form OCR QA checks and corrects the data extracted during the Form OCR process. Various 
tools edit the zone information and assign flags to those templates that are not correctly 
identified. Form OCR QA is not required to run with Form OCR Processing, but it is 
recommended. 

If Form OCR QA is used in your workflow, jobs sent to it from Form OCR Server are sent to a 
common queue. When the Form OCR QA application opens, the first job is automatically 
loaded. As each job is sent onward, the next is pulled in. 

When the Form Verification server is launched, it opens the Performing OCR Verification 
window. This OCR Verification window confirms and corrects values extracted from the 
templates during Form OCR Server processing. Zones identified as High Confirmation zones in 
Form OCR Server must be corrected before the document can be sent to the next queue. 
Zones identified as Medium, Low or None in the confirmation field can be corrected, although it 
is not required. 

Warning: The Form OCR QA does not support processing reference documents. 

Form OCR QA Window 
To open the Form OCR QA window, in Exigen Workflow Explorer, double click the Form OCR 
QA icon.  

 

The Form OCR QA window appears. 
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Figure 26: Form OCR QA window 

The Form OCR QA window consists of the following features and information:  

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• information about the number of incoming batches, processed parcels, documents, and 
pages. Documents having a Y in the Locked column are checked out for editing and cannot 
be modified. 

• status window that displays the current mode of Form OCR QA Server 

• toggle button to display data in either Form view or Column view 
The job display in the window depends on whether the common queue option is enabled as 
follows: 

• If the Get from Common Queue after Send option is enabled for the node in Workflow 
Builder, when the user sends a job, the next available job is automatically pulled from the 
common queue. 

• If the Get from Common Queue after Send option is not enabled for the node in Workflow 
Builder, all user jobs in the server queue are displayed.  

• If the Get from Common Queue after Send option is not enabled for the node in Workflow 
Builder, the user can enable the common queue option by selecting Edit > Queue Settings 
and Use common queue. If this option is selected, the next job is retrieved from the 
common queue by selecting Run > Get Next Job. 

For more information on common queues, see Specifying Queue Settings. 

The following topics are included in this section: 
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• Performing OCR Verification 

• Displaying Additional Document or Parcel Information 

• Linking a Document Page to a Template Page 

Performing OCR Verification 
To perform OCR verification, click Start Server.  

  

The Performing OCR verification window appears.  
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Figure 27: Performing OCR verification window 

One side of the Performing OCR verification window displays an actual page in a document. 
The active work zone is selected. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 4: Form OCR QA 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 69 of 391 

The other side of the window is used to view the zone information and perform any corrections 
or maintenance to the zone, page, or the entire document. Most of the buttons in the window 
are associated with shortcut keys, enabling the verification process to be performed without a 
mouse. 

The document viewer can appear on the left or right side of the Performing OCR verification 
window. The document viewer's default position is configured in Configuration Browser. The 
user can override the setting by selecting View > Dialog Layout > Left or View > Dialog 
Layout > Right in the Form OCR QA window. 

The following buttons at the top left of the window are used to perform verification at the zone 
template level: 

Performing OCR verification, zone template 
Button Description 

Prev. Form Jumps to the previous form template found in the document and displays the first 
zone in the template. PGUP is the shortcut key. 

Next Form Jumps to the next form template found in the document and displays the first zone 
in the template. PGDN is the shortcut key. 

Restart Form Resets all zone values for the current form template and resets verification back to 
the first zone in the template. F10 is the shortcut key. 

Unlink Form Unlinks the template and the associated zones from the current page. If a form 
template signature and its associated zones are assigned in error, this option must 
be used. F4 is the shortcut key. 

Link New Form 
Page 

Links currently displayed document page to a selected template page as described 
in Linking a Document Page to a Template Page. 

The following buttons located at the top right are used to perform maintenance on the individual 
zones on each page: 

Performing OCR verification, individual zones 
Button Description 

Step Back Jumps back to the previous zone found in the document. CTRL+ENTER are the 
shortcut keys. 

Zone Undo Undoes any changes made to the current zone data. ESC is the shortcut key. 

Step Forward Jumps to the next zone found in the document. ENTER is the shortcut key. 

The following fields display data specific to the current zone:  

Performing OCR Verification, current zone data 
Field Description 

Zone X of Y Current zone number in the X value and the total number of zones in the template 
as the Y value. 

Justify Indicates whether the zone is defined as right, left, or not justified in the 
Justification field: 

• R: right justified 

• L: left justified 
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Performing OCR Verification, current zone data 
Field Description 

• N: not justified 

Table Database table to be updated by the zone data. 

Field Database field to be updated by the zone data. 

Confirmation of 
document done 

If selected, displays a message asking if the document is done. If cleared, no 
message appears. 

Check Box 
Entry 

Selects or clears a check box. If the current zone is designated as a check box, the 
button appears to the left of the Done button. The shortcut key is the Space bar. 
The button is not previously displayed in the Performing OCR verification 
window. 

 
Clear Zone Clears the currently selected zone. 

The shortcut keys are used as follows: 
• F2 clears the string in the zone. 
• F3 replaces the string with a 0. 

Done Indicates to the system that OCR QA is finished with the current document. The 
document is automatically sent to the next queue in the workflow to the user COM. 
If additional documents reside in the Form OCR QA queue, the next one is loaded 
into the verification window. If no additional documents are waiting to be verified, 
the Performing OCR verification window closes and the Form verification 
window appears. You can also use the F12 key. 

Document and 
parcel 
information 

Displays additional information about the current document or parcel. 

This field appears only if it is set up in Configuration Browser. For information on 
setting up this field, see Displaying Additional Document or Parcel Information. 

Zone data 
messages 

Generated based on a number of circumstances. They are displayed below the 
Done button. The message on the left pertains to the data read in the entire zone, 
and the message on the right pertains to each individual character read. 

Warning: If the mask verification is not confirmed, the data must be corrected 
before you can proceed to the next zone. 

The following table describes the zone data messages that can appear on the left: 

Zone Data Messages, left 
Message Description 

Check of Zone Data has 
been accepted 

Indicates that both the zone mask requirements are satisfied, and that 
the data in the zone is read and recognized. 

Quality Check was not 
confirmed 

Indicates that the zone mask requirements have not been satisfied. If 
this message appears, you cannot proceed with inspecting the 
remainder of the document or mark it done until the mask requirements 
are corrected. 

Mask Verification was not Indicates that zone data are incorrect and do not match the zone mask. 
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Zone Data Messages, left 
Message Description 
confirmed 

Mask Verification is 
confirmed 

Appears once the zone data is corrected and the new data matches the 
zone mask. 

No FORM TEMPLATE 
assigned to this page 

Appears when a page without the template signature is displayed. This 
information ensures that the page is checked to see if Form OCR Server 
did not recognize the signature zone. 

Zone Content is empty Appears if the zone does not contain any data. 

Mask Verification is not 
confirmed. Check Length! 

Indicates that zone data does not match the zone mask. 

The following table describes the zone data messages that can appear on the right: 

Zone Data Messages, right 
Message Description 

HIGH Confirm. Level Indicates a high confidence level in Form OCR Server’s recognition of 
the selected character. 

LOW Confirm. Level Indicates a low confidence level in Form OCR Server’s recognition of 
the selected character. 

Not Match to Mask Indicates that the character entered does not match the zone mask. 

Out of Mask Bound Indicates that the cursor has reached the zone mask boundary and no 
additional characters can be added to the zone value. 

New Character Indicates that an additional character must be added to the zone data. 

Corrected Character Indicates that the selected character was corrected. 

Added Character Indicates that the selected character was added to the zone data. 

Image not Defined Indicates that the selected character has not been defined by Form 
OCR Server. 

The following table describes the boxes in the next portion of the window:  

Performing OCR Verification, boxes 
Box Description 

Box 1 Data in the current zone. Data not recognized is displayed as a tilde ~. Data recognized 
at a high confirmation level is displayed in black, and data recognized at a low 
confirmation level is displayed in red. By selecting each character, the message 
regarding the confirmation level or status of the character is defined as the messages 
appear on the right. 

Box 2 Portion of the document where the zone was located. A yellow box surrounds the zone 
and the data inside the box is the same as the data displayed in Box 1. 

Box 3 Zone mask for the current zone. As the cursor is moved over each character in Box 1, 
the corresponding position in the mask is selected in Box 3. 

The following table describes the six buttons that perform maintenance at the page level, 
located at the bottom-left side of the Performing OCR verification window:  
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Performing OCR Verification, maintenance buttons  
Button Description 

Break If the Unlink Form option is used to unlink a form template from a page in the 
document, used to insert the value SEPARATOR where the template signature 
zone would be. Routing rules can be set up in the Forms Output queue to route 
this form for further handling and identification of the correct form template 
assignment. F5 is the shortcut key. 

Delete Deletes the page displayed on the right side of the window. F6 is the shortcut key. 

Discard Discards any modifications made to the page and restores the document back to 
the original format. F7 is the shortcut key. 

Reject Places an X value in the QA_REJECT field in the Document table, which can then 
be used to send the document to a specific queue via routing rules for further 
investigation or inspection. F8 is the shortcut key. 

Zone Fit Magnifies the current zone in the viewer on the right, allowing better identification 
of the zone value. F9 is the shortcut key. 

Best Fit Fits the current page in the viewer window, both horizontally and vertically. F11 is 
the shortcut key. 

Alternatively, to modify display settings for the current document, right click in the Image Viewer 
and select one of the following commands: 

Document display, pop-up menu commands  
Command Description 

 Best Fit Fits the current page in the viewer window, both horizontally and vertically. 

Fit In Window Resizes the image to fit horizontally in the window. 

Scale Reduces or enlarges image size. 

The following options are available: 
• 25% 
• 50% 
• 75% 
• 100% 
• 125% 
• 150% 
• 175% 
• 200% 

Rotate Rotates an image 90 degrees. 

The following options are available: 
• Left 
• Right 

Contrast Applies more or less contrast to an image for enhancement purposes. 

The following options are available: 
• More 
• Less 

Invert Changes the display of the image from black-on-white to white-on-black and vice 
versa. 
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Document display, pop-up menu commands  
Command Description 

Image Info Displays document information. 

The following tasks can be performed: 

• To display help for the Performing OCR verification window, click Help. 

• To pause the Form OCR QA process, click Pause and complete work on the current 
document.  

Form OCR Server is stopped, and the process status changes to “cancelled by the 
user.” 

• To continue the document verification process, click Start Server. 

• To view form processing statistics, click Statistics. 

 
Figure 28: Viewing form processing statistics 

The Statistics window displays the following information: 

• number of zones and characters processed per session 

• number and percentage of corrected zones per session 

• number and percentage of corrected characters per session 

• distribution of characters processed per session based on confidence level 

• distribution of characters corrected per session based on confidence level 

Reset is used to reset all values to 0. 

Statistics on a per document basis can be viewed in the audit log. For more information on 
audits and audit events, see the Exigen Workflow Administrator's Guide, Part 1: Design and 
Configuration, Appendix D: Audit Data in Exigen Workflow. 
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Displaying Additional Document or Parcel Information 
If additional document or parcel information must be displayed, an additional field is set up in 
the Performing OCR verification window. The new field appears beneath the Done button. 

To set up a field for displaying additional document or parcel information, proceed as follows: 

1. In the Exigen Workflow Explorer window, select Administration Tools > Workflow 
Tools. 

2. To start Configuration Browser, double click Configuration Browser . 

For information on Configuration Browser, see the Exigen Workflow Administrator's Guide, 
Part 1: Design and Configuration, Chapter 4: Setting Up Exigen Workflow, Viewing and 
Modifying Configurations. 

3. If the Set View Filter window is displayed, click OK. 
4. To create a new section, select Edit > Add Section. 
5. In the New Section window, in the Name field, enter FormOCRQAField. 
6. In the Workflow ID field, enter the workflow ID. 

7. Click OK. 

The Form OCR QA Fields section appears in Configuration Browser. 

8. To display information on a parcel, in the right pane, in the Table item, open the drop-down 
list, select BATCHPARCEL, and click Apply. 

9. To display information on a document, in the right pane, in the Table item, open the drop-
down list, select DOCUMENT, and click Apply. 

10. To select the type of information displayed, in the right pane, in the Field item, enter a field 
name defined in Exigen Workflow Project Builder. 

For example, to display parcel status, for the Table item, BATCHPARCEL is selected, and 
for the Field item, PARCEL_SUBJECT is entered. 

 
Figure 29: Defining a field for additional information 

11. Click Apply. 
12. To close Configuration Browser, select File > Exit. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 4: Form OCR QA 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 75 of 391 

Linking a Document Page to a Template Page 
If no template is linked to a document page or an incorrect template is linked to a document 
page, the Link New Form Page button is used to link the document page to a selected 
template page. 

Pages from both standard templates and Enhanced Form OCR templates can be selected as 
follows: 

• If a standard template page is selected, the default QA information for zones is derived from 
the Form OCR Server setup. 

• If an Enhanced Form OCR template page is selected, the template must be prepared for the 
QA station and must contain valid default QA information. 

For more information on preparing an Enhanced Form OCR template for a QA station, see the 
Enhanced Form OCR User's Guide, Chapter 2: Getting Started, Specifying User Settings. 

To link the currently displayed document page to a template page, proceed as follows: 

1. Click Link New Form Page. 

The Link Form Template window appears. 

 
Figure 30: Linking a document page to a template page 

2. To display a subset of templates defined in the Template Management Utility Where Used 
tab, click Populate Assigned Templates. 

3. To display all templates registered in Template Management Utility, click Populate All. 
4. In the table, select a template. 

5. In the Template Page field, enter the template page number to be assigned to the currently 
selected document page. 
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6. To view the template, click Show Template. 
7. To view all defined zones on the template page, click Zone Preview. 

All defined zones are highlighted. 

8. To assign the template page to the currently displayed document page, click Assign 
Template. 

9. To close the window, click Close. 
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Chapter 5: Form Index Server 
This chapter describes how to run Form Index Server. The following topics are described in this 
section: 

• Overview 

• Form Index Server Window 

• Running Form Index Server 

Overview 
Form Index Server, which usually follows the Form OCR QA queue on the workflow map, 
populates the database with data extracted during the Form OCR process. This process also 
creates parcels and documents based on the settings assigned when the templates were 
registered in Form OCR Server. 

Warning: Form Index Server does not support processing reference documents. 

Form Index Server Window 
To open the Form Index Server window, in Exigen Workflow Explorer, double click the Form 
Index Server icon. 

 

The Form Index Server window appears. 
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Figure 31: Form Index Server window 

The Form Index Server window consists of the following features and information:  

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• information about the number of incoming batches, processed parcels, documents, and 
pages. Documents having a Y in the Locked column are checked out for editing and cannot 
be modified. 

• status window displaying the current mode of Form OCR Server 

• toggle button to display data in either Form view or Column view 
The job display in the window depends on whether the common queue option is enabled as 
follows: 

• If the Get from Common Queue after Send option is enabled for the node in Workflow 
Builder, when the user sends a job, the next available job is automatically pulled from the 
common queue. 

• If the Get from Common Queue after Send option is not enabled for the node in Workflow 
Builder, all user jobs in the server queue are displayed.  

• If the Get from Common Queue after Send option is not enabled for the node in Workflow 
Builder, the user can enable the common queue option by selecting Edit > Queue Settings 
and Use common queue. If this option is selected, the next job is retrieved from the 
common queue by selecting Run > Get Next Job. 

For more information on common queues, see Specifying Queue Settings. 
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Running Form Index Server 
To run Form Index Server, click Start Server.  

If the Auto Send and Server Mode options are selected, the jobs to be processed are loaded 
by batch into Form Index Server. After the entire batch is processed, the new parcels and 
documents are sent to the next queue, and Form Index Server starts processing the next batch. 

If neither Auto Send nor Server Mode is chosen, each new parcel must be manually sent to 
the next queue by clicking Send. 

The status window displays the processes being performed and the time elapsed. 

To stop the server, click Stop Server. 

Form Index Server can be configured to compare the expected number of documents and 
parcels in a batch with the actual number of separated documents and parcels. Configuring this 
feature for Form Index Server is similar to configuring it for Barcode Server. For information on 
how to verify the number of separated documents and parcels, see Verifying the Number of 
Separated Documents and Parcels. 

For information on maintaining Form Index Server as a service, see Appendix B: Maintaining 
Exigen Workflow Servers as Services. 
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Chapter 6: Full Text Search Preprocessor 
This chapter describes how to configure and run Full Text Search Preprocessor. The following 
topics are described in this section: 

• Overview 

• FTS Preprocessor Window 

• Configuring FTS Preprocessor 

• Running FTS Preprocessor 

Overview 
Full Text Search (FTS) Preprocessor extracts text from each page of every document sent 
through the workflow. It performs Optical Character Recognition (OCR) on images and uses 
other methods for other file formats, including DOC, PPT, XLS, and PDF. Custom Conversion 
Engine plugins can be developed for specific formats. By using FTS, you can locate documents 
in the system based on database information, and you can search for documents based on the 
words they contain. 

As an example of how this feature can be used, consider a large company whose human 
resources department receives numerous resumes each week. By incorporating FTS into a 
project called HR Resume, the resumes can be indexed using a social security number or an 
applicant’s name. Later, if a position becomes available in the company’s accounting 
department, a human resources specialist can use the Retrieve object to find all applicants 
whose resumes contain the word accounting. 

FTS Preprocessor 
The following prerequisites must be met to use FTS Preprocessor: 

1. Ensure that FTS Preprocessor is created in your project. 

2. Ensure that FTS Maintenance Utility is configured for your business practice. 

To use FTS Preprocessor, proceed as follows: 

1. In Exigen Workflow Explorer, double click the FTS Preprocessor icon.  

 
2. The FTS Preprocessor window appears. 

For more information on the FTS Preprocessor window, see FTS Preprocessor Window. 

3. To configure FTS Preprocessor, click Setup. 
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For more information on configuring the FTS Preprocessor, see Configuring FTS 
Preprocessor. 

4. Run FTS Preprocessor as described in Running FTS Preprocessor.  

FTS Preprocessor Window 
To open the FTS Preprocessor window, in Exigen Workflow Explorer, double click the FTS 
Preprocessor icon. 

 
Figure 32: FTS Preprocessor window 

The window contains the following features and information: 

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 
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• information about the number of incoming batches, processed parcels, documents, and 
pages on the left. Documents with a Y in the Locked column are checked out for editing and 
cannot be modified. 

• status window displays the current mode of the preprocessor on the right 

• toggle button displays data in either Form view or Column view 

Configuring FTS Preprocessor  
Before running FTS Preprocessor, you can set up additional commands to enhance the quality 
of the images and increase the accuracy of the OCR process.  

To configure FTS preprocessor, proceed as follows: 

1. Select Run > Setup, or click Setup. 

 

The Process Setup window appears. 

 
Figure 33: FTS Process Setup window 

2. In the Maximum size of blank page (in bytes): field, enter an integer value. 

The system ignores all pages whose size is less than the specified number of bytes. 

3. To configure the language switch on and off feature before running FTS Preprocessor, edit 
the visiclt.ini file. In section [fts] of the visiclt.ini file, enter the value ENG or LAT 
next to language for English or Latvian.  

---------------------------------------------------- 
[fts] 
language= 
---------------------------------------------------- 

This feature ensures that Latvian symbols can be used when working with Full Text Search 
Preprocessor. 

Warning: If the visiclt.ini file does not contain this section or entry or if it is set to 
ENG, an application must not use this feature. 
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4. To configure the ability to switch OLE on and off for Word document indexing before running 
FTS Preprocessor, edit the visiclt.ini file. In section [fts], enter the value yes or no 
next to msword.  

---------------------------------------------------- 
[fts] 
msword= 
---------------------------------------------------- 

If the value set is yes, the application uses OLE for Word document indexing. 

Warning: If the visiclt.ini file does not contain this section or entry, or if it is set to no, 
an application must not use this feature. 

Note: FTS Server and FTS Preprocessor use is described in the ocrserv.ini file, which is created 
by FTS Preprocessor after setup.   

Running FTS Preprocessor  
To run FTS Preprocessor, click Start Processes, or select Run > Start Processes. 

The Auto Send function in the Run menu routes processed work items to the next queue in the 
workflow based on the routing rules. If no routing rules exist, Auto Send is automatically 
disabled, requiring a manual send process. If routing rules exist, but the Auto Send feature is 
disabled, a manual send process is also required.  

The Server Mode function allows jobs sent to FTS Preprocessor to be automatically processed. 
When you open the object and click Start, any jobs sent to FTS Preprocessor are processed 
immediately. If Server Mode is not enabled, you must manually start FTS Preprocessor each 
time work items are received.  

For complete automation, both the Auto Send and Server Mode options must be selected with 
the appropriate outgoing routing rules in place. Once started, work items are processed and 
routed to the next queue without the need for user intervention. 

The status window displays the processes being performed and the time elapsed.  

To stop FTS Preprocessor, click Stop Processes or select Run > Stop Processes. 

For information on maintaining FTS Preprocessor as a service, see Appendix B: Maintaining 
Exigen Workflow Servers as Services. 
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Chapter 7: Full Text Search Server 
This chapter introduces the Full Text Search system and explains how to use it. The following 
topics are described in this section: 

• System Data Structure 

• Installing Full Text Search 

• Using FTS Server 

• FTS Server Window 

• Running FTS Server 

System Data Structure 
Full Text Search is used to create indexes of words found and created from documents from a 
workflow. The system consists of two main parts: Full Text Search Preprocessor and Full Text 
Search Index.  
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Figure 34: Full Text Search system 

Full Text Search processes documents as described in the following procedure, where each 
step corresponds to a step in the diagram: 

1. Files are converted as follows: 
• For DMS files, Full Text Search uses optical character recognition (OCR) to identify 

words and phrases within documents. Following OCR, the documents are converted into 
plain text files.  

• DOC and TXT files are converted to plain text files. 
2. Document IDs are added to a special buffer table. 

3. Full Text Search (FTS) Server reads the document ID in the table and creates the FTS 
Index. 

Installing Full Text Search 
Full Text Search is an optional Exigen Workflow component. To install it, select the Full Text 
Search check box under the Exigen Workflow Optional Components node in the Select 
Components step of the Exigen Workflow installation. 
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The following topics are described in this section: 

• Customizing a Project 

• Designing a Workflow 

Customizing a Project 
The Full Text Search function requires additional tables to be created in the Exigen Workflow 
database. There are two ways to create these tables: 

1. In the Project Builder, highlight the project and select Project > Create FTS Tables. 

The project has a Y in the Full Text column in the Project Builder window. 

2. In the Project Builder, click the Project Maintenance icon, and in the Project Table 
Maintenance window, select Maintenance > Create FTS Tables item. 

An FT appears under the Database Type field in the Project Table Maintenance window. 

If you are creating Full Text Search on an existing project, documents created before FTS 
implementation cannot be located using FTS because they were not subject to OCR when they 
entered the system. 

To delete Full Text Search from a project, select the Drop FTS Tables option in one of the 
following: 

• Project menu in the Project Builder window 

• Maintenance menu in the Project Table Maintenance window 

Designing a Workflow 
FTS consists of two main parts:  

• FTS Preprocessor 

• FTS Server 

To include these objects in a workflow, proceed as follows: 

1. Design a typical workflow.  

2. Add an FTS Preprocessor node to the workflow. 

3. Link it to other nodes so that documents can be sent to FTS Preprocessor. For example, set 
a link from a High Volume Scan node to the FTS Preprocessor node. 

4. Add an FTS Server node to the workflow. Do not link it to any object, because the server is 
run in the background. 

5. Add a Retrieve node to the workflow. 

Users open the Retrieve node to search documents based on the indexes created with FTS. 
For more information on FTS document retrieval, see the Exigen Workflow User’s Guide, 
Chapter 9: Document Retrieval, Retrieving FTS Documents. 
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The following figure shows a sample workflow that includes FTS Preprocessor and FTS Server: 

 
Figure 35: Sample workflow diagram with FTS 

Using FTS Server 
To use FTS Server, proceed as follows: 

1. In Exigen Workflow Explorer, double click the FTS Server icon.  

 

The FTS Server window appears. For more information on the FTS Server window, see 
FTS Server Window. 

2. Run FTS Server as described in Running FTS Server.  

FTS Server Window 
To open the FTS Server window, in Exigen Workflow Explorer, double click the FTS Server 
icon.  

The FTS Server window appears. 
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Figure 36: FTS Server window 

The window contains the following features and information: 

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• information about the number of processed documents and pages on the left. Documents 
having a Y in the Locked column are checked out for editing and cannot be modified. 

• status window displays the current mode of the server on the right 

• toggle button displays data in either Form view or Column view 

Running FTS Server 
FTS Server runs in the background. When a document is indexed through FTS Preprocessor, 
its ID is added to a special table that serves as a task for FTS Server. As a batch appears in the 
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table, FTS Server starts creating the FTS Index. FTS Server can be started automatically when 
you turn on your workstation, or it can be started from the Exigen Workflow system. 

To run FTS Server, click Start Processes or select Run > Start Processes. 

The status window displays the processes being performed and the time elapsed. 

To stop the server, click Stop Processes or select Run > Stop Processes. 

FTS Server documents that could not be indexed are displayed in the erroneous documents list, 
as described in the Exigen Workflow Administrator’s Guide, Part 3: Utilities, Chapter 5: Full Text 
Search Maintenance Utility, Viewing Erroneous Documents. 

For information on maintaining FTS Server as a service, see Appendix B: Maintaining Exigen 
Workflow Servers as Services. 
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Chapter 8: Image Enhancement Server 
This chapter describes how to configure and run Image Enhancement Server, which can be 
used in place of or in addition to the enhancement settings at the scanning level. 

The following topics are described in this section: 

• Overview 

• Image Enhancement Server Window 

• Configuring Image Enhancement Server 

• Running Image Enhancement Server 

Overview 
Image Enhancement Server improves the quality of scanned images. The server can be used 
as an alternative to the image enhancement tools available in the scan settings. By using Image 
Enhancement Server, you can speed up the scanning process by separating it from the image 
enhancement process.  

Image Enhancement Server Window 
To open the Image Enhancement Server, in Exigen Workflow Explorer, double click the Image 
Enhancement Server icon. 

   

The Image Enhancement Server window appears. 
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Figure 37: Image Enhancement Server window 

The window contains the following features and information: 

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• information about the number of incoming batches, processed parcels, documents, and 
pages on the left. Documents having a Y in the Locked column are checked out for editing 
and cannot be modified. 

• status window displays the current mode of the server on the right 

• toggle button displays data in either Form view or Column view 

Configuring Image Enhancement Server 
To configure the enhancements, select Run > Process Setup, or click the Process Setup icon. 

 

The Process Setup window appears. 
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Figure 38: Process Setup window 

The following table describes the image enhancement options: 

Process Setup, image enhancements 
Option Description 

Deskew Straightens the page in the Image Viewer. 

Shade Removal Removes any shading from on the page. 

Speck Removal Removes any specks or noise from the page. 

Rotate Right 90 Rotates the pages in the document clockwise 90 degrees. 

Turn Upside Down Rotates the pages in the document 180 degrees. 

Horizontal Line 
Removal 

Removes any horizontal lines, not letters, from the page. 

Vertical Line Removal Removes any vertical lines, not letters from the page. 

Horizontal Margin Adjusts the image horizontally based on a set margin size. 

Vertical Margin Adjusts the image vertically based on a set margin size. 

Create Quick Tile Creates thumbnail views of each page of the image. 

Del. Blank Pages If 
Size is Less than: 

Sets a condition for blank page deletion. In the Bytes field enter the number 
of bytes you want to set as a limit. Any page whose size in bytes is less than 
the number entered is deleted from the document. 

Created By: Value is generated by the system and identifies the date and time the last 
enhancement configuration was created. 

The options in the Image Enhancement Setup section instruct the server to perform the 
selected functions. Specific parameters for the following Image Enhancement Options must be 
assigned in the Image Filtering Settings dialog: 
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• Shade Removal 

• Speck Removal 

• Horizontal Line Removal 

• Vertical Line Removal 

• Horizontal Margin 

• Vertical Margin 

Configuring Image Filtering Settings 
The Image Filtering Settings window sets the parameters for the settings in the Process 
Setup window. 

To configure image filtering settings, proceed as follows: 

1. To open the Image Filtering Settings window, in the Process Setup window, click 
Configuration. 

 

The Image Filtering Settings window appears. 
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Figure 39: Image Filtering Settings window 

Each section in the Image Filtering Settings window performs the settings for one 
enhancement function.  

2. To use the default settings, click Set Default. Otherwise, set the appropriate value for each 
enhancement parameter. 

Horizontal registration positions text horizontally on the page by providing a consistent left 
margin. 
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Horizontal registration 
Setting Description 

Resultant Left 
Margin 

Number of pixels for the left margin after processing. 

Central Focus Register the image using only the middle portion of the image border. This feature 
must be used to ignore letterheads and logos. 

Add Only Expand the current margin of the image to the size specified in the Resultant Left 
Margin field. If the current margin is larger than the Resultant Left Margin field, 
no portion of the image can be cropped. 

Ignore Holes Ignore binder holes that may exist on the left side of the images. 

Find Line For 
Register 

Used for precise registration of forms. The value entered prompts the system to 
search horizontally for a vertical-line segment larger than the value. The text is 
shifted so that the line is shifted to the left edge of the image, based on the value 
entered in the Resultant Left Margin field. 

Vertical registration positions text vertically on the page by providing a consistent upper 
margin. 

Vertical registration 
Setting Description 

Resultant Upper 
Margin 

Number of pixels for the upper margin after processing. A zero value places the 
text flush with the top of the image. 

Central Focus Register the image using only the middle portion of the image border. This feature 
must be used to ignore letterheads and logos. 

Add Only Expand the current margin of the image to the size specified in the Resultant 
Upper Margin field. If the current margin is larger than the Resultant Upper 
Margin field, no portion of the image can be cropped. 

Find Line for 
Register 

Used for precise registration of forms. The value entered prompts the system to 
search vertically for a vertical-line segment larger than the value. The text is shifted 
so that the line is shifted to the upper edge of the image based on the value 
entered in the Resultant Upper Margin field. 

Dot Shading Removal removes areas of dot shading created by dithering in black and 
white images. 

Dot shading removal 
Setting Description 

Min. Area Height Height, in pixels, of the smallest dot-shaded area to be processed. The default 
value is 50. 

Min. Area Width Width, in pixels, of the smallest dot-shaded area to be processed. The default 
value is 100. 

Max Dot Size Maximum size, in pixels, that makes up the dot-shading. The default value is 5. 

Horizontal Size 
Adjust 

Number of pixels to be used as a horizontal adjustment value by the dot-shading 
removal function. For example, if some dots in the shade are 2 pixels wider than 
the Max Dot Size, entering a value of 2 instructs the system to remove dots that 
are 7 pixels wide. This number can also be a negative. 
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Dot shading removal 
Setting Description 

Vertical Size 
Adjust 

Number of pixels to be used as a vertical adjustment value by the dot-shading 
removal function. For example, if some dots in the shade are 2 pixels bigger than 
the Max Dot Size, entering a value of 2 instructs the system to remove dots that 
are 7 pixels tall. This number can also be a negative. 

Character 
Protection 

Protect portions of characters from being removed. 

Speck Removal cleans the image by removing any specks smaller than the parameters 
assigned. 

Speck removal 
Setting Description 

Horizontal 
Speck Removal 

Deletes groups of horizontal lines less than the number of pixels entered. 

Vertical Speck 
Removal 

Deletes groups of vertical lines less than the number of pixels entered. 

Isolated 
Despeck 

Deletes all specks and leaves anything else less than the number of pixels 
entered. 

Period Height Height, in pixels, of periods found in the image. Only specks less than this value 
are deleted. Therefore, periods remain in the image. 

Expected 
Frequency 

Approximate frequency in pixels of the speck location in a document. 

Horizontal line management sets the parameters for the deletion of horizontal lines found 
in the image. 

Horizontal line management 
Setting Description 

Min. Line to 
Detect 

Minimum size, in pixels, of horizontal lines to be deleted. This value must be large 
enough to ensure that horizontal lines such as the cross of a "T" are not removed. 

Max. Line 
Thickness 

Maximum thickness, in pixels, of horizontal lines to be deleted. The default value is 
20. 

Max Line Gap Size of the gap, in pixels, to be ignored so that a line is still considered a 
continuous line. This feature is useful when the image quality is poor and portions 
of the lines are not visible. 

Edge Cleaning 
Factor 

Cleans up the edges of the lines being removed. Enter the extra number of pixels 
you want to be cleaned here. 

Reconstruction 
Size 

Maximum width, in pixels, of characters to be reconstructed if line removal 
removes intersected characters. 

Vertical line management sets parameters for the deletion of vertical lines found in the 
image. 
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Vertical line management 
Name Description 

Min. Line to 
Detect 

Minimum size, in pixels, of vertical lines to be deleted. This value must be large 
enough to ensure that vertical lines such as the vertical portions of the letter "H" 
are not removed. 

Max. Line 
Thickness 

Maximum thickness, in pixels, of vertical lines to be deleted. The default value is 
20. 

Max Line Gap Size of the gap, in pixels, to be ignored so that a line is still considered a 
continuous line. This feature is useful when the image quality is poor and portions 
of the lines are not visible. 

Edge Cleaning 
Factor 

This function cleans the edges of the lines being removed. Enter the extra number 
of pixels you want to be cleaned. 

Reconstruction 
Size 

Maximum width, in pixels, of characters to be reconstructed if line removal 
removes intersected characters. 

3. To apply these settings, click OK. 

Running Image Enhancement Server 
To run Image Enhancement Server, click Start Server. 

The Auto Send function in the Run menu routes processed work items to the next queue in the 
workflow based on the routing rules. If no routing rules exist, Auto Send is automatically 
disabled, requiring a manual send process. If routing rules do exist but the Auto Send feature is 
disabled, a manual send process is also required.  

The Server Mode function allows jobs sent to the server to be automatically processed. When 
you open the object and click Start Server, any jobs sent are processed immediately. If Server 
Mode is not enabled, you must manually start it each time work items are received. 

For complete automation, both options must be selected with the appropriate outgoing routing 
rules in place. Once started, work items are processed and routed to the next queue without the 
need for user intervention. 

The status window displays the processes being performed and the time elapsed. 

To stop the server, click Stop Server. 

For information on maintaining Image Enhancement Server as a service, see Appendix B: 
Maintaining Exigen Workflow Servers as Services. 
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Chapter 9: Import Server 
This chapter describes how to configure and run Import Server. The following topics are 
described in this section: 

• Overview 

• Import Server Window 

• Configuring Import Setup Attributes 

• Running Import Server 

• Viewing Import Server Log and History Files 

• Exporting Setup Data 

Overview 
Import Server can import documents into the Exigen Workflow repository without scanning and 
indexing the imported documents. Import Server supports the following import options: 

• importing without conversion as described in Exigen Workflow Administrator’s Guide, Part 1: 
Design and Configuration, Chapter 4: Setting Up Exigen Workflow, Specifying a Default 
Document Type for a Task  

• importing images using internal conversion  

• importing using conversion by native applications as described in Printing through Native 
Applications 

• importing using additional third party software conversion tools 

Imported documents can be converted to DMS format and sent to a selected workflow node in 
separate parcels for further processing. Alternatively, some document types can be imported 
without converting to DMS. In this case, the original application is used for viewing those 
documents. For example, a PDF document can be imported and Adobe Acrobat Reader can be 
used to view it in the workflow. 

Import Server enables a user to import several image files as one DMS document with many 
pages, where each page contains one imported image. 

Documents can be converted to DMS by printing using their native applications, which must be 
installed on the workstation that runs Import Server. 

The following types of documents can be converted to DMS by printing using a native 
application: 
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Document formats that can be converted to DMS using a native application 
Document format Native application 
TXT Word. 
DOC Word. 
RTF Word. 
XLS Excel. 
HTML Word. 
PDF Adobe Acrobat. 

For more information on printing through the native applications, see Printing through Native 
Applications. 

Import Server may require the following third party software to perform specific conversions 
from the original format to the converted format: 

Third party software Original format Converted format 
Word and NED Image Printer Driver .doc, rtf., .htm., and 

.txt 
.tif or .dms 

Excel and NED Image Printer Driver .xls .tif or .dms 
Adobe Libraries and NED Image Printer Driver .pdf .tif or .dms 

The following file types can be converted to .dms format without additional software: 

• .dms 

• .gif 

• .jpg 

• .bmp 

• the following .tif file variations: 
• uncompressed 
• CCITT 1D 
• CCITT G3 
• CCITT G4 
• LZW 
• JPEG7 
• PackBits 

The importing configuration records must be correctly configured in the Import Setup window to 
obtain parameters such as the location of the source files, the importable documents type, and 
import method. 

To improve the document flow, it is possible to import documents together with the indexing 
information. In this case, the users can omit indexing the imported documents in the workflow 
after importing if full indexing information is provided. Indexing information and the path to the 
source documents must be stored in a simple text file. 

Exigen Workflow also supports importing indexing information separately without documents. 
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By default, Import Server assigns the document type IMP to imported documents when the 
document type is not specified in the Import Server configuration even if the IMP document type 
is not defined in the system. It can cause problems if these imported documents are used by 
Application Services. If Application Services processes imported documents that are assigned 
the IMP document type, the administrator must manually define and add the IMP document type 
to the system. 

Note: Import Server can import documents into one project from another only if both projects are in 
the same database. 

Import Server Window 
To open the Import Server window, in Exigen Workflow Explorer, double click the Import 

Server  icon. 

The Import Server window appears. 

 
Figure 40: Import Server window 
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The Import Server window contains the following fields and options: 

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• information about the current session of Import Server below the button bar 

The following table describes the Import Server window current session statistics: 

Import Server, current session statistics 
Statistics Description 

Start Date Date when the current session was started. 

Start Time Time when the current session was started. 

Received Documents Total number of documents processed by Import Server. 

Received Pages Total number of pages processed by Import Server. 

Messages System messages concerning the actions to be taken or the current 
processing status. 

Current Dir Directory where the imported files are located. Each individual file is 
displayed above the Current Dir field while it is processed. 

Configuring Import Setup Attributes 
Before importing documents, you must provide the following information: 

• location of the source documents and indexing text files 

• import method 

• source files type 

• database fields populated with the indexing information provided in the text files 

Multiple dialog windows are used to perform the import. The selections made during 
configuration determine which dialog windows appear later. All possible dialog window 
sequences are described in this section. 

To start configuring Import Server, select File > Setup or click Setup. 

 

The Import Setup window appears. 
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Figure 41: Import Setup window 

The Import Setup window lists all defined importing configuration records. 

An import configuration record is a line in the table that contains all the information required for 
the particular import session. Users must create at least one import configuration record to 
import documents. 

The following table describes the parameters in the import configuration records table: 

Import configuration records 
Name Description 

Use Activates an importing configuration. 

The selected importing configuration record is used when Import Server is run. 

Source File 
Directory 

Location of the index file, if indexing information is imported, or the location of 
source files, if documents are imported without indexing information. 

Workflow Name Target workflow where data is sent after import. 

Send to Queue 
and User 
columns 

Where and to whom the imported data is sent after import. 

Task Name Task associated with imported data. 

The task is the application used to open and view imported documents. If N/A is 
selected, all imported documents are converted to the DMS format and viewed 
with Image Viewer in the workflow. 

Description Identification assigned to the specific import configuration record. 

The Import Setup window has the following command buttons: 
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Import Setup buttons 
Buttons Description 

Add Adds a new import setup record. 

Modify Modifies an existing setup record. 

Delete Removes an existing record. 

Imprint Settings Sets the imprint type and alignment for imported documents. An electronic imprint 
is placed on each page of the document image. The default location of the imprint 
is the top left-hand corner of the document image. For more information on imprint 
sessions, see Specifying Imprint Settings. 

Help Opens help. 

Close Closes the current window and returns to the Import Server window, from where 
you can start importing after selecting an import configuration record. 

Specifying Imprint Settings 
To specify imprint settings for a particular importing configuration record, proceed as follows: 

1. In Import Setup window, select a configuration record to which the imprint settings are 
applied. 

2. In the Import Setup window, click Imprint Settings. 

The Import Setup - Imprint Settings window appears. 
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Figure 42: Imprint Settings window 

The following table describes the three options available for setting the type:  

Imprint Setting, setting type 
Type Description 

Disabled Does not imprint any information. 

Automatic Imprints the user ID and creation time on each page of the document image. 

Custom Imprints the custom text specified in the Custom Text field. The text cannot 
exceed 60 characters. 

By using the Custom option you can also add multiple parameters to the imprint 
text. For example, this can be creation date, user name, workstation name, and 
many other parameters. 

To add custom imprint parameters, a user can click Parameters and select the 
appropriate fields in the Parameters for Imprint window. 

The following table lists horizontal imprint alignment options: 

Horizontal alignment 
Option Description 

Left Positions the imprint on the left. 

Right Positions the imprint on the right. 

Center Centers the imprint. 
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The following table lists vertical imprint alignment options: 

Vertical alignment 
Option Description 

Top Positions the imprint at the top of the page. 

Bottom Positions the imprint at the bottom of the page. 

3. To apply the imprint settings, click OK. 

Adding or Modifying an Import Setup Record  
The following topics are described in this section: 

• Creating a New Importing Configuration Record 

• Creating Settings for Importing Document Files Only 

• Creating Settings for Importing Indexing Information Only 

• Creating Settings for Importing Document Files and Indexing Information 

• Populating Table Fields 

Creating a New Importing Configuration Record 

During the importing session, Import Server uses the selected record in the Import Setup 
window as a source of configuration settings importing process. 

The following topics are described in this section: 

• Entering Importing Session Information 

• Printing through Native Applications 

• Defining the Import Method 

To create a new importing configuration record, proceed as follows: 

1. Open the Import Setup window. 

2. Click Add. 

The Import Setup - Source and Destination Setup window appears. 
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Figure 43: Import Setup - Source and Destination Setup window with full information 

Entering Importing Session Information 

In the Import Setup - Source and Destination Setup window, provide general information for 
the particular importing session. 

The Source and Destination Setup window is also displayed if you modify an existing 
importing configuration record. 

If the same input directory is used for multiple Import Servers, the Import Servers must be 
configured so that they do not attempt to import the same files simultaneously. For example, 
one server imports only DMS files and another imports only DOC files. 

To specify importing session information, proceed as follows: 

1. To select the directory where the source files are located, click the browse button  next 
to the Source File directory field. 

2. In the Directory Label field, enter the identifying description of the import setup record. 

This field is optional. 

3. Click the browse button next to the Workflow field. 

The Setup window displays a list of all workflows available in the database.  

4. Select the workflow that you want to receive the imported data. 

5. In the Setup window, click the browse button next to the Send to Queue field. 

A list of all available queues in the selected workflow is displayed. 

6. Select the target queue to which you want to send the imported documents. 
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If you import documents without the indexing information, it is recommended that you send 
the documents to the High Volume Index queue. Otherwise, the imported documents cannot 
be retrieved and viewed by other users that do not have access to the selected target 
queue. 

7. To select a user who is to receive the imported documents, click the browse button next to 
the Send to User field. 

8. To list all tasks set up in the database, click the browse button next to the Task Name field. 

A task is the application that is used to open and view the document later in the workflow. 

9. To assign it to the new setup record, click on a task. 

The default value is N/A, not applicable, which means that the source documents are 
converted to the DMS format and Image Viewer is used for viewing and editing those 
documents. 

10. To convert DOC, RTF, XLS, HTML, and PDF documents to DMS format, select the Try to 
print from native application check box. 

For more information on printing through native applications, see Printing through Native 
Applications. 

11. To clear all fields in the Source and Destination Setup window, click Clear. 
12. To close the window, click Close. 

If you are adding a new import configuration record, do not close the window, because all 
data is lost after clicking Close. This does not apply when you are modifying a record. 

13. To open the help topic about this window, click Help. 
14. To go to the next setup dialog, click Next.  

The Import Setup - Input Sources Selection window appears. 

For information on the Import Setup – Input Sources Selection window, see Defining the 
Import Method. 

Printing through Native Applications 

DOC, RTF, XLS, HTML, and PDF documents can be converted and imported as DMS files 
through a specialized printer driver. 

To set up printing using a specialized printer driver, proceed as follows: 

1. To import DOC, RTF, XLS, HTML, and PDF documents as DMS files, install a specialized 
printer driver on your workstation. 

The following printer drivers are supported by Import Server for converting the documents: 

• NED Image Printer 
• Informatik Image Driver 

Note: NED Image printer has to be installed before printing Office and PDF files. 
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At least one of the preceding drivers must be installed before proceeding. 

The NED Image Printer is optional third party software that must be ordered from Exigen. 

2. To install NED Image Printer, follow the instructions described in the NED Image Printer 
driver’s readme.txt file. 

3. After NED Image Printer is installed, select Start > Settings > Printers. 
4. Right click NED Image Printer and select Properties. 

The NED Image Printer Properties window appears. 

5. Select the Advanced tab. 

 
Figure 44: NED Image Printer Properties window 

6. Select the Print directly to the printer option. 

7. Click OK. 
8. To import DOC, RTF, XLS, HTML, and PDF files as DMS documents, in the Source and 

Destination Setup window, select the Try to print from native application check box.  

The Printer button appears. 
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9. To select the printer driver for converting documents to the DMS format, click Printer. 

The Conversion Setup window appears. 

10. In the Conversion Setup window, select either the NED Image Printer or the Informatik 
Image Driver and click OK. 

These printer drivers are available for selection only after they are correctly installed on your 
workstation. Import Server does not support any other printer drivers. 

If you are using NED Image Printer, observe the following rules: 

• Do not select a print quality of 100x100 dpi for color images. 
• Note that a great deal of free hard drive space is required when printing color 

documents, for example, up to 10 MB per page for a resolution of 200x200 dpi. 
• Excel files can be printed only at a dpi resolution of 600x600. 

Defining the Import Method 

The Import Setup - Input Sources Selection window defines the import method used. 

 
Figure 45: Import Setup - Input Sources Selection window 

The Input Sources Selection window contains the following options and buttons: 
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Import Setup, Input Sources options 
Option Description 

Indexing Information 
Only 

Only indexing information is imported from text files. The Source File 
Directory field contains the full path to the text files with all indexing data. 
No documents are imported in this case. 

You can import date and time values as indexing information. 

Time must be in the hh:mm:ss format, where hh is a number with a two-
digit hour value between 0 and 23 inclusive, mm is a number with a two-digit 
minute value between 00 and 59 inclusive, and ss is a number with a two-
digit second value between 00 and 59 inclusive. 

American time format hh:mm:ss AM or hh:mm:ss PM is also supported, for 
example, 

10-27-2003,10:48:11 AM 

Document Files + 
Indexing Information 

Indicates source documents are imported according to the path specified in 
the text files located in the source directory and the indexing information is 
also extracted from these text files. 

The following is an example of the text file that contains indexing information 
and the path to the importable document. 

220101,Brown,Jenny,C:/EWF/2201/data1.doc 

Document Files Only Only documents are imported. The Source File Directory field contains a 
full path to the document location. Text files with additional information are 
not required in this case. 

History Creates a history file. For more information on the History check box, see 
Viewing Import Server Log and History Files. You can select where you want 
the log and history files to be located by using the browse button. 

  
Request to stop every 
X records 

Indicates when to pause the import process. Once the specified number of 
import setup records is processed, the server pauses, and you can either 
stop or continue the process. 

Help, Back, and Next Navigation and help buttons. 

• Next displays new dialog window if the option selected in the Input 
Sources section.  

• Back displays the previous window. 

• Help displays help information. 

Creating Settings for Importing Document Files Only 

If the Document Files Only option is selected, the Import Setup – Document File Processing 
Setup window appears. 
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Figure 46: Import Setup - Document File Processing Setup window 

The Extension of Source Files list box is used to specify the import document type. If you 
select the *.* type, Import Server imports all supported files from the source directory. 

The Structure of Source Files list box is used to define the structure of the source files. 

The Single option is used to import image files of the following types: 

• TIFF 

• JPG 

• BMP 

• GIF 

• DIB 

• DCX 

Selecting the Single option enables you to import several images as one DMS document. 

To import multiple image files as one DMS document, proceed as follows: 

1. Copy all image files that you want to import as one document into the source folder. 

2. Change the extensions of the image files successively to 001, 002, 003, and so on. 

3. Give the same name to all image files. 

The following is an example set of image files that are to be imported as one DMS 
document: 

image.001 
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image.002 

image.003 

image.004 

The number in the image file extension corresponds to the page number in the imported 
DMS document. 

4. To import only these image files, in the Extension of Source Files list box, select 001. 

These image files are also imported if you select *.* in the Extension of Source Files list 
box. 

The Multiple option enables importing files of the following type: 

• TIFF 

• DOC 

• WPD 

• HTML 

• TXT 

• WRI 

• DMS 

• XLS 

• PDF 

• DCX  

The Document Files list box is used to select the action to be performed with the files once the 
import process is completed. The following options are available: 

Document Files Processing Setup 
Option Description 

Remain in 
directory 

Source files remain in the directory where they are located after import. 

Delete Source files are deleted from the source directory once the import process is 
completed. 

Move Source files are moved to a different directory. If Move is clicked, the Recycle 
Directory field appears. You can click the browse button to specify the 
destination directory where the files are moved. 

  
Integrity delay (in 
seconds) 

Import Server processes files only with modification time older than the selected 
value. 
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Document Files Processing Setup 
Option Description 

Save original 
documents 

Saves the original documents. While retrieving these documents, the users are 
able to view the original document with the dedicated application. 

Selecting the Save original documents check box is useful for task documents 
such as Word and Excel documents, if the task name is not specified in the 
Source and Destination Setup window. 

If document versioning is enabled in the project, the Save original documents 
option sets the original document as the first document version. 

The Save original documents functionality is not supported in environments 
that require documents to be committed to the Centera storage system. After a 
document goes through appropriate format transformations during the import 
process, the system is able to commit the document to all supported storage 
devices, including Centera. 

Import rich text 
files as color 
images 

Imports RTF files as color images. 

Use VCET for 
TIFF/GIF/JPG/BMP 
import 

Enabled if VCET Conversion Engine is installed on your computer. It is selected 
to use conversion through VCET. 

Note: The Import rich text files as color images check box is disabled when printing from native 
application is enabled. 

When all settings are set, the import setup process for document files only is complete. 

To save the setup, click Finish. 

If the Remain in Directory option was selected, proceed as follows: 

1. To go to the next setup window, click Next. 

The Import Setup – Document File Selection Setup window appears. 
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Figure 47: Import Setup - Document File Selection Setup window 

2. In the Import Setup – Document File Selection Setup window, enter appropriate values 
as described in the following table: 
Document File Selection Setup window 
Option Description 

All Files in If selected, all source files of the selected type are imported. 

Select the first 
file 

If the All Files in box is cleared, this list box is used to specify the first file in the 
source folder for importing. 

Select the last 
file 

If the All Files in box is cleared, this list box is used to specify the last file in the 
source folder for importing. 

3. Click Finish. 

Creating Settings for Importing Indexing Information Only 

By importing indexing information only, you can create empty folders and subfolders with the 
information extracted from the text files located in the source directory. 

The indexing text files can be any text files in the source folder. 

To import indexing information without any documents, proceed as follows: 

1. In the Input Sources Selection window, select Indexing Information Only. 
2. Click Next. 

The Import Setup - Index File Setup window appears. 
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Figure 48: Import Setup - Index File Setup window 

3. In the Indexing text uses section, select whether the source index file has a Fixed Field 
Length or uses a Delimiter. 

The list box that appears below this section depends on the selection. 

The following table lists the Indexing text uses options: 

Indexing text uses options 
Option Description 

Fixed Field 
Length 

If selected, the length of each record in the indexing files must be the same as the 
length of the corresponding table field that is populated with the indexing 
information. 

For example, if a folder in the corresponding workflow has three fields with field 
length 3, 10, and 5 respectively, and you want to create new folders by extracting 
information from the text file, the indexing text file must contain one line for each 
folder with the following pattern: 

aaabbbbbbbbbbccccc 

where aaa represents for the record of the 3 character field, bbbbbbbbbb 
represents the record of the 10 character field, and ccccc represents the record of 
the 5 character field for the new folder. The user must use the same pattern for all 
indexing text files. 

Delimiter If selected, records in the indexing text file are separated by a delimiter selected in 
the Delimiter list box. In this case, the length of records can vary in the indexing 
files. 

For example, if a folder in the corresponding workflow has three fields with field 
length 3, 10, and 5 respectively, and you want to create new folders by extracting 
information from the text file, the indexing text file must contain one line for each 
folder with the following pattern: 
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Indexing text uses options 
Option Description 

aaa,bbbbbbbbbb,ccccc 

where , is the selected delimiter, aaa represents the record of the 3 character field, 
bbbbbbbbbb represents the record of the 10 character field, and ccccc 
represents the record of the 5 character field for the new folder. Records in the 
indexing file can be shorter than the field length in the folder table. 

If "," is specified as the delimiter, and the parameters start and end with quotation 
marks, the initial and final quotation marks are removed. For example, if the 
following parameters are used: 
"INVOICE","3002" 

the result is as follows: 
INVOICE 
3002 

The selection in the Number of skipped rows section changes the list box below it. 

The following table lists the Number of skipped rows options: 

Number of skipped rows options 
Option Description 

Fixed If selected, Import Server skips n lines in the indexing file before each line 
containing indexing information, where n is the number selected in the Rows in 
header list box. 

Variable If selected, Import Server skips all lines in the indexing file that start with the 
identifier selected in the Header Selection list box. 

4. To proceed to the next setup dialog, click Next. 

The Import Setup – Index File Processing Setup appears. 
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Figure 49: Import Setup - Index File Processing Setup window 

The Processing files after usage list box is used to determine what happens to the index 
files once the import process is completed. The following table lists available options: 

Processing files after usage options 
Option Description 

Remain In 
Directory 

Source files remain in the directory where they are located. 

Delete Source files are deleted once the import process is completed. 

Move Source files are moved to a different directory. 

If you select Move, the Recycle Directory field appears. 

5. To locate the directory where the files are moved, click the browse button . 

6. If the Remain in Directory option was selected, to go to the next setup window, click Next. 

The Import Setup – Document File Selection Setup window appears. 
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Figure 50: Import Setup - Document File Selection Setup window 

7. To extract the indexing information from all text files in the source folder, select All Files in. 
8. To extract the indexing information only from a range of text files in the source folder, clear 

the All Files in check box and identify the first file and the last file in the range of files. 

9. To proceed to the Tables and Fields Setup window, click Next. 

For more information on the Tables and Fields Setup window, see Populating Table Fields. 

Creating Settings for Importing Document Files and Indexing Information 

To import documents with indexing information, proceed as follows: 

1. In the Input Sources Selection window, select Document Files + Indexing Information. 
2. Click Next. 

The Import Setup - Index File Setup window appears. 
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Figure 51: Import Setup - Index File Setup window 

3. Configure parameters as required for your importing session. 

The following table describes parameters in the Index File Setup window: 

Index File Setup window 
Option Description 

Fixed Field 
Length 

If selected, the length of each record in the indexing files must be the same as the 
length of the corresponding table field that is populated with the indexing 
information. The indexing file must also contain the path to the importable source 
document. 

For example, if a folder in the corresponding workflow has three fields with field 
length 3, 10, and 5 respectively, and you want to import documents into folders by 
extracting information from the text file, the indexing text file must contain one line 
for each document with the following pattern: 

aaabbbbbbbbbbccccc<path> 

where aaa represents the record of the 3 character field, bbbbbbbbbb represents 
the record of the 10 character field, ccccc represents the record of the 5 character 
field for the new folder, and <path> is a path to the importable source document, 
for example, C:\IMPORT\source.doc. You can also specify the path to the 
source document relatively to the index file location, for example: 

.\SOURCE\source.doc 

The path to the document must be assigned with the A_FILE_PATH field in the 
DOCUMENT table as described in Populating Table Fields. Otherwise, an error 
occurs during the import. 

The user must use the same pattern for all indexing text files. 
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Index File Setup window 
Option Description 

Delimiter If selected, records in the indexing text file are separated by a delimiter selected in 
the Delimiter list box. In this case, the length of records can vary in the indexing 
files. The indexing file must also contain the path to the importable source 
document. 

For example, if a folder in the corresponding workflow has three fields with field 
length 3, 10, and 5 respectively, and you want to import documents into folders by 
extracting information from the text file, the indexing text file must contain one line 
for each document with the following pattern: 

aaa,bbbbbbbbbb,ccccc,<path> 

where , is the selected delimiter, aaa represents the record of the 3 character field, 
bbbbbbbbbb represents the record of the 10 character field, ccccc represents 
the record of the 5 character field for the new folder, and <path> is path to the 
importable source document, for example, C:\IMPORT\source.doc. You can 
also specify the path to the source document relatively to the index file location, for 
example: 

.\SOURCE\source.doc 

If "," is specified as the delimiter, and the parameters start and end with quotation 
marks, the initial and final quotation marks are removed. For example, if the 
following parameters are used: 
"INVOICE","c:\file1.tif" 

the result is as follows: 
INVOICE 
c:\file1.tif 
The path to the document must be assigned with the A_FILE_PATH field in the 
DOCUMENT table as described in Populating Table Fields. Otherwise, an error 
occurs during the import. 

Records in the indexing file can be shorter than the field length in the folder table. 

Fixed If selected, Import Server skips n lines in the indexing file before each line 
containing indexing information, where n is the number selected in the Rows in 
header list box. 

Variable If selected, Import Server skips all lines in the indexing file that start with the 
identifier selected in the Header Selection list box. 

4. To go to the next setup dialog, click Next. 

The Import Setup - Document and Index File Processing Setup window appears. 
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Figure 52: Import Setup - Document and Index File Processing Setup window 

The Structure of Source Files list box is used to define the structure of the source files. 

The Single option allows importing image files of the following types: 

• TIFF 
• JPG 
• BMP 
• GIF 
• DIB 
• DCX 
 

If the Single option is selected, you can also import several images as one DMS document. 

To import multiple image files as one DMS document, proceed as follows: 

1. In the Structure of Source Files list box, select the Single option. 

2. Copy all image files that you want to import as one document into the source document 
location. 

3. Change the extensions of the image files successively to 001, 002, 003, and so on. 

4. Assign the same name to all image files. 

The following is an example set of image files that are to be imported as one DMS 
document: 

image.001 

image.002 
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image.003 

image.004 

The number in the image file extension corresponds to the page number in the imported 
DMS document. 

5. In the indexing text file, define a full path to the first file in the image files set as in the 
following example: 

C:\Source\image.001 

Do not define a path to the rest of image files with the same name. 

The Multiple option enables importing files of the following types: 

• TIFF 
• DOC 
• WPD 
• HTML 
• TXT 
• WRI 
• DMS 
• XLS 
• PDF 
• DCX 

6. To specify how document files are handled after import, in the Document Files list box, 
select one of the following options: 
Document Files options 
Option Description 

Remain in 
Directory 

Files remain in the directory where they are located. 

Delete Files are deleted when the import process is completed. 

Move Files are moved to a different directory. 

7. To specify how index files are handled after import, in the Index Files list box, select an 
appropriate option. 

The options for index files are the same as those for document files. 

If Move is selected for document files or index files, the Recycle Directory field appears. 

8. To specify the directory to which files are moved, click the browse button . 

Only one directory can be selected. If Move is selected for both list boxes, source 
documents and indexing files are moved to the same location. 

9. To specify a drive for source files, in the Drive for source files list box, select an 
appropriate letter. 

The location of source files is determined as follows: 



Administrator's Guide, Part 2: Business Component Reference  Chapter 9: Import Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 123 of 391 

• If the full path is provided, the full path is used. 
• If a relative path is provided in \<directory>\<document> format, the letter in the 

Drive for source files box is added to the path as follows: 

<drive letter:>\<directory>\<document> 

• If a relative path is provided in .\<directory>\<document> format, the path is 
interpreted as follows: 

<current directory>\<directory>\<document> 

When files are modified, an integrity delay may be required to ensure that file modifications 
are completed before file import. The integrity delay specifies the minimum interval in 
seconds that must elapse before the file is imported. 

10. To specify an integrity delay, enter a number in the Integrity delay (in seconds) field. 

11. To specify additional import options, select appropriate options listed in the following table: 
Import options 
Option Description 

Save original 
documents 

Saves original task documents such as Word and Excel files if the task 
name is not specified in the Source and Destination Setup window.  

When the documents are retrieved, they can be viewed using the 
appropriate external application. 

Import rich text files 
as color images 

Imports RTF files as color images. 

Use VCET for 
TIFF/GIF/JPG/BMP 
import 

Converts using VCET. 

Enabled only if VCET Conversion Engine is installed on your computer. 

Documents into one 
parcel 

If the indexing file contains information about more than one document, 
imports all documents specified in this indexing file as one parcel. The 
folder and parcel information is read from the first successfully indexed 
line in the index file and is the same for all documents in the parcel. 

Import erroneous 
documents 

Imports all documents that cannot be converted to the DMS format as 
binary files. 

12. If the Remain in directory option is selected in the Index Files list box, to open the 
Document File Selection Setup window, click Next. 

13. If the Move or Delete option is selected in the Index Files list box, to open the Tables and 
Fields Setup window, click Next. 
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Figure 53: Import Setup - Document File Selection Setup window 

14. To process all text files in the source directory, select All Files in. 
15. To process only a range of text files in the source directory, clear the All Files in check box, 

select the first file, and select the last file of the range of files. 

16. To proceed to the Tables and Fields Setup window, click Next. 

Populating Table Fields 

The Tables and Fields Setup window determines which database fields are populated with the 
data from the source index files. 

To import documents together with indexing information, add the A_FILE_PATH field from the 
DOCUMENT table in the Tables and Fields Setup window and assign it to the document’s 
path specified in the indexing text file. Otherwise, an error occurs during the importing. Other 
table fields are not required during indexing. 

This section describes how to add tables and fields in the Tables and Fields Setup window 
and how to populate them with the information from the indexing text files. 

The Import Server node number is inserted into the NODE_ID_FROM field if Import Server is 
run in the same workflow as the target workflow. A 0 is inserted in NODE_ID_FROM field if 
Import Server is run in a different workflow from the target workflow. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 9: Import Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 125 of 391 

 
Figure 54: Tables and Fields Setup window 

The top part of the window displays the tables that are affected by the indexing information. 
Initially there are no tables selected. The user must select tables to be populated with the 
information from the source index files. 

The following table describes the Table and Fields Setup window: 

Table and Fields Setup window 
Data Description 

Table Name Tables that are selected for receiving information from the source index files. 

Insert Allowed Incoming data can insert records into the table. 

Update Allowed Incoming data can update records already existing in the table. 

To add a table, proceed as follows: 

1. To add a new table to the list, click Add. 

The Add New Table window appears. 
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Figure 55: Add New Table window 

2. In the Table Name list box, select a table that you want to receive the indexing information. 
The following tables are available:   
• FOLDER 
• SUBFOLDER 
• BATCHPARCEL 
• DOCUMENT 
If you selected to import only the indexing information without documents, the 
BATCHPARCEL and DOCUMENT tables are not available. 

3. To allow incoming records to be inserted in the selected table, select the Insert box. 

4. To allow existing records to be updated, select the Update box. 

Note: For DOCUMENT and BATCHPARCEL tables, the Insert and Update options are selected 
automatically. 

5. To add the new table to the list, click Apply.  
6. To exit the window without adding anything, click Close.  
7. To open the online help, click Help. 
8. To change the Insert and Update settings only for an existing table record, highlight the 

record and click Modify.  
9. To change the table name in an existing record, delete the record and add a new one into 

the system.  

10. To delete a record, highlight it and click Delete. 

The bottom part of the Tables and Fields Setup window displays the table fields that 
receive the indexing information. Each table field corresponds to a fixed place in the 
indexing text file. Initially no fields are selected. 

To add a new table field, proceed as follows: 

1. Select a table in the top part of the table. 
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When you select a table record, the fields that are already configured to receive indexing 
information are displayed in the lower part of the window. 

If the index file structure is set to Fixed Field Length format, the lower part of the table 
contains the columns in the following table: 

Fixed Field Length columns 
Column Description 

Field Name Field that is assigned to a particular place in the source indexing file. 

Field Type Field type. 

Start Pos Starting position of the value for the corresponding field in the incoming index file. 

This parameter can be set automatically by using the Browse option. 

# of Char Number of characters to be extracted from the index file for the corresponding 
field. 

This parameter can be set automatically using the Browse option. 

Index Field Index field. Number 1 indicates that the field is used for indexing in Exigen 
Workflow. Number 0 indicates that the field is not used for indexing. 

If the index file structure is set to Delimiter format, the lower part of the table contains the 
columns described in the following table: 

Fixed Field Length columns 
Column Description 

Field Name Field that is assigned to a particular place in the source indexing file. 

Field Type Field type. 

Order in 
Row 

Which record in the line of the indexing file corresponds to the value of this field. 

This parameter can be set automatically by using the Browse option. 

Index Field Index field. Number 1 indicates that the field is used for indexing in Exigen 
Workflow. Number 0 indicates that the field is not used for indexing. 

2. Click Add. 

The Add New Field window appears. 
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Figure 56: Add New Field window with Fixed Field Length format selected 

If the Fixed Field Length format is selected, the Add New Field window contains the fields 
listed in the following table: 

Add New Field, Fixed Field Length format 
Field Description 

Table Name Selected table. 

Mode Index file structure, in this case, Fixed Field Length. 

Field Name Selected field to be populated with the information from the indexing file. 

Start 
Position 

Starting position in the index file from where the data is to be extracted. This 
parameter can be set automatically using the Browse feature. 

Field Length Length of the field to be extracted. Import Server always suggests the proper value 
for this field. 

Test Value Test data extracted from the index file using the Browse feature. 

If the index file structure is Delimiter, the Add New Field window contains slightly different 
parameters. 
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Figure 57: Add New Field window with Delimiter format selected 

The information and entry fields of the window are described in the following table: 

Add New Field, Delimiter format 
Field name Description 

Table Name Table name. 

Mode Index file structure, in this case, Delimiter. It also displays the delimiter symbol 
shown in the <>. 

Field Name Selected field that is to be populated with the information from the indexing file. 

Order of 
selection 

Which record in the line of the indexing file corresponds to the value of this field. 
This parameter can be set automatically using the Browse feature. 

Test Value Test data extracted from the index file using the Browse feature. 

3. In the Field Name list box, select a field. 

4. Specify which part of the indexing text file corresponds to the value of this field. 

5. Click Browse. 

The Datafile Browser window appears. 
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Figure 58: Datafile Browser window 

6. To open the standard Open File dialog, click Get Datafile. 
7. In the source directory, select any indexing file and click OK. 

The contents of the file are displayed. 

8. Select the portion of the text file that corresponds to the value of the field.  

9. To assign the portion of the text file to the value of the field, click Assign. 
10. To display only the selected portion of the indexing file, click Select Highlight. 
11. To display the whole indexing file, click Select Text. 
12. When a portion of a text is assigned to the field value, click Exit. 

The assigned text appears in the Test Value field. 

Note: Using the Browse function is not compulsory, because all parameters in the Add New Field 
window can be configured manually. Using Browse allows automatic configuration of new 
field’s parameters by highlighting portions of text in the indexing file. 
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13. Click Finish. 

The new field appears in the lower part of the Tables and Fields Setup window. 

14. To modify a field record in the Tables and Fields Setup window, highlight the record and 
click Modify. 

Creating an Empty Parcel with Import Server  
Your business case might need to create a parcel with an empty document and with indexing 
information. An empty document means that it has no image file. The parcel is merged later with 
the parcel containing the appropriate documents. 

Exigen Workflow provides the option to create a parcel with an empty document if an empty 
image path is specified in the indexing information for Import Server.  

The system uses the A_PARCEL_STATUS field in the BATCHPARCEL table as a flag for 
Import Server. If this field is defined in the system and indexing information contains only 
indexing values without the path to documents, Import Server creates a parcel with the indexing 
information and sets the A_PARCEL_STATUS field value to EMPTY PARCEL and creates a 
document with no image in it. If the path to documents is specified, Import Server works in the 
standard way: it creates a parcel with documents containing images.  

To activate this feature, add the A_PARCEL_STATUS field with type VARCHAR and length 12 
to the BATCHPARCEL table. For information on adding custom fields, see the Exigen Workflow 
Administrator's Guide, Part 1: Design and Configuration, Chapter 3: Creating Projects, Creating 
a New Project. 

Running Import Server 
To start the import process, proceed as follows: 

1. Open the Import Setup window. 

2. To select the importing configuration records you want to run, in the first Import Setup 
window, select the boxes to the left of the Source File Directory column. 

A check mark appears to the left of each selected record. 

3. To return to the Import Server window, click Close.  
4. To begin the import process, click Start Server.  

The names of the files being processed are displayed at the bottom of the window. 

Note: Import Server may not respond to user activities during the conversion of large image files. 

5. To stop the process, click Stop Server at any time. 

To check the results of the import operation, if you are importing indexing information, proceed 
as follows:  
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1. Open the Administrator utility. 

2. Select the project where the data was imported.  

3. Click Table Maintenance and double click the table that was updated with the imported 
data. 

4. In the Search for Table Records window, click Find Record. 

  

For information on maintaining Import Server as a service, see Appendix B: Maintaining Exigen 
Workflow Servers as Services. 

Viewing Import Server Log and History Files 
Each time Import Server is started, a log file is created for each import record. If the History box 
is selected for an individual setup record, a history file is also created. 

1. To view the log file, click Log File.  
2. To view the history file, click History. 

The results window displays the source file directory.  

3. To view the associated text file for either the log or history file, highlight the desired source 
file and click Read. 

A text file appears providing a status of the last import session. 

4. To clear the file, click Clear.  
5. To return to the Import Server window without changing the text file, click Close. 

Exporting Setup Data 
To export all import setup data in a specified file, proceed as follows: 

1. In the File menu of the Import Server window, select the Export Setup… item.  

The Export Setup Data window appears. 
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Figure 59: Export Setup Data window 

2. In the Export File Name and Location field, specify the name of the file where you want to 
save the data.  

3. In the Note field, enter an optional short description of this setup data. 

4. To start exporting, click Start Export. 
5. To open the export file using a text editor such as Notepad, click Read File.  
6. To exit this dialog, click Close. 

Note: The records of Import Setup can only be accessed on the local machine where they were 
created. 
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Chapter 10: Distribution Server 
This chapter describes how to configure Distribution Server and use it to distribute image files 
from one project to another.  

The following topics are described in this section: 

• Overview 

• Distribution Server Window 

• Configuring Distribution Server 

• Running Distribution Server 

• Info Files Format 

Overview 
Distribution Server distributes parcels and documents scanned in one project or workflow to 
other projects. The source and target projects can exist in either the same database or different 
databases. Distribution Server exports only current document versions. 

Documents must be indexed prior to their distribution so that their records can be identified by 
Distribution Server. For example, if you are scanning documents to be distributed to both the 
Human Resources and Accounts Payable projects, you can use barcode separator sheets to 
distinguish Resumes from Invoices. When you are configuring the Process Setup, you can 
indicate that Resumes must be distributed to the Human Resources project and invoices to the 
Accounts Payable project. 

Distribution Server Window 
To open the Distribution Server window, in Exigen Workflow Explorer, double click the 
Distribution Server icon. 

  

The Distribution Server window appears. 
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Figure 60: Distribution Server window 

The window contains the following features and information: 

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• information about the number of incoming batches, processed parcels, documents, and 
pages on the left. Documents having a Y in the Locked column are checked out for editing 
and cannot be modified. 

• status window displays the current mode of the server on the right 

• toggle button displays data in either Form view or Column view 

Configuring Distribution Server 
Before running Distribution Server, you must configure the source and target information. This 
process determines the source and destination locations of the document records and image 
files. 

The following topics are described in this section: 

• Setting Up Distribution Server 

• Specifying Export Configurations 
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• Specifying Settings for the Target Exigen Workflow Database and Project 

Setting Up Distribution Server 
To configure Distribution Server, select Run > Process Setup, or click the following: 

 

The Setup window appears. 

Because of its large window size, the Setup window is represented in the following figures in 
three views: 

 
Figure 61: Setup window, first view  
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Figure 62: Setup window, second view  

 
Figure 63: Setup window, third view 

To navigate to the second and third views, use the horizontal scrollbar at the bottom of the 
window. The button bar across the top of the window remains the same, regardless of the view. 

The Setup window contains a button bar and a table of export configuration records. 
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In line with the example described previously, add two export configuration records in this table. 
For example, you can add an export record that describes exporting resumes to the Human 
Resources project. A second record describes exporting invoices to the Accounts Payable 
project. 

The Setup window buttons are used to perform the following functions: 

Setup window buttons 
Button Description 

 
Adds a new export configuration. The Export Setup window appears as described in 
Specifying Export Configurations.  

A black arrow appears in the column to the left of the Export Type field, indicating that 
you can add the new record to this row. 

  

 
Modifies an existing export configuration. The Export Setup window appears as 
described in Specifying Export Configurations. 

 
Deletes a selected export configuration record from the table. 

 
Reverts to the last saved configuration version. 

 
Opens the Help file for the Setup window. 

 
Exits the Setup window. 

The Request to stop every n minutes field specifies the interval in minutes, and a dialog for 
stopping Distribution Server is displayed. For example, if 5 is specified in the Request to stop 
every n minutes field and Distribution Server is started, a dialog appears every 5 minutes, 
allowing the user to stop, interrupt, or continue server operation. 

Note: The Request to stop every n minutes option is useful when processing large documents 
having 100 or more pages. 

The columns in the Setup window table display the configuration settings. Some columns 
contain information only if the export type is DMS or External DMS.  

The Setup window columns are the following: 



Administrator's Guide, Part 2: Business Component Reference  Chapter 10: Distribution Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 139 of 391 

Setup window columns 
Column Description 

Export Type File type into which the exported image file is converted. The export type can be 
one of the following: 

• Single structure: series of single-page TIFF files. TIFF file names are 
constructed as the DMS file name, followed by an underscore _ and four-
digit page number, for example, 00000675_0001.TIF. 

• Multi structure: multipage TIFF file. 

• Adobe PDF: Adobe PDF file.  

• DMS: Exigen Workflow DMS file. 

• External DMS: Exigen Workflow DMS file that is exported from an Exigen 
Workflow system for import into another Exigen Workflow system. For 
example, an external DMS file can be sent via email to another city where 
Exigen Workflow is used. 

Match Table Table in which the match field value is located. 

Match Field Field name from which the match field value is being extracted. 

Match Field 
Value 

Distributes documents to the corresponding project if the data from the Match 
Table and Match Field are equal to the Match Field Value.  

The Match Field Value is a unique, user-defined value that differentiates between 
the Distribution Server configurations if they are performing distribution for different 
projects. This information must match the value in the scanning project.  

The combination of Match Field Value, Match Table, and Match Field must be 
unique for each Setup record used. 

Annotations How document annotations are kept. Annotations can be kept as separate objects 
or merged into the document. If the export type is DMS, annotations are always 
kept as separate objects. 

Doc Info File 
Ext. 

Extension of the document information file. 

Parcel Info File 
Ext. 

Extension of a parcel information file. 

Export File 
Location 
(Current Drive 
Map) 

Directory location where the exported documents are stored. This is a mandatory 
field and must contain a valid directory string or export is not successful. You can 
view database records, but no images are found and displayed. If export type is 
DMS, the export file location is set in the Target setup of the Export database 
setup window, and it must point to the location of the target project file, which is 
the main directory for folders labeled date-and-time that store DMS files. For 
information on the Export database setup window, see Specifying Settings for the 
Target Exigen Workflow Database and Project.  

If export to DMS is set up, information appears in the following columns of the Setup window: 

Setup window export to DMS columns 
Column Description 

Export Project 
Database 

Exigen Workflow database containing the target project. 
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Setup window export to DMS columns 
Column Description 

Export Database 
User 

Exigen Workflow database user ID for the target project database. 

Export Project 
ID 

Three-character project ID of the target project. 

Export WFlow 
ID 

Numeric workflow ID of the target workflow. 

WFlow Node ID Workflow node ID of the target workflow. 

Visi User ID User ID required to assign the documents to the target workflow. 

Use RSNs From Indicates whether the RSN, such as internal numbers assigned to each folder, 
document, batch, parcel, and other records in the database, is retained from the 
source project or a new RSN is created in the target project. 

Doc. File Action Removes the original image file from the source project. 

Export File 
Location 
(Customer Drive 
Map) 

Directory location where the exported documents are stored. This parameter 
shows the same directory location as it appears to the target computer to which 
documents are exported. 

 

Additional File 
Location 
(Current Drive 
Map) 

Additional directory location if the image files to be distributed reside on an 
additional drive.  

 

Additional File 
Location 
(Customer Drive 
Map) 

Displays an additional directory location as it appears to the target computer to 
which documents are exported. This location is displayed if the image files residing 
on the additional file location are to be distributed to a drive map location different 
than the export file location. 

 

If export to external DMS is set up, information appears in the following additional columns of 
the Setup window: 

Setup window export to external DMS columns 
Column Description 

Header Indicates whether a header is exported with the external DMS file. The header 
describes the file’s indexing information, listing table and field information used by 
Import Server. An x indicates that a header is used. 

Relative path Variable string that is added to the beginning of the exported file’s relative path. 
For example, if the user knows that the exported file is to be placed on drive c, this 
field contains c: This facilitates the location of the file by Import Server. 

Delete 
document 

Indicates whether the source file is deleted from the current Exigen Workflow 
system after export. An x indicates deletion. 

Delete index 
info 

Indicates whether the source file’s indexing structure is deleted from the current 
Exigen Workflow system after the export. For example, if the document was the 
last item in a particular subfolder, that subfolder is deleted. An x indicates deletion. 
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Specifying Export Configurations 
The Export Setup window is used to add or modify an export configuration. 

 
Figure 64: Export Setup window 

This section describes how to add or modify an export configuration using the following 
procedures: 

• Specifying the Export Type and Selecting Export Files 

• Creating Information Files 

• Specifying Directories for Exported Files 

Specifying the Export Type and Selecting Export Files 

To specify the export type and select the files to be exported, proceed as follows: 
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1. Open the Export Setup window. 

2. To specify the export type, select a value in the Choose export type field. 

This is the file type into which the exported DMS image files are converted. 

Note: Task documents created with Word or other third-party applications are not converted. 

The export type can be one of the following: 

Export types 
Name Description 

Single structure Series of single-page TIFF files. 

Multi structure Multipage TIFF file. 

Adobe PDF Adobe PDF file. 

DMS Exigen Workflow DMS file. 

External DMS Exigen Workflow DMS file for export from the current Exigen Workflow 
system. 

If the export type is DMS, the Target Setup button is enabled. 

3. If the export type is DMS, click Target Setup and specify settings for the target project that 
receives exported documents. 

For more information on the Export database setup window, see Specifying Settings for 
the Target Exigen Workflow Database and Project. 

If the documents to be exported include task documents, and the export type is Single 
structure, Multi structure, or Adobe PDF, the task documents are copied by default to the 
target directory without conversion. 

4. To specify that task documents are skipped during export, proceed as follows: 
1. Open the visiclt.ini file. 
2. At the end of the file, add the following: 

[setup_exp] 
TaskFiles=S 

The S value ensures that task files are not copied to the target directory. After 
processing, these task files have the flag ExpSK, which appears in the Status column of 
the Distribution Server window. 

If TaskFiles is set to C, the task documents are copied to the target directory and the flag 
is ExpOK. 

Note: The option to skip or copy task files applies only if the export type is Single structure, Multi 
structure, or Adobe PDF.  

5. To select the table where the value identifying the document is located, in the Table field, 
select one of the following: 
• FOLDER 
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• BATCHPARCEL 
• DOCUMENT 

6. To select the field name and value identifying the document to be exported, enter values in 
the Field and Value fields.  

7. To export all documents from Distribution Server, specify the following configuration: 
Settings for exporting all documents 
Field Value 

Table DOCUMENT 

Field IMAGE_LOCATION 

Value ALL 

8. To specify a setting for document annotations, in the Document Annotations area, select 
either of the following options: 
Document annotations options 
Name Description 

Keep as separate objects All annotations added to the document are retained as separate 
graphical objects in the resulting file. They can be selected and 
changed individually. If the Export Type is DMS, annotations are 
always kept as separate objects. 

Merge into a document All graphical objects are merged into the resulting file, forming only 
one layer. In this case, graphical objects cannot be selected or 
changed separately. If the export type is Adobe PDF or External 
DMS, all annotations are merged into the resulting file. 

Creating Information Files 

To create information files, proceed as follows: 

1. To create a parcel information file, select Create parcel info file with extension (3 
characters) and enter a file extension, for example, txt. 

During export, one file per exported parcel is created that lists database information for the 
documents contained in each specific parcel. The file name is the parcel ID and the 
extension that is entered. 

2. To create a document information file, select the appropriate check box and enter a file 
extension, for example, txt. 

For each exported document, one file with the given extension is created that contains 
information about the exported document. The file name is derived from the DMS file name. 

3. To create a header in the exported information file, select Create header in info file. 

Specifying Directories for Exported Files 

To specify the directories for exported files, proceed as follows: 

1. To indicate the exported file’s relative path, select Use relative path.  
2. To indicate a prefix for the relative path, enter it in the field next to Use relative path. 
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For example, if it is known that the exported file is to be stored in a particular folder, the 
folder name is entered. 

3. To delete the source document in the Exigen Workflow system upon export, select Delete 
exported documents. 

4. To delete the exported document’s indexing information, select Delete exported 
document’s indexing information. 

Indexing information is deleted only if the folder and subfolder information is not used by any 
other document. 

5. To select a directory for the exported files, click the browse button next to the Directory for 
exported document files field. 

6. To select a directory for the exported index files, click the browse button next to the 
Directory for exported index files field. 

If no directory is selected, the index files are exported by default to the directory displayed in 
the Directory for exported document files field. 

7. To save the settings, click Apply. 

Note: Apply is enabled only if all mandatory fields contain valid information. 
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Specifying Settings for the Target Exigen Workflow Database 
and Project 
If you selected the DMS export format, you must specify settings for the target Exigen Workflow 
database and project in the Export database setup window.  

 
Figure 65: Export Setup database 

To specify settings for the target Exigen Workflow database and project, proceed as follows: 

1. In the Export database setup window, set the target database connection parameters: 
• Enter the database containing the target project. 
• Enter the database user ID for the target project database. 
• Enter the database password for the target project database. 
• If an Oracle database is used and the Exigen Workflow tables in the target database are 

not in the user’s schema, enter a database schema. 
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• To make sure that the data you entered is correct, click Test Connection. 
Note: The target project parameters are enabled only if the test is successful. Otherwise, you are not 

allowed to complete the setup. 

2. Set the target project parameters: 
• Select the user ID to assign the documents to in the target workflow.  
• Select the target project ID. As soon as you select the project ID, the path to the location 

of the corresponding project appears in the Customer Drive map field. 
• Select the workflow ID of the target workflow.  

3. Select the workflow node ID of the target workflow. 

4. Decide whether you want to use the RSN, or internal numbers assigned to each folder, 
document, batch, parcel, and other records in the database, from the source project or from 
the target project by selecting the appropriate radio button. Select the source project only if 
the target project does not contain any document records because duplicate numbers 
cannot be inserted in the document RSN field in the target project. In case of a violation, 
data is not updated and erroneous data can be created. 

5. Specify where the export files in the source project must be placed. To remove these files 
from the export project, select the Remove exported files from source check box. 

6. Specify the export file locations: 
• Select a directory location where the exported documents are stored. This is a 

mandatory field and must contain a valid directory string; otherwise, export is not 
successful. You can view database records, but no images are found and displayed. 

• Enter a directory location where the exported documents are stored. This parameter 
shows the same directory location as it appears to the target computer. 

Note: Both parameters Current Drive Map and Customer Drive Map must point to the same 
physical location on the disk or network. In most cases, this means that they must be equal. 
They cannot be equal when the export directory is seen differently from the target project than 
from the source project. For example, project A must export DMS files to project Z. Each project 
resides on a different computer. Project Z has configured the DMS storage location on a 
network directory, which is mapped as the disk M, but project A has mapped the DMS storage 
location on a network directory as disk P. When viewed from the workflow, DMS files are 
opened relative to each computer's current drive mapping. To ensure that drive maps are 
correct when exporting, the file paths must be changed from P in project A, and to M in project 
Z. 

7. If the distributed image files reside on an additional drive, specify the additional file 
locations: 
• Select an additional directory location for the current drive map. 
• Enter an additional directory location for the customer drive map.  

8. These fields are not mandatory. 

9. To save the settings, click Apply. 

Note: Apply is enabled only if all mandatory fields are filled in and they contain valid information. 
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Running Distribution Server 
The following topics are included in this section: 

• Starting Distribution Server 

• Stopping Distribution Server 

Starting Distribution Server 
To start Distribution Server, click Start Server. 

 

The Auto Send function from the Run menu routes processed work items to the next queue in 
the workflow based on the routing rules. If no routing rules exist, Auto Send is automatically 
disabled, requiring a manual send process. If routing rules do exist but the Auto Send feature is 
disabled, a manual send process is also required.  

The Server Mode function allows jobs sent to the server to be automatically processed. When 
the object is opened and you select Start, any jobs sent are processed immediately. If Server 
Mode is not enabled, you must manually start the server each time the work items are received.  

For complete automation, both options must be selected with the appropriate outgoing routing 
rules in place. Once started, work items are processed and routed to the next queue without the 
need for user intervention. The status window displays the processes being performed and the 
time elapsed. 

For information on maintaining Distribution Server as a service, see Appendix B: Maintaining 
Exigen Workflow Servers as Services. 

Stopping Distribution Server 
To stop Distribution Server, click Stop Server. 

 

If a large document of 100 or more pages is processed, the Distribution Server window 
becomes blank. 

To ensure that Distribution Server can be stopped, interrupted, and restarted when processing 
large documents, specify a time interval in the Request to stop every n minutes field as 
described in Setting Up Distribution Server. 

If the Request to stop every n minutes option is used and the server processes a large 
document, the Request to Stop Server dialog appears at the specified intervals. 
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Figure 66: Dialog for stopping Distribution Server 

The Request to Stop Server dialog remains open for 5 seconds. If no actions are taken during 
this time, Distribution Server continues processing documents. 

To pause and configure frequency at which the Distribution Server stops, proceed as follows: 

1. In the Request to Stop Server dialog, click Pause. 

The Request to Stop Server dialog changes. 

 
Figure 67: Dialog for stopping Distribution Server with additional buttons 

2. In the Next request will be available after n minutes list box, select the time after which 
the Request to Stop Server dialog reappears. 

3. To stop Distribution Server, click Stop. 
4. To continue processing, click Continue. 

Info Files Format 
The description files are created if the following fields in the Setup window have any non-blank 
values: 

• Parcel Info File Ext. 

• Doc. Info File Ext. 

Parcel Info Files 

These files contain one line for each document that was exported from the given parcel. 

Values are comma-delimited. In the event of an empty value, a single space is written. 
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The values are as follows: 

1. Parcel ID of the parcel being exported, such as parcel ID in the source project. If in the 
source project the parcel ID is 64, but in the target project it is 80, 64 is written to the file. 

2. Document file name without extension. The file names are from those of the target project. 

3. File extension of the exported file. 

4. Finally, two trailing commas without spaces are added to indicate termination of the line. 

Document Info Files 

Each file contains only one line of text. Values are separated with vertical bars |. 

The number of values in the line depends on the number of additional fields used in the project. 
In particular, these are fields which have value A in the field FIELDSTATUS in the 
SYSCOLUMNS table of the project. 

1. If FLD_RSN of the given document is not '999999999', for example, default folders are not 
used, all additional folder field values for the document are written to the following file: 
SYSCOLUMNS.TBNAME='FOLDER'. 

2. If SUB_FLD_RSN of the given document is not '999999999', all additional subfolder field 
values for the given document are written to the following file: 
SYSCOLUMNS.TBNAME='SUBFOLDER'. 

3. All additional field values of the batchparcel of the given document are written to the 
following file: 

SYSCOLUMNS.TBNAME='BATCHPARCEL'. 

4. The values of additional fields of the document and the values of the following mandatory 
fields are written as follows: 
• document type 
• document description 
• document scan date 
• number of image pages in document 
• full path to the document in the target project 

The order of fields can differ. 

Note: In all four steps, the order of the values is the same as in the tables from which they come. See 
SQL clause 'ORDER BY ORDER IN TABLE'. 

To determine the indexing fields sequence, in the Export Setup window, select Create header 
in info file.  
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Chapter 11: Escalation Server and Log 
This chapter describes how to set up and run Escalation Server and display and interpret the 
Escalation log data.  

The following topics are described in this section: 

• Overview 

• Escalation Server Window 

• Configuring Escalation 

• Escalation Log Window 

• Specifying Escalation Server Settings 

Overview 
Escalation Server routes work items and email to users defined in those queues in the 
workflow that are escalation enabled. It locates and executes the escalation process based on 
the criteria set in the workflow nodes. Once the escalation process has occurred, the 
Escalation Log views the work items that are moved. 

For instructions on configuring escalation in a queue, see the Exigen Workflow Administrator's 
Guide, Part 1: Design and Configuration, Chapter 5: Designing a Workflow, Escalation Tab. 

For information on maintaining Escalation Server as a service, see Appendix B: Maintaining 
Exigen Workflow Servers as Services. 

Escalation Server Window 
To open the Escalation Server window, in Exigen Workflow Explorer, double click the 
Escalation Server icon. 

 

The Escalation Server window appears. 
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Figure 68: Escalation Server window 

The Escalation Server window consists of the following features and information:  

• button and menu bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• information about the number of work items in the queue currently being processed and the 
number of jobs processed for that queue 

• information about the start time 

• information about the total number of jobs processed since Escalation Server was started 

• information about total queues 

• table of nodes information 

Note: To ensure that the server runs continuously, the Keep running after started option in the 
Escalation Settings dialog must be selected. For more information on escalation settings, see 
Specifying Escalation Server Settings. 

Escalation Server window, field values 
Field Description 

Jobs in Queue Identifies the number of jobs being escalated in the queue. 

Jobs Processed Identifies the number of jobs processed in the current queue. 

Start Time Date and time when the current session of Escalation Server began. 
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Escalation Server window, field values 
Field Description 

Last Process Date and time when Escalation Server performed the last action. 

Total Processed Total number of jobs processed in the current session of Escalation Server. 

Total Queues Number of queues in the workflow configured to use the Escalation process. 

Node  Current node ID being escalated. 

Node Title Current node name being escalated. 

Configuring Escalation 
The following topics are described in this section: 

• Configuring Execution Times 

• Excluding Non-Business Days and Holidays 

Configuring Execution Times 
To configure escalation execution times, edit the [setup_escalation] section in the 
visiclt.ini file: 

[setup_escalation] 
EscTimes=9:00 AM, 11:50 AM, 3:30 PM, 6:00 PM 

In this example, escalation occurs every working day at 9:00 AM, 11:50 AM, 3:30 PM, and 6:00 
PM. 

Excluding Non-Business Days and Holidays 
To exclude non-business days and holidays, proceed as follows: 

1. In the Table Maintenance window, select the table ESC_CAL. 
2. If you do not have the ESC_CAL table available, to upgrade your database, in Project 

Builder, run Check Project Version.  
ESC_CAL table 
Field Name Format  Description 
CAL_KEY smallint Calendar key. Default value is 1. 

CAL_DATE date Calendar date. 
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ESC_CAL table 
Field Name Format  Description 
STATUS char (3) Status. The following values can be used: 

• SAT: Saturday is a non-business day. The field 
CAL_DATE can be NULL. 

• SUN: Sunday is a non-business day. The field CAL_DATE 
can be NULL. 

• WRK: the date in CAL_DATE is a business day. 

• OFF: the date in CAL_DATE is a non-business day. 

Note: Non-business days are excluded from escalation 
calculations, but Escalation Server can run on non-business 
days. 

3. Enter appropriate values as shown in the following example. 
ESC_CAL table fields example 
CAL_KEY CAL_DATE STATUS Explanation 
1 <NULL> SAT Saturday is a non-business day, but Sunday is a 

business day because the CAL_DATE combined with 
STATUS equals SUN. 

1 07/04/2001 OFF Date 07/04/2001 is a non-business day. 
1 07/04/2003 OFF  
1 05/15/2001 WRK Date 05/15/2001 is a specified business day, used if 

Saturday is a business day. 

The following rules apply when excluding days: 

• If at least one record in the ESC_CAL table is assigned SAT status, all Saturdays are non-
business days. 

• If at least one record in the ESC_CAL table is assigned SUN status, all Sundays are non-
business days. 

• The holiday dates must be written for each year, for example, 07/04/2001, 07/04/2003. 

• If the ESC_CAL table is empty or does not exist in the database, all calendar days are 
business days. 

Escalation Log Window 
Each session of Escalation Server generates a detailed record of the escalated parcels. This 
information is located in the Escalation Log. 

To view the log, click Escalation Log. The Escalation Log Table window appears. 
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Figure 69: Escalation Log Table 

The Run Date column displays the date and time when each session of Escalation Server 
began. The Workflow Title column shows in which workflow the escalation process occurred. 
The Processed column shows the total number of work items that were escalated.  

To view the detail of the work items for a specific Run Date, highlight the run date and click 
Populate. The lower portion of the window displays the requested information. The following 
table describes the columns listed: 

Escalation Log Table 
Column Description 

Parcel Parcel number of the escalated work item. 

Folder Folder number to which the escalated work item is assigned. 

Node From Node ID in which the escalated item was located. 

User From User ID to whom the escalated item was assigned. 

Node To Node ID to which the escalated item was sent. 

User To User ID to whom the escalated item was sent. 

Date Date when the escalation occurred. 

To remove run date records from the Escalation Log window, highlight the run dates to be 
deleted and click Purge.  
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Specifying Escalation Server Settings 
To specify Escalation Server settings, proceed as follows: 

1. Click Process Setup. 

The Escalation Settings window appears. 

 
Figure 70: Escalation Settings dialog 

2. To ensure that the server runs continuously, select the Keep running after started check 
box.  

Note: Escalation Server does not check the Keep running after started setting if the EscTimes 
parameter is set in the visiclt.ini file as described in Configuring Execution Times. 

3. Enter the value for the process interval in which the escalation must be performed. 

4. In the Process Interval field, enter a number. 

5. In the drop-down list that appears, select the units. 

6. Click OK. 
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Chapter 12: Document Retention 
This section describes how to configure retention policies and use Retention Server to manage 
the disposal of documents that are out of date. 

The following topics are described in this section: 

• Retention Server Overview 

• Enabling Document Retention 

• Configuring Retention Policies 

• Running Retention Server 

• Approving Retention Collections 

Retention Server Overview 
Retention Server is an automatic workflow object that manages the disposal of outdated 
documents and documents that are marked for deletion. 

Retention Server can operate in the following modes: 

Retention Server operation modes 
Mode Description 
Document recycling Retention Server deletes workflow documents from the document recycling 

bin. 
The recycling bin is a logical container for Exigen Workflow documents 
that are marked for deletion. Documents are physically removed from the 
database and document storage systems only when Retention Server 
deletes them from the recycling bin. 
For document recycling operation mode, the Retention Server software 
license is not required. 
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Retention Server operation modes 
Mode Description 
Retention collection 
disposal 

Retention Server deletes workflow documents that pass the retention 
period calculated from the cut off date according to defined retention 
policies. 
Disposable documents are compiled into retention collections. When a new 
retention collection is created, the person responsible for Retention Server 
maintenance receives an email from Retention Server and makes one of 
the following decisions: 
• approves the collection for disposal 
• freezes the collection 
• modifies the contents of the collection 
A retention policy is a set of rules used by Retention Server to create 
retention collections. Using the Administrator utility, administrators define 
retention policies and assign them to a document type or a document 
collection created with Exigen Publisher Collector. 
A document’s cut off date is the date from which the retention period is 
calculated for the document. For example, if the cut off date is November 6, 
2006, and the retention period is 20 days, the document is sent to the 
retention collection if Retention Server is run on November 26, 2006 or 
later. 
For retention collection disposal operation mode, the Retention Server 
software license is required. 

For ERM document disposal, corresponding records and files in the ERM storage project can 
also be removed, if there is no dependency for existing ERM documents. As an ERM storage 
file can contain several ERM documents, storage is removed only upon removal of the last ERM 
document referring to that storage file. For more information on ERM documents, see Chapter 
14: Configuring Enterprise Report Management. 

Enabling Document Retention 
To enable document retention in a workflow, proceed as follows: 

1. Create a Retention Server node in the workflow. 

For information on creating workflow nodes, see the Exigen Workflow Administrator’s Guide, 
Part 1: Design and Configuration, Chapter 5: Designing a Workflow. 

2. Create a mechanism for defining a cut off date for the documents in the workflow. 

A document’s cut off date is stored in the DOCUMENT table in the CUTOFF_DATE field. A 
common mechanism for setting the document cut off date is by using Exigen Workflow 
events. 

For information on setting up Exigen Workflow events, see the Exigen Workflow 
Administrator’s Guide, Part 1: Design and Configuration, Chapter 4: Setting Up Exigen 
Workflow, Setting Up Events. 

3. Define and activate the retention policies for the documents in the workflow as described in 
Configuring Retention Policies. 
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4. Start Retention Server. 

Configuring Retention Policies 
The following topics are described in this section: 

• Managing the Policy List 

• Creating and Modifying Retention Policies 

• Managing Document Type Retention Policies 

• Managing Document Collection Retention Policies 

• Viewing Document Collections 

• Selecting a Retention Policy 

Managing the Policy List 
All actions related to the document retention policy configuration are performed in the Policy 
list window. 

To open the Policy list window, proceed as follows: 

1. In Exigen Workflow Explorer, select Administration Tools > Workflow Tools > 
Administrator. 

The Administrator Utilities window appears. 

2. Select Administrator > Retention Setup. 

The Select project window appears. 

 
Figure 71: Project list 
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3. In the Select project window, select the project in which to create or modify the retention 
policies, and click OK. 

The Policy list window appears. 

 
Figure 72: Retention policies list 

The Policy list window displays all retention policies defined for the selected project. 

The following table describes the columns in the Policy list window: 

Policy list window columns 
Column Description 
Name Policy name. 

The check box in this column identifies whether the policy is currently active. 
Description Policy description. 
Authority User responsible for approving the disposal of documents. 

The following table describes the buttons and menu options in the Policy list window: 
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Policy list window buttons and menu options 
Button Menu option Description 

 

Policy > New policy Creates a new policy. 
For information on creating new policies, see Creating and 
Modifying Retention Policies. 

 

Policy > Edit policy Modifies the information of the selected policy. 
For information on modifying policies, see Creating and 
Modifying Retention Polices. 

 

Policy > Delete policy Deletes the selected retention collection. 

 

Management > 
Document type 

Displays a list of all document types to which existing 
retention policies can be assigned as described in 
Managing Document Type Policies. 

 

Management > 
Collection 

Displays a list of all document collections to which existing 
retention policies can be assigned as described in 
Managing Document Collection Retention Policies. 

 

Management > 
Disposal 

Opens the Approve document disposal window. 
For information on approving, freezing, and modifying 
retention collections, see Approving Retention Collections. 

 

Policy > Exit Closes the Policy list window. 

4. To apply any changes made in the Policy list window, click OK. 
5. To close the Policy list window without applying the changes, click Cancel. 

Creating and Modifying Retention Policies 
To create a new retention policy, proceed as follows: 

1. In the Policy list window, select Policy > New policy. 

The New policy window appears. 
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Figure 73: New policy window 

If you modify a retention policy, the same window appears. 

2. In the Name field, enter the name of the policy. 

3. In the Description field, enter a short description of the policy. 

This field is optional. 

4. To enable the policy, select the Is active check box. 

5. In the Retention period fields, specify the retention period of the policy. 

The retention period is the time after which the documents assigned to this policy are 
disposable, starting from the cut off date. 
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6. In the Responsible person list, select the user responsible for approving the retention 
collections for disposal. 

The responsible person receives an email from Retention Server when a new retention 
collection is created. 

7. In the Disposal instructions field, enter the instructions for the responsible person about 
the policy. 

This field is optional. 

8. To assign the policy to a document type, in the Assigned document types box, click Add. 

The Select document type window appears. 

 
Figure 74: Assigning the policy to a document type 

The following table describes the columns in the Select document type window: 

Select document type window columns 
Column Description 
Name Document type name. 
Description Document type description. 
Policy Policy currently assigned to the document type. 

9. Select a document type and click OK. 

The retention policy is assigned to the selected document type. Assigning a retention policy 
to a document type means that the retention policy applies to all documents of the selected 
document type. 

10. To view the information about the selected document type, in the New policy window in the 
Assigned document types box, click View. 

11. To remove an assigned document type from the policy, in the Assigned document types 
box, select the document type and click Remove. 
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12. To assign the policy to a document collection created with Exigen Publisher Collector, in the 
Assigned collections box, click Add. 

The Select collection window appears. 

 
Figure 75: Assigning the policy to a document collection 

13. In the Select collection window, select a document collection and click OK. 

The retention policy is assigned to the selected document collection. Assigning a retention 
policy to a document collection means that the retention policy applies to all documents in 
the selected document collection. 

14. To view the information about the selected document collection, in the New policy window 
in the Assigned collections box, click View. 

15. To remove an assigned document collection from the policy, in the Assigned collections 
box, select the document collection and click Remove. 

16. To create the defined policy, in the New policy window, click OK. 

The new policy appears in the Policy list window. 

17. To activate the policy, in the Policy list window, select the check box in the Name column, 
or in the New policy window, select the Is active check box. 

Managing Document Type Retention Policies 
The Policy list window is used to assign existing retention policies directly to document types. 

To assign retention policies to document types, proceed as follows: 

1. In the Policy list window, click Manage document type policies . 
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The Document type policy management window appears. 

 
Figure 76: Assigning retention policies to document types 

The table displays names, descriptions, and assigned retention policies of all document 
types defined in the system. 

2. Double click the appropriate document type. 

The Select policy window appears. 

3. Select the appropriate retention policy as described in Selecting a Retention Policy. 

The selected retention policy is assigned to the document type. 

4. To close the Document type policy management window, click OK. 

Managing Document Collection Retention Policies 
The Policy list window is used to assign existing retention policies directly to document 
collections. 

To assign retention policies to document collections, proceed as follows: 

1. In the Policy list window, click Manage collection policies . 

The Manage collection policies window appears. 
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Figure 77: Assigning retention policies to document collections 

The table displays all document collections defined in the system and their assigned 
retention policies. 

2. To view documents in a document collection, select the appropriate collection and click 
View collection. 

For information on viewing documents in a collection, see Viewing Document Collections. 

3. Double click the appropriate document collection. 

The Select policy window appears. 

4. Select the appropriate retention policy as described in Selecting a Retention Policy. 

The selected retention policy is assigned to the document collection. 

5. To close the Manage collection policies window, click OK. 

Viewing Document Collections 
In the Manage collection policies or Approve document disposal windows, when a user 
clicks View collection, the Collection window appears. 
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Figure 78: Viewing and modifying the contents of a document collection 

The tree structure displays the contents of the selected document collection. 

To view or modify the contents of the document collection, proceed as follows: 

1. To browse through the contents of the retention collection, use the tree structure. 

2. To view a selected document in Image Viewer, click View. 

Only DMS documents can be viewed. 

3. To remove a selected document from the retention collection, click Remove. 

The documents that are removed from the retention collection are not destroyed during the 
next Retention Server activity. 

The Remove button is not available if the selected collection is viewed from the Manage 
collection policies window. 

4. To close the Collection window, click OK. 

Selecting a Retention Policy 
This section describes the Select policy window. 
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Figure 79: Assigning a retention policy 

The Select policy window appears under the following circumstances: 

• A user double clicks a document type in the Document type policy management window 
as described in Managing Document Type Retention Policies. 

• A user double clicks a document collection in the Manage collection policies window as 
described in Managing Document Collection Retention Policies. 

The Select policy window displays the name, description, retention period, and user 
responsible for document disposal for all retention policies defined in the system. 

To assign a retention policy to the selected document type or collection, in the table, select the 
appropriate retention policy and click OK. 

Running Retention Server 
Retention Server performs the following tasks: 

• deletes documents from the recycling bin 

• checks all documents in the workflow according to the active retention policies 

• creates retention collections from the disposable documents 

• notifies the responsible user about the created retention collections 

• disposes of the documents in the retention collections that are approved by the responsible 
user 

All the preceding tasks are performed when an administrator runs Retention Server. 

To run Retention Server, proceed as follows: 
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1. In Exigen Workflow Explorer, run Retention Server. 

The Retention Server window appears. 

 
Figure 80: Retention Server window 

The black area in the Retention Server window displays information about the Retention 
Server status and selected operation mode. 

The following table describes the counters in the Retention Server window: 

Retention Server window counters 
Counter name Description 
Documents 
recycled 

Number of documents deleted from the recycle bin since Retention Server 
was last started. 

Collections created Number of retention collections created since Retention Server was last 
started. 

Documents marked Number of documents identified as disposable since Retention Server was 
last started. 

Documents 
destroyed 

Number of documents destroyed since Retention Server was last started. 

Failed to destroy Number of documents identified as disposable but not destroyed since 
Retention Server was last started. 
If Retention Server fails to destroy a document, the error is registered in 
the audit log. If the file selected for destruction does not exist, a file 
removal record is registered in the audit log. 

The following table describes the buttons and associated menu options in the Retention 
Server window: 
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Retention Server window buttons and associated menu options 
Button Menu option Description 

 

Run > Process Setup Opens the Setup window to specify the following: 
• Retention Server operation mode 
• location of the email notification template file 

 

File > Save Configuration Saves the current window configuration. 

 

Run > Start Server Runs Retention Server. 

 

Run > Stop Server Stops Retention Server. 

 
Help > Context Help Opens the context help. 

 

File > Exit Exits Retention Server. 

When Retention Server is started for the first time, the Setup window appears. 

 
Figure 81: Specifying document retention options 

2. To specify the Retention Server operation mode, select one or more of the following options: 
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Retention Server operation modes 
Mode Description 
Document recycling Removes deleted documents from the recycling bin. 

If a document that is stored on an image server is deleted from any Exigen 
Workflow object, the document is moved to the recycle bin and is 
physically deleted only when Retention Server is run in document recycling 
mode. 

Retention collection 
destroying 

Destroys documents in retention collections. 

Retention collection 
preparing 

Database is scanned for documents with an expired retention date. These 
document are added to the retention collections and an email is sent to the 
person responsible for Retention Server maintenance. 

Any combination of options can be selected. If no operation mode is selected, Retention 
Server runs without performing tasks. 

3. To specify the location of the email template file that is used to notify the responsible person 
about a new retention collection being created, in the Email section, click the browse button 

. 

4. In the Open window, select the template file and click Open. 

The Retention Server notification template file is a text file created by the administrator 
following specific rules. 

The following is an example of the Retention Server notification template file: 

HEAD: 

Notification. 

 

BODY: 

A new collection '$NAME' has been created on $CREATED. 

 

FOOT: 

Thank You 

The following table describes the Retention Server notification template file sections: 

Retention Server notification template file sections 
Section name Description 
HEAD Email introduction text. 

BODY Information about the created retention collections. This section may 
contain notifications about several retention collections. 

FOOT Email conclusion text. 
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The following aliases are recognized in the Retention Server notification template file: 

Retention Server notification template file aliases 
Alias Description 
$NAME Retention collection name. 

$DESCRIPTION Retention collection description. 

$CREATED Retention collection creation date. 

$PROJECT Project in which the retention collection is created. 

The aliases are recognized only in the BODY section and are automatically replaced with 
the corresponding value in the email. 

To enable the email notification, an Outlook Express or a compatible email client profile 
must be configured and enabled to send email. 

5. To close the Setup window and save the settings for the next session, click OK. 
6. To cancel changes and close the Setup window, click Cancel. 
7. To run Retention Server, in the Retention Server window, select Run > Start Server. 

Retention Server runs in the operation mode specified in the Setup window. 

8. To keep the workflow free of unnecessary documents, run Retention Server regularly. 

9. To stop Retention Server before the end of the current cycle, in the Retention Server 
window, select Run > Stop Server. 

The following actions occur when Stop Server is selected: 

Actions that occur when Retention Server is stopped 
Operation mode Action 
Document recycling Stops removing documents from the recycling bin. 
Retention collection 
destroying 

Stops destroying the documents in the retention collection. 

Retention collection 
preparing 

Stops the collection preparation process. An email notification about the 
process halt is sent to the person responsible for Retention Server 
maintenance. 

Approving Retention Collections 
Retention Server creates new retention collections containing disposable documents. The user 
responsible for maintaining the retention policy in the workflow must review the created 
retention collections before disposal. 

To review the retention collections, proceed as follows: 

1. To open the Approve document disposal window, in the Policy list window, select 
Management  > Disposal. 

The Approve document disposal window appears. 
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Figure 82: Approve document disposal window 

The Approve document disposal window lists all retention collections created by 
Retention Server. 

2. In the list, select a retention collection. 

3. To approve the selected retention collection for disposal, click Dispose Collection. 

The next time Retention Server is run in Retention collection destroying mode, the 
selected retention collection is destroyed. 

4. To freeze the selected retention collection, click Freeze collection. 

A frozen retention collection remains in the system until its status is changed. 

5. To change an approved or frozen retention collection’s status back to the initial status, click 
Reset status. 

6. To view and modify the contents of the selected retention collection, click View collection 
and follow instructions as described in Viewing Document Collections. 

7. To apply changes, in the Approve document disposal window, click OK. 
8. To close the Approve document disposal window without applying changes, click Cancel. 

The changes made in the Approve document disposal window are implemented the next 
time Retention Server is run. 
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Chapter 13: Push Server 
This chapter describes Push Server and explains how to run it. The following topics are 
described in this section: 

• Overview 

• Push Server Window 

• Starting and Stopping Push Server 

Overview 
Push Server automatically sends work items to the next node and user according to workflow 
rules. Work items and email are immediately sent to the next queue or user.  

Push Server is used in situations when workflow rules are not complex.  

Push Server Window 
To open the Push Server window, in Exigen Workflow Explorer, double click the Push 
Server icon.  

  

The Push Server window appears. 
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Figure 83: Push Server window 

The Push Server window consists of the following features and information:  

• menu and button bars as described in Appendix A: Exigen Workflow Object Menus and 
Button Bars 

• information about the number of incoming batches, processed parcels, documents, and 
pages on the left. Documents having a Y in the Locked column are checked out for editing 
and cannot be modified. 

• status window displays the current mode of Push Server on the right 

• toggle button is used to display data in either Form view or Column view 

Starting and Stopping Push Server 

To run Push Server, click Start Server .   

If the Auto Send and Server Mode options are selected, the jobs to be processed are loaded 
by batch into Push Server. After the entire batch is processed, the new parcels and documents 
are sent to the next queue, and the processing of the next batch begins. 
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If neither of the preceding selections is selected, each new parcel must be manually sent to the 
next queue by clicking Send. 

The status window displays the processes being performed and the time elapsed. 

To stop the server, click Stop Processes.  

For information on codetable and legacy based routing, see Appendix C: Push Server 
Advanced Functionality. 

For information on maintaining Push Server as a service, see Appendix B: Maintaining Exigen 
Workflow Servers as Services. 
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Chapter 14: Configuring Enterprise Report 
Management 
This chapter describes how to configure Exigen Enterprise Report Management (ERM). The 
following topics are described in this section: 

• Overview 

• Creating a Report Template 

• ERM Locator Application 

• Main ERM Setup Tasks 

• Changing ERM Setup Options 

• ERM Report Viewer and Report Presentation 

Overview 
The following topics are described in this section: 

• Data Formats 

• Preliminary Tasks 

• Input Data File Definition 

Data Formats 
Exigen ERM processes electronic documents in text format. 

Electronic text documents are usually computer printouts or database excerpts. Both types of 
documents are referred to as reports or ERM documents. Exigen Workflow Import Server is 
used to process reports in binary format, for example, Word documents. Any binary format can 
be processed by ERM after being converted to text format. 

In addition, ERM can directly process AS/400 report printstreams from an output queue using 
Report Queue Monitor. AS/400 printstreams can contain data in the following formats: 

• system network architecture character string (SCS) 

• advanced function presentation (AFP) 

Printstream data is converted to text by Report Queue Monitor. 

During the ERM production cycle, the report input stream is processed according to report 
definition rules defined in ERM Setup by the ERM administrator. Incoming reports are 
compressed as ZIP archives and moved into storage located on the network. Indexing 
information from the reports populates target custom Exigen Workflow projects. At the back end, 
Exigen Workflow end users can access reports via standard database queries using indexing 
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information. By default, ERM documents are presented as text in green-bar reports. However, if 
a presentation form overlay is registered in ERM Setup, ERM documents can be presented in 
other formats. The following formats can be selected for presentation forms: 

• DMS 

• RTF 

• XLS 

DMS files are represented as TIFF images. AFP reports can be presented in original AFP 
format. 

Before using ERM in the Exigen Workflow system, the ERM administrator decides how to store, 
set up, and manage electronic documents. 

Preliminary Tasks 
Before running Exigen Workflow, the ERM administrator must perform the following preliminary 
tasks: 

1. Familiarize yourself with Office products. 

2. Optionally, familiarize yourself with Monarch. 

3. Organize all source information to be used in production. 

4. Decide the following: 
• how to distinguish between different report layouts 
• which fields must be indexed 
• where to store archives 
• which types of form overlay are required 

5. Prepare a sample report file for each report layout. 

Input Data File Definition 
Exigen ERM can process a variety of electronic text documents. Input data files are defined by 
the following categories: 

• origin 

• text data format 

• output type 

• input file contents 

The following table summarizes report types recognized by Exigen ERM: 
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Report file definition types recognized by Exigen ERM 
Origin Description 
 Format Output Contents 
Printouts Fixed Green-bars or form 

overlays 
Multi or single layout 

Database excerpts Delimited or fixed Form overlays Multi or single layout 
 

Printouts look like text documents written with a monospace font. They always have a fixed text 
field format. Besides the text, printouts can contain binary information, such as printer control 
codes or other commands. Depending on the type of required output in the Retrieve object, 
printouts can be green-bars or form overlays. The original contents of green-bar printouts can 
be viewed directly in the form and are easily understood by the user. Form overlays always 
require a template, or graphical form, to insert text data from the report. 

Excerpts from databases usually resemble collections of strings of sequential data fields in 
either fixed or delimited format. These types of electronic documents always require a form 
overlay to present the content to the user. 

A file in the input stream for both fixed format and delimited format can contain reports of one 
layout or several layouts. Fixed format reports and delimited format reports cannot be combined 
in one input file or loaded into the same import directory because different indexing engines 
process these report types. An AS/400 printstream is converted by Report Queue Monitor to 
fixed format text. 

Creating a Report Template 
Report templates are used by ERM Indexer and ERM Storage Maintenance for indexing, and by 
Exigen Workflow or Exigen Workflow Web Queue objects for retrieving and viewing reports. 
Depending on the report format, report templates are prepared as described in the following 
table: 

Report template preparation 
Format Preparation method 

Fixed format The following methods are available: 
• Exigen Report Definition Wizard is used to create 

templates as described in Chapter 17: Report 
Definition Wizard. 

• Monarch data extraction templates are imported. 
Delimited format The script is created in the d32_dlm.ini file. 

To create report templates, you can use either Exigen Report Definition Wizard or Monarch. 

For information on creating report templates using Report Definition Wizard, see Creating 
Report Templates. 

The following topics are described in this section: 
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• Creating Report Templates for Fixed Format Using Monarch 

• Adding a New Model for Delimited Format Reports 

Creating Report Templates for Fixed Format Using Monarch 
This section describes creating report templates with Monarch. 

Any valid Monarch data extraction model can be imported and registered in ERM Setup as a 
report template. To make a Monarch model file understandable to ERM Setup, the following 
field and trap name conventions must be observed: 

• Each report layout must have a unique model. This is achieved by assigning one or more 
traps as signature traps. During indexing, the ERM indexing engine recognizes different 
report layouts by the signature traps. To assign a trap in Monarch to be a signature for ERM, 
when editing the template, in the Name window, signature must be entered. For more than 
one signature, the names signature or signature1 must be entered as required. A trap of a 
one-level extraction model is the signature by default. 

• If different report layouts require similar non-signature or signature traps, multi-signature 
models with more traps must be used to ensure that ERM Indexer correctly recognizes 
different layouts. 

• In selecting data extraction templates, traps that are based solely on capturing wildcard 
characters cannot be used. 

• For a model with more than one trap, a Page Header attribute must be assigned to the top 
trap. 

• A Page Header trap of one model cannot be used as an ordinary trap in another model. 

• Field names, which are intended for overlay only, not for indexing, must start with O_, for 
example O_CUST_NAME. This field is not seen for auto-indexing settings. 

• The special page marker field must be used to mark the start of each page in the following 
instances: 
1. An exact document page count by ERM Indexer is required. 
2. Multi-page overlay templates are used. 

The page marker field must be formatted as follows: 

O_PAGNN 

where NN is the double-digit number of a template page, for example, O_PAG04. If 
overlay templates are not used in Retrieve, O_PAG01 must be used. The page marker 
field should not be confused with the Page Header trap in Monarch. 

Warning: Monarch V5 performs smart conversion of date fields by default. This conversion can 
affect data extraction by ERM. To ensure correct data extraction by the model saved from 
Monarch V5, all date fields in Monarch must be changed to characters before saving the model. 
Monarch V6 and higher are not supported. 
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Data Extraction Model by Monarch is converted into a section of the ERM configuration file 
d32_mnr.ini. 

Adding a New Model for Delimited Format Reports 
For delimited reports, that is, database excerpts, data extraction is not performed by templates, 
but by the field sequential number. To add a new model, proceed as follows: 

1. In any text editor, such as Notepad, open the existing d32_dlm.ini file. 

2. Create a new section with a unique 3-character name, for example, [ABC]. 

To view a sample ERM configuration file, see Appendix E: ERM Configuration File 
Keywords. 

3. Add a string model description with comments about the layout. 

4. Select a field in the delimited record that serves as a signature for this layout, and enter the 
corresponding keyword string under the [ABC] ini section. 

Example: In the delimited database excerpt, the field IN serves as a signature, the 
sequential number of this field is 3 starting from 0, and the corresponding keyword string 
in the d32_dlm.ini file is as follows: 
[ABC] 
model description=Modern Art Enterprises Invoice 
trap0=3 IN 

5. Add keyword strings to the d32_dlm.ini file for each field to extract during indexing, as 
shown in the following example: 

Example: In the delimited database excerpt fields, the numbers 0, 5, 8, 30, and 34 are 
index fields and the corresponding block of keyword strings is as follows: 
[ABC] 
. . . 
field00=0 REF_NO 
descr00= Reference Number 
field01=5 CUST 
descr01= Customer name 
field02=8 TO_NAME 
descr02= Sold name 
field03=30 PO_NO 
descr03= P.O. Number 
field04=34 SLS_ID 
descr04= Salesman ID 

ERM Locator Application 
The documents processed through ERM Indexer are attached to a custom target workflow and 
respective Exigen Workflow project. However, to set up ERM for a specific Exigen Workflow 
installation, you first have to create a storage project, which hosts common ERM-related 
information from all custom projects. As soon as the storage project is created, the ERM Locator 
Workflow automatically appears in the list of applications. 
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The ERM storage project and its workflow are usually created only once, but multiple storage 
projects are also supported. 

The ERM Locator application contains the following nodes: 

• ERM Setup 

• ERM Indexer 

• ERM Storage Maintenance 

Note: If your version of Exigen Workflow does not create the ERM Storage Maintenance object 
automatically, this node must be added to the workflow using Workflow Builder. 

These objects allow configuring indexing engines, scheduling production, and maintaining ERM 
storage. 

ERM Setup registers sample files, report definition templates, and presentation form overlays 
for all report layouts that are processed by ERM Indexer.  

If a DMS form overlay is required for presentation purposes, for information on how to create 
DMS form templates, see the Exigen Workflow Administrator's Guide, Part 3: Utilities, Chapter 
8: Template Management Utility. 

Note: The location of ERM settings is stored in the database as soon as the administrator enters the 
ERM Setup object for the first time. This location can be changed by modifying the ERM setup 
options as described in Changing ERM Setup Options. 

Main ERM Setup Tasks 
The following topics are described in this section: 

• Starting ERM Setup 

• Registering a New Report Layout 

• Auto-indexing 

• Specifying Form Overlay Settings 

• Importing and Exporting ERM Settings 

Starting ERM Setup 
To start ERM Setup, proceed as follows: 

1. In the Exigen Workflow Explorer window, open the ERM Locator workflow.  

2. Double click the ERM Setup icon. 
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Figure 84: Exigen Workflow Explorer with ERM Locator application 

The ERM Setup window appears, displaying a list of registered models, which are report 
definition templates, with corresponding import directories and statuses. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 14: Configuring Enterprise Report Management 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 183 of 391 

 
Figure 85: ERM Setup Utility window 

The columns display the following information: 

ERM Setup Utility columns 
Column Description 

Model Three-character ID of the selected report definition template. 

Description ERM setting description. 

Priority ERM setting priority.  
• In multi-model processing, documents are processed by priority. Lower 

numbers are processed first. 
• In single-model processing, documents are processed by file order. Model 

priority does not take effect. 
For more information on multi- and single-model processing, see Multi- and Single-
Model Options. 

Import Directory 
Label 

Import directory name for the incoming files for this ERM setting. 

Status Current directory status. The values are Active or Disabled. 

Registering a New Report Layout 
To register a new report layout, click Add Entry or select Setting > New. 

The New window appears. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 14: Configuring Enterprise Report Management 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 184 of 391 

 
Figure 86: Registering a new report layout 

The following tasks are performed in this window: 

• Assigning Input Parameters 

• Assigning Target Parameters 

• Assigning Processing Parameters 

Assigning Input Parameters 

To assign input parameters, proceed as follows: 

1. In the New window, in the Description field, enter a description of the report. 

2. To specify a formatting option, make a selection in the Format field as described in the 
following table: 
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Format options 
Option Description 

Fixed (Computer Printout) Fixed format reports. 

Delimited (Pipe-separated values) Delimited reports. 

Custom Custom engine. 

If Custom is selected, the file browser window displays the contents of the Exigen Workflow 
system directory. 

3. In the system directory, select the dynamic link library (DLL) file for the required custom 
ERM engine. 

For more information on input report formats, see Input Data File Definition. 

4. To assign an import directory, click the browse button  next to the Import Directory 
Label. 

The ERM Input window for the selected report format appears and lists registered import 
directories. 

5. To select an existing import directory, double click it, or to create a new directory, click Add 

. 

For more information on the import directory, see Creating or Editing the Import Directory. 

6. Click Attach Sample and select a sample file for the report. 

The sample file must contain at least one page of the original report. 

If the report type requires a form overlay, the sample page must contain enough information 
to populate every field in the form. 

7. If a multi-page form overlay is used or different indexing information is extracted from 
different pages, include an example of each page in the sample file. 

The selected sample file appears in the preview window. If the sample matches any of the 
previously registered report templates, the system assigns this template by default to this 
report type, and the Template ID window in the Processing section group displays a 
corresponding template ID. 

8. Accept the default template or create a new template. 

9. Assign target parameters as described in Assigning Target Parameters. 

Creating or Editing the Import Directory 
ERM Indexer searches for incoming text files in all active ERM import directories. 

To create, edit, or disable an import directory, proceed as follows: 

1. In the New window, click the browse button next to the Import Directory Label. 

In the ERM Input window, a list of existing import directories appears. 
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Figure 87: Viewing existing import directories 

2. Click Add Entry . 

The ERM Directories - New dialog appears. 

 
Figure 88: Adding an import directory 
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3. In the Label field, enter a directory label. 

4. To select a directory or create a new one, click the browse button next to Import. 
5. Select or create a directory and click Select. 

Setup creates all appropriate subdirectories, which appear in respective windows. By 
clicking the respective browse buttons next to the directory fields, you can reassign any 
subdirectory to a desired location on the network. Storage and log subdirectories must 
reside in the same parent folder. 

 
Figure 89: Viewing ERM subdirectories 

The system creates the following subdirectories under the selected directory. In the previous 
example, the root directory is C:\erm_settings\erm\in-8. 

The following table describes ERM subdirectories: 

ERM subdirectories 
Subdirectory Description 
in Directory that contains the incoming text files. 

storage Directory to which incoming text files are moved after processing by ERM 
Indexer. 

trash Directory that contains discarded files. 

This directory is for system use only. 

temp Directory that contains temporary files. 

This directory is for system use only. 
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ERM subdirectories 
Subdirectory Description 
log Directory for annotations and other attachments to ERM documents 

located in the corresponding storage directory. 

6. To activate a directory, select the Active (Status) check box. 

7. To disable an existing import directory, clear the Active (Status) check box. 

8. To accumulate temporary files in temp, and trash subdirectories for troubleshooting or other 
purposes, select the Keep temporary files checkbox.  

If the Keep temporary files checkbox is cleared, all temporary files are deleted. 

9. Click Apply Modifications. 

Assigning Target Parameters 

Before assigning target parameters, ensure that an Exigen Workflow custom project is created, 
and that all custom fields are added to folder, subfolder, and document tables. 

To assign target parameters, proceed as follows: 

1. In the New window, in the Workflow field, select a workflow. 

2. In the Queue field, select a workflow node. 

If the indexed report does not need to be processed through a workflow, Retrieve is 
selected. 

If Retrieve is selected, a parcel is not created. If any other node is selected, a parcel is 
always created. 

Exigen Workflow servers cannot be selected as target nodes. 

3. In the User field, select a user. 

4. To save the changes, click Apply Modifications. 

Assigning Processing Parameters 

To assign processing parameters, proceed as follows: 

1. In the New window, click Report Definition. 

The ERM Report Definition window with the list of available report definition templates for 
the specified report format and indexing engine appears. 
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Figure 90: Viewing the list of available report definition templates 

2. To use an existing report template, double click the template. 

The sample report is automatically checked against the template signature traps. 

3. To process a report file as-is without recognition and without extracting any fields, in the list, 
select no template. 

If no template is selected, only global variables such as the report file name, report file 
extension, and report file creation date can be used in auto-indexing. The no template 
option, which appears as template ID (_!_), is reserved by the system and must not be used 
for other templates. 

4. To proceed to the auto-indexing or form overlay settings, click Apply or use shortcut 
buttons. 

5. To add a new report template, click . 

6. To modify an existing template, click .  

For more information on adding and modifying templates, see Adding a New or Modifying an 
Existing Report Template. 

Note: For reports in delimited format, the add and modify features are not available. A new model 
must be created by adding a new section to the d32_dlm.ini file. For more information on report 
definition templates, see Adding a New Model for Delimited Format Reports. 
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Adding a New or Modifying an Existing Report Template 

To add a new or modify an existing report template, click . 

The New Report Definition Template window appears. You can either use Exigen Report 
Definition Wizard (RDW) to create a new report template or import a previously created 
Monarch model. 

Note: Only a template related to the current sample report should be used. To add or edit a report 
definition template related to another ERM setting and sample file, the user must close the 
current ERM setting, open the new one with the appropriate sample report, and define the 
report. 

 
Figure 91: New Report Definition Template window using RDW 

To use Report Definition Wizard to create a report definition template, proceed as follows: 

1. Click Launch Wizard. 

Report Definition Wizard is started with a current sample report file.  

2. Create a report definition template and import it into the d32_mnr.ini file.  

3. In the ..\EWF\etdm\Template directory, save the template, entering the 3-character 
template ID as the file name when saving the template. 

This allows the Wizard to open a template file automatically for modifications. 

4. Close the Report Definition Wizard window. 

5. To close the New Report Definition Template window, click Exit. 

The new report template appears in the list. 

6. Alternatively, create report templates as follows: 
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• In the main menu, start Report Definition Wizard. 
• Select Tools > Report Definition Wizard. 
The new report definition template is available to ERM Setup after it is exported to the 
d32_mnr.ini file. 

• To ensure that the template opens automatically, in the EWF\etdm\Template directory, 
store template files as described in step 3. 

If you are using Monarch, proceed as follows: 

1. Click the button to the right of the Monarch model window. 

The file browser window appears. 

2. Select the Monarch model file containing the data extraction template. 

 
Figure 92: New Report Definition Template window using the Monarch model 

3. In the Template ID field, enter a 3-character template ID. 

If no value is entered, a numerical ID in the range of 000...999 is assigned automatically. 

4. To register a model as a new report definition template, click Import. 
5. To close the New Report Definition Report Template window, click Exit. 

The new report template appears in the list. 

6. To modify an existing report template, click . 

The Report Definition Wizard window opens with a sample report and a previously used 
template, if it was used in creating the template. Otherwise, a Monarch window opens with 
the respective sample report and model file if a model was imported. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 14: Configuring Enterprise Report Management 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 192 of 391 

7. Re-export the updated Report Definition Wizard template into the d32_mnr.ini file. 

Re-importing the updated Monarch model is performed automatically. 

8. To make the changes available to the ERM Setup, in the ERM Report Definition window, 
double click the selected report template. 

If a report definition template is not saved in  ..\EWF\etdm\Template\<template 
ID>.rdt, Report Definition Wizard opens only with a sample report. 

9. If only a sample report opens, open the template manually. 

For more information on using Report Definition Wizard, see Chapter 17: Report Definition 
Wizard. 

ERM Indexer Log File 

The log file is used to diagnose errors and other abnormal operations of ERM Indexer. For more 
information on ERM Indexer, see Chapter 15: ERM Indexer. 

By default, the ERM Indexer log file is written to the following subdirectory: 

..\<Exigen Workflow>\etdm 

The log file is appended every time ERM Indexer is activated. To disable the append function, 
add the keyword log=0 to the general section of the appropriate configuration file d32_mnr.ini 
or d32_dlm.ini. 

For information on keywords for the ERM configuration, see Appendix E: ERM Configuration 
File Keywords. 

Auto-indexing  
Auto-indexing includes the following: 

• mapping index data fields extracted from the report to custom fields of the folder, subfolder, 
and document table structure of an Exigen Workflow project 

• setting default values to project table fields 

• converting the original data format of a report field to a desired format in the database 

Editing Auto-indexing Settings 

To edit auto-indexing settings, proceed as follows: 

1. To open the Auto-Indexing window, perform one of the following steps: 
• Select a model and select Edit > Auto Indexing. 
• Right click a model and select Auto Indexing. 
• If the New or Modify window is displayed for a model, click Auto-Indexing >>. 
The Auto-Indexing window appears. 
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Figure 93: Editing auto-indexing settings 

2. To copy auto-indexing settings from an existing ERM Setup entry, in the Copy auto-
indexing rules from list box, select an item. 

Copying is enabled only for setup entries that have the same set of indexing fields in their 
report definition templates. 

3. To modify the insert or update flags for a table, in the Tables section, perform one of the 
following steps: 
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• Double click the table name. 
• Select the table name and click Modify Entry. 
The Modify Insert/Update Flags window appears. 

 
Figure 94: Modifying flags 

4. To enable the insert flags option, select Insert. 
5. To disable the insert flags option, clear Insert. 
6. To enable the update flags option, select Update. 
7. To disable the update flags option, clear Update. 
8. To save changes and close the window, click Apply Modifications. 
9. To specify the field assignment, perform one of the following steps: 

• In the Columns section, double click the required row. 
• In the Columns section, select the row and click Modify Entry. 
The Field Assignment window appears. 
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Figure 95: Modifying a field assignment 

10. To make an assignment for the selected field, in the Template Field list or Global Variable 
list, select an item, or assign the default value. 

If an item is selected in the Template Field list, it assigns the selected template field 
extracted from the body of the report. 

If an item is selected in the Global Variable list, it assigns the selected global variable, such 
as a file parameter or user environment. 

A selection in the Template Field list overrides a selection in the Global Variable list, which 
overrides the default selection. If no selection is made in the Template Field or Global 
Variable lists, the value in the Default Value field is assigned. 

11. To convert input data to another format, click Conversion. 

The Field Processing Settings window appears. For information on the Field Processing 
Settings window, see Chapter 3: Form OCR Server. 
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Figure 96: Specifying field processing settings 

12. Enter appropriate format changes and click OK.  

By default, quotation marks appear in the Remove All field, and conversion removes double 
quotes from all fields. This is mandatory. 

Template fields containing a date are supplied in string format, and must be converted to the 
respective database date format. 

13. Click Apply. 
14. To select a new field for assignment, go to step 9. 

15. To finish auto-indexing, click Close. 

If a report layout needs a form overlay in the Retrieve node, specify form overlay settings as 
described in Specifying Form Overlay Settings. 
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Specifying Form Overlay Settings 
To specify form overlay settings, proceed as follows: 

1. To open the Form Overlay window, perform one of the following steps: 
• Select a model and select Edit > Form Overlays. 
• Right click a model and select Form Overlays. 
• If the New or Modify window is displayed for a model, click Form Overlay >>. 
The Form Overlay window appears, listing available overlay types and statuses. 

 
Figure 97: Viewing overlay types 

2. To display an empty template, click View Empty Form . 

3. To display a template populated from a sample file, click Test Form . 

4. If a form overlay includes field security, to hide secured fields during document display 
testing, select Field Security On. 

If the Field Security On check box is not selected, all fields are shown. 

5. If the report format is delimited, register a text template for data mapping before proceeding 
with image overlay. 

The text template converts a delimited string to a fixed format. The default template for 
converting a delimited format to fixed is provided in the DLM_Templ.txt. For fixed format, 
the order in which different types of overlays are added is arbitrary. 

One of the following form overlay tasks must be performed: 



Administrator's Guide, Part 2: Business Component Reference  Chapter 14: Configuring Enterprise Report Management 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 198 of 391 

• Specifying an Image Form Overlay 

• Specifying a Plain Text or Rich Text Format (RTF) Overlay 

• Specifying Excel (XLS) Overlay Settings 

Specifying an Image Form Overlay 

This section describes how to specify an image form overlay using the following procedures: 

• Selecting a Template 

• Adding, Deleting, and Modifying Zones 

• Mapping a String to a Zone 

Selecting a Template 

To select a template for image form overlay, proceed as follows: 

1. In the list of overlays, select DMS overlay. 

2. To select the .dms file as the image template, click New File. 

After selecting a new file, it is registered in the Template Management Utility, where it can 
later be accessed. 

The image template file can be created by scanning a hard copy of an empty form or 
converting any type of image file such as .bmp or .tiff, or a non-image file such as 
.doc, into a .dms file using the Exigen Workflow Template Management Utility. For more 
information on managing image templates, see the Exigen Workflow Administrator's Guide, 
Part 3: Utilities, Chapter 8: Template Management Utility. 

3. To assign the template already registered in the Template Management Utility, select the 
template in the Assign available DMS-overlay list. 

Adding, Deleting, and Modifying Zones 

To add, delete, or modify zones, proceed as follows: 

1. Click Modify Form, or double click the template in the table. 

The Image Overlay window appears on the left and the Image Viewer appears on the right. 
The Image Overlay window has two tabs:  

• Zone Definition 
• Map Data by Sample 
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Figure 98: Image Overlay window 

2. To define new or edit existing zones, in the Zone Definition tab, enter appropriate values.  

3. To specify data mapping for any zone in the image form overlay, in the Map Data by 
Sample tab, enter appropriate values.  
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The user can toggle between the two tabs at any time. 

4. To view all existing zones on the image template, in the Image Overlay window, click Show 

All Zones . 

5. To edit a zone, double click the zone or select it in the Zone ID field. 

6. To resize a zone, in the Resize section, click the appropriate buttons. 

7. To relocate a zone, in the Relocate section, click the appropriate buttons. 

Modifications are viewed in the Image Viewer. 

8. To save the changes, click Save Zone . 

9. Proceed to the next zone. 

10. After editing zones, to save the changes, on the toolbar, click Save template . 

11. To create a new zone, click New Zone . 

12. In the Image Viewer, draw a rectangular zone. 

13. In the Image Overlay window, enter the appropriate values. 

14. To save the changes, click Save Zone. 

Mapping a String to a Zone 

To map a string from the sample file to the current zone, proceed as follows: 

1. Select the Map Data by Sample tab and proceed as follows: 
1. In the lower section of the Image Overlay window, locate the text fragment to be 

mapped to the selected zone. 
2. In the text fragment, select the entire substring of the first line, and click Map Selection. 

The length of the text box is calculated automatically. It is acceptable to select only the 
starting portion of the string and enter the required length manually. The Sample data 
preview window shows the selected string. 

3. If the zone is multi-line, enter the number of rows or calculate the zone size 
automatically. 

4. To calculate the zone size automatically, in the Test Area field, enter the contents of the 
text box to be mapped into the zone. 

Length and row parameters are calculated. 

5. To see how the test area is mapped on the image, click Test Zone . 
6. To save the changes, click Save Zone. 
7. Continue data mapping for other zones. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 14: Configuring Enterprise Report Management 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 201 of 391 

2. To save the changes, on the toolbar, click Save template . 

 
Figure 99: Specifying data mapping for a zone 

3. For multi-page templates, select the right page in the sample. 
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4. For fields that must be hidden for certain categories of users, select Use Field Security. 

This includes users of all security levels for whom the Hide column is cleared in the 
Security Level Setup window. For information on the Security Level Setup window, see 
the Exigen Workflow Administrator's Guide, Part 1: Design and Configuration, Chapter 4: 
Setting Up Exigen Workflow, Specifying Security Levels. 

Note: Sample view pages shown in the Image Overlay window are recognized in the sample report 
file by their respective settings in the report template. For a Monarch model, a template must 
have page marker fields indicating which sample page maps to which form overlay page. In 
Report Definition Wizard, pages are recognized by page header trap attributes. For multi-page 
overlays, the sample report file must always have one sample page per each form overlay 
page. 

5. To view an image overlay in Queue and Retrieve nodes, select View > Show ERM 
Left/Right as...> Default. 

Specifying a Plain Text or Rich Text Format (RTF) Overlay 

To specify a plain text or rich text format overlay, proceed as follows: 

1. In the list of overlays, select the appropriate overlay. 

2. To select the template file, click New file. 
3. Click Modify Form or double click a template in the table. 

Notepad is used for text overlay and Word for RTF overlay. 

The following tasks must be performed: 

• Design the form overlay. 

• Populate the form overlay with data field tags. 

Actual data inserted into a text or RTF form overlay in Retrieve is controlled by the report 
template registered in the following two locations: 

• configuration file  

• text, RTF form overlay 

An Exigen Workflow RTF overlay is a Word document saved in rich text format. Other word 
processors capable of saving files as RTF can be used to prepare form overlays. An RTF 
document contains data tags in places where actual data fields from the retrieved documents 
must be inserted. The style in which data tags are entered in the overlay template is the style in 
which actual data appears in Retrieve. A data tag includes a prefix &, followed by a field number 
in the corresponding section of the configuration file, for example, &00, &134. 

Text overlay uses the same conventions for data tags as RTF overlay. 

When creating an Exigen Workflow RTF form overlay, use the following guidelines: 

1. Create and edit the overlay as a Word document and save its final version in RTF, keeping 
a copy in DOC format. 
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2. Avoid editing the form overlay in RTF. 

Field security for these types of overlays is implemented through a Report Definition Wizard 
report template. 

3. To build a Report Definition Wizard template for the fields that must be hidden for certain 
categories of users, select the Hide box in field attributes. 

To view plain text and RTF overlays in Queue and Retrieve nodes, proceed as follows: 

1. To view a plain text overlay, for a default viewer, select View > Show ERM Left/Right as...> 
Default, or to invoke an external viewer, select View > Show ERM Left/Right as...> Plain 
Text. 

For information on selecting an external viewer, see Changing ERM Setup Options. 

2. To view an RTF overlay, select View > Show ERM Left/Right as...> Rich Text Format. 

Specifying Excel (XLS) Overlay Settings 

Actual data inserted into an Excel template in Retrieve is controlled by information located in the 
following two locations: 

• configuration file  

• Excel template 

The configuration file has the following standard syntax of Windows INI files:  

• d32_mnr.ini for fixed format reports  

• d32_dlm.ini for delimited reports  

This file has a section for each report layout. The section heading is the corresponding Model 
ID, a three-character model identifier used in Exigen Workflow, which is 001 in the following 
example. Keywords related to Excel form overlay setup are listed as follows: 

[001] 
; Name of sheet where the output is directed 
xls sheet = Sheet2 
; Prefix for header and footer names 
Header = Col 
; Number of detail and sub-detail levels, not including 
; ‘header and footer’ level 
xls number of levels = 2 
; Prefixes for details and sub-details levels 
xls level1 = Det 
xls level2 = Sub 
; Number of row where to insert rows 
xls start row = 25 

For information on ERM configuration keywords, see Appendix E: ERM Configuration File 
Keywords. 

The start row must be located below all detail and sub-detail template rows. When all the data is 
inserted, template rows are deleted from the resulting document. 
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An Excel template is an Excel file. When a new document with actual data is created, this file is 
copied, leaving the original template intact. 

To work with Excel templates, proceed as follows: 

1. To create a new template file, create a new XLS file using Excel. 

2. To modify an existing template, open the template file with Excel. 

The template must be registered by selecting MS Excel Overlay in ERM Setup in the Form 
Overlay window. 

The field security feature is currently not available for Excel overlays. 

3. To view Excel overlays in Queue and Retrieve nodes, select View > Show ERM Left/Right 
as...> MS Excel. 

Importing and Exporting ERM Settings  
Existing ERM settings can be exported to an external file, and imported from the external file 
back to another Exigen Workflow installation or computer. 

The following topics are described in this section: 

• Exporting ERM Settings 

• Importing ERM Settings 

• ERM Settings Import Limitations 

Exporting ERM Settings 
To export ERM settings, proceed as follows: 

1. In the ERM Setup table, select one or several entries. 

2. In the menu, select Setting > Export. 

The Export selected ERM settings window appears. 

 
Figure 100: Exporting ERM settings 

3. Click the browse button and select the desired location and file name. 
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The default name is ERMsettings.zip. 

4. Click Start Export. 
5. If the operation is successful, exit the window. 

Importing ERM Settings 
To import ERM settings, proceed as follows: 

1. In the menu, select Setting > Import. 

The Import ERM settings window appears. 

 
Figure 101: Importing ERM settings 

2. Click the browse button and select the file from which to import the settings. 

3. Click Start Import. 

4. If the operation is successful, exit the window. 

ERM Settings Import Limitations 
The following limitations apply when performing an ERM settings import or export: 

• All target Exigen Workflow projects referred to in the exported ERM settings must already be 
created in the installation when the import operation is performed. If the target workflow 
project is not found for any ERM setting, the import operation for this setting is cancelled. 
Exigen Workflow projects are compared by name. 

• All ERM import directories referred to in the exported settings must be present in the 
installation when the import operation is performed. If a directory that is referred to is not 
found, the first existing directory of a similar input format in the current ERM setup is 
assigned instead. If no such directory exists, the import operation is cancelled. Import 
directories are compared by the label.   

• ERM configuration file general section settings are not copied along with the selected 
individual ERM entries into the export package. If these settings have different source and 
target configuration files, the respective general section must be edited appropriately. 

For more information on ERM configuration file general section settings, see Appendix E: ERM 
Configuration File Keywords.  
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Changing ERM Setup Options 
To change ERM setup options, select Tools > Options. The ERM Setup Options window 
includes the following tabs: 

• Location 

• Pre-Processor 

• Viewers 

• Print/E-mail 

 
Figure 102: ERM Setup Options, Location tab 

The Location tab displays the location of the ERM directory. This location is detected 
automatically the first time ERM Setup is launched after the Exigen Workflow installation. If 
ERM Setup directories are later relocated, the settings must be modified to point to the new 
locations to ERM. This is important for multiple Exigen Workflow installations that must access 
the same ERM directory. 

The Pre-Processor tab displays a selection of filters that can be applied before input files are 
processed by ERM Indexer. 
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Figure 103: ERM Setup Options, Pre-Processor tab 

The current version supports only one filter, which converts ANSI carriage controls into page 
breaks and line breaks.  

The following table describes ANSI controls: 

ANSI controls  
ANSI control character value, first position 
in line 

Function 

"1" Inserts a page break. 
"0" Inserts an extra line. 
"-" Inserts two extra lines. 
"+" Merges the line with the previous line; non-blank 

characters from the line overwrite the corresponding 
non-blank characters, if any, in the previous line. 

Other chars, including blank No function. 

A custom filter can be selected if the installed d32_etp.dll file includes the appropriate custom 
filtering function. 

The pre-processing filter is applied to all files processed via fixed format import directories. 
When a filter is involved, original input files are automatically deleted upon successful 
conversion and converted files are zipped into storage. 

The Viewers tab displays a selection of external viewers when a user decides to present an 
ERM document in an external viewer. This selection is allowed for plain text or rich text format. 
The ERM text search function, which allows performing searches across multiple reports, is 
enabled only if the default ERM Report Viewer is selected. For cases in which the default viewer 
option invokes the Image Viewer or the IBM AFP Viewer, ERM Report Viewer can be assigned 
as the plain text viewer option instead of external viewers. 
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Figure 104: ERM Setup Options, Viewers tab 

The Print/E-mail tab is used to select a format in which an ERM report is printed or sent via 
email. 

 
Figure 105: ERM Setup Options, Print/E-mail tab 

The following table displays options for green-bar reports: 
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Green-bar report options 
Name Description 
Print as Print format. 

List box is disabled because the current version of Exigen Workflow supports only the default 
print format. Default means the format of the currently assigned right click viewer is used. If no 
viewer is assigned, Report Viewer is used.  

E-mail as Email format. 
The following options are available: 

Name  Description  
default Format of the currently assigned right click viewer. If no viewer is 

assigned, ERM Report Viewer is used. 
PDF Adobe Portable Document format. 
ZIP Compressed file.  

 
The following table displays options for form overlay reports: 
Form overlay report options 
Name Description 
Print as Print format. 

The following options are available: 
Name  Description  
default Format of the currently assigned right click viewer. If no viewer is 

assigned, Image Viewer is used. 
DMS DMS format. 
RTF Rich text format. 
TXT Text file format. 
XLS Excel format.  

E-mail as Email format. 
List box is disabled because the current version of Exigen Workflow supports only the default 
email format. Default means the format of the currently assigned right click viewer is used. If no 
viewer is assigned, Image Viewer is used. 

The Export Page Limit field limits the number of pages that can be printed or sent via email for 
a single document. The up and down arrows are clicked to select a number. 

Multi- and Single-Model Options 
A file in the input stream can contain reports of only one layout, or of several layouts.  By 
default, ERM Indexer uses the single-model option. In this option, initially only the first document 
in the imported file is recognized against all registered report templates in the configuration file. 
After that, ERM Indexer continues to look for similar documents. For information on the ERM 
Indexer, see Chapter 15: ERM Indexer. 

The single-model option ensures the highest efficiency of the ERM production cycle.  
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Different document layouts may be contained in the same input file. In this case, the multi-model 
option is recommended. Under the multi-model option, ERM Indexer tries to recognize each 
document in the input file against all registered report templates in the configuration file. 

This option does not ensure the highest efficiency, but provides a convenient automatic sorting 
of mixed input.  

To use the multi-model option, add the keyword multimodel=1 to the [general section] of 
the appropriate configuration file d32_mnr.ini or d32_dlm.ini. 

Note: Fixed format reports and delimited reports cannot be combined in one input file or loaded into 
the same import directory because different indexing engines process these types of reports. 

ERM Report Viewer and Report Presentation 
ERM Report Viewer is used to view and annotate ERM reports in text format. Other viewing 
applications can be used for report presentation. 

A precondition for using ERM Report Viewer is that an ERM report is available in Exigen 
Workflow. 

To view and annotate an ERM report, proceed as follows: 

1. Open the Exigen Workflow object in which the ERM report is located, or example, by 
selecting Applications > Project Name > Retrieve. 

2. To set the left viewing option for ERM reports, select View > Show ERM (left) as. 
3. To set the right viewing option for ERM reports, select View > Show ERM (right) as. 
4.  In the submenu, select one of the following formats for viewing the ERM report: 

ERM report viewing options 
Option Description 
Default ERM Report Viewer or DMS Viewer if a DMS overlay is defined. 

If the original document format is AFP and the presentation form is 
stored, the default option invokes the AFP Viewer 

Plain Text Plain text viewer application defined in ERM Setup.  
Rich Text 
Format 

Word, WordViewer, or the default application registered to display RTF 
files. 

MS Excel Excel. 

5. To display the image on the left, in the toolbar, click Left Image Display. 

 
6. To display the image on the right, in the toolbar, click Right Image Display. 
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The report appears. The display options do not allow adding, deleting, or responding to 
annotations. 

7. To add a comment to the report, in the toolbar, click Modify Image. 

 
8. Select a part of the report to which to attach the comment. 

A comment must be attached to the selected text. 

9. To attach a comment, right click the selection and select Comment. 
10. In the Comment dialog, in the Security field, select one of the following security levels for 

the annotation: 
Annotation security levels 
Level Description 
Public object No security level is assigned. All users can view and modify the 

annotation. 
Private object Security level is assigned. Only the annotation’s author can view and 

modify the annotation. 

11. In the field below Security, enter a comment. 

12. Click OK. 
13. To respond to a comment, right click in the report and select Respond. 
14. In the field below Security, enter a comment. 

15. To delete the annotation, in the report, right click the area where the comment is attached. 

16. Select Delete. 

If a report is processed by Report Queue Monitor from the AFP printstream, the default viewer 
for the document may be the AFP Viewer or ERM Report Viewer, depending on whether the 
document has a presentation form and resources stored with the original AFP file. Exigen 
Workflow automatically selects a viewer for the specific document based on the availability of 
presentation resources. 
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Figure 106: Viewing a document in the AFP Viewer 
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Chapter 15: ERM Indexer 
This chapter describes how to set up and run ERM Indexer. The following topics are described 
in this section: 

• Overview 

• Setting up and Running ERM Indexer 

• Using ERM Report Queue Monitor 

Overview 
ERM Indexer is used to schedule and maintain a production cycle of processing an input 
stream of reports. ERM Indexer processes the data according to the parameters provided in the 
ERM Setup object. 

ERM Indexer processes reports in text format and converts them into ERM documents within 
Exigen Workflow. ERM documents can be retrieved for viewing in original text format as green-
bar reports, or presented using form overlay templates. 

Setting up and Running ERM Indexer 
To set up and run ERM Indexer, proceed as follows: 

1. In Exigen Workflow Explorer, double click the ERM Indexer icon . 

The ERM Indexer - ERM Locator window is displayed.  
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Figure 107: ERM Indexer window 

2. Click Settings . 

The Settings window appears. 
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Figure 108: Specifying ERM Indexer settings 

3. In the Indexer tab, specify required options as described in the following table: 
ERM Indexer settings options 
Option Description 

Start Date Server start date. 

By default, the server starts immediately and runs for approximately one year. 

Start 
Time 

Server start time. 

Stop Date Server stop date. 

Stop 
Time 

Server stop time. 

Idling 
Interval 

Interval between consecutive searches of all active import directories. The default is 9 
seconds. 

Send e-
mail to 

Settings for e-mail notifications. 

User ID specifies the user to whom the email is sent. 

The following options specify the conditions under which emails are sent: 

never Emails are never sent to the specified user. 
on errors Emails are sent to the specified user when server errors 

occur. 
This is the default. 

on all messages Emails are sent to the specified user on server messages. 
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ERM Indexer settings options 
Option Description 

 

The user must have a default email program with a valid email address set on the 
computer. The user to be notified must have a valid email address registered in the 
Exigen Workflow Administrator Workflow User Setup. 

Unknown 
Files 

Specifies actions to be performed with incoming files in which ERM Setup cannot 
detect documents. 

The following options are available: 

move to input_extras Moves files to the ..\input_extras subdirectory. 
zip to storage Compresses files and moves them to the storage 

directory without indexing and creating documents. 
These files can be accessed in ERM Storage 
Maintenance Utility for re-indexing later, after appropriate 
definition templates are added to ERM Setup.  

If ERM Indexer runs on the server or workstation where IBM Client Access for Windows is 
installed, which allows access to the AS/400 computer, it is possible to process the AS/400 
printstream directly from the output queue using ERM Report Queue Monitor. In this case, 
the AS/400 tab is enabled and the ERM administrator can enter appropriate Report Queue 
Monitor parameters to establish access to the AS/400 output queue. 

For more information on setting up the connection to the AS/400 computer, see Using ERM 
Report Queue Monitor. 
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Figure 30: Specifying settings to import AS/400 files 

The string at the upper right of the AS/400 tab displays the IBM Client Access version 
currently in use. 

4. To specify settings for importing AS/400 computer spool files, in all fields of the AS/400 tab, 
enter appropriate values. 

The values must match the parameters that are predefined on the AS/400 computer as 
described in Using ERM Report Queue Monitor. 

The AS/400 tab includes the following fields: 

AS/400 tab fields 
Field Description Example 

System Name Name of the connection to the 
AS/400 computer. 

AS400 

Output/Data Queue 
Library 

AS/400 library name that contains 
the output queue and associated 
data queue for monitoring. 

QUSRSYS 

Output Queue Name Output queue name. ERM_TEST 

Data Queue Name Data queue name. ERMDATAQ 

IFS Target Directory ERM import directory in the 
AS/400 IFS root directory. AS/400 
path syntax must be used.  

/ERMImport/in 
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AS/400 tab fields 
Field Description Example 

This directory is also displayed as 
a shared folder on the Windows 
network. 

ERM Import Directory ERM import directory label that 
corresponds to the previously 
listed IFS target directory. 

AFP 

5. To test the configuration, click Test Configuration. 
6. If a message appears and indicates that the test is unsuccessful, verify the values in the 

AS/400 tab and the access rights to AS/400. 

7. If a message appears and indicates that the test is successful, to save changes and close 

the window, click Apply Modifications . 

8. To cancel changes and close the window, click . 

9. To start ERM Indexer, perform one of the following tasks: 

• Click Start . 
• Select Process > Start Server. 
ERM Indexer scans all active import directories, such as the \in subdirectories, for input 
reports.  

Processed reports are removed from the \in subdirectories and stored as compressed 
archives in the \storage subdirectory, depending on the date and time of processing. On 
the hour, a new subdirectory such as \storage\YYMMDDHH is created. For more information 
on creating import directories and registering data extraction models, see Main ERM Setup 
Tasks.  

The following information is displayed as the server is running: 

Information displayed during server run-time 
Information 
displayed 

Description 

Start Date Date that the current session began. 

Start Time Time that the current session began. 

Elapsed 
Time 

Elapsed time since the current session began. 

The time is displayed in hours, minutes, and seconds. 

Created 
Documents 

Number of documents created in the current session. 
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Information displayed during server run-time 
Information 
displayed 

Description 

Created 
Folders 

Number of folders created in the current session. 

Current 
Processing 
Directory 

Directory of the file being processed. 

Selected 
Files 

List of files awaiting processing.  

In the right pane, messages indicate the current status of ERM Indexer. The following table 
describes displayed status messages: 

ERM Indexer status messages 
Message Description 

Monitoring Queue ERM Indexer is monitoring the AS/400 printer output queue. 

Search in Progress ERM Indexer is searching for incoming files to process. 

Indexing File ERM Indexer is processing a file. 

Idle...NN ERM Indexer is not running. 

The next import directories search begins in NN seconds. 

Please define ERM 
Attributes 

No ERM configuration is selected in the ERM Setup object. 

Process has been 
cancelled by (User 
ID) 

Stop was clicked, halting the ERM process. 

10. To stop ERM Indexer, perform one of the following steps: 

• Click Stop . 
• Select Process > Stop. 

11. To exit ERM Indexer, click Exit . 

Note: All settings except times are stored for the next session on the local computer in the 
visiclt.ini file. 

For information on maintaining ERM Indexer as a service, see Appendix B: Maintaining Exigen 
Workflow Servers as Services. 

Using ERM Report Queue Monitor 
The following topics are included in this section: 
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• Overview 

• Setting Up AS/400 Report Processing with Report Queue Monitor 

Overview 
If IBM Client Access is installed on the workstation running ERM Indexer, ERM Indexer can use 
Report Queue Monitor to acquire the AS/400 report printstream directly from the AS/400 output 
queue. AS/400 reports are imported into the Exigen Workflow system and processed in ERM as 
follows: 

1. On an AS/400 computer, reports are directed to a designated ERM output queue instead of 
the default printer queue. 

2. ERM Indexer initiates monitoring the output queue by Report Queue Monitor according to 
the schedule set for scanning ERM import directories. 

3. Report Queue Monitor connects to the AS/400 computer and converts spool files from the 
output queue into the text format recognized by ERM Indexer. After that, converted files are 
processed as usual fixed-format text input. 

4. After conversion, Report Queue Monitor removes files from the output queue and 
disconnects from the AS/400 computer until the next scheduled scan. 

Report Queue Monitor processes SCS and AFP spool files as follows: 

• Because SCS files do not contain presentation forms, they are stored as text and retrieved 
with ERM Report Viewer similarly to green-bar reports. 

• AFP files that do not contain presentation forms are processed in the same way as SCS 
files. 

• For AFP files that contain presentation forms, ERM stores both extracted text and the 
original AFP stream, including all external resources required for report presentation. ERM 
documents created from an AFP stream can be presented using the AFP Viewer. Alternative 
presentation options are plain text or using an ERM form overlay. The ERM form overlay 
option requires creating an ERM presentation form for the document type. 

The following diagram describes how Exigen ERM processes AS/400 reports: 
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Figure 109: Exigen ERM AS/400 reports processing 

Setting Up AS/400 Report Processing with Report Queue 
Monitor 
To set up AS/400 report processing with Report Queue Monitor, proceed as follows: 

1. On the computer where ERM Indexer is run, install IBM Client Access for Windows. 

For information on the IBM Client Access for Windows version, see the Exigen Workflow 
readme file. 
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The ERM administrator must have a valid user name and password to access AS/400 via 
the IBM Client Access interface. For information on installing IBM Client Access for 
Windows, see the IBM Client Access for Windows documentation. 

2. On the AS/400 computer, create an output queue and an associated data queue for use by 
ERM Report Queue Monitor. 

This task is performed or supervised by the AS/400 system administrator. 

Example: 

1. CRTDTAQ DTAQ(QUSRSYS/ERMDATAQ) MAXLEN(128) AUT(*USE)  

The preceding statement creates a data queue named ERMDATAQ within a standard library 
named QUSRSYS. 

2. CRTOUTQ OUTQ(QUSRSYS/ERM_TEST) DTAQ(QUSRSYS/ERMDATAQ) 
TEXT('ERM/RQM Testing Queue')  

The preceding statement creates an output queue named ERM_TEST within the QUSRSYS 
library. The output queue is associated with the ERMDATAQ data queue. 
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The ERM administrator must have access to the created queues. For information on access 
rights, consult the AS/400 system administrator.  

 
Figure 110: Setting up output queues 

3. In the AS/400 Integrated File System (IFS) root directory, create an import directory. 

This directory can be accessed from the AS/400 computer and the Windows network, and is 
used as an import subdirectory when assigning import directory parameters in ERM Setup. 

4. Ensure that the IFS directory is shared with the Windows network for the user who is the 
ERM administrator. 

This task is performed by the AS/400 system administrator. 

When connecting to the AS/400 computer, Report Queue Monitor uses the AS/400 login 
information of the current user. For this reason, the ERM administrator who is launching 
ERM Indexer must have access rights to the output queue library and IFS directories. 
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5. In ERM Indexer, in the Settings window, in the AS/400 tab, configure and test the settings 
for AS/400 report handling as described in Setting up and Running ERM Indexer, steps 1 
through 7. 

Conducting a test run of Report Queue Monitor is recommended. 

6. To conduct a test run of Report Queue Monitor, proceed as follows: 
1. In ERM Setup, define one entry having the no template (_!_) report definition. 

This template does not require a sample report. 

2. Assign target parameters to the Retrieve node or to a temporary Queue node. 
3. On the AS/400 computer, print at least one sample of each report to the ERM output 

queue. 
4. Use Client Access Navigator to monitor the contents of the output queue. 

 
Figure 111: Sending printer spool files to the output queue 

5. Start ERM Indexer and process the files in the output queue. 

For more information on running ERM Indexer, see Setting up and Running ERM 
Indexer. 

Report Queue Monitor is started automatically. Spool files from the output queue are 
processed to Exigen Workflow based on no template indexing rules. 

6. Use these ERM documents to generate sample text files to create report definition 
templates required to produce report indexes in Exigen Workflow. 

For more information on creating report templates, see Creating a Report Template. 
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Chapter 16: ERM Storage Maintenance 
Utility 
This chapter describes ERM Storage Maintenance Utility and explains how to run it. The 
following topics are described in this section: 

• Overview 

• Running ERM Storage Maintenance Utility 

Overview 
ERM Storage Maintenance Utility is used to perform the following: 

1. Move ERM storage files from the original location to any other location on the network 
including optical storage. 

2. View indexed documents related to each file in storage and reindexed storage files.  

Running ERM Storage Maintenance Utility 
To start ERM Storage Maintenance Utility, proceed as follows:  

1. In Exigen Workflow Explorer, double click the ERM Storage Maintenance icon  or, 
in the Applications folder, double click ERM Storage Maintenance. 

The ERM Storage Maintenance window appears. 
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Figure 112: Transfer ERM Files window 

2. In the ERM Storage Maintenance window, enter search values and the location of storage 

files and click Search . 

If you did not specify a search range, all archives registered so far in ERM Storage are 
selected. 

The Storage Transfer/Update window appears. It lists all selected archives in ERM storage 
by creation dates in descending order. 
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Figure 113: Storage Transfer/Update window with Transfer Storage Files tab 

3. To move storage files to another location, select the Transfer Storage Files tab and 
proceed as follows: 
• To select the target location, click the browse button by Target Directory. 

The directory browser window appears. 

• Select the target directory or enter the full path to the target location on the network and 
click OK. 

• In the table, select the storage files to transfer. 

It is possible to select multiple files. 

• Click Transfer. 
• Confirm the deletion or overwriting of each storage file. 
• To create a page index for storage files processed in Exigen Workflow versions prior to 

5.4.1, click Create Page Index. 
It is possible to select multiple files. In Exigen Workflow version 5.4.1 and later, ERM 
Indexer creates the page index automatically if report files are longer than 500 pages. 

4. To find out which documents in which workflow, such as indexing records, are created for a 
specific storage file, select the Update Document Records tab. 
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You can create new documents or update old ones by applying a similar procedure as in the 
Indexer to compressed storage files. 

5. Select an import directory for processing the storage file. You can select all report templates 
to reindex the file from scratch, or select a template. 

If you select a template, only documents of the selected type are found and indexed in the 
storage file. 

 
Figure 114: Storage Transfer/Update window with Update Document Records tab 

6. To view files in Exigen Report Viewer, in the Storage Transfer/Update window, double click 
on the storage file or on a selected document. 

Only ERM administrators have access to all ERM storage files.  

7. If a user must access an ERM storage file that is accessible only by using Remote Storage 
Server (RSS), proceed as follows: 
• Open a storage file that is accessible without using RSS. 
• Open the file that is accessible using RSS. 

8. To return to the Storage Transfer/Update window, click Query on the toolbar, or select the 
next archive. 
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9. To search for a string or amount across all storage files selected in the query, click Multi-
Report Search on the toolbar.  

Note: The following user settings are stored for the next session on a local computer in the 
visiclt.ini file: the last search string "path to storage", the last "target directory", and the 
tab that was on top the last time. 
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Chapter 17: Report Definition Wizard 
This chapter describes the basic concepts of report definition in Exigen Workflow and explains 
how to use Report Definition wizard for this purpose. The following topics are described in this 
section: 

• Overview 

• Report Definition Basic Concepts in Exigen Workflow 

• Creating Report Templates 

Overview 
Report Definition Wizard is an application that creates templates for extracting data from 
computer output to laser disk (COLD) reports. The templates are imported into Exigen Workflow 
by initiating the ERM Setup object. ERM Indexer uses report templates as rules of parsing and 
indexing the incoming electronic documents. Also, Exigen Workflow Retrieve can use report 
templates for viewing reports with overlays. 

Report Definition Basic Concepts in Exigen 
Workflow 
Report Definition, basic concepts 
Concept Description 

Report Unit of electronic text document processed by ERM. 

Report File Input file containing one or more reports. Reports in one report file may have 
similar or different Report Layouts. 

Report Layout Format in which the report is printed. A separate Report Template can define each 
report layout. 

Report Template Collection of rules of extracting data from report. These rules are defined as traps 
and fields attached to the traps. 

Trap Single string of characters, including wildcard characters. A trap serves to capture 
a certain report line while the report is scanned line by line. The line is captured 
when its characters coincide by position with every non-blank character specified 
in the trap. Traps are used for the following purposes: 

• recognizing a report layout 

• locating the correct part of the report for extracting data by fields 

Field Rule for extracting a sub-string or a box of sub-strings from the report relative to 
the line captured by a parent trap. 
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Creating Report Templates 
To create a report template, the following main steps must be performed:  

1. Construct traps. 

2. Attach fields to traps. 

The following topics are described in this section: 

• Example Report 

• Traps 

• Fields 

• Template Tree Window 

• Changing Report Template Attributes 

Example Report 
A sample report, STUDENT LOAN INTEREST PAYMENT REPORT, is used throughout this 
guide to illustrate each step of the report template preparation. For more information on this 
example, see Appendix D: Example Report. 

The final task of the Exigen Workflow administrator is to create a report definition template that 
can extract the following information from the sample report: 

• report title for index 

• social security number of a student for index 

• student's name for index 

• student's address for overlay only 

• total interest paid for index 

Traps 
The following topics are described in this section: 

• Trap Overview 

• Trap Attributes 

• Adding and Editing a Trap 

• Deleting a Trap 

• Example Task 1 
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Trap Overview 

A trap is a single-line character string that finds report lines that match characters specified in 
the trap. One report template can contain up to 16 traps. Each trap is independent of other 
traps. 

The topmost trap must not be further than 256 lines from the top of the document. 

A trap serves the following purposes: 

• It defines the beginning of a new page in a multi-page form overlay, such as header trap. If 
the Page header attribute is selected and the number of the form overlay is entered, the 
trap is assigned in the Form Page field. By default, Report Definition Wizard assigns the 
topmost trap as the header trap.  

• It identifies a specific report layout. The signature attribute is selected for this type of trap. 
Each template must have at least one signature trap. A trap can be a header trap and a 
signature trap at the same time. 

• It determines where to extract data for indexing and overlays. In this case, fields must be 
attached to the trap. The header trap and signature trap may or may not have fields 
attached. 

Fields are always attached to their parent trap. A field is a rule that determines how to extract 
data relative to the position captured by the parent trap. It can be single-line or multi-line. Field 
attributes instruct ERM Indexer what to do with the extracted information. The maximum number 
of fields allowed for a trap is 100.  

Note: Traps should not be assigned in such a manner that the same line in the report is captured by 
more than one trap of a template. This may lead to unpredictable indexing results. 

Traps and fields are added and edited in a trap window.  

The trap window is displayed on the right side of the window. The Trap dialog consists of the 
following: 
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Trap  
Field Description 
Trap Name Trap name. 
Trap Edit Box Field where the trap characters string is entered. To enter the trap 

characters string, proceed as follows: 
1. Enter any printable characters using the keyboard. 
2. Enter wild-card characters by clicking the following 

buttons: 

 [Alpha] Captures any letter of English alphabet. 

 [Numeric] Captures any decimal digit. 

 [Blank] Captures a blank. 

 [Non-blank] Captures any printable non-blank 
character. 

 Clears the trap edit box. 
3. Use a combination of the preceding two steps. 

It is possible to cut, copy, and paste text in the edit text box by using 
appropriate buttons and commands in the menu: 

Button Shortcut Key Menu Option  

 
CTRL + X Edit > Cut 

 
CTRL + C Edit > Copy 

 
CTRL + V Edit > Paste 

Note: Any nonprintable characters in the report, for example, 
control codes, are considered blank. 

Sample Text 
View 

Area that is used to select fields to add to this trap as described in 
Adding a Field. Sample Text View is also used to create the trap as 
follows: 

1. Select report lines in the following report view. 
2. To have the lines appear in the sample text view, click 

. 
3. The application automatically searches for the line in 

Sample Text View that matches the trap characters 
edited in the trap edit box. The line is highlighted in pink. 

Report View Entire report. 

Trap Attributes 

To open the Trap Attributes window, click Trap attributes  next to the trap name field. 

The Trap Attributes window appears. 
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Figure 115: Trap Attributes dialog window 

The following table describes trap attributes: 

Trap Attributes 
Attribute Description 

Name Comment for the user. The name trap1 is set by default, where 1 is the number of 
the trap added in this session. 

Page Header 
and Signature 

Selects required type of trap if appropriate. By default Page Header is assigned to 
the first trap in the template. 

Form Page Defines the relevant form overlay page number. By default, 1 is set. Several traps 
in the template can be assigned to the same form overlay page, as there can be 
several form overlay pages per document. 

Adding and Editing a Trap 

To add or edit a trap, proceed as follows: 

1. When a report is opened in the report window, to add a new trap, select Template > Add 

Trap… or click Add New Trap  on the toolbar. 

2. To select an existing trap in the template window, highlight it and select Template > Edit 

Item, or click Edit Selected Item  on the toolbar. You can also double click on it to 
configure the existing trap. 

Note: If the trap window is opened for a particular trap and another item, for example, a trap or field, is 
to be added, edited, or deleted without closing the window, the user is prompted to save the 
changes made to the currently edited trap. 

Deleting a Trap 

To delete a trap from the current template, highlight the selected trap in the template window 

and click Delete Selected Item , or select Template > Delete Item. 

To delete all the traps in the template, click Delete All Items , or select Template > Clear 
Template. 
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Note: If the trap window is opened, it is not possible to delete the item. 

Example Task 1 

In the example report, construct a trap, which captures the head of the report. 

To construct the trap, proceed as follows: 

1. In the toolbar, click Add New Trap . 

2. To enter a trap name, click Trap Attributes  next to the Trap field. 

The Trap Attributes dialog appears. 

3. To specify the trap name, in the Trap Attributes dialog, leave the default name or enter a 
new one. 

4. To use the trap as a page header, select the Page Header option. 
5. To use the trap as a signature for the report, select the Signature option. 
6. Click OK. 
7. In the lower window, select a line containing the sample text. 

In this example, select FOR IRS FORM 1098E. 

8. Click Change Sample. 

The selected text appears in the upper window. 

9. To specify the trap mask, in the field below OK, enter the sample text exactly above the 
location where it appears in the document. 
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Figure 116: Trap window 

10. Click OK. 

The application closes the trap definition window. In the document, the traps are highlighted.  
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Figure 117: Report window 

Fields 
The following topics are described in this section: 

• Fields Overview 

• Adding a Field 

• Editing a Field 

• Deleting a Field 

• Example Task 2 

• Example Task 3 

Fields Overview 

Fields define a rule of extracting a sub-string from the report relative to position, captured by a 
parent trap. Fields are always related to a trap. Fields have their coordinates set relative to the 
following: 

• trap 
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• fixed length 

• name 

• description 

There are the following field types: 

Field types 
Type Description 

Index field Populates Exigen Workflow custom project. It can be used in database queries 
while retrieving information. For more information on enterprise report 
management, see Chapter 14: Configuring Enterprise Report Management. 

Form overlay Retrieves reports using form overlays. Form overlay fields can extract multiple 
lines or boxes. For overlays with multiple pages, form overlay fields can define the 
number of overlay template pages to be used with this document page. For more 
information on form overlays, see the Exigen Workflow Administrator's Guide, Part 
3: Utilities, Chapter 8: Template Management Utility. 

Adding a Field 

A field can be added to a trap opened in the trap window. After selecting a sample text view and 
constructing a trap, you can add a field to this trap by highlighting the desired substring in the 
sample text view with the mouse pointer. As the mouse is released, the Field Attributes dialog 
appears. 

 
Figure 118: Field Attributes window 

To add a field, proceed as follows: 
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1. In the Name field, enter a field name. 

The default name is FIELD1, where 1 is the number of the field added in this session. This 
name appears in the auto-indexing settings of ERM Setup. 

2. In the Description field, enter a field description. 

The description also appears in the auto-indexing settings of ERM Setup. 

3. If the Description field is an index field, select Index field. 
4. If the Description field is a qualifier, select Qualifier. 

A qualifier field is used when a standard, single line trap is insufficient for extracting precise 
information from a report. If the field is a qualifier, the value in the Description field serves 
as an additional trap. The extracted field value and the Description field value are 
compared, and if these strings do not match, the entire parent trap with which the qualifier 
field is associated is considered as not matching. 

For example, if the field value is “Student Loan”, this field qualifies as matching when 
the Description value is “stude” or “ tud” and does not qualify if “study” is entered. 
The standard Report Definition Wizard trap rules are applied during string comparison as 
described in Traps. 

5. If the Description field is a form ID, select Form ID. 
6. To hide the field from specified user groups, select the Hide check box. 

7. To select the data type, such as String, Numeric, or Date, select an item in the Data type 
list. 

8. In the Increment, Position, and Length fields, modify values as appropriate. 

These values are set automatically by the position of the highlighted substring in the sample 
text view. 

9. For a multiline field, select one of the following types for defining the number of lines: 
Multiline field types 
Type Description 

By Line Count Number of lines. Defined by user parameter. 

Left indent Field is left-indented. Number of lines is set dynamically, with the field 
terminating line being defined by the first occurrence of a non-blank printable 
character in the first position to the right of the field starting position and 
below the first line. 

Right indent Field is right-indented. Number of lines is set dynamically, with the field 
terminating line being defined by the first occurrence of a non-blank printable 
character in the first position to the left of the field starting position and below 
the first line. 

After-blanks Blank lines specify format. Number of lines is set dynamically, with the field 
terminating line being defined by the first occurrence of a user specified 
number of consecutive blank lines below the first line for the whole field 
length. 

10. To save changes, click OK. 
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Editing a Field 

To configure an existing field, select it in the template view and click Edit Selected Item , or 
select Template > Edit Item. You can also double click on the field. The field attributes 
window appears.  

Edit the field attributes as described in Adding a Field. 

Deleting a Field 

To delete the field, select it in the template view and select Template > Delete Item, or click 

Delete Selected Item . 

Example Task 2 

In the example report, to add a field to the title trap, which extracts the report title, proceed as 
follows: 

1. To edit the title trap, on the toolbar, click Edit Trap . 

2. In the sample text view, select STUDENT LOAN INTEREST PAYMENT REPORT. 

3. In the dialog box, enter the following: 
• TITLE for the field name 
• Report Type for the description 

4. Select an index field. 

5. Click OK twice. 

The line captured by the trap is highlighted in pink. 
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Figure 119: Template, example report with one trap and one field; line captured by trap is highlighted in 

pink and attached field is highlighted in gray 

Example Task 3 

In the example report, proceed as follows: 

1. Construct a trap that captures a line with a social security number.  

2. Add fields extracting social security number, name, and address to this trap.  

3. Construct a trap that captures the last line of the report and attach a field extracting the total 
interest paid. 

This section describes how to enter values for Example Task 3 using the following procedures: 

• Adding a Trap for Personal Data 

• Adding a Trap for Total Interest Paid 

Adding a Trap for Personal Data 

To add a trap for personal data, proceed as follows: 

1. To add a new trap, on the toolbar, click Add Trap . 

2. Enter a trap name: ssn. 
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3. Select three lines in the report view starting from the line with ssn. 

4. To populate the sample text view with these lines, click . 

5. In the sample text view, select the following line as a sample for the trap: 

SSN: 891-62-3685    SMITH JAMES A. 

6. To ensure that the sample appears directly above the social security number in the sample 

text view, to obtain the following result, in the trap definition window, click  and enter 
ÑÑÑ-ÑÑ-ÑÑÑ.  

7. In the sample text view field below OK, select 891-62-3685. 

8. In the dialog box, enter SSN for the field name, Social Security Number for the description, 
and select an index field. 

9. Click OK.  
10. Select SMITH JAMES A. 

Other names can be longer, so extra space should be reserved. 

11. In the dialog box, enter NAME for the field name, Student Name for the description, and 
select an index field.  

12. Click OK. 
13. Select 12708 RIVERSIDE ST, ensuring that extra space is reserved for longer addresses. 

14. In the dialog box, enter ADDRESS for the field name, Student Address for the description, 
and clear the index field. 

15. In the multi-line box, select By left indent. 
16. Click OK twice. 

Adding a Trap for Total Interest Paid 

To add a trap for total interest paid, proceed as follows: 

1. To add a new trap, click Add Trap  on the toolbar. 

2. Enter the trap name totals. 

3. Select the last line in the report view. 

4. To populate the sample text view with this line, click . 

5. In the trap definition window, exactly above the line in the sample text view, enter TOTAL 
INTEREST PAID.  

6. In the sample text view, select 678.55. 

7. In the dialog box, enter TOT_INTEREST for the field name, Total Interest for the description, 
and select the index field. 

8. Click OK twice. 
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The application closes the trap definition window. In the report window, all captured lines are 
highlighted in pink. 

 
Figure 120: Template of the example report having three traps that extract five fields 

Template Tree Window 
A report template can be viewed as a tree, where a root node is a template name and a tree 
node represents traps and fields attached to appropriate traps. This tree is displayed in the 
template window. Report templates are stored as files in text format with an extension .rdt. 

Template tree represents template attributes, traps, trap attributes, and fields with their 
attributes. In such a way the template window provides quick access to all template elements. 
By clicking on an element of such template tree, the user can start template editing, which 
ensures editing the appropriate element such as trap or field. 
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The following topics are described in this section: 

• Opening a Report Template 

• Importing a Template 

• Exporting a Template 

• Displaying Captured Data in the Report Window 

Opening a Report Template 

To create a new template, select File > New Template, or click New template . 

To open an existing template, proceed as follows: 

1. Select File > Open Template or click Open Template  on the toolbar.  

2. Select a template and click Open.  

The template window appears. 

 
Figure 121: Template window 

No report is displayed in the report window. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 17: Report Definition Wizard 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 245 of 391 

Note: Only one template can be opened at once. Before opening a new template, the user is 
prompted to save the changes made to the previous template, if any. For information on saving 
a template, see Exporting a Template. 

3. To expand a branch, click on the plus sign + on the left of the template tree. 

4. To collapse a branch, click on the minus sign - on the left of the template tree. 

Importing a Template 

To import an existing template from an XML file, select File > Import Template. 

The template is imported from the location specified in View > Option. For more information on 
exporting a template, see Exporting a Template. 

Exporting a Template 

Report Definition Wizard offers two formats in which to save the report template, INI and XML. 

To export a template, proceed as follows: 

1. To define the file name where the template is to be exported in the Exigen Workflow 
System directory, select View > Options. 

The Options window appears. 

 
Figure 122: Options window 

The Wildcard characters group contains four fields in which you can enter the titles of the 
following buttons that appear in the trap definition window: 

• Alpha 
• Numeric 
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• Blank 
• Non-blank 

2. To restore default wildcard character values, click Default. 
3. Enter the path to ERM settings, or use the browse button to locate the ERM settings 

directory ../ETDM, and click OK. 
4. To export to both INI and XML files when the template is saved, check the To save the 

configuration files when saving templates check box. 

5. To export the template to the ERM INI and ERM XML files indicated in the Options window, 
in the menu, select File > Export Template. 

6. To save the template data in the ERM configuration file, export the template to the ERM 
XML file. 

Templates exported using XML format can be imported into RDW as described in Importing 
a Template. 

Note: If the ERM INI or ERM XML files already contain a template with the same extension as the 
template currently being exported, the user is prompted to overwrite the template. 

Displaying Captured Data in the Report Window 

The template window displays the template, but you can also view the template in the report 
window. In the report window, all traps and appropriate fields of the template are highlighted in 
the places where they occur. 

Changing Report Template Attributes 
Report template attributes are part of a report template and are stored in the same file where 
the report template is stored. 

To view and change report template attributes, proceed as follows: 

1. To open the Template Attributes window, use any of the following methods: 
• Double click on the template node in the tree. 

• Select the template and, on the toolbar, click Edit Selected Item . 
• Select Template > Edit Item. 
The Template Attributes window appears. 
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Figure 123: Template Attributes window 

2. In the Description field, enter a template description, for example, IRS form 1098E. 

3. In the Extension field, enter a unique three-character alphanumeric code to be used in the 
Exigen Workflow ERM configuration file as the identifier of this report layout, for example, 
IRS.  

4. In the Face Name field, select a font for the report. 

5. In the Size field, select a font size for the report. 

6. In the Paper type field, select a report paper type. 

7. If the report must appear in landscape layout, select the Landscape option. 

8. In the Left, Top, Right, and Bottom fields, enter the appropriate distance from the page 
margins. 

9. Click OK. 
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Chapter 18: E-Capture Server 
This section describes how to set up and run E-Capture Server. The following topics are 
described in this section: 

• Overview 

• Opening E-Capture Server 

• E-Capture Server Setup 

• Running E-Capture Server 

Overview 
E-Capture Server receives and processes PDF and PCL files and transforms them into Exigen 
Workflow documents. E-Capture Server captures information from these files and uses it for 
indexing and routing. 

E-Capture Server also can obtain indexing information from other sources, such as the legacy 
system, text files, and file names. If required, E-Capture Server places extracted information in 
temporary storage for use by other applications. 

E-Capture Server is represented as a node on the workflow map. 

Important setup operations that can be performed using E-Capture Server include the following: 

• selecting the directories from which to retrieve PDF and PCL files 

• selecting a destination workflow, queue, node, user, Exigen Workflow task type, document 
type, and default subfolder 

• selecting a processing mode, either compound document or batch 

• specifying instructions regarding custom scripts, history and error logs, post-processing 
procedures, and reference tables, which are interfaces for receiving indexing information 
from legacy systems 

• reviewing error log files, history files, and data placed in temporary storage 

• selecting parameters for splitting large PCL files  

To use E-Capture for processing PDF files, Adobe Libraries is required. For more information on 
system requirements, see the Exigen Workflow readme file. 

To process PCL files, a third party component, PCLTool SDK Runtime, must be installed in the 
VISIFLOW/SYSTEM directory. For information on obtaining PCLTool SDK Runtime, consult 
Exigen Support Services. 
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Opening E-Capture Server 
Before using E-Capture Server, you must set it up using E-Capture Administrator and E-Capture 
Definition Utility.  

To open E-Capture Server, proceed as follows: 

1. In Exigen Workflow Explorer, select the appropriate workflow. 

2. Double click the E-Capture Server icon .  

The E-Capture Server window appears. 

 
Figure 124: Starting E-Capture Server 

For information on the toolbar, menus, and buttons of the E-Capture Server window, see E-
Capture Server in Appendix A: Exigen Workflow Object Menus and Button Bars. 
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E-Capture Server Setup 
Before running E-Capture Server, select the directories where files arrive for processing. 

The following topics are described in this section: 

• Setting Up E-Capture Server 

• Adding a Directory Configuration 

• Defining Recognized Document Types 

• Processing PCL Files 

• Modifying a Directory Configuration 

• Deleting a Directory Configuration 

• Exporting and Importing Configuration Settings 

• Recovering PCL Files 

Setting Up E-Capture Server 
To set up E-Capture Server, proceed as follows: 

1. In the E-Capture Server window, click Setup. 

 

The E-Capture Server Setup: Input Directories window appears.  
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Figure 125: E-Capture Server Setup: Input Directories window 

The E-Capture Server Setup: Input Directories window displays the directory 
configurations that tell E-Capture Server where to obtain files and what actions to perform 
with them. 

2. To manage directory configurations, use the E-Capture Server Setup: Input Directories 
interface.  

For more information on managing directory configurations, see the following sections: 

• Adding a Directory Configuration 
• Defining Recognized Document Types 
• Processing PCL Files 
• Modifying a Directory Configuration 
• Deleting a Directory Configuration  
• Recovering PCL Files 

3. To select the directories for E-Capture Server to process, click in the gray column to the left 
of the Source file directory column. 

A check mark appears. You can select as many directories as required. 

When selecting directories, observe the following rules:  

• The selected directories must not be write protected. 
• The path to the directory must not contain two or more adjacent spaces. 

Adding a Directory Configuration 
E-Capture Server provides a setup wizard for easy directory configuration. 
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This section describes how to add a directory configuration using the following procedures: 

• Selecting Workflow Components 

• Recording History and Log Files and Enabling Custom Scripts 

• Specifying Settings for Batch Separation, Preprocessing, and Verification 

• Specifying File Types and Post-Processing Actions 

• Specifying Files to Process 

Selecting Workflow Components 

To select workflow components, proceed as follows: 

1. In the E-Capture Server Setup: Input Directories window, click Add.  

The E-Capture Server Setup: Step 2 - Workflow Components window appears.  

 
Figure 126: Selecting workflow components 

This window requires familiarity with the standard Exigen Workflow concepts of workflow, 
queue, user, task name, document type, and subfolder. For more information on these 
concepts, see the Exigen Workflow Administrator’s Guide, Part 1: Design and Configuration.  

2. Click the browse button next to the Input directory field, and select the source document 
directory. 

The path to the source document directory can have a maximum of 128 characters. 

3. In the Directory label field, enter a descriptive name. 

4. To select a destination workflow, click the browse button next to the Workflow field.  
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A drop-down list appears in the lower part of the window. 

5. In the drop-down list, select a destination workflow. 

A workflow can only be selected under the following conditions: 

• An E-Capture output group is defined in that workflow’s project. 
• The output group is used in at least one form. 

6. To select a destination queue, click the browse button next to the Send to queue field.  

A drop-down list appears in the lower part of the window. 

7. In the drop-down list, select a destination queue. 

8. To select a destination user, click the browse button next to the Send to user field.  

A drop-down list appears in the lower part of the window. 

9. In the drop-down list, select a destination user. 

10. To select a workflow node where problematic processed documents are sent, in the 
Exception queue field, select a workflow node. 

A problem occurs when a mandatory field is empty or there is no corresponding record in 
the reference table. 

If the Exception queue field is <N/A>, this feature is not used. The Exception queue field 
must not be empty. 

11. If an exception queue is selected, in the Exception user field, select a user to whom 
documents are sent in the exception queue. 

12. To select a task name, click the browse button next to the Task name field.  

A drop-down list appears at the bottom of the window. 

13. In the drop-down list, select a task name.  

To store or view a document created from PDF files in PDF format, a registered Adobe 
Acrobat Reader task must be selected. 

To store the files in TIFF format or to process PCL files, <N/A> must be selected. 

To initiate conversion of PDF files to TIFF or DMS files, the files must be printed on a virtual 
printer. Before a virtual printer can be selected, the print driver must be installed. 

Note: The NED Image Printer Driver is optional third party software that must be ordered from Exigen. 

14. To install and configure the NED Image Printer Driver, proceed as follows: 
1. To install the NED Image Printer Driver, follow the instructions described in the NED 

Image Printer Driver’s readme.txt file. 
2. After the NED Image Printer Driver is installed, select Start > Settings > Printers. 
3. Right click NED Image Printer and select Properties. 
4. The NED Image Printer Properties window appears. 
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5. Select the Advanced tab. 

 
Figure 127: NED Image Printer Properties window 

6. Select the Print directly to the printer option. 
7. Click OK. 

15. To select the virtual printer, click Printer. 

The Conversion Setup window appears. 

16. In the Driver name field, select the virtual printer. 

17. Click OK. 
18. In the Assign to subfolder field, select the default subfolder to which processed documents 

are assigned. 

This feature can only be used if the folder, subfolder, document indexing structure, and 
default subfolder feature are used. If the requirements are met, it is possible to select a 
predefined default subfolder. All documents coming from the selected directory are assigned 
to the selected subfolder after processing. 

If <N/A> is selected, documents are not assigned to a subfolder. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 18: E-Capture Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 255 of 391 

19. In the Default document type field, select a default document type for documents arriving 
in the selected directory. 

All document types defined in the project are available for selection, but if the project is 
configured so that administrators can define a list of available document types for each 
default subfolder, only the assigned document types are available for selection depending 
on the selected default subfolder. 

This option has the lowest priority and does not occur in the following situations: 

• The required document type is extracted from the document content. 

The coordinates for extraction must be assigned in E-Capture Definition Utility. This 
assignment has the highest priority. 

• The document type of the processed document is recognized based on the set of 
assigned keywords. 

This option works only in batch separation mode. The newly recognized document type 
replaces the default document type. 

<N/A> means no default document type is assigned. 

20. To apply the selections, click Next.  

Recording History and Log Files, and Enabling Custom Scripts 

The E-Capture Server Setup: Step 3 window appears. 

 
Figure 128: E-Capture Server Setup: Step 3 

To record history and log files, and enable custom scripts, proceed as follows: 

1. In the E-Capture Server Setup: Step 3 window, specify the following settings: 
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E-Capture Server Setup: Step 3 window objects 
Object Description 
File processing 
delay (min.) 

Number of minutes for delaying file processing. For example, this can be 
the minimum delay between the time the file is created and the time it can 
be processed.  

Log and history file 
directory 

Directory in which the history and log files are placed. 

Use custom scripts If selected, enables E-Capture Server to execute registered custom scripts. 
Custom scripts are registered in E-Capture Administrator. 

Send to default 
folder 

If selected, assigns all processed documents to the default folder. The 
default folder ID is 999999999. 

History If selected, enables E-Capture Server to record the processing history. 
Debug If selected, enables E-Capture Server to display messages about 

processing status to assist in setup verification. This feature is not 
applicable if E-Capture Server is used in production. 

2. To go to the next step of the wizard, click Next. 

Specifying Settings for Batch Separation, Preprocessing, and Verification 

The E-Capture Server Setup: Step 4 window appears. 

 
Figure 129: E-Capture Server Setup: Step 4 

The appearance of the window and the set of available options depend on the selected 
configuration settings. 

To specify settings for batch separation, preprocessing, and verification, proceed as follows: 

1. In the E-Capture Server Setup: Step 4 window, configure parameters as described in the 
following table: 
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E-Capture Server Setup: Step 4 window objects 
Object Description 
Batch separation Enables batch separation mode. 

Batch separation mode splits complex batches of documents into separate 
documents for processing. By default, documents are processed normally as 
Exigen Workflow documents. If the Output directory option is selected, 
documents are sent to the specified output directory. 
For batch separation mode to work correctly, the following tasks must be 
completed in the E-Capture Definition Utility: 
• The first page of each template must be registered as a separator form. 
• A multipage indicator must be mapped. 

Recognize 
document type 

Replaces the Preprocessing check box when the Batch separation check 
box is selected. 
Selecting the check box opens the Document Type Recognition window as 
described in Defining Recognized Document Types. 

Preprocessing If selected, enables E-Capture Server to use default preprocessing or 
customized scripts for preprocessing. 
The scripts are registered in E-Capture Administrator. 
Preprocessing refers to any preliminary file processing that does not require 
validation or transformation. Preprocessing is used to determine additional 
useful information about a processed file. 
E-Capture supports the following sources of information for preprocessing: 
• Control Record refers to the information contained on the first page of a 

PCL file. After processing, this control record page becomes the last in 
the Exigen Workflow document.  

• Control File refers to information contained in a separate, single page text 
file. This file has the same name as the source file, but a different 
extension. After processing, the control file is deleted. 

• File Name refers to the file name, which in some cases can provide 
preliminary information. 

You can configure E-Capture Server to preprocess additional data with 
custom scripts. 

Completeness If selected, enables E-Capture Server to verify the completeness of 
compound documents. 
To verify completeness, E-Capture Server compares the content of a 
compound document to its schedule of forms. Verification of completeness is 
available only in compound document mode.  
The check box is enabled only if the following requirements are met: 
• The Batch separation check box is cleared. 
• A schedule of forms is registered for the current Exigen Workflow project 

using E-Capture Definition Utility. 
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E-Capture Server Setup: Step 4 window objects 
Object Description 
Presentation 
order 

Defines the form presentation order as follows: 
Option Description 
Original Keeps forms in their original sequence. If 

preprocessing is required, the control record page is 
placed at the end of the file. Similarly, a control file 
is converted to an image and placed at the end of 
the file. 

Categories Based Rearranges forms of the compound document 
according to the sequence of the form categories 
defined using E-Capture Administrator. The control 
record page and converted control file are placed at 
the end of the file. 

The list box is enabled only in compound document mode.  
Number of final 
pages to delete 

Specifies the number of pages to be deleted from the end of a processed 
batch. 
This option is typically used when the final pages in a batch contain company 
internal information that has no relation to the content of documents inside the 
batch. 
This option is available only when the following requirements are fulfilled: 
• The Batch separation option is enabled. 
• The Task name field in the E-Capture Server Setup: Step 2 - Workflow 

Components window contains the value <N/A>. 
Control file 
extensions 

Defines the set of control file extensions used for preprocessing. 
The field is enabled only when the Preprocessing check box is selected. 
The file extensions must be delimited by a comma and the following file 
extensions must not be used: 
• .txt  
• .ps 
• .pdf  
• .tif  
• .pcl 

When preprocessing using control files, it is recommended that file processing 
be delayed using the File processing delay option. This ensures that control 
files arrive in the source directory before the corresponding source file is 
processed. 

Output directory 
check box 

If selected, activates the Output directory combo box, which contains all 
input directories except the one that is currently selected and used. 
The check box is enabled only if the Batch separation check box is selected. 

Output directory 
combo box 

Defines the directory where files are sent after batch separation. The files are 
not saved to Exigen Workflow storage, but can be processed using the 
selected output directory as the input directory for the created files. 

Multiple parcels Each new document is assigned to a separate parcel. 
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E-Capture Server Setup: Step 4 window objects 
Object Description 
Use reference 
table 

Enables E-Capture Server to use additional information from a reference table 
named <Project_ID>_REF_TABLE. 
The table can be created using Project Builder. 
The reference table can be used to extract additional indexing information for 
imported documents and folders and subfolders containing them. 
The table contains two types of columns:  
• columns containing known information that is used in the SQL WHERE 

conditions 
• columns containing the retrieved information used for indexing 
If no records are found, the corresponding information is sent to the exception 
queue. Reference documents are created if more than one record appears in 
the record set. 
A SQL query statement based on a script template specific to the reference 
table must be written and added to the TransRefTableCondition script. 
All required information must be added to activate the script. For information 
on the SQL statement, see the corresponding script template. 

2. To go to the next wizard step, click Next. 

Specifying File Types and Post-Processing Actions 

The E-Capture Server Setup: Step 5 window opens. 

              
Figure 130: E-Capture Server Setup: Step 5 

To specify file types and post-processing actions, proceed as follows: 

1. In the E-Capture Server Setup: Step 5 window, configure parameters as described in the 
following table: 
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E-Capture Server Setup: Step 5 window objects 
Object Description 
Document files 
extension 

Extension for files processed in the source directory. 
E-Capture Server can process only one type of file from each source 
directory. 
The appearance of the E-Capture Server Setup: Step 5 window depends 
on the selected file extension. 
If batch separation mode is used and the PCL file extension is selected, 
additional objects appear in the window as described in Processing PCL 
Files. 

Document files Action performed with source files after processing. 
The following options are available: 

Option Description 
Move Moves source files to a different directory. You 

are prompted to select the recycle directory. 

Delete Deletes processed source files. 

Remain in directory Leaves the files in the source directory 

E-Capture Server stops after all source files are 
processed. 

Rename Renames all processed source files, providing 
the extension "___". 

In this case, E-Capture Server does not stop 
and continues scanning for new source files.  

Recycle directory Directory where the processed source files are moved. 
This option appears only when the Move option is selected. 

Document type 
reference file 

Path of the text file containing the following reference information: 
• signature on the form of the first page of the extracted document 
• predefined document type 
This option is available only if the following conditions are true: 
• The PDF file type is specified. 
• The <Use Ref. file> document type is selected. 

Use bookmarks If selected, enables E-Capture to separate PDF files into Exigen Workflow 
documents based on bookmarks. 
If selected, the information in the Number of final pages to delete option 
in step 4 is ignored. 
This option is available only if the following conditions are true: 
• The Batch separation check box is selected. 
• The PDF file type is specified. 
• The document type is not <Use Ref. file>. 
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E-Capture Server Setup: Step 5 window objects 
Object Description 
New folder is not 
allowed 

If selected, E-Capture does not create a new folder when processing PDF 
files. If no corresponding folder exists, the original PDF file is sent to the 
exception queue. 
This option is available only if the following conditions are true: 
• The Use bookmarks check box is selected. 
• An exception queue is selected. 
• An exception user is selected.  

Bookmark control 
file document type 

If selected, displays the document type of the Exigen Workflow text 
document that is created by E-Capture in Use bookmarks mode. 
The text document lists document numbers and their associated 
bookmarks as extracted from the original PDF file. The text document is 
located in the destination queue and is assigned to the destination user. 
If cleared, E-Capture does not create a text document. 
This option is available only if Use bookmarks is selected. 

Rejection keyword Word that identifies a page in documents having multiple pages. For 
example, the word Page can be used to identify pages. 
The rejection keyword is used to filter out bookmarks that point to 
individual pages in a multiple page document. All bookmarks containing 
the rejection keyword as the first word are eliminated from consideration, 
that is, these bookmarks are not used for document separation. 
This option is available only if Use bookmarks is selected. 

Delete empty pages If selected, blank pages are removed from the processed documents. 
This option is available only if the Batch separation check box is selected. 

2. If the Retain in directory option is not selected, to finish the configuration process, click 
Finish. 

3. If the Retain in directory option is selected, click Next. 

Specifying Files to Process 

The E-Capture Server Setup: Step 6 window appears. 
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Figure 131: E-Capture Server Setup: Step 6 

This window is used to specify the files to be processed from the named source directory. 

 

To specify the files to be processed, proceed as follows: 

1. In the E-Capture Server Setup: Step 6 window, to enable E-Capture Server to process all 
files in the named directory, select the All files in option. 

Selecting All files in disables the Select first file and Select last file list boxes. 

2. To specify a group of files to be processed, in the Select first file and Select last file list 
boxes, select appropriate files. 

These list boxes display all the files in the named directory. 

3. To apply the new configuration, click Finish. 

Defining Recognized Document Types 
E-Capture Server can assign document types to processed documents based on a set of 
defined keywords extracted from the source files. 

To define the keywords used to recognize document types, proceed as follows: 

1. In the E-Capture Server Setup: Step 4 window, select the Recognize doc type check box. 

The Recognize doc type check box is available only when the Batch separation check 
box is selected. 

The Document Type Recognition window appears. 
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Figure 132: Recognize Doc Types window 

In the Document Type Recognition window, all document types defined in the project are 
listed in the Registered document type text box. The Recognition keywords text box lists 
all keywords for the selected document type. 

2. To add a new keyword to the selected document type, in the New keyword field, enter the 
keyword and click Add. 

3. To delete a keyword, select it and click Delete. 

The set of keywords for each document type must be unique. 

A document type is recognized if all assigned keywords are found on the first document 
page. If no document type is recognized, the default document type is assigned to the 
document. 

4. To save the changes, click OK. 

Processing PCL Files 
If the PCL file extension is selected in the E-Capture Server Setup: Step 5 window, additional 
window objects appear. 
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Figure 133: Processing PCL files 

The following table describes the E-Capture Server Setup: Step 5 window additional objects: 
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Additional E-Capture Server Setup: Step 5 window objects 
Object Description 
Resolution Image resolution of the TIFF files produced from the original PCL files. 
Remote split Enables E-Capture Server to create small, split PCL files in specific child directories. 

Each child directory has a corresponding input directory in which the large PCL 
source files are located. 

Note: All input directories using the same remote split mode must have the 
same direct parent directory. 

This option is available only when the File split mode check box is selected. 
File split mode Indicates that E-Capture Server produces smaller files from the source PCL files 

and processes them separately. This option improves network traffic when files are 
accessed through the network. 

Start page First page in the document from which the information is extracted. 
This option is available only when the File split mode check box is selected. 

Page range Number of pages in a single PCL file portion that is separated as a smaller PCL file. 
This option is available only when the File split mode check box is selected. 

Split directory Directory where newly created files await processing. 
This option is available only when the File split mode check box is selected but the 
Remote split check box is cleared. 

Parent input 
directory 

Parent directory containing the automatically created child directories. 
This option is available only when the Remote split check box is selected. 

Modifying a Directory Configuration 
To modify a directory configuration, proceed as follows: 

1. In the Input Directories window, select a directory configuration.  

2. Click Modify.  

The E-Capture Server Setup: Step 2 - Workflow Components window appears and 
displays the assigned workflow components. 

3. To revise any of the workflow component selections, select appropriate values in the list 
boxes as described in Adding a Directory Configuration. 

4. To proceed through the E-Capture Server setup wizard, click Next. 
5. To save the changes, in the final wizard window, click Finish. 

Deleting a Directory Configuration 
To delete a directory configuration, proceed as follows: 

1. In the E-Capture Server Setup: Input Directories window, select a directory configuration.  

2. Click Delete.  

The confirmation window appears. 
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Figure 134: Deleting a directory configuration 

3. To delete the directory configuration, click Yes. 
4. To cancel your request, click No. 

Exporting and Importing Configuration Settings 
E-Capture Server configuration settings can be exported from one environment and imported 
into another. The export and import feature makes it possible to use the same setup for different 
E-Capture Servers. 

An environment is defined by one or more of the following factors: 

• network 

• computer 

• Windows version 

• workflow that includes E-Capture Server 

• workflow to which E-Capture Server sends processed documents 

• workflow node that represents E-Capture Server 

• workflow node that receives documents from E-Capture server 

• workflow user who receives documents from E-Capture Server 

• exception queue for processing problematic documents in the new environment 

• user receiving documents in the exception queue 

• task name in the new environment 

• default subfolder to which documents are assigned in the new environment 

• default document type for incoming documents in the new environment 

The following topics are included in this section: 

• Exporting E-Capture Server Configuration Settings 

• Importing E-Capture Server Configuration Settings 

Exporting E-Capture Server Configuration Settings 

To export E-Capture Server configuration settings, proceed as follows: 
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1. In the E-Capture Server window, select File > Export. 

The Export Setup window appears. 

 
Figure 135: Exporting E-Capture Server setup 

2. To select an E-Capture Server setup to export, in the Export directory field, select the 
setup directory. 

3. To specify the export destination file, in the Export file path directory, perform one of the 
following steps: 
• Enter a path and file name. 

• Click the browse button , select a file and path name, and click Open. 

The export file is a text file. Its file extension is .ini. 

 
Figure 136: Defining export settings 

4. To create the export file, click Export. 
5. To view the contents of the export file, click Read. 

The export file is displayed. 
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Figure 137: Export file 

6. To save changes and close the window, click Close. 

For information on importing E-Capture Server configuration settings, see Importing E-Capture 
Server Configuration Settings. 

Importing E-Capture Server Configuration Settings 

E-Capture Server configuration settings must be exported before they can be imported. 

For information on exporting E-Capture Server configuration settings, see Exporting E-Capture 
Server Configuration Settings. 

To import E-Capture Server configuration settings, proceed as follows: 

1. In the E-Capture Server window, select File > Import. 

The Import setup window appears. 
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Figure 138: Importing an E-Capture Server setup 

2. To select the setup to import, click the browse button next to the Import file path field, 
select a path, and click Open. 

3. To read the selected import file, click Read. 
4. To select the import directory, click the browse button next to the Import directory field, 

select a path, and click Open. 

 
Figure 139: Specifying import settings 

5. To import the setup, click Import. 

The Check Imported Workflow Components window appears. The following table 
describes the values displayed in the Check Imported Workflow Components window: 
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Check Imported Workflow Components window values 
Value Description 
Not Found Imported workflow component does not match the new environment. 
Any other 
value 

Imported workflow component matches the new environment or a match is not 
possible. 

 
Figure 140: Checking imported components 

The following table describes the fields in the Check Imported Workflow Components 
window: 
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Check Imported Workflow Components window fields 
Field Description 
Input 
Directory 

Directory into which E-Capture Server setup is imported. 

Directory 
Label 

Import directory descriptive name. 
This field is optional. 

Workflow Destination workflow. 
Send to 
Queue 

Destination queue. 

Send to 
User 

Destination user. 

Exception 
Queue 

Workflow node to which problematic processed documents are sent. 

Exception 
User 

User to whom documents are sent in the exception queue. 

Task Name Task name. 
Assign to 
Subfolder 

Default subfolder to which processed documents are assigned. 

Default 
Document 
type 

Default document type for documents arriving in the selected directory. 

If any field contains Not Found, the E-Capture Server setup cannot be imported. The OK 
button is disabled. 

6. To enable E-Capture Server setup import, in all fields containing the value Not Found, enter 
an appropriate value from the new environment. 

A value can be selected using the browse button or entered manually. 

If the Workflow field contains the value Not Found, it is recommended to correct it before 
correcting the other fields. 

7. To import the E-Capture Server setup, click OK. 

The setup is imported. 

Recovering PCL Files 
E-Capture Server can recover large PCL files if a problem occurs during processing. 

To resolve PCL file processing problems, proceed as follows: 

1. In Exigen Workflow Explorer, select the appropriate workflow. 

2. Double click the E-Capture Server icon . 

The E-Capture Server window appears. 
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3. In the E-Capture Server window, select View > Show Recovery info button. 

The E-Capture Server Setup: Input Directories window appears. 

4. In the E-Capture Server Setup: Input Directories window, click Recovery Info. 

The Recovery Info window appears.  

 
Figure 141: Recovery Info window 

This window is used only in file split mode if the processing of a large PCL file is interrupted, 
to resume processing from the location where the problem appeared. 

8. Click the browse button next to the Original Source File field, and select the PCL server 
where the original files reside for importing. 

When an original file is selected, E-Capture Server automatically tries to locate the current 
extracted file and add the path in the Current Extracted File field. 

9. If E-Capture Server cannot find the file automatically, to locate the file manually, in the 
Current Extracted File field, enter the path. 

10. Click Calculate. 

The correct page number of the extracted file appears in the Start a New Processing From 
Page field.  

11. Note the number in the Start a New Processing From Page field. 

12. Open the E-Capture Server Setup: Step 5 window and enter the page number in the Start 
page field. 

13. Finish the E-Capture Server setup. 

14. If the E-Capture Split Server is stopped, start E-Capture Split Server.  

For more information on E-Capture Split Server, see Chapter 20: E-Capture Split Server. 
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15. Start the PCL server. 

Running E-Capture Server 
E-Capture Server pulls the requested files from each checked directory in the E-Capture 
Server Setup: Input Directories window. The files are processed according to the 
configurations specified in the E-Capture Server setup wizard.   

E-Capture Server scans the directories in the sequence listed in the E-Capture Server Setup: 
Input Directories window. After processing all marked directories, E-Capture Server returns to 
the first directory and repeats scanning until you stop the server. Only directories configured to 
leave processed files in the source directory are automatically cleared.  

The following topics are described in this section: 

• Starting the Server 

• Stopping the Server 

• Viewing an Error Log File 

• Viewing a History Log 

• Viewing Data in Temporary Storage 

Starting the Server 
In the E-Capture Server window, to start E-Capture Server, click Start Server. 

  

If directories are properly configured, the status section of the E-Capture Server window 
displays the following messages as it searches for and processes files: 

• Searching for files 
• Import in Process 

The message window also displays the source directory and the name of the file that the server 
is currently processing.  

The following status information appears in the E-Capture Server window: 

E-Capture Server window 
Status Description 

Start date  Date that E-Capture Server was opened. 

Start time Time that E-Capture Server was opened. 

Received 
documents 

Number of documents placed into Exigen Workflow. 

Received pages Total number of pages placed into Exigen Workflow documents. 
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Figure 142: Running E-Capture Server 

E-Capture Server requires at least one selected directory before it can start. If no directories are 
checked, an error message appears. 

 
Figure 143: E-Capture Server error message 

Note: You cannot configure directories for processing while the server is running. 

Note: File names in the 1000.pdf - 9999.pdf range are reserved. Files with names in this range 
cannot be used as input files for processing. 

For information on running E-Capture Server as a service, see Appendix B: Maintaining Exigen 
Workflow Servers as Services. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 18: E-Capture Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 275 of 391 

Stopping the Server 
To stop the server, click Stop Server.  

 

Viewing an Error Log File 
To review any errors E-Capture Server encountered during processing, proceed as follows: 

1. In the E-Capture Server window, click Error log file. 

 

The Error Log Files for the Input Directories window appears. 

 

Figure 144: Opening an error log file 

The window displays a list of the source directories E-Capture Server scanned. 

2. Select a directory. 

3. Click Read.  

The text log file opens in Notepad.  
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Figure 145: Reviewing an error log file 

The log file lists errors, the corresponding file name and path, and the date and time of 
processing. 

4. Close the error log file. 

5. To delete the error log, in the Error Log Files for the Input Directories window, click 
Clear.  

6. To return to the E-Capture Server window, click Close.  

Viewing a History Log 
If E-Capture Server is set up to record a history, the history can be viewed after E-Capture 
Server processes the configured directory. 

For information on recording a history, see Adding a Directory Configuration. 

To view the history log, proceed as follows: 

1. In the E-Capture Server window, click Track file. 

 

The Track Log Files for the Input Directories window appears. 
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Figure 146: Opening a history log file 

The window displays a list of the source directories E-Capture Server scanned. 

2. Select a directory. 

3. Click Read.  

The text log file opens in Notepad. 

 

Figure 147: Reviewing a history log file 

The log file lists the processing history, the corresponding file name and path, and the date 
and time of processing. 

4. To close the history log file, select File > Exit. 
5. To delete the history log, in the Track Log Files for the Input Directories window, click 

Clear.  
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6. To return to the E-Capture Server window, click Close.   

Each day, E-Capture automatically opens a new log file in the predefined directory. The 
creation date is included in the file name. 

Viewing Data in Temporary Storage 
Exigen E-Capture gives you the option to view captured information placed in temporary 
storage. You can also view tables with the following information:  

• forms 

• locations 

• insured persons 

The data in these tables can be used by applications other than Exigen Workflow. You can also 
review the contents of these tables to confirm the accuracy of captured information. 

The following topics are described in this section: 

• Viewing the Temporary Storage Table 

• Viewing the Schedule of Forms Table 

• Viewing the Schedule of Locations Table 

• Viewing the Named Insured Table 

Viewing the Temporary Storage Table 

If E-Capture Server is set up to send data to the Temporary Storage table, you can view the 
contents of this table. 

E-Capture Definition Utility is used to configure this option. For information on E-Capture 
Definition Utility, see the Exigen Workflow Administrator's Guide, Part 3: Utilities, Chapter 10: E-
Capture Definition Utility. 

To view the Temporary Storage table, proceed as follows: 

1. In the E-Capture Server window, click Temp. storage. 

 

This button is enabled if temporary storage is not empty.  

The Select Input directory window appears. 
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Figure 148: Selecting the input directory 

The Select Input directory window displays a list of the source directories that E-Capture 
Server scanned. 

In the Select Input directory window, proceed as follows: 

1. Select the input directory from the list. 
2. To delete the input directory, select a directory and click Clear.  
3. To return to the E-Capture Server window, click Close.  
4. To open the Temporary Storage table, click Read. 

The Temporary Storage table appears, displaying relevant data for the selected input 
directory. 
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Figure 149: Opening the Temporary Storage table 

The Temporary Storage table contains the file name, the extracted data, and other general 
attributes about the extracted information. The following table describes the Temporary 
Storage table attributes: 

Temporary Storage table attributes 
Attribute Description 
Source File  Processed file name. 
Identifier Output field name to which the extracted data is assigned. 
Date Processing date. 
Content  Extracted field contents. The ¶ character delimits rows extracted from a box 

with multiple lines. 
Form Name Unique form name. 
Output Name Output group associated with the extracted field. 
Company Name  Company to which the form is assigned. 

2. To delete a record, select it and click Delete.  
3. To delete the contents of the entire table, click Clear.  
4. To return to the E-Capture Server window, click Close. 
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Viewing the Schedule of Forms Table 

To view the Schedule of Forms table, proceed as follows: 

1. In the E-Capture Server window, click View > Schedule of Forms Info.  

The Select Input directory window appears. 

 
Figure 150: Selecting the input directory 

The Select Input directory window displays a list of the source directories that E-Capture 
Server scanned. 

In the Select Input directory window, proceed as follows: 

1. Select the input directory from the list. 
2. To delete the input directory, select a directory and click Clear.  
3. To return to the E-Capture Server window, click Close.  
4. To open the Schedule of Forms table, click Read. 

The Schedule of Forms table appears, displaying relevant data for the selected input 
directory. 
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Figure 151: Opening the Schedule of Forms table 

This table lists each form within a processed file that contains a Schedule of Forms. Each 
attribute recorded in the Schedule of Forms table is described in the following table: 

Schedule of Forms table 
Attribute Description 
Source File  Processed file name containing a Schedule of Forms. 
Policy # Output field that records a client policy number. 
Agent # Output field that records an underwriting agent identification number.  
Date Processing date. 
Signature  Form signature. 

Issue Date Date the form was released. This is usually part of the signature. 
Form Title Unique name assigned to the form. 

2. To delete a record, select it and click Delete.  
3. To delete the contents of the entire table, click Clear.  
4. To return to the E-Capture Server window, click Close. 

Viewing the Schedule of Locations Table  

To view the Schedule of Locations table, proceed as follows: 

1. In the E-Capture Server window, click View > Schedule of Locations Info.  
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The Select Input directory window appears. 

 
Figure 152: Selecting the input directory 

The Select Input directory window displays a list of the source directories that E-Capture 
Server scanned. 

In the Select Input directory window, proceed as follows: 

1. Select the input directory from the list. 
2. To delete the input directory, select a directory and click Clear.  
3. To return to the E-Capture Server window, click Close.  
4. To open the Schedule of Locations table, click Read. 

The Schedule of Locations table appears, displaying relevant data for the selected input 
directory. 
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Figure 153: Opening the Schedule of Locations table 

The Schedule of Locations table displays each location listed on a schedule of locations. 
The attributes are similar to those of the Schedule of Forms table. However, the Schedule of 
Locations table also includes additional mapped fields relevant to the commercial insurance 
industry, such as premium number, building number, address, and building occupancy. 

2. To delete a record, select it and click Delete.  
3. To delete the contents of the entire table, click Clear.  
4. To return to the E-Capture Server window, click Close. 

Viewing the Named Insured Table 

To view the Named Insured table, proceed as follows: 

1. In the E-Capture Server window, select View > Schedule of Named Insured Info.  

The Select Input directory window appears. 
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Figure 154: Selecting the input directory 

The Select Input directory window displays a list of the source directories that E-Capture 
Server scanned. 

In the Select Input directory window proceed as follows: 

1. Select the input directory from the list. 
2. To delete the input directory, select a directory and click Clear.  
3. To return to the E-Capture Server window, click Close.  
4. To open the Named Insured table, click Read. 

The Named Insured table appears, displaying relevant data for the selected input directory. 
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Figure 155: Opening the Named Insured table 

The Named Insured table displays the name of each insured person and includes general 
insurance industry output fields, such as policy number and agent number. 

2. To delete a record, select it and click Delete.  
3. To delete the contents of the entire table, click Clear.  
4. To return to the E-Capture Server window, click Close. 
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Chapter 19: Automatic Queue Server 
This chapter describes Automatic Queue Server and explains how to configure it to process 
automated tasks. 

The following topics are described in this section: 

• Starting the Automatic Queue Server Service 

• Changing Service Startup Options 

• Starting Automatic Queue Server in Interactive Mode 

• Automatic Queue Server Process 

• Automatic Queue Server Submitter Optimization Process 

• COM+ and Blocked Calls 

• Queue Server Console 

• Automatic Queue Server Scripts 

• Using Automatic Queue Server to Apply Security 

• Viewing the Automatic Queue Server Log 

For information on installing Automatic Queue Server, see the Exigen Workflow Installation 
Guide, Chapter 9: Installing Automatic Queue Server. 

Automatic Queue Server is an automated queue that processes work items in background 
mode without user interaction. Automatic Queue Server can be mapped to multiple custom 
scripts that implement customer-specific business logic.  

Automatic Queue Server works in tandem with Exigen Workflow Application Services. 
Application Services provides access to the workflow data store and enables tasks with work 
items to be executed. Automatic Queue Server and Application Services must be installed on 
the same computer, and Application Services must be configured before using Automatic 
Queue Server as described in the Exigen Workflow Installation Guide, Chapter 8: Installing 
Application Services. 

Automatic Queue Server replaces Advanced Event Server, which was used in earlier Exigen 
Workflow releases to process events. For information on processing events using Automatic 
Queue Server handlers, see Automatic Queue Server Handler for Exigen Workflow Events. 

Starting the Automatic Queue Server Service 
To start the Automatic Queue Server service, proceed as follows: 

1. Select Start > Settings > Control Panel. 
2. In the Control Panel window, double click Administrative Tools. 
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3. In the Administrative Tools window, double click Services. 
4. To start the Automatic Queue Server service, in the Services window, right click Exigen 

Workflow Automatic Queue Server and select Start. 

Exigen Workflow Engine Cache Supervisor must be running to use the Automatic Queue 
Server service. 

5. To start the Exigen Workflow Engine Cache Supervisor service, in the Services window, 
right click Exigen Workflow Cache Supervisor and select Start. 

Changing Service Startup Options 
The following table describes Automatic Queue Server service startup options: 

Automatic Queue Server service startup options 
Option Description 
Manual Automatic Queue Server is started manually, as described in Starting the Automatic 

Queue Server Service. 
Automatic Automatic Queue Server is started automatically when the computer is started. 
Disabled Automatic Queue Server is disabled. 

It is recommended that the manual startup option is used if Automatic Queue Server is not fully 
configured. 

The following topics are included in this section: 

• Starting Automatic Queue Server Automatically 

• Specifying Additional Service Startup Options 

Starting Automatic Queue Server Automatically 
To set Automatic Queue Server to start automatically, proceed as follows: 

1. In the Services window, right click Exigen Workflow Automatic Queue Server and select 
Properties. 

2. In the Exigen Workflow Queue Server Properties window, in the Startup type options list, 
select Automatic. 

3. Click Apply. 
4. Click OK. 

Specifying Additional Service Startup Options 
To specify additional Automatic Queue Server service startup options, proceed as follows: 

1. Select Start > Settings > Control Panel. 
2. In the Control Panel window, double click Administrative Tools. 
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3. In the Administrative Tools window, double click Services. 
4. Right click Exigen Workflow Queue Server and select Properties. 

The Exigen Workflow Queue Server Properties window appears. 

5. To temporarily set service startup options, in the Start parameters field, add the Automatic 
Queue Server command line parameter. 

For information on command line parameters, see Starting Automatic Queue Server in 
Interactive Mode. 

6. To start the service, click Start. 
7. Click OK. 
8. To permanently set additional startup options for the service, in the system registry, append 

the appropriate Automatic Queue Server command line parameters to the value of the 
ImagePath variable located in the following directory: 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vfqpsrv 

The effect of these steps is temporary and must be repeated every time the service is restarted. 

Adding the command line parameters causes the service startup options to take effect when the 
service is restarted. 

For information on command line options, see Starting Automatic Queue Server in Interactive 
Mode. 

Starting Automatic Queue Server in Interactive 
Mode 
In interactive mode, Automatic Queue Server runs in the command line window and displays its 
status messages in the window.  

1. To start Automatic Queue Server in interactive mode, start it from the command line with the 
/local switch as follows: 

start VisiFLOW.QP.Service.exe /local 

In idle mode, Automatic Queue Server suspends execution activities, but it can be 
configured using Queue Server Console. Adding the /idle switch ensures that Automatic 
Queue Server is in idle mode on startup.  

2. To start Automatic Queue Server in idle mode, start it from the command line with the 
/idle switch as follows: 

start VisiFLOW.QP.Service.exe  /idle 

By default, Automatic Queue Server uses the configuration file VisiFLOW.QP.Config.xml in 
the QueueServer directory. An alternative path to the configuration file can be specified if 
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required. This is useful if two or more Automatic Queue Servers or Queue Server services 
must use the same configuration file.  

3. To specify an alterative configuration file path, add the -cfg switch as follows: 

start VisiFLOW.QP.Service.exe  -cfg <filename> 

where <filename> is an absolute or relative location to the QueueServer directory. 

The following are command line examples: 

• -cfg \\FileServer\Shared\VisiFLOW.QP.Config.xml 

• -cfg H:\Config\VisiFLOW.QP.Config.xml 

• -cfg ..\..\Config\VisiFLOW.QP.Config.xml 

All of the preceding command line parameters can be combined and used together as in the 
following example: 

start VisiFLOW.QP.Service.exe /local /idle -cfg MyConfig.xml 

Automatic Queue Server Process 
The following information is included in this section: 

• Automatic Queue Server Job Types 

• Automatic Queue Server Process Overview 

Automatic Queue Server Job Types 
The following table describes Automatic Queue Server job types: 

Automatic Queue Server job types 
Type Description 
Parcel aware Triggered by the arrival of an Exigen Workflow parcel at a location 

specified in the Automatic Queue Server job properties. 
Parcelless Executed during each Automatic Queue Server iteration.  

Iterations take place at regular intervals. During each iteration, 
Automatic Queue Server scans the job configuration and executes 
active jobs. 

Automatic Queue Server Process Overview 
When a parcel aware job is executed, it scans a workflow location for new parcels as defined in 
the job parameters. The workflow location that is checked for new parcels is specified by the 
following job parameters: 

• workflow 
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• node 

• mailbox 

An Automatic Queue Server filter is used to add additional criteria for workflow nodes. If an 
Automatic Queue Server filter is specified in the configuration, Automatic Queue Server 
executes the filter object and retrieves the filter criteria. If an Exigen Workflow parcel arrives at a 
workflow node and meets the filter criteria, the parcel is ready for processing. 

An Automatic Queue Server object, Submitter, retrieves parcels and locks them before 
submitting the Queue Server job instance to Message Queuing (MSMQ). 

Parcel processing occurs as follows: 

1. The Submitter object submits a call via MSMQ to another object, Dispatcher. 

Submitter works in a separate transaction, which is committed as soon as the call to 
Dispatcher is successfully submitted to the MSMQ queue ewf queue server. 

2. An Automatic Queue Server MSMQ listener executes the Dispatcher object, which starts a 
new distributed transaction. While Dispatcher is running, the Automatic Queue Server 
MSMQ listener saves the call to Dispatcher in the designated temporary MSMQ queue. 

The role of Dispatcher is to call the Worker object and control the outcome.  

3. The Worker object creates a new distributed transaction and calls the Automatic Queue 
Server handler object. 

The handler object uses the transaction created by the Worker object. 

If the handler object fails, the distributed transaction is rolled back. This includes all actions 
performed by the handler object and the Worker object. 

4. If the call to the Worker object causes an error that falls within the error range registered for 
the job, the Dispatcher object calls the error handler object associated with the job. 

5. If the error handler object finishes work without exceptions, the Dispatcher object commits 
the distributed transaction. 

6. If there is no error handler associated with the job, or if the associated error handler fails, the 
Dispatcher object raises an error. 

7. If the call to the Dispatcher object fails, the distributed transaction initiated by the Dispatcher 
object is rolled back, and the Automatic Queue Server MSMQ listener places the call to the 
Dispatcher at the end of the MSMQ queue. If the job instance fails five times, the call to the 
Dispatcher object is removed from MSMQ and the locked parcel is released. 

8. If the call to Dispatcher succeeds without exceptions, the distributed transaction initiated by 
the Dispatcher object is committed and the locked parcel is released. 
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Automatic Queue Server Submitter Optimization 
Process 
During the Automatic Queue Server Submitter optimization process, the Submitter object 
retrieves parcels and locks them before submitting an Automatic Queue Server job instance to 
MSMQ. The parcel retrieval process is constantly adjusted during run-time to minimize the 
number of SQL queries sent to the database and improve the performance of the parcel 
retrieval process. 

Submitter maintains two virtual sets of Automatic Queue Server jobs: 

• a combined set that contains jobs whose parcel retrieval can be merged into one database 
query 

• an individual set that contains jobs whose database query must be executed separately for 
each job 

 
Figure 156: Automatic Queue Server process 

During the first Automatic Queue Server iteration, all jobs belong to the individual set. If parcel 
retrieval for a job does not return any parcels, the job falls into the combined set. This rule does 
not apply to jobs that must always be executed in separate queries. This is especially the case 
when a job has a custom sort order property defined or when the job's duty cycle is set to -1. 
When executed from an individual set, the job preserves its batch size configuration parameter. 

A database query for jobs that belong to the combined set is constructed using the following 
rules: 
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(job 1 query as 1) UNION 

(job 2 query as 2) UNION 

.... 

(job n query as n) 

A combined query uses the largest batch size from all jobs in the combined set. The job that 
returns the largest number of parcels in the combined query is transferred to the individual set 
and is executed in a separate database query during the next Automatic Queue Server iteration. 

COM+ and Blocked Calls 
A known limitation of COM+ is that apartment-threaded objects avoid blocked calls. When an 
apartment-threaded object encounters a blocked call, errors can result. The following are 
examples of situations in which a call is blocked: 

• A handler is sleeping. 

• A handler is waiting for a semaphore. 

• A handler is waiting for the release of a database lock. 

If a call is blocked, and COM+ assigns other objects to the same apartment from the single-
threaded apartment (STA) pool, some objects may stop responding. This occurs because all 
scripting objects are apartment-threaded, and a handler that is not responding causes other 
handlers to stop responding. 

To release a blockage, proceed as follows: 

1. In the handler trace log, locate the call that is causing the blockage. 

2. To correct the error, modify the handler. 

To avoid blocked calls, implement the following recommendations: 

• Use free-threaded objects instead of apartment-threaded objects. 

• If the use of free-threaded objects cannot be avoided, implement the following 
recommendations: 
• Ensure that jobs are short. 
• Avoid using calls that can result in blockage. 

• If the system includes database operations that can be blocked, use lock hints. 

For more information on COM+ and the STA pool, see the following: 

http://msdn.microsoft.com/library/default.asp?url=/library/en-
us/dncomser/html/PortingWinNTApps_MTStoCOM.asp 

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dncomser/html/PortingWinNTApps_MTStoCOM.asp
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dncomser/html/PortingWinNTApps_MTStoCOM.asp
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Queue Server Console 
The following topics are included in this section: 

• Overview 

• Starting Queue Server Console 

• Registering an Automatic Queue Server Component 

• Unregistering an Automatic Queue Server Component 

• Creating an Automatic Queue Server Job 

• Modifying an Automatic Queue Server Job 

• Deleting an Automatic Queue Server Job 

• Starting an Automatic Queue Server Job 

• Stopping an Automatic Queue Server Job 

• Clearing All Job Instances from MSMQ 

• Viewing Automatic Queue Server Job Statistics 

• Exporting an Automatic Queue Server Job Configuration Package 

• Importing an Automatic Queue Server Job Configuration Package 

• Configuring an Automatic Queue Server Instance 

• Importing Automatic Queue Server Jobs 

• Pausing an Automatic Queue Server Instance 

• Resuming an Automatic Queue Server Instance 

• Registering and Viewing Several Automatic Queue Servers in a Console 

• Managing a Remote Automatic Queue Server Instance 

• QSConsole Window Buttons 

Overview 
Queue Server Console is a snap-in for the Management Console (MMC) and is used to 
perform the following tasks: 

• manage Automatic Queue Server components 

• manage Automatic Queue Server jobs 

• configure Automatic Queue Server instances 

• start Automatic Queue Server jobs 

• stop Automatic Queue Server jobs 

• export or import Automatic Queue Server job configurations 
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• control Automatic Queue Server job instances submitted to MSMQ 

• manage remote Automatic Queue Server instances 

An Automatic Queue Server component is a COM component that is registered in COM+ in 
the Exigen Workflow Event Handlers COM+ library application. An Automatic Queue Server 
component is usually implemented as a Windows script component script file with the file 
extension.wsc. Sample scripts are installed with Automatic Queue Server in the Automatic 
Queue Server working directory in the Sample Scripts subfolder. 

An Automatic Queue Server job is a combination of parameters describing a subset of work 
items processed by an Automatic Queue Server component. A job describes the iteration cycle 
and priority. 

Starting Queue Server Console 
To start Queue Server Console, perform one of the following steps: 

• In the QueueServer directory, run the QSConsole.msc file. 

• Select Start > Programs > Exigen Solution > Exigen Workflow > Queue Server 
Console. 

The QSConsole window appears. 

 
Figure 157: Exigen Workflow Queue Server Console 

The left pane displays the Automatic Queue Server instances to which the console is 
connected. By default, the Automatic Queue Server instance on the local computer is displayed. 

The right pane displays the following information: 

• When the Jobs node is selected, the right pane displays a list of all registered Automatic 
Queue Server jobs. 

• When a job category is selected, the right pane displays only jobs that belong to the 
selected category. 
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• When the Components node is selected, the right pane displays a list of Automatic Queue 
Server components. 

For information on QSConsole window buttons, see QSConsole Window Buttons. 

Registering an Automatic Queue Server Component 
Before creating a job in Queue Server Console, at least one Automatic Queue Server 
component must be registered. 

One or more jobs can be associated with a single Automatic Queue Server component. 

The Automatic Queue Server component registration process includes the following steps: 

• registering the Automatic Queue Server COM component on a local computer 

• registering the Automatic Queue Server COM component as part of the Exigen Workflow 
Event Handlers COM+ library application 

To register an Automatic Queue Server component, proceed as follows: 

1. In the left pane of the QSConsole window, click Components. 
2. To initiate component registration, perform one of the following steps: 

• Select Action > New > Register Component. 
• Right click Components and select New > Register Component. 
The Open dialog appears. 

3. In the dialog, select the .dll or .wsc file of the COM component to register. 

4. Click Open. 
5. Close the Open window. 

The registered component is listed in the right pane of the QSConsole window. 

 
Figure 158: Registered Automatic Queue Server components 
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The following table describes the columns in the right pane of the QSConsole window when the 
Components node is selected: 

QSConsole window, component columns 
Column Description 
Automatic 
Queue Server 
Component 

COM component programmatic identifier (progid). 

ClassID COM component class ID (classid). 
Path Full path to the COM component .wsc or .dll file.  

Unregistering an Automatic Queue Server Component 
To unregister an Automatic Queue Server component, proceed as follows: 

3. In the right pane of the QSConsole window, select the associated component. 

4. To unregister the component, perform one of the following steps: 
• Right click the component and select Unregister. 
• Select Action > Unregister. 
The COM component is unregistered from the local computer and from the Exigen Workflow 
Event Handlers COM+ library application. 

Creating an Automatic Queue Server Job 
After a component is registered, a job associated with the component can be created in Queue 
Server Console. 

To create an Automatic Queue Server job, proceed as follows: 

1. In the left pane of the QSConsole window, select Jobs. 

The right pane displays a list of jobs associated with the current Automatic Queue Server 
instance. 

If a job category is selected, only jobs in that category are displayed in the right pane. 
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Figure 159: Viewing registered jobs 

2. To initiate job creation, perform one of the following steps: 
• Select Action > New > Job. 
• Right click Jobs and select New > Job. 
The New Queue Server Job dialog appears. 

 
Figure 160: Creating a job 

In the New Queue Server Job dialog, job properties are grouped in the following tabs: 

New Queue Server Job dialog tabs 
Tab Description 
General General job properties. 
Additional Custom job parameters. 
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New Queue Server Job dialog tabs 
Parameters 
Error Handling Job error handler properties. 
Associated Files Files associated with the job. 

3. In the General tab, enter appropriate values as described in the following table: 
New Queue Server Job window, General tab parameters 
Parameter Description 
Workflow Target workflow identifier. 

For parcelless jobs, this property is passed to the handler as part of a 
cognomen parameter. If a parcelless job does not require a workflow 
identifier, this property must be set to an arbitrary, non-zero value. 
This property is mandatory. 

Node Target workflow node identifier. 
This is a number identifying a node, such as Exigen Workflow Retrieve. 
This property is optional. If this property is omitted, Automatic Queue Server 
submits parcels for processing without considering the parcel node. 

Mailbox Exigen Workflow user ID. 
This property is optional. If omitted, Automatic Queue Server submits 
parcels for processing without considering the user ID. 

Category Job category. 
Categories are used to group jobs in Queue Server Console. Categories 
are displayed in the left pane as subitems of the Jobs node. The drop-down 
list displays categories that are registered for jobs in Automatic Queue 
Server. If a category is not available from the drop-down list, it can be 
entered manually. If the category is not specified, Queue Server Console 
automatically assigns the default category. 

Queue Limit Maximum number of job instances in MSMQ for the job. 
When the number of job instances in MSMQ reaches this limit, Automatic 
Queue Server stops submitting new job instances for the job until MSMQ 
processes a maximum of one-third of the queue limit value. 

Batch Size Number of parcels processed during a single Automatic Queue Server 
iteration. 
Setting the batch size value greater than the queue limit value is not 
recommended because Automatic Queue Server submits parcels for 
processing only until the count of job instances in MSMQ is smaller than the 
queue limit value. 
The batch size value is optional for parcelless jobs and mandatory for 
parcel aware jobs.  

Duty Cycle Frequency of job execution in Automatic Queue Server iterations. 
For example, if the duty cycle is set to 1, the job is executed once during 
each Automatic Queue Server iteration. If the duty cycle is set to 2, the job 
is executed once during every second iteration. 
If the duty cycle is set to -1, Automatic Queue Server does not use an 
optimized parcel retrieval mechanism for the job. 

Parcelless Job Identifies a job as parcelless. 
When this option is enabled, the node, mailbox, batch size, filter ID, and 
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New Queue Server Job window, General tab parameters 
sort order job properties are ignored. 

Filter ID Filter component progid. 
The filter component can implement additional criteria and reduce the 
subset of parcels returned to Automatic Queue Server for processing. The 
drop-down list displays the components that are registered on the local 
computer and available for use. When Queue Server Console is used to 
configure a remote Automatic Queue Server instance, the drop-down list is 
empty and the filter ID can be entered manually. 

Sort Order String that defines the order of retrieved work items. 
A string of work item fields delimited by commas and spaces is entered. 
Each field can be preceded by a sorting option, where + is ascending 
alphabetical order and - is descending alphabetical order. Ascending order 
is the default and can be omitted. 
The following are examples of Sort Order strings: 
• +A_MYFIELD, -A_YOURFIELD 
• A_FIELD, A_FIELD_2, A_FIELD_3 

This property is ignored for parcelless jobs. 
Component ID Automatic Queue Server component progid. 

The drop-down list displays the components that are registered on the local 
computer and available for use.  
When Queue Server Console is used to configure a remote Automatic 
Queue Server instance, the drop-down list is empty and the component ID 
must be entered manually. 

4. In the Additional Parameters tab, enter appropriate values as described in the following 
table: 
New Queue Server Job window, Additional Parameters tab parameters 
Parameter Description 
Job Description Information that describes the business context or the meaning of the job. 

Parameter Strings Set of KEY=VALUE parameters that are passed to the handler object as a 
parameter collection object. 
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Figure 161: Additional Parameters tab 

5. In the Error Handling tab, enter appropriate values as described in the following table: 
New Queue Server Job window, Error Handling tab parameters 
Parameter Description 
Error Handler ID Automatic Queue Server error handler component progid. 
Error list Error codes that are handled by the assigned error handler object. 

The list can contain single error codes or ranges of error codes separated 
by commas. A range of error codes must consist of two error numbers 
separated by two consecutive periods. 
The following is an example of an error range string:   
-1000,-900..-800,100..150,181,183 



Administrator's Guide, Part 2: Business Component Reference  Chapter 19: Automatic Queue Server 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 302 of 391 

 
Figure 162: Error Handling tab 

6. In the Associated Files tab, enter appropriate values as described in the following table: 
New Queue Server Job window, Associated Files tab parameters 
Parameter Description 
Associated Files List of files associated with the job. 

Queue Server Console calculates the checksum for these files and saves it 
in the job configuration. If an associated file is later modified or missing, 
Queue Server Console displays an Invalid status in the Associated Files 
column of the Jobs list. 

Associated files are exported with the job component file during the Export 
Configuration Package procedure. 
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Figure 163: Associated Files tab 

7. To apply the settings, click Apply. 
8. To apply the settings and close the window, click OK. 
9. To close the window without saving the settings, click Cancel. 

The job appears in the QSConsole window. 

 
Figure 164: Automatic Queue Server job list 

The following table describes the columns in the right pane of the QSConsole window when the 
Jobs node is selected: 
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QSConsole window, job columns 
Name Description 
Symbols  indicates that a job is passive. 

 indicates that a job is active. 
Category Job category name. 

 
Workflow Workflow identifier. 

 
Node Workflow node identifier. 
Mailbox Exigen Workflow user ID.  
Batch Size Number of parcels submitted for processing in a single Automatic Queue Server 

iteration. 
Queue Limit Maximum number of job instances in MSMQ for the job. 
Component ID progid of the Automatic Queue Server component. 
Filter ID progid of the Automatic Queue Server filter component. 
Associated 
Files 

Checksum status of the files associated with the job. The following values are 
available: 

Ok Checksum matches the information saved in the 
configuration file. 

Invalid Checksum does not match the information saved in the 
configuration file.  

Error ID Automatic Queue Server error handler component progid. 
Status Automatic Queue Server job status. 

The following values are available: 
• Active 
• Passive 

Message Message returned by Automatic Queue Server for a job registration error. 

Modifying an Automatic Queue Server Job 
To modify an Automatic Queue Server job, proceed as follows: 

1. To open the Properties window, perform one of the following steps: 
• Select the job in the right pane of the QSConsole window and select Action > 

Properties. 
• Right click the job and select Properties. 
• Double click the job. 

2. In the Properties window, modify the parameters. 

3. To apply the new settings, click OK. 

Deleting an Automatic Queue Server Job 
To delete an Automatic Queue Server job, perform one of the following steps: 
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• In the right pane of the QSConsole window, right click the job and select Delete. 

• In the right pane of the QSConsole window, select the job and select Action > Delete. 

• In the right pane of the QSConsole window, select the job and press Delete. 

Starting an Automatic Queue Server Job 
To start an Automatic Queue Server job, proceed as follows: 

1. In the left pane of the QSConsole window, select Jobs. 
2. In the right pane, select one or more jobs. 

3. To start the jobs, perform one of the following steps: 

• Click Start Job .  
• Right click the job and select Start Job. 
• Select Action > All Tasks > Start Job. 

Stopping an Automatic Queue Server Job 
To stop an Automatic Queue Server job, proceed as follows: 

1. In the left pane of the QSConsole window, select Jobs. 
2. In the right pane, select one or more jobs. 

3. To stop the jobs, perform one of the following steps: 

• Click Stop Job . 
• Right click the job and select Stop Job. 
• Select Action > All Tasks > Stop Job. 

Clearing All Job Instances from MSMQ 
To clear all job instances from MSMQ, proceed as follows: 

1. In the left pane of the QSConsole window, select the instance. 

2. Perform one of the following steps: 
• Select Action > Clear Queue. 
• Right click an instance and select Clear Queue. 

 
Automatic Queue Server clears instances of all jobs from MSMQ and releases parcels locked 
by these instances. 

 

Viewing Automatic Queue Server Job Statistics 
To view statistics for a selected Automatic Queue Server job, proceed as follows: 

1. In the left pane of the QSConsole window, select Jobs. 
2. In the right pane, select a job. 
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3. Perform one of the following steps: 
• Right click the job and select Job Statistics. 
• Select Action > Job Statistics. 
The Job Statistics window appears. 

 
Figure 165: Viewing job statistics 

The following table describes the information displayed in the Job Statistics window: 

Job Statistics window items 
Item Description 
Processed Since Start Number of job instances processed since the last time 

Automatic Queue Server was started. 
 

Sent To Retry Since Start Number of job instances sent back to MSMQ as a result of a 
job handler failure since the last time Automatic Queue 
Server was started. 

Currently In MSMQ Number of job instances waiting in MSMQ. 
Failed Maximum Number Of Times Number of job instances that failed the maximum number of 

times since the last time Automatic Queue Server was 
started. The maximum number of failures is currently five. 

Total Execution Time Total time in seconds spent processing job instances since 
the last time Automatic Queue Server was started. 

4. To close the Job Statistics window, click Close. 

Exporting an Automatic Queue Server Job Configuration 
Package 
To export an Automatic Queue Server job configuration package, proceed as follows: 

1. In the left pane of the QSConsole window, select Jobs. 
2. In the right pane, select one or more jobs. 

3. Perform one of the following steps: 
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• Click Export Configuration Package . 
• Right click the jobs and select Export Configuration Package. 
• Select Action > Export Configuration Package. 

4. In the Save As dialog, select the target directory. 

5. In the File name window, enter the file name for the configuration package CAB file. 

6. To complete the export, click Save. 

The configuration package is a CAB file containing the following files: 

• exported_config.xml file contains the configuration of the selected jobs. 

• Automatic Queue Server component files contains selected jobs in .dll or .wsc file 
format. 

• Files are included that are associated with the selected jobs. 

• A generated deploy.bat batch file is included that copies exported files to appropriate 
directories and registers exported Automatic Queue Server components. 

• filelist.txt file contains a list of files in the CAB package. 

• Generated VBScript files are included that are used by the deploy.bat batch file to deploy 
Automatic Queue Server components. 

Importing an Automatic Queue Server Job Configuration 
Package 
To import an Automatic Queue Server job configuration package, proceed as follows: 

1. Extract the contents of the configuration package CAB file to a temporary directory. 

2. Run the deploy.bat batch file. 

3. In Queue Server Console, import the extracted exported_config.xml file as described 
in Importing Automatic Queue Server Jobs. 

Configuring an Automatic Queue Server Instance 
To configure an Automatic Queue Server instance, proceed as follows: 

1. In the left pane of the QSConsole window, select the instance. 

2. To open the Automatic Queue Server Configuration window, perform one of the following 
steps: 
• Select Action > Configuration. 
• Right click the instance and select Configuration. 
The Automatic Queue Server Configuration window appears. 
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Figure 166: Configuring an Automatic Queue Server instance 

3. To configure the instance, enter appropriate values as described in the following table: 
Automatic Queue Server Configuration window fields 
Field Description 
Log Successful Jobs Automatic Queue Server logs successfully 

executed jobs to the Windows event log. 
Log Failed Jobs Automatic Queue Server logs failed jobs to the 

Windows event log. 
Interval (seconds) Number of seconds between Automatic Queue 

Server iterations. 
The default value is 10. If the default value is 
used, Automatic Queue Server scans the job 
configuration and executes active jobs every 10 
seconds. 

Thread Limit Maximum number of concurrent Automatic Queue 
Server worker threads. 

4. To save the settings, click OK. 

Importing Automatic Queue Server Jobs 
To import Automatic Queue Server jobs, proceed as follows: 

1. In the left pane of the QSConsole window, select an instance. 

2. To import Queue Server jobs, perform one of the following steps: 
• Select Action > Import. 
• Right click the instance and select Import. 

3. In the Open dialog, select an XML file to import. 

4. Click Open. 

The Import window appears. 
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Figure 167: Importing Automatic Queue Server jobs 

5. To overwrite the existing Automatic Queue Server configuration, select Overwrite existing 
configuration. 

6. To append the imported jobs to existing jobs, select Append Jobs. 
7. To overwrite existing jobs, select Overwrite Jobs. 
8. To save the changes and close the window, click OK. 

Pausing an Automatic Queue Server Instance 
To pause an Automatic Queue Server instance, proceed as follows: 

1. In the left pane of the QSConsole window, select the instance. 

2. To pause, perform one of the following steps: 
• Click Pause . 
• Select Action > Pause. 
• Right click the instance and select Pause. 

The Automatic Queue Server instance switches to idle mode. In idle mode, Automatic Queue 
Server suspends execution activities, but it can be configured using Queue Server Console. 
Automatic Queue Server can be paused only when it is in active mode. 

Resuming an Automatic Queue Server Instance 
To resume an Automatic Queue Server instance, proceed as follows: 

1. In the left pane of the QSConsole window, select the instance. 

2. To resume the Automatic Queue Server instance, perform one of the following steps: 

• Click Resume . 
• Select Action > Resume. 
• Right click the instance and select Resume. 

The Automatic Queue Server instance switches to active mode. In active mode, Automatic 
Queue Server continues job processing. 

An Automatic Queue Server instance can be resumed only when Automatic Queue Server is in 
idle mode. 
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Registering and Viewing Several Automatic Queue Servers in 
a Console 
This section describes how to register and view several Automatic Queue Servers in a single 
Queue Server console using the following procedures: 

• Registering Snap-Ins 

• Connecting a Snap-In to a Computer 

• Saving the Configuration 

Registering Snap-Ins 

To register snap-ins, proceed as follows: 

1. In the Windows Start menu, select Start > Run. 

2. In the Open field, enter mmc. 

3. Click OK. 

The Console window appears. 

 
Figure 168: Creating a Management Console file 

The Console window is used to create an MMC file. In the file, a snap-in must be added for 
each Automatic Queue Server to be managed. Snap-ins provide management functionality 
via the MMC interface. 
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4. To add one or more snap-ins, select Console > Add/Remove Snap-in. 

The Add/Remove Snap-in window appears. 

 
Figure 169: Adding a snap-in 

5. Click Add. 

The Add Standalone Snap-in window appears. 
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Figure 170: Selecting an Automatic Queue Server snap-in 

6. In the Available Standalone Snap-in box, use the scroll bar to view available snap-ins and 
select the Automatic Queue Server Management Console snap-in. 

7. Click Add. 
8. To register more than one Automatic Queue Server, repeat steps 6 and 7 for each 

Automatic Queue Server to be added. 

9. In the Add Standalone Snap-in window, click Close. 
10. In the Add/Remove Snap-In window, click OK. 

The registered snap-ins appear in the Console Root window.  

Connecting a Snap-In to a Computer 

To connect a snap-in to a computer, proceed as follows: 

1. Select the snap-in and right click. 

2. In the pop-up menu, select Connect to another computer. 

The Select Computer window appears. 

3. To select a computer, enter the computer name or click Browse, select the computer, and 
click OK. 

4. To close the Select Computer window, click OK. 
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By default, Queue Server Console is in Author mode, which allows adding and removing 
snap-ins. If User mode is selected, the number of snap-ins is locked and cannot be 
changed. 

Saving the Configuration 

To save the configuration, proceed as follows: 

1. To select User mode and permanently lock in the number of snap-ins, select Console > 
Options. 

2. In the Options window, in the Console mode field, select User mode - limited access, 
single window. 

3. Click OK. 
4. To save the console configuration, select Console > Save. 

The Save As window appears and displays an .msc file for saving the console 
configuration. 

5. To save the .msc file, click Save. 
6. To exit the Console window, select Console > Exit. 

The console configuration is saved. 

7. To view the configuration, in Windows Explorer, double click the saved .msc file. 

Managing a Remote Automatic Queue Server Instance 
Queue Server Console is used to manage Automatic Queue Server instances on remote 
computers. 

An Automatic Queue Server instance can be managed remotely only if the interactive user of 
the local computer has administrative access rights for the remote computer and DCOM support 
is enabled on both computers. 

To manage a remote Automatic Queue Server instance, proceed as follows: 

1. In the left pane of the QSConsole window, select the current Automatic Queue Server 
instance. 

2. Select Action > Connect. 

The Connect to Remote Computer window appears. 

3. To initiate connection to a remote computer, select Remote computer. 
4. In the Remote computer field, enter the name of the remote computer. 

5. To save changes and connect to the remote computer, click Finish. 

The remote connection appears in the left pane of the QSConsole window. 

Note: The Components node is not available for remote computers. 
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Figure 171: Connecting to a remote computer 

6. To create an Automatic Queue Server job, follow the instructions as described in Creating 
an Automatic Queue Server Job. 

7. To modify an Automatic Queue Server job, follow the instructions as described in Modifying 
an Automatic Queue Server Job. 

8. To delete an Automatic Queue Server job, follow the instructions as described in Deleting an 
Automatic Queue Server Job. 

9. To configure an Automatic Queue Server instance, follow the instructions as described in 
Configuring an Automatic Queue Server Instance. 

10. To start an Automatic Queue Server job, follow the instructions as described in Starting an 
Automatic Queue Server Job. 

11. To stop an Automatic Queue Server job, follow the instructions as described in Stopping an 
Automatic Queue Server Job. 

QSConsole Window Buttons 
The following table describes the QSConsole window buttons: 

QSConsole window buttons 
Button Name Description 

 Back Selects the previous item. 

 Forward Selects the next item. 

 Up One Level Select the next higher level in the pane. 

 Resume 
Server 

Resumes the Automatic Queue Server instance. 

 Pause Server Pauses the Automatic Queue Server instance. 

 Delete Deletes an Automatic Queue Server job. 

 Properties Displays Automatic Queue Server job properties. 
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QSConsole window buttons 

 
Refresh Updates the QSConsole window by retrieving the latest data from the 

Automatic Queue Server service. 

 Export List Exports Queue Server Console columns to a text file. 

 Help  Displays Queue Server Console online help. 

 Start Job Starts an Automatic Queue Server job. 

 
Stop Job  Stops an Automatic Queue Server job. 

 Export 
Configuration 
Package  

Exports the selected configuration package. 

Note: Depending on the action performed, some buttons may be hidden or disabled. 

Automatic Queue Server Scripts 
An Automatic Queue Server handler component is created by using VBScript to create a .wsc 
file. 

The following topics are included in this section: 

• Automatic Queue Server Script Template 

• Automatic Queue Server Error Handler Script Template 

• Automatic Queue Server Filter Script Template 

Automatic Queue Server Script Template 
The following topics are included in this section: 

• Sample Automatic Queue Server Script Template 

• Modifying the Automatic Queue Server Script Template 
 

Sample Automatic Queue Server Script Template 
The following is an Automatic Queue Server error handler script template: 

<?xml version="1.0"?> 

<component> 

<registration 

 description="replace with description of the component" 

 progid="replace with progid of the component" 
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 version="1.0" 

 classid="replace with classid of the component" 

> 

</registration> 

<public> 

        <method name="Process" dispid="1"> 

                <PARAMETER name="nameItem"/> 

                <PARAMETER name="param"/> 

        </method> 

</public> 

<script language="VBScript"> 

<![CDATA[ 

Option Explicit 

sub Process (nameItem, param) 

 add code here 

End Sub 

]]> 

</script> 

</component> 

The Automatic Queue Server handler exports a single method, Process. The following table 
describes the Process parameters:  

Process parameters 
Name Description 
nameItem Cognomen of work items that Automatic Queue Server passes to a handler 

component. The cognomen is defined by configuration information for the job with 
additional criteria set by the filter script, if present.  

param Collection of additional KEY=VALUE parameters as defined by the Automatic 
Queue Server configuration information for the appropriate job. 

Modifying the Automatic Queue Server Script Template 

To modify the Automatic Queue Server script template, proceed as follows: 

1. In the registration part of the script, replace the following properties: 
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Script properties 
Name Description 
Description Component description. 
progid Component progid, for example, “Workflow.Handler.Form”. 
classid Newly generated globally unique identifier (GUID).  

2. To generate a GUID, run the following file: 

guidgen.exe 

This utility is included in Visual Studio® Tools and is delivered with Microsoft Platform SDK. 

3. To implement the functionality, add code to the Process procedure.  

Automatic Queue Server Error Handler Script Template 
The Automatic Queue Server error handler script handles logical errors thrown by the Automatic 
Queue Server handler script. The Automatic Queue Server error handler is called only if an 
error code falls into the range of error codes registered for the job. The only difference from the 
regular handler object is that the clump parameter receives the following additional key and 
value pairs: 

Error handler clump parameter additional keys 
Key Value 
__ERROR_CODE Error number. 
__ERROR_MESSAGE Error message. 
__ERROR_SOURCE Error source. 

The following is a template of the Automatic Queue Server error handler script: 

<?xml version="1.0"?> 

<component> 

<registration 

 description="<description of the component>" 

 progid="<component progid, for example Workflow.ErrorHandler.Test>" 

 version="1.0" 

 classid="<component classid>" 

> 

</registration> 

<public> 

        <method name="Process" dispid="1"> 
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                <PARAMETER name="nameItem"/> 

                <PARAMETER name="param"/> 

        </method> 

</public> 

<script language="VBScript"> 

<![CDATA[ 

Option Explicit 

sub Process (nameItem, param) 

‘param(“__ERROR_CODE”)  - error code 

‘param(“__ERROR_MESSAGE”) – error message 

‘param(“__ERROR_SOURCE”) – error source 

‘<your code to Process procedure that implements the necessary functionality> 

End Sub 

]]> 

</script> 

</component> 

The Automatic Queue Server error handler exports one method named Process, which requires 
the following parameters:  

Process method parameters 
Parameter Description 
nameItem Cognomen of work items that Automatic Queue Server passes to the error handler 

component. 
The cognomen is defined by the configuration information for the job with 
additional criteria set by the filter script, if it exists. 

param Collection of additional KEY=VALUE parameters as defined by the Automatic 
Queue Server configuration information for the corresponding job. 

In the registration part of the script, replace the classid property with a newly generated GUID. 
You can use the guidgen.exe utility to generate a new GUID. The guidgen.exe utility is a part 
of Visual Studio Tools and is delivered together with Microsoft Platform SDK. 

Automatic Queue Server Filter Script Template 
The Automatic Queue Server filter script returns additional criteria that define the subset of work 
items passed to the handler component of the corresponding Automatic Queue Server job. 
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The following topics are included in this section: 

• Sample Automatic Queue Server Filter Script Template 

• Modifying the Automatic Queue Server Filter Script Template 
 

Sample Automatic Queue Server Filter Script Template 
The following is an Automatic Queue Server filter script template: 

<?xml version="1.0"?> 

<component> 

<registration 

        description="replace with description of the component" 

        progid="replace with progid of the component" 

        classid="replace with classid of the component" 

> 

</registration> 

<public> 

        <method name="GetFilter" dispid="1"> 

                <PARAMETER name="nameVault"/> 

                <PARAMETER name="clump"/> 

        </method> 

</public> 

<script language="VBScript"> 

<![CDATA[ 

function GetFilter (nameVault, clump) 

  Set f = CreateObject ("EWF.VO.Filter") 

  ‘ Example ‘ f.Construct 5, "BAT_PRIORITY", 0, "42" 

  Add custom criteria to the filter here 

  Set GetFilter = f 

end function 
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]]> 

</script> 

</component> 

The Automatic Queue Server filter script exports a single method, GetFilter. The following 
table describes the GetFilter parameters:  

GetFilter parameters 
Name Description 
nameVault Vault access that Automatic Queue Server passes to a filter component. 
clump Collection of additional KEY=VALUE parameters. 

Modifying the Automatic Queue Server Filter Script Template 

To modify the Automatic Queue Server filter script template, proceed as follows: 

1. In the registration part of the script, replace the filter properties described in the following 
table: 

Filter properties 
Name Description 
Description Description of the component to be created. 
progid Progid of the component, for example, “Workflow.Filter.Form”. 
classid Newly generated GUID.  

2. To set the filter criteria, add code to the GetFilter procedure. 

The code creates and returns a filter object to Automatic Queue Server. The code’s content 
is defined by business logic and individual requirements. 

Using Automatic Queue Server to Apply Security 
Automatic Queue Server can be used to automatically assign security to documents that are 
imported into Exigen Workflow or created by an Exigen Workflow process such as high volume 
scanning. 

After the documents are imported or created, they are sent to the Automatic Queue Server 
node, where Automatic Queue Server designates security. 

Automatic Queue Server obtains the security settings based on entitlements or on a legacy 
system. 

If information must be retrieved from a legacy system, the security designation process is driven 
by an Automatic Queue Server script, which may contain Exigen Integrator method invocations. 
On the basis of the information retrieved, an access control list (ACL) is generated. 

For information on entitlements, see the Exigen Workflow Administrator's Guide, Part 1: Design 
and Configuration, Chapter 4: Setting Up Exigen Workflow, Defining Entitlements. 
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For more information on Exigen Workflow security, see the Exigen Workflow Administrator's 
Guide, Part 1: Design and Configuration, Chapter 3: Creating Projects, Exigen Workflow 
Security. 

Viewing the Automatic Queue Server Log 
Automatic Queue Server automatically logs errors to the Exigen Workflow section of the 
Windows event log. 

To view the log entries in the Windows Event Viewer, proceed as follows: 

1. Select Start > Settings > Control Panel. 
2. In the Control Panel window, double click Administrative Tools. 
3. In the Administrative Tools window, double click Event Viewer. 

The Automatic Queue Server event log can contain messages from other Exigen Workflow 
components with which it interacts, such as Application Services. 

Trace information that is produced by Automatic Queue Server can be controlled by the trace 
QueueServer mask. 

For information on trace masks, see Exigen Workflow Installation Guide, Chapter 8: Installing 
Application Services, Configuring Application Services. 
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Chapter 20: E-Capture Split Server 
This section describes how to configure and use E-Capture Split Server. 

The following topics are described in this section: 

• E-Capture Split Server Overview 

• Using E-Capture Split Server 

E-Capture Split Server Overview 
E-Capture Split Server is an optional E-Capture module that extracts small portions from PCL 
files and sends them to a child directory for processing in E-Capture Server. 

For information on E-Capture Server and child directories, see Chapter 18: E-Capture Server. 

E-Capture Split Server does not require a login name, password, or registration in the 
Administrator utility and is not connected to the Exigen Workflow database. 

E-Capture Split Server must be installed and run on the computer where the original PCL files 
are located. 

E-Capture Split Server extracts a portion of a PCL file based on the following information 
provided by E-Capture Server: 

• source PCL file 

• first page in the portion 

• number of pages to be extracted 

E-Capture Split Server requires access to the Centura runtime environment and a PCLTool 
SDK environment. 

Using E-Capture Split Server 
To configure and use E-Capture Split Server, proceed as follows: 

1. To run E-Capture Split Server, in the EWF\SYSTEM directory, run the ecapsplt.exe file. 

The E-Capture Split Server window appears. 
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Figure 172: E-Capture Split Server window 

2. In the Server (This computer) field, enter the path to the parent directory for the child 
directories containing the original PCL files that require processing. 

The child directories are remote input directories for E-Capture Server. There is no limitation 
on the number of child directories. If only one input directory is used for processing large 
PCL files, it can be entered instead of the parent directory. 

3. In the Remote Client field, enter the path to the local parent directory specified for E-
Capture Server. 

4. To start E-Capture Split Server, click Start . 

During processing, the following fields in the E-Capture Split Server window are updated: 

E-Capture Split Server window fields 
Field Description 
Last processed file Source PCL file from which the last portion was extracted. 
Start page First page number in the source PCL file. 
Split range Number of pages extracted from the source PCL file starting from the start 

page. 

5. To stop E-Capture Split Server, click Stop . 
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6. To exit E-Capture Split Server, click Exit . 
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Chapter 21: Exigen Workflow Handlers 
Exigen Workflow handlers use automated Automatic Queue Server processes to perform 
workflow jobs. Exigen Workflow handlers can be used in place of Exigen Workflow servers. In 
systems with large workflows and a high processing volume, server maintenance issues can be 
avoided by using Exigen Workflow handlers instead of servers. 

After Exigen Workflow handlers are configured in Queue Server Console, they become 
Automatic Queue Server jobs. These jobs are started automatically by Automatic Queue Server, 
and can be monitored and administered remotely using Queue Server Console. 

Exigen Workflow handlers are fault tolerant and are designed to automatically retry operations 
that fail. If an error occurs, Exigen Workflow handlers send messages to the Windows event log, 
so that the administrator can investigate and correct problems. By using Exigen Workflow 
handlers, some network and database problems can be resolved automatically without 
administrator intervention. 

The Exigen Workflow installation package includes a component named Automatic Queue 
Server Handlers. These are Automatic Queue Server script templates, which are described in 
Automatic Queue Server Scripts. 

The following topics are included in this section: 

• Commit Handler 

• Task Oriented Workflow Engine 

• Automatic Queue Server Handler for Exigen Workflow Events 

Commit Handler 
Commit Handler commits documents to permanent storage using an automated Automatic 
Queue Server process. 

Commit Handler supports only the In Place option for committing files. This means that 
documents are not physically moved, but are marked in the database as committed. For more 
information on the commit process, see the Exigen Workflow User's Guide, Chapter 8: 
Committing Documents. 

To ensure that parcels are committed in the correct order, the Automatic Queue Server filter 
sorts the parcels in the queue based on the value in the PARCEL_ACT_DATE field. The oldest 
parcel is placed at the beginning of the queue. Commit Handler processes the oldest parcel first 
and marks it as processed, sending it to the end of the queue. 

The following topics are included in this section: 

• Installing Commit Handler 

• Setting up the Operating System 
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• Configuring Commit Handler 

• Viewing the Commit Handler Configuration 

• Uninstalling Commit Handler 

• Running Commit Handler 

• Using the Exigen Workflow Cache 

• Commit Handler Error Handling 

• Commit Handler Audit Event 

• Commit Algorithm 

Installing Commit Handler 
To install Commit Handler, install Exigen Workflow, ensuring that the following components are 
selected: 

• Commit Handler 

• Application Services 

• Automatic Queue Server 

• Configuration Accessor 

• DMS COM API 

• File Management COM 

For more information on installing Exigen Workflow, see the Exigen Workflow Installation Guide. 

The Commit Handler installation process performs the following tasks: 

• registers the Commit Handler assemblies in the Global Assembly Cache 

• registers the handler assembly as a COM component 

• imports the components in COM+ 

• activates the Transactions Supported mode 

The following progids are created: 

• VisiFLOW.ProcHandler.QS.Commit.Handler 

• VisiFLOW.ProcHandler.QS.Commit.FilterDelayedParcels 

Setting up the Operating System 
To ensure optimal performance, the operating system must be set up before configuring 
Commit Handler. 

To set up the operating system, proceed as follows: 
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1. To set the Distributed Transaction Coordinator (MSDTC) transaction timeout, proceed as 
follows: 
• Select Start > Settings > Control Panel. 
• Double click Administrative Tools. 
• Double click Component Services. 
• Double click Computers. 
• Right click My Computer and select Properties. 
• In the My Computer Properties window, select Options. 
• In the Transaction timeout field, enter a value equal to or exceeding 300. 
• Click OK. 
Entering a value equal to or exceeding 300 seconds ensures that documents containing 
hundreds of pages can be processed. The timeout value can be increased if required. 

2. To ensure optimal script performance, optionally set the maximum number of COM+ threads 
to 4. 

If the Exigen Workflow system is running on Windows XP, there is no need to change the 
COM+ thread settings. 

3. If the Exigen Workflow system is running on Windows 2000, to set the maximum number of 
COM+ threads, proceed as follows: 
• In the Windows Start menu, select Start > Run. 
• In the Open field, enter regedit. 
• Click OK. 
• In the Registry Editor window, in the left pane, locate the following directory: 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\COM3\Debug 

• If the Debug key does not exist, to create it, right click COM3 and select New > Key. 
• In the key name, enter Debug. 
• Right click Debug and select New > DWORD Value. 
• Rename the newly created value to QCListenerMaxThreads. 
• Double click the value and, in the Value data field, enter 4. 
• Click OK. 
• Close the Registry Editor window. 

Configuring Commit Handler 
Commit Handler reads the configuration in the following order: 

1. VISICLT.INI file parameters 

2. Exigen Workflow database parameters 

3. Queue Server Console parameters 

This means that the Commit Handler parameters set in Queue Server Console override the 
Exigen Workflow database parameters, and the Exigen Workflow database parameters override 
the VISICLT.INI file parameters. 
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If Commit Server is installed and configured, Commit Handler uses the existing Commit Server 
configuration. This configuration can be retained or modified as described in the following 
section. 

To configure Commit Handler, proceed as follows: 

1. In the Windows system directory, locate the VISICLT.INI file. 

2. In the VISICLT.INI file, in the [setup_commit] section, set appropriate configuration 
options as described in the following table: 
VISICLT.INI file configuration options 

Keyword Description 
OriginalDocuments Specifies whether the original document is 

committed. 

The following values are available: 

Commit Original document and the 
DMS file created from it are 
committed. 
This is the default. 

Delete Original document is 
deleted.  

CommitVersions Specifies whether revision information is retained in 
the DMS file. 

The following values are available: 

All All revision information is 
retained in the DMS file. 
This is the default. 

Current Only the current revision 
information is retained in the 
DMS file.  

UseAuditFilters Specifies whether audit event filters are used when 
DMS audit information is saved to the database. 

The following values are available: 

YES Filters are used. 

NO Filters are not used, and all 
audit information is saved to 
the database. 

This is the default.  
3. To specify settings for deleting parcels and audit information, in the Exigen Workflow 

Explorer window, double click Project Builder. 
4. In the Project Builder window, select the project. 

5. Select Project > Project Configuration. 
6. Select the Optical tab. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 21: Exigen Workflow Handlers 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 329 of 391 

7. To ensure that a parcel is deleted when its document is committed, select the Delete Parcel 
after Commit option. 

8. To ensure that a parcel is not deleted when its document is committed, clear the Delete 
Parcel after Commit option. 

9. To ensure that all audit event information is removed from the DMS file after the document is 
committed, select the Delete DMS audit information after Commit option. 

10. To ensure that audit event information is not removed from the DMS file after the document 
is committed, clear the Delete DMS audit information after Commit option. 

Options for committing DMS files are specified when creating or modifying an Automatic 
Queue Server job. Parameters and values are entered in the Parameter strings field. For 
more information on creating an Automatic Queue Server job, see Creating an Automatic 
Queue Server Job. 

11. To specify options for committing DMS files, in the Parameter strings field, enter 
appropriate values as described in the following table: 
DMS file commitment options 
Keyword Description 
COMMIT_ACTION Specifies whether committed files are physically 

moved. 

The following values are available: 

INPLACE Files are marked as 
committed, but are not 
moved. 
This option is supported. 

OPTICAL Files are moved. 

This option is not supported.  
CREATE_QUICK_TILES Specifies whether thumbnails are generated in the 

DMS file. 

The following values are available: 

TRUE Thumbnails are generated. 

FALSE Thumbnails are not 
generated. 

This is the default.  
AUTO_RECOVER_LOCKS Specifies system behavior if a DMS file is locked. 

The following values are available: 

TRUE If a DMS file is locked, the 
system tries to unlock the 
file and commit it. 
This is the default. 

FALSE If a DMS file is locked, it is 
not committed.  
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DMS file commitment options 
Keyword Description 
REDUCE_RESOLUTION Specifies whether the resolution of DMS files is 

reduced before commitment. 

The following values are available: 

0 DMS file resolution is not 
reduced. 

100 DMS file resolution is reduced to 
100 dpi. 

150 DMS file resolution is reduced to 
150 dpi. 

200 DMS file resolution is reduced to 
200 dpi.  

FILE_PROCESSING_TIMEOUT Specifies the interval in seconds after which file 
processing is interrupted and Commit Handler is 
restarted. 

Any value equal to or exceeding 20 can be entered. 
The default is 50. 

It is recommended that you specify a value that is 5 
to 10 seconds less than the MSDTC transaction 
timeout value. This allows time for Commit Handler 
cleanup. 

12. To specify options for testing or debugging Commit Handler, in the Parameter strings field, 
set appropriate options as described in the following table: 
Testing and debugging options 
Keyword Description 
DISABLE_DMS_PROCESSING Specifies whether DMS files are processed before 

being committed. 

The following values are available: 

TRUE DMS files are not processed 
before being committed. 

FALSE DMS files are processed 
before being committed. 

This is the default.  
OVERRIDE_AUDIT_PROJECT Overrides the project ID of DMS audit events. 

To override an existing project ID, a new one is 
entered. 

Overriding the project ID is useful if the DMS file 
contains audit events from different projects. 
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Testing and debugging options 
Keyword Description 
SKIP_AUDIT_SYNC Specifies whether audit event information is 

synchronized in the DMS file and the database. 

The following values are available: 

TRUE Audit events are not 
synchronized in the DMS file 
and the database. 

FALSE Audit events are 
synchronized in the DMS file 
and the database. 

This is the default.  
SKIP_INDEXING_SYNC Specifies whether indexing information for the 

current folder, subfolder, and document fields is 
synchronized in the DMS file. 

The following values are available: 

TRUE Indexing information is not 
synchronized. 

FALSE Indexing information is 
synchronized. 

This is the default.  
TRACE_LEVEL Specifies the trace level. 

The following values are available: 

1 Only critical information is 
logged. 

2 Only critical and important 
information is logged. 

This is the default. 

3-5 Detailed trace is generated. 
Levels 3 through 5 are 
recommended for 
troubleshooting only. 

The maximum trace level is 
5, which generates a highly 
detailed trace, including 
information on function calls.  
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Testing and debugging options 
Keyword Description 
DISABLE_CACHE Specifies whether data is read from the Exigen 

Workflow cache. 

The following values are available: 

TRUE Data is not read from the 
cache. 
Setting this value impairs 
system performance. This 
value is set for testing 
purposes only. 

FALSE Data is read from the cache. 

This is the default.  
IGNORE_CONCURRENT_LOCKS Specifies whether locks on concurrent DMS files 

are ignored. 

The following values are available: 

TRUE Locks on concurrent DMS 
files are ignored. If two 
threads access the same 
DMS file concurrently, DMS 
operations may fail. 
This is used for testing 
purposes only. 

FALSE Locks on concurrent DMS 
files are not ignored. When 
DMS files are processed 
concurrently, files must be 
locked and unlocked to 
ensure that operations are 
completed correctly. 

This is the default.  
SINGLE_STAGE Specifies whether parcels are processed in a single 

operation. 

The following values are available: 

TRUE Parcels are processed in a 
single operation. 

FALSE Parcels are processed in 
multiple stages to avoid 
extended transactions. 

This is the default.  

To improve database performance, it may be useful to create a database index for the 
PARCEL_ACT_DATE column in the project’s xxx_BATCHPARCEL table. This can facilitate 
the Automatic Queue Server parcel sorting process. 

13. Optionally, create a database index for the PARCEL_ACT_DATE column. 



Administrator's Guide, Part 2: Business Component Reference  Chapter 21: Exigen Workflow Handlers 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 333 of 391 

For information on creating a database index, see the administration documentation for the 
given database. 

14. To test Commit Handler without running Automatic Queue Server, run the 
CommitTest.exe file. 

For more information on running the CommitTest.exe file, contact Exigen Support 
Services. 

Viewing the Commit Handler Configuration 
To view the Commit Handler configuration, proceed as follows: 

1. Set the trace level to 5 as described in Configuring Commit Handler, step 12. 

2. Start the Commit Handler job using Queue Server Console. 

For information on starting an Automatic Queue Server job, see Starting an Automatic 
Queue Server Job. 

After Commit Handler reads and parses the configuration and receives documents and 
starts processing them, it prints a report to the log file. The report contains configuration 
data and information about actions to be performed. 

The DbgView utility is used to view configuration information in the log file. To download the 
DbgView utility, see the following website: 
http://www.sysinternals.com/ntw2k/freeware/debugview.shtml 

3. Run the dbgview.exe file. 

Commit Handler log messages appear in the Debug View window. 

Uninstalling Commit Handler 
To uninstall Commit Handler using the Commit Handler installer file, proceed as follows: 

1. In the \EWF\Windows\CommitHandler directory, run the CommitHandler.msi file. 

2. Follow the uninstall instructions in the windows. 

To uninstall Commit Handler using the Add/Remove Programs window, proceed as follows: 

1. In the Windows Start menu, select Start > Settings > Control Panel. 
2. Double click Add/Remove Programs. 
3. Select Exigen Commit Handler. 
4. Click Remove and follow the uninstall instructions in the windows. 

The Commit Handler components are removed from COM+, unregistered from COM, and 
removed from the Global Assembly Cache. 

http://www.sysinternals.com/ntw2k/freeware/debugview.shtml
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Running Commit Handler 
Before running Commit Handler, Commit Handler jobs must be created for all commit nodes in 
the workflow, and the jobs must be started. 

To create and start a job, proceed as follows: 

1. Create a job as described in Creating an Automatic Queue Server Job. 

The following table describes the mandatory fields for a Commit Handler job: 

Commit Handler job mandatory fields 
Field Description 
Workflow Target workflow identifier. 

Node Target workflow node identifier. 

Component ID Automatic Queue Server component progid. 

For Commit Handler, this must be the following: 

VisiFLOW.ProcHandler.QS.Commit.Handler 

Filter ID Filter component progid, usually a script. 

For Commit Handler, this must be the following: 

VisiFLOW.ProcHandler.QS.Commit.FilterDelayedParcels 

 
Figure 173: Creating a Commit Handler job 

2. To specify a configuration other than the default, in the Additional Parameters tab, enter 
KEY=VALUE parameters. 

The following is an example of KEY=VALUE parameters: 
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COMMIT_ACTION=INPLACE 
CREATE_QUICK_TILES=TRUE 
REDUCE_RESOLUTION=100 
FILE_PROCESSING_TIMEOUT=50 
SKIP_AUDIT_SYNC=TRUE 
TRACE_LEVEL=5 

For more information on parameters, see Configuring Commit Handler. 

For more information on the Additional Parameters, Error Handling, and Associated 
Files tabs, see Creating an Automatic Queue Server Job. 

3. To start the job, proceed as described in Starting an Automatic Queue Server Job. 

Using the Exigen Workflow Cache 
When Commit Handler retrieves configuration information from the database, the information is 
stored in the Exigen Workflow cache. When modifying a workflow, it is recommended that 
Automatic Queue Server be stopped to ensure that Commit Handler is also stopped. Otherwise, 
Commit Handler continues to use previous configuration values until the values expire in the 
cache. 

Before restarting Automatic Queue Server, restart the Exigen Workflow Engine Cache 
Supervisor service. 

If the Exigen Workflow database workflow schema or configuration is modified, the Exigen 
Workflow Engine Cache Supervisor service must be stopped and restarted. 

To start and stop the Exigen Workflow Engine Cache Supervisor service, proceed as follows: 

1. In the Windows Start menu, select Start > Settings > Control Panel. 
2. Double click Administrative Tools. 
3. Double click Services. 
4. To start the service, right click Exigen Workflow Engine Cache Supervisor and select 

Start. 
5. To stop the service, right click Exigen Workflow Engine Cache Supervisor and select 

Stop. 

Commit Handler Error Handling 
The error handling process is as follows: 

1. If an error is detected in a parcel, the parcel is pushed automatically from the Commit node 
to the error queue, which is the next node in the workflow. 

2. Commit Handler writes a message to the Windows Event Log. 

3. A system administrator inspects the error message and the parcel in the error queue. 

4. The system administrator corrects the error. 
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To ensure that error handling functions correctly, a link must be created from the Commit node 
to the error queue. The link must be assigned an automatic routing rule to ensure that parcels 
are pushed to the error queue automatically. A simple Else routing rule is used. 

For information on setting up workflow nodes, links, and routing rules, see the Exigen Workflow 
Administrator's Guide, Part 1: Design and Configuration, Chapter 5: Designing a Workflow. 

Commit Handler Audit Event 
Commit Handler writes one custom audit event, 76901: 

DMS file committed 

For information on audit events, see the Exigen Workflow Administrator's Guide, Part 1: Design 
and Configuration, Appendix D: Audit Data in Exigen Workflow. 

Commit Algorithm 
The following algorithm is applied when committing documents using Commit Handler:  

1. Commit Handler checks the document's assigned commit date and time. 

2. If the commit date and time are later than the current time and time, the document is 
skipped because it is scheduled for future commitment. 

3. Commit Server checks the IMAGE_LOCATION parameter to determine the file's current 
location: 
• If the IMAGE_LOCATION value is O for optical or H for image server, an error is 

generated because only magnetic storage is supported. 
• If the IMAGE_LOCATION value is L, it means the document is committed. No action is 

taken. 
• If the IMAGE_LOCATION value is M for magnetic, the document is processed. 

4. If the document is a reference document, the following options are available: 
• If the First reference option is specified in the Optical tab during project configuration, 

the original document is committed, and document and parcel records of the reference 
document are updated. 

• If the Last reference option is specified in the Optical tab during project configuration, 
Commit Server checks whether all related reference documents are collected in the 
Commit node. If so, the original document is committed and the document and parcel 
records of the reference document are updated. If not, the current reference document is 
skipped. It is marked as waiting for other documents to arrive. 

5. Commit Server processes the DMS document as follows: 
• If this option is configured, Commit Server changes the document image resolution. 
• If this option is configured, Commit Server creates thumbnails. 
• If this option is configured, Commit Server retrieves indexing information on folder, 

subfolder, and document additional fields, and writes the information to the DMS file in 
XML format. 

• Commit Server saves audit events in the DMS file to the database. 

For information on configurable options, see Configuring Commit Handler. 
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6. Commit Server updates the document record as follows: 
• NODE_ID=0 
• USER_ID=NULL 
• IMAGE_LOCATION=L 
• COMMIT_DATE=<current date/time> 

7. Commit Server updates the document parcel as follows: 
• NODE_ID=0 
• NODE_ID_FROM=<current node>  
• USER_ID_FROM=<current user> 

8. If the Delete Parcel after Commit option is selected during project configuration, the parcel 
is deleted. 

9. If an error occurs while processing a document in a parcel, the parcel is pushed to the error 
queue for inspection, and Commit Handler writes an error message to the Windows Event 
Log, in the Exigen Workflow section. 

Task Oriented Workflow Engine 
In Exigen Workflow systems, Task Oriented Workflow is implemented to automate business 
processes by means of electronic tasks lists, interactive scripts, and automatic task processing 
using Automatic Queue Server. 

Task Oriented Workflow Engine performs automatic operations on parcels in queues and marks 
the parcel as processed. Task Oriented Workflow Engine contains a script that allows replacing 
Taskflow Server with an Automatic Queue Server job. 

To ensure that parcels are processed in the correct order, Automatic Queue Server sorts the 
parcels in the queue according to the value in the PARCEL_ACT_DATE field. The oldest parcel 
is placed at the beginning of the queue. TaskList Handler processes the oldest parcel first and 
marks it as processed, sending it to the end of the queue. 

Note: For more information on Task Oriented Workflow, see the Task Oriented Workflow User's Guide 
and Task Oriented Workflow Administrator's Guide. 

The following topics are included in this section: 

• System Requirements 

• Installing Task Oriented Workflow Engine 

• Configuring Task Oriented Workflow Engine 

• Uninstalling Task Oriented Workflow Engine 

• Running Task Oriented Workflow Engine 

System Requirements 
Before installing Task Oriented Workflow Engine, Exigen Workflow must be installed. The 
Exigen Workflow installation must include the following components: 
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• Application Services 

• Automatic Queue Server 

• Configuration Accessor 

Installing Task Oriented Workflow Engine 
To install Task Oriented Workflow Engine, perform one of the following steps: 

• Run the TOWHandler.msi file. 

• At the command prompt, run the TOWInstall.bat batch file. 

The installation process registers the Task Oriented Workflow assemblies in the Global 
Assembly Cache as COM components, sets the Transactions Supported mode, and imports the 
following progids: 

• VisiFLOW.ProcHandler.QS.TOWEngine.TaskFlow.API 

• VisiFLOW.ProcHandler.QS.TOWEngine.TaskFlow.Handler 

• VisiFLOW.ProcHandler.QS.TOWEngine.TaskFlow.FilterDelayedParcels 

• VisiFLOW.ProcHandler.QS.TOWEngine.TaskList.API 

• VisiFLOW.ProcHandler.QS.TOWEngine.TaskList.Handler 

To access Task Oriented Workflow Engine functionality from a custom Automatic Queue Server 
script, the Taskflow API is used. For more information on custom Automatic Queue Server 
scripts, contact Exigen Support Services. 

Configuring Task Oriented Workflow Engine 
The following topics are described in this section: 

• Configuring Task Oriented Workflow Engine TaskList Handler 

• Configuring Task Oriented Workflow Engine TaskFlow Handler 

Configuring Task Oriented Workflow Engine TaskList Handler 

To configure Task Oriented Workflow Engine TaskList Handler, proceed as follows: 

1. For each taskflow node in the workflow, create an appropriate Automatic Queue Server job. 

For information on creating an Automatic Queue Server job, see Creating an Automatic 
Queue Server Job. 

The following table describes the mandatory fields when creating a Task Oriented Workflow 
Engine TaskList Handler job: 
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Task Oriented Workflow Engine TaskList Handler job mandatory fields 
Field Description 
Workflow Target workflow identifier. 

Node Target workflow node identifier. 

Component ID Automatic Queue Server component progid. 

For Task Oriented Workflow Engine TaskList Handler, this must be the 
following: 

VisiFLOW.ProcHandler.QS.TOWEngine.TaskList.Handler 

Sort Order String that defines the order of retrieved work items. 

For Task Oriented Workflow Engine TaskList Handler, this must be the 
following: 

PARCEL_ACT_DATE 

 
Figure 174: Creating a Task Oriented Workflow Engine TaskList Handler job 

2. To specify a configuration other than the default, in the Additional Parameters tab, enter 
KEY=VALUE parameters. 

The following is an example of a KEY=VALUE parameter: 
TRACE_LEVEL=3 

For more information on parameters, see Configuring Commit Handler. 

For more information on the Additional Parameters, Error Handling, and Associated 
Files tabs, see Creating an Automatic Queue Server Job. 

3. If a trace is required for troubleshooting, in the New Queue Server Job dialog, set the trace 
level as described in Configuring Commit Handler, step 12. 
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4. Optionally, to improve database performance, in the project’s xxx_BATCHPARCEL table, 
create a database index for the PARCEL_ACT_DATE column. 

This can facilitate the Automatic Queue Server parcel sorting process. 

5. To create a database index for the PARCEL_ACT_DATE column, follow the instructions in 
the administration documentation for the database. 

6. To test Task Oriented Workflow Engine TaskList Handler without running Automatic Queue 
Server, run the TaskListTest.exe file. 

For more information on running the TaskListTest.exe file, contact Exigen Support 
Services. 

Configuring Task Oriented Workflow Engine TaskFlow Handler 

To configure Task Oriented Workflow Engine TaskFlow Handler, proceed as follows: 

1. For all nodes in the taskflow, create an appropriate Automatic Queue Server job. 

For information on creating an Automatic Queue Server job, see Creating an Automatic 
Queue Server Job. 

The following table describes the mandatory fields when creating a Task Oriented Workflow 
Engine TaskFlow Handler job: 

Task Oriented Workflow Engine TaskFlow Handler job mandatory fields 
Field Description 
Workflow Target workflow identifier. 

Node Target workflow node identifier. This field must be left empty. The handler 
monitors all nodes. 

Mailbox Exigen Workflow user ID.  

For Task Oriented Workflow Engine TaskFlow Handler, this must be QS. 

Component ID Automatic Queue Server component progid. 

For Task Oriented Workflow Engine TaskFlow Handler, this must be the 
following: 

VisiFLOW.ProcHandler.QS.TOWEngine.TaskFlow.Handler 
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Figure 175: Creating a Task Oriented Workflow Engine TaskFlow Handler job 

2. To specify options for configuring Task Oriented Workflow Engine TaskFlow Handler, in the 
Parameter strings field, set appropriate parameters as described in the following table: 

Task Oriented Workflow Engine TaskFlow Handler optional configuration parameters 
Parameter  Description Example 
TRACE_LEVEL Specifies the trace level. 

The following values are available: 

1 Only critical information is 
logged. 

2 Only critical and important 
information is logged. 

This is the default. 

3-5 Detailed trace is generated. 
Levels 3 through 5 are 
recommended for 
troubleshooting only. 

The maximum trace level is 5, 
which generates a highly 
detailed trace, including 
information on function calls.  

TRACE_LEVEL=4 
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Task Oriented Workflow Engine TaskFlow Handler optional configuration parameters 
Parameter  Description Example 
DISABLE_CACHE Specifies whether data is read from the Exigen 

Workflow cache. 

The following values are available: 

TRUE Data is not read from the 
cache. 
Setting this value impairs 
system performance. This 
value is set for testing 
purposes only. 

FALSE Data is read from the cache. 

This is the default.  

DISABLE_CACHE=TRU
E 

PCS_DS_URL Location URL of server where PCSDS Web Services 
runs. 
If it is empty, DS calls fail.  
This parameter is required if Exigen Workflow contains 
conditions that depend on the PCS_DS service. 

PCS_DS_URL=http://ap
pvno01.exigengroup.co
m:18080/PCSDSWS/ser
vices/PCSDecisionServi
ce 

WS_RETRY_TIME
OUT 

Timeout period in seconds. This specifies how long to 
keep trying if the Web Service call fails.  
If the value is set to 0, if there is a Web Service call, the 
parcel is sent to the ERR queue for later inspection by 
an administrator. 
In a production environment, it is recommended to set 
the timeout to a few hours, that is, 3600 or more. 
The maximum value, 432000 seconds, is approximately 
5 days. 
The errors are logged to the Windows Event Log, and 
the WS call is retried again until the timeout expires. If 
unsuccessful, the parcel is sent to the ERR queue and 
the message is logged to the Event Log. 

WS_RETRY_TIMEOUT
=7200 

CUSTOMIZATION_
PLUGIN 
 

Name of the TaskFlow customization plugin assembly 
to load. This assembly provides customer specific 
functionality. 
The assembly implements the CTaskFlowPlugin class 
that provides the 
VisiFLOW.ProcHandler.QS.TOWEngine.TaskFlow.Plug
in.ITaskFlowPlugin interface.  
The assembly must be signed with a special strong 
name key and installed in the Global Assembly Cache. 

CUSTOMIZATION_PLU
GIN=VisiFLOW.ProcHa
ndler.QS.TOWEngine.T
askFlow.Plugin.HelloWo
rld 
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Task Oriented Workflow Engine TaskFlow Handler optional configuration parameters 
Parameter  Description Example 
FOLDER_HIERAR
CHY_PLUGIN 
 

Name of the TaskFlow plugin assembly to load. This 
assembly provides FolderHierarchy functionality. 
The assembly implements the CFolderHierarchyPlugin 
class that provides the 
VisiFLOW.ProcHandler.QS.TOWEngine.TaskFlow.Plug
in.IFolderHierarchyPlugin interface. 
The assembly must be signed with a special strong 
name key and installed in the Global Assembly Cache. 

FOLDER_HIERARCHY
_PLUGIN=VisiFLOW.Pr
ocHandler.QS.TOWEngi
ne.TaskFlow.Plugin.Fol
derHierarchy 
 

All of the parameters in the preceding table are optional. 

For more information on Additional Parameters, Error Handling, and Associated Files 
tabs, see Creating an Automatic Queue Server Job. 

3. To test Task Oriented Workflow Engine TaskFlow Handler without running Automatic Queue 
Server, run the TaskFlowTest.exe file. 

For more information on running the TaskFlowTest.exe file, contact Exigen Support 
Services. 

Uninstalling Task Oriented Workflow Engine 
To uninstall Task Oriented Workflow Engine, proceed as follows: 

1. In the \EWF\Windows\TOWHandler directory, run the TOWHandler.msi file. 

2. Follow the uninstall instructions in the windows. 

The Task Oriented Workflow Engine components are removed from COM+, unregistered from 
COM, and removed from the Global Assembly Cache. 

Running Task Oriented Workflow Engine 
To run Task Oriented Workflow Engine, start the appropriate Task Oriented Workflow Engine 
job as described in Starting an Automatic Queue Server Job. 

When Task Oriented Workflow Engine retrieves configuration information from the database, 
the information is stored in the Exigen Workflow cache. Cache operations are similar for Task 
Oriented Workflow Engine and Commit Handler. For information on using the Exigen Workflow 
cache, see Using the Exigen Workflow Cache. 

Automatic Queue Server Handler for Exigen 
Workflow Events 
In earlier Exigen Workflow releases, Advanced Event Server processed Exigen Workflow 
events. 
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Advanced Event Server is replaced by Automatic Queue Server. For compatibility reasons, the 
Exigen Workflow installation package contains an Automatic Queue Server handler that 
simulates Advanced Event Server. 

Automatic Queue Server Handler for Exigen Workflow Events uses the 
VisiFLOW.ProcHandler.EventServer component to process Exigen Workflow events as 
Advanced Event Server did. 

To set up Automatic Queue Server Handler for Exigen Workflow Events, proceed as follows: 

1. Create an Automatic Queue Server job as described in Creating an Automatic Queue 
Server Job. 

2. In the General tab, in the Component ID field, enter the 
VisiFLOW.ProcHandler.EventServer component ID. 

3. To ensure that jobs are created without parcels, in the General tab, select the Parcelless 
Job option. 

4. In the Additional Parameters tab, in the Parameter Strings field, specify the project whose 
events are processed in the following format: 

PROJECT_ID=<project id> 

5. In the Parameter Strings field, specify the number of events to process in a single iteration 
in the following format: 

BATCH_SIZE=<number> 

The default and recommended value is 25. 

6. In the Parameter Strings field, specify the honor event date in the following format: 

HONOR_EVENT_DATE=<True|False> 

If False, all pending events are processed. This is the default. If True, only events whose 
time is equal to or earlier than the current database time are processed. This setting 
ensures that events can be assigned a future date and time, and Automatic Queue Server 
waits until the specified date and time to process the event. 

7. In Queue Server Console, register all Advanced Event Server scripts to be used in the 
workflow as components as described in Registering an Automatic Queue Server 
Component. 

For information on Advanced Event Server scripts, see the Advanced Event Server 
Administrator's Guide. 
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Appendix A: Exigen Workflow Object Menus 
and Button Bars   
The following topics are described in this section: 

• Barcode Server 

• Form OCR Server 

• Form OCR QA and Form Index Server 

• FTS Preprocessor 

• FTS Server 

• Image Enhancement Server 

• Import Server 

• Distribution Server 

• Escalation Server 

• Push Server 

• ERM Indexer 

• Report Definition Wizard 

• E-Capture Server 

Barcode Server 
The button and menu bars of the Barcode Server window contain the following utilities:  

Button Menu option Shortcut key Description 

 

File > Refresh List F5 Refresh List 

Refreshes the job list in Barcode Server. 

 

File > Send Batch CTRL+D Send Batch 

Opens a dialog to manually send the 
selected document or parcel to another 
queue. 

 

File > Exit F12 Exit 

Closes the Barcode Server window. 

 Edit > Clear All Flags CTRL+C Clear All Flags 

Clears flags for all documents in the list. 

 Edit > Apply Status 
Changes 

F9 Apply Status Changes 

Updates the database with any status 
changes made. 
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Button Menu option Shortcut key Description 

 

Edit > Delete 
Document 

CTRL+DEL 

 

Delete Document 

Deletes the selected document. 

 Edit > Recovery  

 

Recovery 

Recovers the Barcode Server status if the 
process is interrupted for some reason. 

 

Run > Process Setup CTRL+S Process Setup 

Opens the Barcode Setup window to 
specify the barcode configurations. 

 
 

Run > Start Server CTRL+E Start Server 

Starts Barcode Server. 

 
Run > Stop Server CTRL+Z Stop Server 

Stops Barcode Server. 

 Run > Auto Send CTRL+A Auto Send 

When selected, processed jobs are 
automatically sent to the next queue in the 
workflow. 

 Run > Server Mode CTRL+L Server Mode 

When selected, the application runs 
continuously. 

 Run > Start Test  Start Test 

Used to begin running Barcode Server to 
test the configurations. 

 Run > Release Test  Release Test 

Stops the testing of the barcode 
configurations. 

 Run > Get from 
Common Queue 

 Get from Common Queue 

Retrieves a document from the common 
queue. 

 

View > Right Image 
Display 

CTRL+R Right Image Display 

Displays the selected document in Image 
Viewer on the right side of the window. 

 

View > Modify Image CTRL+M Modify Image 

Opens the Image Viewer on the right side of 
the window for document editing. 

 View > Advanced 
Display Settings 

 Advanced Display Settings 

Opens the Advanced display settings 
dialog to specify document display settings. 
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Button Menu option Shortcut key Description 
 View > Show Original CTRL+O Show Original 

Displays the original version of the selected 
document. 

 View > Show 
Versions 

CTRL+V Show Versions 

Displays a list of all versions of the selected 
document. The current version is displayed 
at the bottom of the list. 

 

File > Save 
Configuration 

 Save Configuration 

Saves the configuration of the current 
Barcode Server window that appears in the 
window. 

 

Help > Context Help F1 Context Help 

Opens the Help section for this application. 

 Help > Help Topics CTRL+F1 Help Topics 

Displays a list of available help topics. 

 Help > About Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

Form OCR Server 
The button and menu bars of the Form OCR Server window contain the following utilities:  

Button Menu option Shortcut key Description 

 

File > Refresh List F5 Refresh List 

Refreshes the job list in Form OCR Server.  

 

File > Send Batch CTRL+D Send Batch 

Opens a dialog to manually send the 
selected document or parcel to another 
queue. 

 

File > Exit F12 Exit 

Closes the Form OCR Server window. 

 Edit > Clear All Flags CTRL+C Clear All Flags 

Clears flags for all documents in the list. 

 Edit > Apply Status 
Changes 

F9 

 

Apply Status Changes 

Updates the database with any status 
changes made. 

 

Edit > Delete 
Document 

CTRL+DEL 

 

Delete Document 

Deletes the selected document. 
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Button Menu option Shortcut key Description 
 Edit > Recovery  

 

 

Recovery 

Recovers the Form OCR Server status if the 
process is interrupted for some reason. 

 

Run > Process Setup CTRL+S Process Setup 

Opens the Process Setup window to set up 
the Form OCR configurations. 

 
Run > Start Server CTRL+E Start Server 

Starts Form OCR Server. 

 
Run > Stop Server CTRL+Z Stop Server 

Stops Form OCR Server. 

 Run > Auto Send CTRL+A Auto Send 

When selected, processed jobs are 
automatically sent to the next queue in the 
workflow. 

 Run > Server Mode CTRL+L Server Mode 

When selected, the application runs 
continuously. 

 Run > Start Test  Start Test 

Starts testing the configurations in Form 
OCR Server. 

 Run > Release Test  Release Test 

Stops testing the configurations in Form 
OCR Server. 

 Run > Get from 
Common Queue 

 Get from Common Queue 

Loads the next parcel from the common 
queue. 

 

View > Right Image 
Display 

CTRL+R Right Image Display 

Displays the selected document in the 
Image Viewer on the right side of the 
window. 

 

View > Modify Image CTRL+M Modify Image 

Opens the Image Viewer on the right side of 
the window for document editing. 

 View > Advanced 
Display Settings 

 Advanced Display Settings 

Opens the Advanced display settings 
dialog to specify document display settings. 

 View > Show Original CTRL+O Show Original 

Displays the original version of the selected 
document. 
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Button Menu option Shortcut key Description 
 View > Show Versions CTRL+V Show Versions 

Displays a list of all versions of the selected 
document. The current version is displayed 
at the bottom of the list. 

 

File > Save 
Configuration 

 Save Configuration 

Saves the configuration of the current Form 
OCR Server window in the window. 

 

Help > Context Help F1 Context Help 

Opens the Help section for this application. 

 Help > Help Topics CTRL+F1 Help Topics 

Displays a list of available help topics. 

 Help > About Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

Form OCR QA and Form Index Server 
The button and menu bars of the Form OCR QA and Form Index Server windows contain the 
following utilities: 

Button Menu option Shortcut key Description 

 

File > Refresh F5 Refresh 

Refreshes the job list in the Server window. 

 

File > Send CTRL+D Send 

Opens a dialog to manually send the 
selected document or parcel to another 
queue. 

 

File > Exit F12 Exit 

Closes the Server window. 

 Edit > Clear All Flags CTRL+C Clear All Flags 

Clears flags for all documents in the list. 

 Edit > Apply Status 
Changes 

F9 

 

Apply Status Changes 

Updates the database with any status 
changes made. 

 

Edit > Delete CTRL+DEL 

 

Delete 

Deletes the selected document. 

 Edit > Recovery  

 

 

Recovery 

Recovers the Server status if the process is 
interrupted for some reason. 



Administrator's Guide, Part 2: Business Component Reference Appendix A: Exigen Workflow Object Menus and Button Bars 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 350 of 391 

Button Menu option Shortcut key Description 
 Edit > Queue 

Settings 
 Queue Settings 

Defines queue settings. 

 
Run > Start Server CTRL+E Start Server 

Starts Server. 

 
Run > Stop Server CTRL+Z Stop Server 

Stops Server. 

 Run > Auto Send CTRL+A Auto Send 

When selected, processed jobs are 
automatically sent to the next queue in the 
workflow. 

 Run > Server Mode CTRL+L Server Mode 

When selected, the application runs 
continuously. 

 Run > Get Next Job CTRL+J Get Next Job 

When selected, automatically gets the next 
job. 

 

View > Right Image 
Display 

CTRL+R Right Image Display 

Displays the selected document in the 
Image Viewer on the right side of the 
window. 

 

View > Modify Image CTRL+M Modify Image 

Opens the Image Viewer on the right side of 
the window for document editing. 

 View > Advanced 
Display Settings 

 Advanced Display Settings 

Opens the Advanced display settings 
dialog to specify document display settings. 

 View > Dialog Layout  Dialog Layout 

Specifies the position of the document 
viewer in the Performing OCR verification 
window. The following options are available: 
• Left 
• Right 
• System default 

 View > Show Original CTRL+O Show Original 

Displays the original version of the selected 
document. 

 View > Show 
Versions 

CTRL+V Show Versions 

Displays a list of all versions of the selected 
document. The current version is displayed 
at the bottom of the list. 
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Button Menu option Shortcut key Description 

 

File > Save 
Configuration 

 Save Configuration 

Saves the current window configuration. 

 

Help > Context Help F1 Context Help 

Opens the Help section for this application. 

 Help > Help Topics  CTRL+F1 Help Topics 

Displays a list of available help topics. 

 Help > About Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

FTS Preprocessor 
The button and menu bars of the FTS Preprocessor window contain the following utilities: 

Button Menu option Shortcut key Description 

 

File > Refresh List F5 Refresh List 

Refreshes the job count in FTS 
Preprocessor. 

 

File > Send Batch CTRL+D Send Batch 

Opens a dialog to manually send the 
selected document or parcel to another 
queue. 

 

File > Exit F12 Exit 

Closes the FTS Preprocessor window. 

 Edit > Clear All Flags CTRL+C Clear All Flags 

Clears flags for all documents in the list. 

 Edit > Apply Status 
Changes 

F9 

 

Apply Status Changes 

Updates the database with any status 
changes made. 

 

Edit > Delete 
Document 

CTRL+DEL 

 

Delete Document 

Deletes the selected document. 

 Edit > Recovery  

 

 

Recovery 

Recovers the FTS Preprocessor status if 
the process is interrupted for some reason. 

 
 

  Document Info 

Displays document information. 
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Button Menu option Shortcut key Description 

 

Run > Process Setup CTRL+S Process Setup 

Opens the FTS Setup window to set up the 
FTS configuration. 

 
Run > Start Server CTRL+E Start Server 

Starts FTS Preprocessor. 

 
Run > Stop Server CTRL+Z Stop Server 

Stops FTS Preprocessor. 

 Run > Auto Send CTRL+A Auto Send 

When selected, processed jobs are 
automatically sent to the next queue in the 
workflow. 

 Run > Server Mode CTRL+L Server Mode 

When selected, the application runs 
continuously. 

 

View > Right Image 
Display 

CTRL+R Right Image Display 

Displays the selected document in the 
Image Viewer on the right side of the 
window. 

 

View > Modify Image CTRL+M Modify Image 

Opens the Image Viewer on the right side of 
the window for document editing. 

 View > Advanced 
Display Settings 

 Advanced Display Settings 

Opens the Advanced display settings 
dialog to specify document display settings. 

 View > Show Original CTRL+O Show Original 

Displays the original version of the selected 
document. 

 View > Show 
Versions 

CTRL+V Show Versions 

Displays a list of all versions of the selected 
document. The current version is displayed 
at the bottom of the list. 

 

File > Save 
Configuration 

 Save Configuration 

Saves the configuration of the current FTS 
Preprocessor window that appears in the 
window. 

 

Help > Context Help F1 Context Help 

Opens the Help section for this application. 

 Help > Help Topics  CTRL+F1 Help Topics 

Displays a list of available help topics. 
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Button Menu option Shortcut key Description 
 Help > About Exigen 

Workflow 
 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow 

FTS Server 
The button and menu bars of the FTS Server window contain the following utilities: 

Button Menu option  Shortcut key Description 

 

File > Refresh 
List 

F5 Refresh List 

Refreshes the job count in FTS Server. 

 

File > Save 
Configuration 

 Save Configuration 

Saves the configuration of the current FTS 
Server window that appears in the window. 

 

File > Exit F12 Exit 

Closes the FTS Server window. 

 
Run > Start 
Server 

CTRL+E Start Server 

Starts FTS Server. 

 
Run > Stop 
Server 

CTRL+Z Stop Server 

Stops FTS Server. 

 

View > Right 
Image Display 

CTRL+R Right Image Display 

Displays the selected document in the 
Image Viewer on the right side of the 
window. 

 

View > Modify 
Image 

CTRL+M Modify Image 

Opens the Image Viewer on the right side of 
the window for document editing. 

 View > 
Advanced 
Display 
Settings 

 Advanced Display Settings 

Opens the Advanced display settings 
dialog to specify document display settings. 

 View > Show 
Original 

CTRL+O Show Original 

Displays the original version of the selected 
document. 

 View > Show 
Versions 

CTRL+V Show Versions 

Displays a list of all versions of the selected 
document. The current version is displayed 
at the bottom of the list. 

 

Help > Context 
Help 

F1 Context Help 

Opens the Help section for this application. 
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Button Menu option  Shortcut key Description 
 Help > Help 

Topics  
CTRL+F1 Help Topics 

Displays a list of available help topics. 

 Help > About 
Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

Image Enhancement Server 
The Image Enhancement Server window button and menu bars contain the following utilities: 

Button Menu option Shortcut key Description 

 

File > Refresh List F5 Refresh List 

Refreshes the job list in Image 
Enhancement Server. 

 

File > Send Batch CTRL+D Send Batch 

Opens a dialog to manually send the 
selected document or parcel to another 
queue. 

 

File > Exit F12 Exit 

Closes the Image Enhancement Server 
window. 

 Edit > Clear All Flags CTRL+C Clear All Flags 

Clears flags for all jobs in the list. 

 Edit > Apply Status 
Changes 

F9 

 

Apply Status Changes 

Updates the database with any status 
changes made. 

 

Edit > Delete 
Document 

CTRL+DEL 

 

Delete Document 

Deletes the selected documents from the 
queue. 

 Edit > Recovery  

 

Recovery 

Recovers the Image Enhancement Server 
status if the process is interrupted for some 
reason. 

 

Run > Process Setup CTRL+S Process Setup 

Opens the Process Setup window to 
configure the Image Enhancement Server. 

 
Run > Start Server CTRL+E Start Server 

Starts Image Enhancement Server. 
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Button Menu option Shortcut key Description 

 
Run > Stop Server CTRL+Z Stop Server 

Stops Image Enhancement Server. 

 Run > Auto Send CTRL+A Auto Send 

When selected, processed jobs are 
automatically sent to the next queue in the 
workflow. 

 Run > Server Mode CTRL+L Server Mode 

When selected, the application runs 
continuously. 

 Run > Start Test  Start Test 

Starts testing the configurations in Image 
Enhancement Server. 

 Run > Release Test  Release Test 

Stops testing the configurations in e Image 
Enhancement Server. 

 

View > Right Image 
Display 

CTRL+R Right Image Display 

Displays the selected document in the 
Image Viewer on the right side of the 
window. 

 

View > Modify Image CTRL+M Modify Image 

Opens the Image Viewer on the right side of 
the window for document editing. 

 View > Advanced 
Display Settings 

 Advanced Display Settings 

Opens the Advanced display settings 
dialog to specify document display settings. 

 View > Show Original CTRL+O Show Original 

Displays the original version of the selected 
document. 

 View > Show 
Versions 

CTRL+V Show Versions 

Displays a list of all versions of the selected 
document. The current version is displayed 
at the bottom of the list. 

 

File > Save 
Configuration 

 Save Configuration 

Saves the configuration of the current 
Image Enhancement Server window that 
appears in the window. 

 

Help > Context Help F1 Context Help 

Opens the Help section for Image 
Enhancement Server. 
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Button Menu option Shortcut key Description 
 Help > Help Topics  CTRL+F1 Help Topics 

Displays a list of available help topics. 

 Help > About Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

Import Server 
The Import Server window menu and button bars contain the following utilities: 

Button Menu option Shortcut key Description 

 

File > Import Setup F2 Setup 

Opens the Import Setup window that is used 
to configure the import parameters and 
criteria.  

 File > Export Setup  Export Setup 

Opens the Export Setup Data window that is 
used to write all Import Server data to a 
.cnv file. 

 
File > Log File F5 Log File 

Opens the Log Errors File window to see the 
errors that occurred during the import 
process. 

 
File > Track File F6 Track File 

Opens the Track Messages File to view the 
history of all Import Server activity. 

 

File > Exit Import 
Server 

F12 Exit 

Closes the Import Server window.  

 
Run > Start Import 
Server 

F3 Start Server 

Starts Import Server. 

 
Run > Stop Import 
Server 

F4 Stop Server 

Stops Import Server. 

 

Help > Context Help F1 Context Help 

Opens the Help section for Import Server. 

 Help > Help Topics  CTRL+F1 Help Topics 

Displays a list of available help topics. 
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Button Menu option Shortcut key Description 

 Help > About Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

Distribution Server 
The Distribution Server window menus and button bar contain the following utilities: 

Button Menu option Shortcut key Description 

 

File > Refresh List  F5 Refresh List 

Refreshes the job list in Distribution Server. 

 

 

File > Send Batch CTRL+D Send Batch 

Opens a dialog to manually send the 
selected document or parcel to another 
queue. 

 

File > Exit F12 Exit 

Closes the Distribution Server window. 

 Edit > Clear All Flags CTRL+C Clear All Flags 

Clears flags for all jobs in the list. 

 Edit > Apply Status 
Changes 

F9 

 

Apply Status Changes 

Updates the database with any status 
changes made. 

 

Edit > Delete 
Document  

CTRL+DEL 

 

Delete Document 

Deletes the selected document. 

 Edit > Recovery  

 

 

Recovery 

Recovers Distribution Server status if the 
process is interrupted for some reason. 

 

Run > Process Setup CTRL+S Process Setup 

Opens the Setup window. 

 
 

Run > Start Server CTRL+E Start Server 

Starts Distribution Server. 

 
Run > Stop Server CTRL+Z Stop Server 

Stops Distribution Server. 
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Button Menu option Shortcut key Description 
 Run > Auto Send CTRL+A Auto Send 

When selected, processed jobs are 
automatically sent to the next queue in the 
workflow. 

 Run > Server Mode CTRL+L Server Mode 

When selected, the application runs 
continuously. 

 

View > Right Image 
Display 

CTRL+R Right Image Display 

Displays the selected document in the 
Image Viewer on the right side of the 
window. 

 

View > Modify Image CTRL+M Modify Image 

Opens the Image Viewer on the right side of 
the window for document editing. 

 View > Advanced 
Display Settings 

 Advanced Display Settings 

Opens the Advanced display settings 
dialog to specify document display settings. 

 View > Show Original CTRL+O Show Original 

Displays the original version of the selected 
document. 

 View > Show 
Versions 

CTRL+V Show Versions 
Displays a list of all versions of the selected 
document. The current version is displayed 
at the bottom of the list. 

 

File > Save 
Configuration 

 Save Configuration 

Saves the configuration of the current 
Distribution Server window that appears in 
the window. 

 

Help > Context Help F1 Context Help 

Opens the Help section for Distribution 
Server. 

 Help > Help Topics  CTRL+F1 Help Topics 

Displays a list of available help topics. 

 Help > About Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

Escalation Server 
The Escalation Server window menus and button bar contain the following utilities: 
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Button Menu option Shortcut key Description 

 

File > 
Refresh 

F5 Refresh 

Refreshes the jobs in Queue count in 
Escalation Server. 

 

File > Save 
Configuration

 Save Configuration 

Saves the window configuration. 

 

File > 
Process 
Setup 

CTRL+S Process Setup 

Opens the Escalation Settings window. 

 

Run > Start 
Server 

 Start Server 

Starts Escalation Server. 

 

Run > Stop 
Server 

 Stop Server 

Stops Escalation Server. 

 

Help > 
Context Help 

F1 Context Help 

Opens the Help section for Escalation 
Server. 

 Help > Help 
Topics 

CTRL+F1 Help Topics 

Displays a list of available help topics. 

 Help > About 
Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

 

File > Exit F12 Exit 

Closes the Escalation Server window. 

Push Server 
The Push Server window menus and button bar contain the following utilities: 

Button Menu option Shortcut key Description 

 

File > Refresh F5 Refresh 

Refreshes the job list in Push Server. 

 

File > Send CTRL+D Send 

Opens a dialog to manually send the 
selected document or parcel to another 
queue. 

 

File > Save 
Configuration 

 Save Configuration 

Saves the configuration of the Push Server 
window in the window. 
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Button Menu option Shortcut key Description 

 

File > Exit F12 Exit 

Closes the Push Server window. 

 Edit > Clear All Flags CTRL+C Clear All Flags 

Clears flags for all jobs in the list. 

 Edit > Apply Status 
Changes 

F9 

 

Apply Status Changes 

Updates the database with any status 
changes made. 

 

Edit > Delete CTRL+DEL 

 

Delete 

Deletes the selected job. 

 Edit > Recovery  

 

 

Recovery 

Recovers the Push Server status if the 
process is interrupted for some reason. 

 
 

Run > Start Server CTRL+E Start Server 

Starts Push Server. 

 
Run > Stop Server CTRL+Z Stop Server 

Stops Push Server. 

 Run > Auto Send CTRL+A Auto Send 

When selected, processed jobs are 
automatically sent to the next queue in the 
workflow. 

 Run > Server Mode CTRL+L Server Mode 

When selected, the application runs 
continuously. 

 

View > Right Image 
Display 

CTRL+R Right Image Display 

Displays the selected document in the 
Image Viewer on the right side of the 
window. 

 

View > Modify Image CTRL+M Modify Image 

Opens the Image Viewer on the right side of 
the window for document editing. 

 View > Advanced 
Display Settings 

 Advanced Display Settings 

Opens the Advanced display settings 
dialog to specify document display settings. 

 View > Show Original CTRL+O Show Original 

Displays the original version of the selected 
document. 
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Button Menu option Shortcut key Description 
 View > Show 

Versions 
CTRL+V Show Versions 

Displays a list of all versions of the selected 
document. The current version is displayed 
at the bottom of the list. 

 

Help > Context Help F1 Context Help 

Opens the Help section for Push Server. 

 Help > Help Topics  CTRL+F1 Help Topics 

Displays a list of available help topics. 

 Help > About Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

ERM Indexer 
The ERM Indexer window menus and button bar contain the following utilities: 

Button Menu option Shortcut key Description 

 

  Settings 

Opens the ERM Server Settings window 
that is used to configure the server 
parameters. 

 
Process > Start  F3 Start 

Starts ERM Indexer 

 
Process > Stop  F4 Stop 

Stops ERM Indexer. 

 

Process > Exit F12 Exit 

Closes the ERM Indexer window.  

 

Help > Context Help F1 Context Help 

Opens the Help section for this application. 

 Help > Help Topics  CTRL+F1 Help Topics 

Displays a list of available help topics. 

 Help > About Exigen 
Workflow 

 About Exigen Workflow 

Shows copyright and release information 
regarding Exigen Workflow. 

Report Definition Wizard 
The RDW window menus and button bar contain the following utilities: 
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Button Menu option Shortcut key Description 

 
File > Open Report CTRL+O Open Report 

Opens a report in the report window. 

 
File > Close Report  Close Report 

Closes currently active report. 

 File > Close All 
Reports 

 Close All Reports 

Closes all currently open reports. 

 
File > New Template CTRL+N New Template 

Opens a new template. 

 
File > Open Template  Open Template 

Opens an existing template. 

 
File > Save Template CTRL+S Save Template 

Saves the currently active template. 

 File > Save Template 
As 

 Save Template As 

Saves the current template with a different 
name or location. 

 File > Export 
Template > Export to 
ERM INI File 

 Export to ERM INI File 

Exports the template to Exigen Workflow 
ERM INI file, specified in View > Options. 

 File > Export 
Template > Export to 
ERM XML File 

 Export to ERM XML File 

Exports the template to Exigen Workflow 
ERM XML file, specified in View > 
Options. 

 File > Import 
Template 

 Import Template 

Imports template from the Exigen Workflow 
database. 

 File > Print CTRL + P Print Report 

Prints the report currently active. 

 File > Print Preview  Print Preview 

Shows an actual view of the report before 
it is printed. 

 File > Exit  Exit 

Exits Report Definition Wizard, prompting 
the user to save the unsaved changes. 

 
Edit > Cut CTRL+X Cut 

Removes selected text and places it on the 
clipboard. Enabled only for editing text in 
edit trap box. 

 
Edit > Copy CTRL+C Copy 

Copies the selected text in the clipboard. 
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Button Menu option Shortcut key Description 

 
Edit > Paste CTRL+P Paste 

Inserts the contents of the clipboard at the 
insertion point. You can paste the text only 
if cut or copy functions are performed. 

 Edit > Select All CTRL+A Select All 

Selects all report. 

 
Edit > Find  Find 

Searches for the specified text. 

 Edit > Find Next F3 Find Next 

Performs the next search 

 View > Text Size  Text Size 

Is used to select the font size for the 
report. 

 View > Encoding  Encoding 

Lists possible report encoding. 

 View > Toolbars  Toolbars 

Lists possible toolbars combinations. To 
select one, click on it. 

 View > Status Bar  Status Bar 

Displays or hides the status bar. 

 View > Options  Options 

Opens options window that is used to 
specify the file names to which to export 
the templates. 

 Template > Add Trap Ins New Trap 

Opens the Trap window with a new trap 
added to the template. You can edit the 
trap in this window. 

 Template > Edit Item Enter Edit Item 

Opens the selected item for editing. 

 Template > Delete 
Item 

Delete Delete Item 

Deletes the selected item. 

 Template > Clear 
Template 

 Clear Template 

Clears the template opened. 

 Window > New 
Window 

 New Window 

Opens the currently active report in a new 
window. 



Administrator's Guide, Part 2: Business Component Reference Appendix A: Exigen Workflow Object Menus and Button Bars 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 364 of 391 

Button Menu option Shortcut key Description 
 Window > Cascade  Cascade 

Arrange report windows so that they 
overlap. 

 Window > Tile  Tile 

Arranges report windows as non-
overlapping tiles. 

 Window > Arrange 
Icons 

 Arrange Icons 
Arranges icons at the bottom of the report 
window. 

 Help > Help Topics F1 Help Topics 
Opens the Help section for this application. 

 Help > About RDW  About RDW 
Shows program information, version 
number, and copyright. 

E-Capture Server 
The E-Capture Server window menus and button bar contain the following utilities: 

E-Capture Server tools 
Button Menu option Shortcut 

key 
Description 

 

File > Setup F2 Sets up E-Capture Server. 

 File > Local Parent 
Directory 

F7 Selects the local parent directory required to 
process large PCL files. 

 View > Show Recovery 
Info Button 

 Recovers the corrupted portion of large PCL 
files if a problem occurs during processing. 

 

Run > Start Server F3 Starts E-Capture Server. 

 

Run > Stop Server F4 Stops E-Capture Server. 

 

Help > Context Help F1 Opens context help.  

 Help > Help Topics CTRL+F1 Opens help. 
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E-Capture Server tools 
Button Menu option Shortcut 

key 
Description 

 Help > About Exigen 
Workflow 

 Displays the Exigen Workflow version and 
copyright information. 

 

File > Exit Server F12 Closes the application. 

 
 

File > Error Log File F5 Opens the error log. 

 
File > Track File F6 Opens the history log. 

 
 

View > Temp. Storage 
Info 

 Opens the Temporary Storage table. 

 View > Schedule of 
Forms Info 

 Opens the Schedule of Forms table. 

 View > Schedule of 
Locations Info 

 Opens the Schedule of Locations 
Information table. 

 View > Schedule of 
Named Insured Info 

 Opens the Named Insured table. 
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Appendix B: Maintaining Exigen Workflow 
Servers as Services  
The following objects are enhanced to function as true Windows NT® active desktop services: 

• Barcode Server 

• Distribution Server 

• E-Capture Server 

• Escalation Server 

• Event Server 

• Form OCR Server 

• Form Index Server 

• FTS Preprocessor 

• FTS Server 

• Image Enhancement Server 

• Import Server 

• ERM Indexer 

• Push Server 

These objects are now able to run in service mode; that means they can function without user 
interaction for a long time, processing documents according to workflow rules. 

Note: To use Exigen Workflow servers as true Windows NT–active desktop services, you must 
specify a user account in the service properties Log On pane. 

The following topics are described in this section: 

• Installing and Configuring Services 

• Uninstalling Services 

• Starting Services 

• Stopping Services 

• Getting Help 

• Events in the Event Log 

• Tuning Escalation Server 

• Running Multiple Server Instances From the Command Prompt 
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Installing and Configuring Services 
The following topics are included in this section: 

• Installing Services from the User Interface 

• Installing Services Using the Command Prompt 

• Configuring Services 

• Running Servers as Services Using a Trusted Connection and the CCID Win32 Login 

Installing Services from the User Interface 
To install a service from the Exigen Workflow Explorer window, proceed as follows: 

1. Right click the object that can be used as a service. 

A popup menu appears. 

 
Figure 176: Installing a service from Exigen Workflow Explorer 

2. Select Install Service.  
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The relevant sections in the visiclt.ini file are filled in automatically, and the service is 
installed. 

Note: Multiple instances of services can be installed for one server. The maximum number of 
instances is 99.  

Installing Services Using the Command Prompt 
To install services using the command prompt, run the following command from the command 
prompt: 
Serv_all.exe —install name description path section_name [response_time] 
 
Parameters for installing services 
Parameter Description 
install Installs a flag. 
name Service name, which must be unique name for each service. 
description Service description. 
path Full path to the serv_all.exe program if it differs from the current install 

path. 
section_name Corresponding section name in the visiclt.ini file for each Exigen 

Workflow server. 
response_time Timeout in minutes; if specified and exceeded, the service terminates the 

server process. 

No spaces are allowed in service names. 

The description must be passed as one parameter. Text with spaces must be placed in “ ”.   

The path parameter is not used; the current path name to serv_all.exe is used instead. 

The parameter section_name is used as a reference section name in the visiclt.ini file. 
Service parameters are stored in the following registry: 

HKEY_LOCAL_MACHINE\SOFTWARE\Exigen\Exigen Workflow\Services.  

Response time is used to determine if a server is responding in case of an unexpected error. If 
the service time differs from the server time more than specified in the response time, the 
service terminates the server and stops. 

During the Exigen Workflow installation, the default response_time is set to 10 minutes. 

Service status after installation is Not Started, Manual. 

The following example represents a part of the visiclt.ini file:  
 … 
 [setup_import]   
 Service_StartupString=C:\ExigenWorkflow\SYSTEM\objimpr.exe 19 DTM 8 DTM Y Y 
 Service_CurrentDir=C:\ExigenWorkflow\SYSTEM 
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 Service_Status=stop 
 Service_WindowTitle=Import Server 
 [setup_escalation] 
 Service_StartupString=C:\ExigenWorkflow\SYSTEM\srvesc.exe 4 DTM 1 dtm Y Y 
 Service_CurrentDir=C:\ExigenWorkflow\SYSTEM 
 Service_Status=stop 
 Service_WindowTitle=Escalation Server - IMPORT SERVER TEST  
 … 

The following command-line sample represents the installation of several Exigen servers:  

serv_all.exe -install DTM_Import "Exigen Import Server" serv_all.exe 

SETUP_IMPORT 10 

serv_all.exe -install DTM_Escalation "Exigen Escalation Server" 

serv_all.exe setup_escalation 10 

serv_all.exe -install DTM_Barcode "Exigen Barcode Server" serv_all.exe 

setup_barcode 10 

serv_all.exe -install DTM_Event "Exigen Event Server" serv_all.exe 

setup_event 10 

serv_all.exe -install DTM_Push "Exigen Push Server" serv_all.exe 

setup_push 10 

serv_all.exe -install DTM_Pdf "Exigen E-Capture Server" serv_all.exe 

setup_pdf_serv 10 

serv_all.exe -install DTM_Ftx "Exigen FTX Server" serv_all.exe 

setup_ftx 10 

Configuring Services 
To configure services, proceed as follows: 

1. For Windows 2000, select Start > Settings > Control Panel > Administrative Tools > 
Services.  

2. For Windows NT, select Start > Settings > Control Panel > Services.  
3. Right click the service and select Properties. 
4. To modify the service display name, in the General tab, in the Display name field, modify 

the value. 

Although the service display name can be modified, the service name itself cannot be 
changed. 

5. To add or modify an optional service description, in the Description field, enter an 
appropriate text. 
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6. To specify a user account for the service, select the Log On tab and select the This 
account option. 

The following Workflow services perform file and database operations and must be run 
under a specific DOMAIN user account that is granted read and write access to the Image 
repository and administrative access on a local computer:  

• Barcode Server 
• Form OCR Server 
• Form Index Server 
• Import Server 
• E-Capture Server 
• Distribution Server 
• Retention Server 
• Image Enhancement Server 
• FTS Server 
• Audit Server 

Workflow services that perform only database operations, such as Push Server and 
Escalation Server, are not required to run under a specific user account, although it is 
recommended. 

7. In the This account field, enter a user account. 

8. In the Password field, enter the password for the user account. 

9. In the Confirm password field, enter the password again. 

10. To specify system behavior in case of service failure, select the Recovery tab and enter 
appropriate values. 

11. To save the settings, click OK. 

Running Servers as Services Using a Trusted Connection 
and the CCID Win32 Login 
To run servers as services using a trusted connection to the database and the CCID Win32 
login to Exigen Workflow, proceed as follows: 

1. In the local visiclt.ini file, define the following modes: 
[winclient] 

authentication_mode=C 

db_connection_mode=T 

2. Log in to Exigen Workflow under the specific windows user account that is registered in the 
Exigen Workflow database as a CCID Win32 authentication allowed user. 

3. While logged in, install the service. 

4. In Exigen Workflow, run the service under the same Windows user that is used to install 
services. 
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Uninstalling Services 
The following topics are included in this section: 

• Uninstalling Services from the User Interface 

• Uninstalling Services Using the Command Prompt 

Uninstalling Services from the User Interface 
To uninstall a service from the Exigen Workflow Explorer window, proceed as follows: 

1. Right click the object that can be used as a service. 

2. Select Remove Service.  

The Remove Service dialog appears.  

 
Figure 177: Removing a service 

A list of all services that are installed for the selected server is shown. 

3. Select a service instance and click Remove.  

Uninstalling Services Using the Command Prompt 
To uninstall services using the command prompt, run the following command from the 
command prompt: 
Serv_all.exe —remove name 
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Parameters for uninstalling services 
Parameter Description 
remove Removes a flag. 
name Service name, which is unique for each service. 

The uninstall function marks a service for deletion from the service control manager database. 

The database entry is not removed until all open handles to the service are closed and the 
service has stopped running. A running service is stopped by a call to the ControlService 
function with the SERVICE_CONTROL_STOP control code. If the service cannot be stopped, the 
database entry is removed when the system is restarted. 

The service control manager deletes the service by deleting the service key and its subkeys 
from the registry. 

The following sample represents command lines: 
Serv_all.exe -remove DTM_Import 
Serv_all.exe -remove DTM_Escalation 

Starting Services 
To start services, run the following command from the command prompt: 

Serv_all.exe -start name 

Parameters for starting services 
Parameter Description 
start Starts a flag. 
name Service name, which is unique for each service. 

The following process occurs: 

1. When the command for starting a service is run, the server is started with parameters for 
service mode. 

No messages are displayed in this mode, and no other user interaction is required. 

2. The server creates an event that is used as a communications link to monitor the server 
from the service. 

3. After every 10 seconds in the loop, the service reads the server status: 
• If the status changed, the server is running. 
• If the status did not change, the server is busy. 
• If the status has not changed in the last 20 minutes, the service assumes that the server 

is not responding. The server is terminated and the service stops. 
Note: The non-response interval can be modified in the service registry. 

• If the service is started and the server runs successfully, the server updates the 
response values in the visiclt.ini file. 
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4. The service does not restart the server by default. However, in Windows 2000 you can 
select the corresponding check box to restart the service automatically. 

5. The service writes information to the Windows event log. 

Stopping Services 
To stop services, run the following command from the command prompt: 
Serv_all.exe -stop name 

Parameters for stopping services 
Parameter Description 
stop Stops a flag. 
name Service name, which is unique name for each service. 

The following results occur: 

• Service exits from its loop, sets Service_Status = stop in the visiclt.ini file, and exits. 

• The Exigen Workflow server reads Service_Status = stop, terminates the operation, and 
exits. 

Getting Help 
To access online help, run the following command from the command prompt: 
Serv_all.exe /? 

Events in the Event Log 
The following table describes events for services: 
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Event type Event number Event message 
Information 1 Service %1 was installed. 
Information 2 Service %1 was started. 
Information 3 Service %1 was stopped. 
Information 4 Service %1 was removed. 
Information 12 Service %1 was stopped. Server %2 was stopped by %3. 
Error 5 Service %1 was terminated. Server %2 was terminated by an 

unexpected error. 
Error 6 Service %1 was terminated. %4 

Event 6 is used to write custom text into an event log. Usually, 
this is a server error message. If the server displays an error 
message in service mode, the error is passed to the service 
and is written to the event log. If there is more than one error 
message, only the last one is written. 

Error 7 Service %1 was terminated. Server %2 timeout (%3 minutes) 
was exceeded. 

Error 8 Service %1 was terminated. No main server window. 
Note: Not used in Exigen Workflow version 5.4.1 and later. 

Error 9 Service %1 was terminated. Server cannot be started. 

Error 10 Service %1 was terminated. Server was stopped manually. 

Error 11 Service %1 was terminated. Service/server communication 
cannot be established. 

Tuning Escalation Server 
Escalation Server can be tuned to set the speed of response to a termination request and the 
intervals for performing escalation. To do this, modify two additional variables in the Escalation 
Server section [setup_escalation] in visiclt.ini: 

Variables for tuning Escalation Server 
Variables Description 
ExitCheckInterval   Time interval for checking exit requests; default is 1000 ms or 1 

second. 
ProcessInterval   Time interval for processing; default is 50,000 ms or 50 seconds, 

and the maximum value is 2147483646 ms, or 24 to 25 days 

The following is an example where the interval is 1 day: 

ProcessInterval=86400000 
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Running Multiple Server Instances from the 
Command Prompt 
Multiple Exigen Workflow server instances can be run. The following example describes how to 
run multiple instances of Push Server from the command prompt. 

1. Create or modify the [Multiinstance] section in the visiclt.ini file. 

2. Create or modify two sections, OBJPUSH_x_y and OBJPUSH_x_y, where x is a workflow node 
ID and y is a workflow ID for each Push Server object that has to be started as a service.  

[Multiinstance] 
 ;the first Push Server (node ID=6, workflow ID=7) 
 ;to turn on multiple instances for the following object, set 
value to 1, to turn off, set value to 0. 
 OBJPUSH_6_7=1 
 ;the section name for the first Push Server, where server 
information is written (server status and so on). 
 OBJPUSH_6_7_section=setup_push1 
 
 ;the second Push Server (node ID =3, workflow ID=2) 
 OBJPUSH_3_2=1 
 OBJPUSH_3_2_section=setup_push2 

3. In Exigen Workflow Explorer, start each Push Server. 

Starting the Push Server automatically adds a section to the visiclt.ini file for this object 
and fills it with the required run-time information. 

Two new sections are added to the visiclt.ini file: 
 [setup_push1] 
 .... 
 [setup_push2] 
 .... 

4. If the Exigen Push Server service appears in the services list, remove it by running the 
following command: 

serv_all.exe -remove DTM_Push 

5. Create a service for each Push Server object by running the following command: 
ExigenWorkflow\SYSTEM\serv_all.exe. 

4. To create two services with the sections setup_push1 and setup_push2, run 
serv_all.exe with the following parameters in the command line: 

 serv_all.exe -install setup_push1 "Exigen Push Server 1" 
serv_all.exe setup_push1 10 

 serv_all.exe -install setup_push2 "Exigen Push Server 2" 
serv_all.exe setup_push2 10 

6. Open the service properties and specify a system or user account that the service logs in. 
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Appendix C: Push Server Advanced 
Functionality 
This appendix describes the advanced functionality of Push Server. The following topics are 
described in this section: 

• Routing Using a Codetable 

• Legacy-Based Routing: Integration with Exigen Integrator 

Routing Using a Codetable 
In contrast to simple routing, Push Server analyzes the values described in a codetable and 
performs the corresponding actions. This approach is flexible and convenient because it 
eliminates the need to describe separate conditions and makes the server work more 
effectively. 

Requirements 
The project must contain a codetable. Using Project Builder, create a codetable with the 
following fields: 

Codetable fields 
Field name Data type Size Description 
ACT_CODE VARCHAR 199 Code field, which identifies codetable record. Must contain a 

value for comparison. 
WFL_ID INTEGER 4 ID of the workflow that uses this table.  

NODE_FROM INTEGER 4 Node ID to which this record applies. 

NODE_TO INTEGER 4 Node ID to which the parcel must be sent if the code field is 
verified. 

UID_TO VARCHAR 32 User ID to which the parcel must be sent if the code field is 
verified. 

ACT_DESC VARCHAR 199 Description of the current action record. Can be any text or 
blank. 

To populate the codetable, use the Table Maintenance utility in the Administrator application. 
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Figure 178: Example of table content 

To enable the codetable during a routing procedure, routing rules must contain the keywords 
<USE TABLE:CODETABLE NAME>. 

Figure 179: Example of routing rules using a codetable 
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The following table describes the numbered sections of the preceding figure: 

Modify Node window sections 
Section number Description 
1 Field to look up in ACTIONS codetable. 

2 Keyword that enables use of the ACTIONS codetable. 

3 Routes to nodes and users. Values are not used, but are required for 
compatibility with regular routing rules. It can contain any node and user pair. 

This example uses a codetable named ACTIONS and illustrates the situation when a codetable 
is combined with regular routing rules. In this case, the upper rules are verified sooner. The 
action sequence for this example is the following: 

1. If field A_BRANCH equals 0002, route parcel to the node named “Else condition” and user 
“DTM”. If not, proceed to the next routing rule. 

2. Take the value from field A_USER_ACTION and try to find this value in the codetable field 
ACT_CODE. If the value is found in the codetable, route to the node ID and user ID 
specified in the codetable. If this value is not found in codetable, proceed to the ELSE 
condition. 

3. ELSE condition: route parcel to the node named “Else condition” and user “DTM”. 

The routing rule using the ACTIONS table must be the following: 
<field name> = '<USE TABLE:ACTIONS>' 

If the field data type is not VARCHAR or CHAR, <field name> must also contain the 
appropriate conversion valid for the current server. 

For DB/2 it must resemble the following: 
cast( <field_name> as varchar(199)) 

<field_name> is the field to be used with the codetable. 

Example: CAST(A_USER_ACTION AS VARCHAR(199))=’<USE TABLE:ACTIONS>’ 

Legacy-Based Routing: Integration with Exigen 
Integrator 
Before users can integrate Push Server with Exigen Integrator, Exigen Integrator must be 
installed. 

Note: The Exigen Integrator installation includes the D32_EIS.DLL file that is required for integration. 
The D32_EIS.DLL file is not included in the Push Server installation. 

Exigen Workflow invokes Exigen Integrator and provides it with the parameters necessary to 
retrieve the required data. 

Function DTM_EISRoute accepts appropriate parameters from Exigen Workflow, connects to 
Exigen Integrator, and executes the Workflow_Route method and returns data. 
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Function DTM_EISRoute takes seven parameters. 
BOOL DTM_EISRoute(   
     LPCTSTR eis_DBSpec,  
     LPCTSTR eis_host,  
     int eis_port,  
     long Doc_ID,  
     LPCTSTR Project_ID,  
     LPLONG lpReturn,  
     LPTSTR lpStrError ); 
 

Parameters in DTM_EISROUTE 
Parameter Description 
eis_DBSpec RDBMS resource name, which must be used to connect to the database. 

eis_host Hostname on which Exigen Integrator resides. 

eis_port Port number to which Exigen Integrator listens. 

Parcel_ID Parcel ID. 

Project_ID Project ID. 

lpReturn Return code. If function succeeds, a return code contains the value returned 
by Exigen Integrator. 

lpStrError Error message. If function fails, an error message is passed to this parameter. 

If eis_host is blank and eis_port is 0, the default host localhost and port 9000 are used. 

Return values: 

If DTM_EISRoute succeeds, it returns TRUE; otherwise, FALSE is returned. 

Declaration in Centura: 

Function DTM_EISRoute must be declared in Exigen Workflow application code in the following 
way: 

Library name: D32_EIS.DLL 
 Function: DTM_EISRoute 
  Description: 
  Export Ordinal: 0 
  Returns 
   Boolean: BOOL 
  Parameters 
   String: LPSTR 
   String: LPSTR 
   Number: INT 
   Number: LONG 
   String: LPSTR 
   Receive Number: LPLONG 
   Receive String: LPSTR 

The BATCHPARCEL table must contain a field named A_EIS_ROUTE with type INTEGER. 

The visiclt.ini file must contain the section: 
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[EIS_setup] 
EIS_Host =  
EIS_Port =  
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Appendix D: Example Report 
This is an example of a report for Report Definition Wizard. 
891623685                                                                                  
 

                           STUDENT LOAN INTEREST PAYMENT REPORT                           
                                    FOR IRS FORM 1098E                                    
 
   SSN: 891-62-3685                 SMITH JAMES A                                         
                                    12708 RIVERSIDE ST                                      
                                    DALLAS, TX 75233-5009                                  
 
 
                                  *** STAFFORD LOAN ***                                    
   LOAN     LOAN        LOAN      LOAN       LOAN        LOAN        IRS         1998      
   SEQ      BEGIN       END       DAYS       GRACE     ADJUSTED    60-MONTH    INTEREST    
   NUM      DATE        DATE    DEFERMENT    DATE      END DATE     DATE         PAID      
                                                                                           
   002   06/21/1995  06/20/2000      0    06/20/1995  06/30/2000  06/20/2000      32.33    
   003   06/21/1995  06/20/2000      0    06/20/1995  06/30/2000  06/20/2000      56.63    
   004   06/21/1995  06/20/2000      0    06/20/1995  06/30/2000  06/20/2000      56.81    
   005   06/21/1995  06/20/2000      0    06/20/1995  06/30/2000  06/20/2000     170.05    
   006   06/21/1995  06/20/2000      0    06/20/1995  06/30/2000  06/20/2000     170.05    
                                                                             __________    
                                                                SUB TOTAL:       485.87    
 
 
                          *** SUPPLEMENTAL LOAN FOR STUDENT ***                            
   LOAN     LOAN        LOAN      LOAN       LOAN        LOAN        IRS         1998      
   SEQ      BEGIN       END       DAYS       GRACE     ADJUSTED    60-MONTH    INTEREST    
   NUM      DATE        DATE    DEFERMENT    DATE      END DATE     DATE         PAID      
                                                                                           
   002   08/07/1993  12/06/1999    486    08/06/1993  12/31/1999  08/07/1998      27.50    
   003   09/07/1993  12/15/1999    464    09/06/1993  12/31/1999  09/07/1998      82.53    
   004   10/20/1993  12/15/1999    421    10/19/1993  12/31/1999  10/20/1998      82.65    
                                                                             __________    

                                                                SUB TOTAL:       
192.68    
 
                                TOTAL INTEREST PAID ON ALL LOANS FOR 1998:       678.55    
 

Figure 180: Example report 
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Appendix E: ERM Configuration File 
Keywords 
In the following ERM configuration file example, keywords and values related to name 
conventions are highlighted: 
 

[general section] 
;general section contains options for ERM Indexer 
next entry extension = 500 
;this keyword stores next automatically assigned model ID 
multimodel = 0 
;value (0, default) disables or enables (1) multimodel processing  
notstrict = -1 
;value (-1) enables variations in traps position 
;relative to Monarch model trap 
;can be +1 or -1 (default 0) 
log = 0 
;value (1, default) enables or disables (0) posting messages 
;to ETDM log file  
 
 
[ABC] 
;ABC is three-character model ID (extension) 
model description = Modern Art Industries Invoice 
 
batch = 0 
;value (0) disables batch processing mode which, otherwise, is default 
 
;printer settings 
page orientation = Landscape 
;or Portrait, Landscape is default 
 
print margins = 0.4 0.4 0.4 0.4 
;order of margins is left, right, top, bottom in inches 
;0.5 by default 
 
paper size = Letter 
font size=9 
font face = Lucida Console 
;or other in compliance with Windows 
;default values are Letter, 8, Courier New 
 
;fixed format reports (d32_mnr.ini) 
signature = 0 8 
;value lists blank separated trap numbers which are signatures 
 
page shift=-26 
;value is the difference between top document line number (0) 
;and top trap line number(26) for page header traps which are 
;not at the top document line, default value is 0 
 
;trap example 
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trap1="           ÑÑÑÑ/ÑÑ/ÑÑ    ÑÑÑÑ/ÑÑ/ÑÑ ß1/" 
;keyword: 1 is trap number, trap0 must be on top; 
;trap numbers are hexadecimal (trap0, trap1, …, trapF) 
;value: trap line in double quotes 
 
;example of index field (for number of field <=9) 
field10=2 3 23 CONTRACT 
;keyword: 1-trap number, 0-field number (decimal <99) 
;value: blank separated row increment(2), start position(3), 
;length(23), and field name without blanks (CONTRACT) 
descr10=Contract number 
;keyword: 1-trap number, 0-field number 
;value: field description string (Contact number) 
 
;example of overlay field 
field11=-10 1 77 O_TIT 
;keyword: same as index field 
;value: blank separated row increment(-10), start position (1), length 
(77), and field name started with O_ (O_TIT) 
descr11=multi 1 5 
;keyword: same as index field 
;value: separated by blanks keyword multi 
;multiline parameter(1)and line count (5) 
 
;example of page header overlay field 
field14 = 2 0 3 O_PAG01 
;keyword: same as index field 
;value: blank separated row increment(2), start position (0) 
;length (3), field name started with O_PAG (O_PAG01) 
;where 01 is number of page in form overlay template (1, 2, 3, … ,99). 
;Field name starting with O_PAG is reserved for page header fields 
;and cannot be used otherwise. 
 
 
;other example of field (for number of field >9) 
fieldA13=0 48 12 INVOICE_NO 
descrA13=invoice number 
;this is index field 13 related to trap A 
 
 
;delimited reports (d32_dlm.ini) 
trap0=3 IN 
;keyword: same as fixed format reports 
;value: sequential field number (3) starting from 0, trap field (IN) 
;where blanks not allowed 
 
;example of index field 
field02=8 TO_NAME 
;keyword: same as fixed format reports 
;value: sequential field number (8) starting from 0 
;field name (TO_NAME), blanks not allowed 
 
 
;XLS templates 
xls sheet = Sheet2 
;value (Sheet2) is name of sheet where output is directed to 
xls Header = Col 
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;value (Col) is the prefix for header (and footer) cell names 
xls number of levels = 2 
;Number (2) of detail and sub-detail levels 
;not including ‘header and footer’ level 
xls level1 = Det 
xls level2 = Sub 
;value (Det), (Sub) - prefixes for detail and sub-detail levels 
xls start row = 25 
;value (25) is the number of template row to insert detail level rows 
 
;TXT templates 
lines per page = 58 
;limit of table lines per page for multi-page tables 
 

 

 



Administrator's Guide, Part 2: Business Component Reference  Index 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 385 of 391 

Index 
  

A 
access control list based security. See ACL 

based security 
ACL based security, 320 
Advanced Event Server, 287, 343 
AFP printstream, 211 
AFP reports, 176 
AFP spool files, 220 
AFP Viewer, 211 
AS/400 printstream, 220 
AS/400 reports, 176 

processing, 221 
AS/400 setup, 217 
audit event filters, 328 
audit logs 

viewing statistics, 73 
audits 

Barcode Server, 39 
auto-indexing 

ERM, 192 
auto-indexing settings 

editing, 192 
automated tasks 

processing, 287 
automatic operations 

performed by Task Oriented Workflow 
Engine, 337 

Automatic Queue Server, 287 
assigning document security, 320 
changing startup options, 288 
components, 295 
definition, 287 
job types, 290 
jobs, 295 
log, 321 
managing a remote instance, 313 
modifying filter script template, 320 
modifying script template, 316 
process, 290 
Queue Server Console, 294 
scripts, 315 
starting Automatic Queue Server service, 287 
starting from command line, 289 
starting in interactive mode, 289 
submitter optimization process, 292 

Automatic Queue Server Handler for Exigen 
Workflow Events 
definition, 343 

setting up, 344 

B 
bar codes 

troubleshooting, 36 
barcode engine, 29 
barcode format, 29 
barcode masks, 27 

adding, 31 
barcode method 

specifying, 28 
Barcode Server, 25 

adding a barcode mask, 31 
adding index fields, 33 
assigning document types, 38 
audit file, 39 
configuring, 26 
definition, 25 
document status, 36 
menus and buttons, 345 
running, 36 
selecting a barcode engine, 29 
selecting a format, 29 
setting maximum size of processed pages, 39 
setting stop conditions, 35 
specifying queue settings, 30 
specifying the barcode method, 28 
stopping, 36 
verifying the number of separated documents 

and parcels, 37 
viewing index fields, 28 
viewing masks, 27 

bookmarks 
enabling separation based on bookmarks, 

260 
buttons 

description, 345 

C 
calls 

blocked, 293 
characters 

removing and replacing, 56 
codetables, 376 

populating, 376 
COLD reports, 230 
COM+ 

limitation, 293 
Commit Handler 
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audit event, 336 
commit algorithm, 336 
configuring, 327 
definition, 325 
error handling, 335 
installing, 326 
running, 334 
setting up the operating system, 326 
uninstalling, 333 
viewing configuration, 333 

common queues, 66, 78 
components 

registering, 296 
unregistering, 297 

computer output to laser disk. See COLD 
configuration settings 

exporting, 266 
importing, 268 

Conversion Engine 
third party software, 99 

conversions 
third party software requirements, 99 
without additional software, 99 

cut off date, 157 

D 
D32_EIS.DLL file, 378 
database fields 

associating with template zones, 50 
databases 

improving performance, 332 
delimited format reports, 180 
description files 

creating with Distribution Server, 148 
Distribution Server, 134 

configuring, 135 
definition, 134 
info files format, 148 
menus and buttons, 357 
running, 147 
specifying export configurations, 141 
specifying settings for the target database and 

project, 145 
starting, 147 
stopping, 138, 147 

document page 
linking to template page, 75 

document recycling, 156 
document status, 36 
document types, 50 

assigning, 38 
documents 

committing to permanent storage, 325 
convertible document formats, 98 
converting imported, 98 

cut off date, 157 
defining the import method, 109 
deleting obsolete, 156 
displaying additional information, 74 
distributing using Distribution Server, 134 
failure to destroy, 168 
importing, 98 
information files, 149 
recycling, 156 
retention, 156 
searching, 80 
verifying number, 37 

E 
E-Capture Server, 248 

adding a directory configuration, 251 
buttons and menus, 364 
defining recognized document types, 262 
definition, 248 
deleting directory configurations, 265 
exporting configuration settings, 266 
importing configuration settings, 268 
modifying a directory configuration, 265 
opening, 249 
recording history files, 255 
recording log files, 255 
recovering PCL files, 271 
running, 273 
selecting workflow components, 252 
setting up, 250 
setup tasks, 248 
specifying file types processed in source 

directory, 259 
specifying files to be processed, 262 
specifying post-processing actions, 259 
specifying settings for batch separation, 256 
starting, 273 
status information, 273 
stopping, 275 
viewing data in temporary storage, 278 
viewing history logs, 276 
viewing Schedule of Forms table, 281 
viewing the error log file, 275 
viewing the Named Insured table, 284 
viewing the Schedule of Locations table, 282 

E-Capture Split Server, 322 
configuring, 322 
definition, 322 
running, 322 

Enterprise Report Management. See ERM 
ERM 

adding a model for delimited format reports, 
180 

adding report templates, 190 
annotating reports, 210 
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assigning processing parameters, 188 
assigning target parameters, 188 
auto-indexing, 192 
configuration file keywords, 382 
configuring, 176 
creating report templates, 178 
creating report templates with Monarch, 179 
data formats, 176 
documents, 176 
Excel (XLS) overlay settings, 203 
excerpts from databases, 178 
form overlay settings, 197 
import directories, 185 
plain text overlays, 202 
preliminary tasks, 177 
printouts, 178 
processing AS/400 reports, 220 
recognized report types, 177 
registering a report layout, 183 
report presentation, 210 
Report Queue Monitor, 219, 221 
reports, 176 
rich text format (RTF) overlays, 202 
sample configuration file, 382 
setting up, 181 
setup options, 206 
viewing reports, 210, 211 
workflow, 180 

ERM Indexer, 181, 213 
buttons and menus, 361 
definition, 213 
log files, 192 
setting up, 213 

ERM Locator application, 180 
nodes, 181 

ERM Report Viewer, 210 
ERM Setup, 181 
ERM Storage Maintenance, 181 
ERM Storage Maintenance Utility, 225 

definition, 225 
running, 225 

erroneous documents, 89 
errors 

objects not responding, 293 
viewing, 275 

escalation logs 
viewing, 153 

Escalation Server, 150 
configuring, 152 
definition, 150 
excluding non-business days and holidays, 

152 
menus and buttons, 358 
specifying settings, 155 
tuning, 374 
viewing logs, 153 

escalation times 
configuring, 152 

event log, 373 
events 

processing with Automatic Queue Server, 343 
Excel (XLS) overlays, 203 
Excel templates, 204 
Exigen Integrator 

using with Automatic Queue Server, 320 
Exigen Workflow cache, 335 
Exigen Workflow Engine Cache Supervisor 

service 
starting, 335 
stopping, 335 

Exigen Workflow handlers 
definition, 325 

Exigen Workflow object menus and button bars, 
345 

F 
field configurations 

adding, 50 
fields 

adding, 238 
deleting, 240 
editing, 240 
multiline, 239 
Report Definition Wizard, 232, 237 
validating, 57 

font settings 
specifying, 47 

form bar codes, 49 
form identification 

adding, 48 
specifying settings, 45 

Form Index Server, 77 
buttons and menus, 349 
definition, 77 
running, 79 
stopping, 79 
verifying document and parcel numbers, 79 

Form OCR QA, 65 
buttons and menus, 349 
creating additional field, 74 
definition, 65 
document display, 72 
linking a template to a document, 75 
pausing the Form OCR QA process, 73 
performing OCR verification, 67 

Form OCR Server, 40 
adding a form identification, 48 
associating database fields with template 

zones, 50 
buttons and menus, 347 
configuring, 41 
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definition, 40 
form signature flexible search, 58 
formatting extracted data, 53 
registering form templates, 44 
running, 64 
searching zone data, 62 
specifying advanced font settings, 47 
status messages, 63 
stopping, 64 
testing configurations, 63 
using document types, 49 
using form bar code, 49 
validating fields, 57 
zone data flexible search, 62 

form overlay settings 
ERM, 197 

form processing 
viewing statistics, 73 

form signatures 
searching, 58 

form templates 
linking to documents, 75 
registering, 44 

FTS 
creating tables, 86 
definition, 84 
designing a workflow, 86 
installing, 85 

FTS Preprocessor 
buttons and menus, 351 
configuring, 82 
definition, 80 
prerequisites for use, 80 
running, 83 
using, 80 

FTS Server 
buttons and menus, 353 
running, 88 
stopping, 89 
using, 87 

Full Text Search. See FTS 
Full Text Search Preprocessor. See FTS 

Preprocessor 
Full Text Search Server. See FTS Server 

G 
guide 

audience, 9 
related information, 9 
required experience, 9 
typographic conventions, 10 

H 
history logs 

viewing, 276 

I 
IBM Client Access for Windows, 216, 220 
Image Enhancement Server, 90 

buttons and menus, 354 
configuring, 91 
definition, 90 
image filtering settings, 93 
running, 97 
stopping, 97 

image files 
distributing, 134 

images 
configuring enhancements, 91 
configuring filtering settings, 93 
positioning text horizontally, 94 
positioning text vertically, 95 
removing dot shading, 95 
removing specks, 96 
setting parameters for line deletion, 96 

import directories 
ERM, 185 

import records 
creating, 105 

Import Server, 98 
configuring, 101 
creating an empty parcel, 131 
defining the import method, 109 
definition, 98 
entering importing session information, 106 
exporting setup data, 132 
import setup records, 105 
importing document files and indexing 

information, 118 
importing document files only, 110 
importing indexing information only, 114 
importing multiple image files, 111 
importing multiple image files as a DMS 

document, 121 
log and history files, 132 
menus and buttons, 356 
populating fields with indexing information, 

124 
printing using native applications, 107 
running, 131 
specifying imprint settings, 103 
statistics, 101 
using multiple servers, 106 

import sessions 
setting up, 106 

imprint settings 
specifying, 103 

index fields, 28 
adding, 33 
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indexing problems, 89 
instances 

configuring, 307 
pausing, 309 
resuming, 309 

J 
job configuration packages 

exporting, 306 
importing, 307 

jobs 
clearing instances, 305 
creating, 297 
deleting, 304 
importing, 308 
modifying, 304 
retrieving automatically, 66, 78 
starting, 305 
stopping, 305 
viewing statistics, 305 

K 
keywords 

defining, 262 

L 
log files 

ERM, 192 
viewing, 275, 321 

logs 
viewing escalation logs, 153 

M 
mailbox 

Automatic Queue Server, 291 
menu commands 

description, 345 
menus 

description, 345 
Monarch 

creating report templates, 179 
multi-model option, 209 

N 
Named Insured table, 284 
NED Image Printer Driver, 14 

O 
objects 

not responding, 293 
OCR, 80 
OCR verification, 67 

optical character recognition. See OCR 
Optical Character Recognition. See OCR 

P 
pages 

setting maximum size, 39 
parcels 

displaying additional information, 74 
distributing using Distribution Server, 134 
information files, 148 
splitting, 37 
verifying number, 37 

PCL files 
extracting and sending, 322 
processing, 263 
recovering, 271 

plain text overlays, 202 
policy lists, 158 
Print Monitor, 18 

changing job attributes, 22 
definition, 11 
deleting jobs, 20 
printing jobs, 20 
searching jobs, 21 
setting refresh frequency, 20 
suspending a job, 24 
viewing documents, 24 
viewing print job details, 19 

Print Monitor Log 
definition, 11 

Print Monitor window 
printing a report listing, 21 

Print Server 
adding a device, 14 
assigning a device, 17 
configuring, 12 
configuring default options, 18 
definition, 11 
extended printing, 17 
running, 18 
selecting a default printer, 17 
viewing logs, 24 

printing 
adding a device, 14 
advanced options, 14 
assigning a device, 17 
changing job attributes, 22 
configuring default options, 18 
deleting a job, 20 
jobs, 20 
recovering a suspended job, 24 
report, 21 
searching jobs, 21 
selecting a default printer, 17 
setting refresh frequency, 20 



Administrator's Guide, Part 2: Business Component Reference  Index 

 

Copyright © 1994-2005, Exigen Properties, Inc. and/or affiliates. All rights reserved.   
Exigen Workflow 5.6 Page 390 of 391 

suspending a job, 24 
using native applications, 107 
viewing a document, 24 
viewing logs, 24 
viewing pending print job details, 19 

processing parameters 
ERM, 188 

Push Server, 173 
advanced functionality, 376 
definition, 173 
integration with Exigen Integrator, 378 
legacy based routing, 378 
menus and buttons, 359 
routing using a codetable, 376 
running, 174 
stopping, 175 

Q 
Queue Server. See Automatic Queue Server 
Queue Server Console, 325 

buttons, 314 
clearing job instances, 305 
configuring an instance, 307 
creating a job, 297 
definition, 294 
deleting a job, 304 
exporting a job configuration package, 306 
importing a job configuration package, 307 
importing jobs, 308 
managing a remote instance, 313 
modifying a job, 304 
pausing an instance, 309 
registering a component, 296 
registering several Automatic Queue Servers 

in a console, 310 
resuming an instance, 309 
starting, 295 
starting a job, 305 
stopping a job, 305 
unregistering a component, 297 
viewing Automatic Queue Server 

configurations, 310 
viewing job statistics, 305 

queues 
common, 66, 78 

R 
recycling bin, 156 
Report Definition Wizard, 230 

buttons and menus, 361 
changing report template attributes, 246 
concepts, 230 
definition, 230 
example report, 381 

template trees, 243 
working with report templates, 244 

report layouts 
registering, 183 

Report Queue Monitor, 211, 219, 221 
report templates 

adding, 190 
changing attributes, 246 
creating, 178, 231 
exporting, 245 
importing, 245 
opening, 244 
viewing as trees, 243 

reports 
delimited format, 180 
Report Definition Wizard, 381 
viewing in AFP Viewer, 211 

retention policies 
configuring, 158 

retention policy, 157 
Retention Server 

approving retention collections, 171 
configuring retention policies, 158 
creating retention policies, 160 
definition, 156 
document recycling, 156 
enabling document retention, 157 
location of email template, 170 
retention collection disposal, 157 
running, 167 
setting up, 169 
stopping, 171 
viewing statistics, 168 

rich text format (RTF) overlays, 202 
routing 

codetable, 175, 376 
legacy based, 175 

S 
Schedule of Forms table, 281 
Schedule of Locations table, 282 
SCS reports, 176 
SCS spool files, 220 
security 

preventing unauthorized users from viewing 
documents, 14 

using Automatic Queue Server to assign, 320 
servers 

maintaining as services, 366 
replacing with handlers, 325 

services, 366 
configuring, 369 
events, 373 
help, 373 
installing, 367 
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running multiple instances, 375 
starting, 372 
stopping, 373 
uninstalling, 371 

single-model option, 209 
statistics 

Import Server, 101 
viewing form processing, 73 

strings 
removing and replacing, 56 

T 
target parameters 

ERM, 188 
Task Oriented Workflow Engine 

definition, 337 
running, 343 
system requirements, 337 
uninstalling, 343 

Task Oriented Workflow Engine TaskFlow 
Handler 
configuring, 340 

Task Oriented Workflow Engine TaskList 
Handler 
configuring, 338 

template trees, 243 
templates. See form templates 

temporary, 280 
temporary storage, 248 

viewing data, 278 
TIFF format 

storing files, 253 
traps, 231 

adding and editing, 234 
attributes, 233 
definition, 230 
deleting, 234 
purposes, 232 

typographic conventions, 10 

V 
Virtual Print Queue, 14 

W 
Windows NT active desktop services, 366 
workflows 

designing for FTS, 86 

Z 
zones 

testing, 63 
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